#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai at 15:55:47 UTC (full logs).

Meeting summary

  1. - last meeting minutes (Sai, 15:56:26)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-07-05-15.56.html (Sai, 15:56:30)

  2. - Agenda (Sai, 15:56:36)
    1. - 1. Call for any topics (Sai, 15:57:51)
    2. - 2. Review the existing action items (Sai, 15:59:57)
    3. - 3.Blocking bugs review query - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=--- (Sai, 16:00:24)
    4. - 4. Review the new Dashboards - Core Patches Merged In Last 7 Days & Core Patches Modified In Last 7 Days (Sai, 16:01:05)

  3. - Call for any topics (Sai, 16:01:48)
  4. - Review the existing action items (Sai, 16:06:01)
    1. - [DONE] Ryan will followup with Tony regarding M3 status. Tony said it would be done by 06/14/2016 (Sai, 16:06:24)
    2. - [DONE] Ryan to address AAA M5 status (Sai, 16:06:40)
    3. ACTION: - skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we thnk are erroneous at this point) - https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit https://bugs.opendaylight.org/show_bug.cgi?id=5973 (Sai, 16:07:08)
    4. - skitt is on vacation (Sai, 16:07:16)
    5. ACTION: - Ryan to followup author regarding changes in bug 6149 (Sai, 16:07:29)
    6. ACTION: - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution. (Sai, 16:07:53)
    7. - [DONE] Ryan to link corresponding gerrit patch on bug 6010 (Sai, 16:08:20)
    8. - [DONE] Bug 5923 - Ryan to followup with author on how to proceed further. (Sai, 16:08:36)

  5. - Blocking bugs review query (Sai, 16:09:28)
    1. - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=--- (Sai, 16:11:36)
    2. ACTION: - Ryan to send an email wrt remaining / in progress critical bugs of offset release (Sai, 16:12:04)
    3. ACTION: - Bug 5923 - Ryan to followup with author on the status (Sai, 16:12:37)
    4. ACTION: - Bug 6154 - Ryan to followup with author on the status (Sai, 16:14:38)
    5. ACTION: - Bug 6152 - Ryan to followup with author on the status (Sai, 16:15:02)
    6. ACTION: - Bug 6152 - Igor still need more info on circumstances. Igor to followup with Ambika. (Sai, 16:17:08)
    7. ACTION: - Bug 5807 - Ryan to followup with author on the status. (Sai, 16:18:52)

  6. - Review the new Dashboards (Sai, 16:20:06)
    1. - Core Patches Merged In Last 7 Days (Sai, 16:20:18)
    2. - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged (Sai, 16:20:28)
    3. - no concerns on odl parent / yangtools patches (Sai, 16:23:46)
    4. - Bug 4784 - Opendaylight copyrights existsted during hydrogen release, but were removed due to concerns. (Sai, 16:24:38)
    5. - Robert suggests Ryan a different approach which uses xml. (Sai, 16:25:19)
    6. - An says yang rfc 6121 has been superseded by 6991, due to which ietf-inet-types-upgrade is necessary. (Sai, 16:31:54)
    7. - An sees some infrastructure issues & approvals but else it is on track. (Sai, 16:32:49)
    8. ACTION: - Ryan to reach out Anil wrt gerrit patch 40820 (Sai, 16:33:34)
    9. - Robert says upgrading ietf model is to avoid consistent transitive dependencies (binding spec v2 should alleviate this problem in future) (Sai, 16:35:07)
    10. - Robert says the changes are documented in binding spec . (Sai, 16:36:19)
    11. - An requests to Robert to communicate the tentative plan to avoid going to each individual project for upgrade. (Sai, 16:37:29)
    12. - entire versioning in yang assume it always go through committee and strictly compatible, which means there is a change in namespace. It doesn't work good with software development. Here open version semantics help. (Sai, 16:40:10)
    13. - colin requests more transparency on changes (Sai, 16:42:04)
    14. - colin agrees on goals but more concerned about implications. (Sai, 16:43:24)
    15. it's not so much more transparency, as trying to make sure that we understand the implications of adding a layer of indirection between Java APIs and YANG models which may make it difficult for an ODL app to understand what YANG models it's using, which matters when interacting with the outside world (colindixon, 16:44:30)
    16. - Robert thinks a prototype is necessary (on how different consumers uses code and impacts). (Sai, 16:47:29)

  7. - participants (Sai, 16:52:19)
    1. - Sai / Ryan / An / Brinda / Colin / Igor / Robert / TomP / Vaclav / Venkatrangan / Vratko (Sai, 16:53:05)


Meeting ended at 16:53:22 UTC (full logs).

Action items

  1. - skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we thnk are erroneous at this point) - https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit https://bugs.opendaylight.org/show_bug.cgi?id=5973
  2. - Ryan to followup author regarding changes in bug 6149
  3. - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution.
  4. - Ryan to send an email wrt remaining / in progress critical bugs of offset release
  5. - Bug 5923 - Ryan to followup with author on the status
  6. - Bug 6154 - Ryan to followup with author on the status
  7. - Bug 6152 - Ryan to followup with author on the status
  8. - Bug 6152 - Igor still need more info on circumstances. Igor to followup with Ambika.
  9. - Bug 5807 - Ryan to followup with author on the status.
  10. - Ryan to reach out Anil wrt gerrit patch 40820


People present (lines said)

  1. Sai (51)
  2. odl_meetbot (6)
  3. colindixon (2)


Generated by MeetBot 0.1.4.