#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai__ at 16:06:55 UTC (full logs).

Meeting summary

  1. - last-meeting-minutes (Sai__, 16:07:04)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-07-12-15.55.html (Sai__, 16:07:22)

  2. - Action-Items (Sai__, 16:07:35)
    1. ACTION: - skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we think are erroneous at this point) - https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit https://bugs.opendaylight.org/show_bug.cgi?id=5973 (Sai__, 16:08:18)
    2. - [DONE] - Ryan to followup author regarding changes in bug 6149 DONE: Followed up with author; no answer yet. The candidate patch was abandoned. (Sai__, 16:08:51)
    3. - [DONE] Ryan to send an email wrt remaining / in progress critical bugs of offset release DONE (Sai__, 16:09:07)
    4. ACTION: - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution. (Sai__, 16:09:19)
    5. ACTION: - [IN PROGRESS] Bug 5923 - Ryan to followup with author on the status Will be solved with upgrade to karaf 3.0.7; an actual JCE problem in some environments (Sai__, 16:09:40)
    6. - [DONE] Bug 6154 - Ryan to followup with author on the status DONE: resolved fixed by Jakub Morvay (Sai__, 16:10:03)
    7. ACTION: - [IN PROGRESS] Bug 5923 - Ryan to followup with author on the status Will be solved with upgrade to karaf 3.0.7; an actual JCE problem in some environments (Sai__, 16:10:18)
    8. ACTION: - [IN PROGRESS] Bug 6152 - Ryan to followup with author on the status Added Tom P. as a watcher; he has taken the lead on CSS issues this release. (Sai__, 16:10:33)
    9. ACTION: - [IN PROGRESS] Bug 5099 - Igor still need more info on circumstances. Igor to followup with Ambika. Igor followed up, seems that more info is still needed to reproduce. (Sai__, 16:10:45)
    10. - [DONE] Bug 5807 - Ryan to followup with author on the status. DONE: No answer from author. I tried to reproduce this locally, and it worked for me. Resolved WorksForMe. (Sai__, 16:10:56)
    11. - [DONE] - Ryan to reach out Anil wrt gerrit patch 40820 DONE: it was merged. (Sai__, 16:11:08)

  3. - Deviation changes in yangtools (Weather Item) (Sai__, 16:12:33)
    1. - API waiver may be necessary here, since API code freeze is done. (Sai__, 16:13:29)
    2. - only one project is affected through this (Sai__, 16:14:49)
    3. - Robert apologizes for breaking the API (Sai__, 16:16:42)
    4. ACTION: - Robert follows up with team wrt API change [ gerrit id 40592 ] (Sai__, 16:18:07)

  4. - clustered-app-config and external default data XML file (Sai__, 16:19:02)
    1. - TomP asks where should we look for xml files (Sai__, 16:20:54)
    2. - TomP leans toward configuration/initial folder. (Sai__, 16:22:38)
    3. - Robert says configuration may not be best name since we use the files for operational too. (Sai__, 16:26:06)
    4. - Robert & TomP agrees on configuration doesn't mean it is configuration datastore (Sai__, 16:29:45)
    5. - consensus is /etc/opendaylight/datastore/initial/config (Sai__, 16:32:11)
    6. this will allow us to perform migrations between persistence by storing snapshots in etc/opendaylight/snapshot/ ;-) (rovarga, 16:34:14)
    7. this will allow us to perform migrations between persistence by storing snapshots in etc/opendaylight/datastore/snapshot/ ;-) (rovarga, 16:34:26)
    8. - same module name & same container name but no different namespaces yields in manually specifying where the files are coming from (Sai__, 16:37:23)
    9. - colon is a bad idea but underscore would do, no need for revision. (Sai__, 16:40:47)

  5. - Deviation Changes in Yangtools (Sai__, 16:41:04)
    1. - Robert fixes it live is during the call (Sai__, 16:41:21)

  6. - different consistency models in distributed datastore (Sai__, 16:41:37)
    1. -example:Eventual Consistency or NWR (Sai__, 16:41:43)
    2. - e-mail thread in Opendaylight TSC project (Sai__, 16:43:45)
    3. - more pointers on how to read / understand would help (Sai__, 16:44:25)
    4. - Robert says we have javadocs in md-sal but none other (Sai__, 16:45:04)

  7. - Blocking bugs (Sai__, 16:46:17)
    1. - Bug 6149 (Sai__, 16:47:53)
    2. - Robert says we may not be able to fix it (Sai__, 16:48:10)
    3. - Bug 6152 (Sai__, 16:49:53)
    4. - Downgraded from blocker to critical due to distributions (Sai__, 16:50:27)
    5. - Robert says it is coming from datatree, server provided leaf is definitely configurable (Sai__, 16:51:48)
    6. - Bug 6209 (Sai__, 16:54:36)
    7. - Ryan asks for logs (Sai__, 16:55:04)
    8. - Bug 5099 (Sai__, 16:55:23)
    9. - Igor says this is not a bug in yangtools (Sai__, 16:55:46)
    10. - Igor considers to close it as invalid (Sai__, 16:56:37)
    11. - since the casting a leaf as an xml is not supported. (Sai__, 16:57:06)
    12. - Bug 5923 (Sai__, 16:57:22)
    13. - Ryan follows up with author (Sai__, 16:58:28)
    14. https://git.opendaylight.org/gerrit/#/c/42066/ bumps the version to JDK8 (rovarga, 16:59:21)
    15. - Bug 6148 (Sai__, 16:59:40)
    16. - Ryan working with mohammed and it is in progress (Sai__, 17:00:05)
    17. - Bug 6113 (Sai__, 17:00:32)
    18. - Martin suggests to decrease the importance to major (Sai__, 17:01:20)

  8. - participants (Sai__, 17:03:32)
    1. - Sai / Ryan / An Ho / Brinda / Colin / Igor / Jakub / Lori / Martin / Robert / TomP / Vaclav / Viera (Sai__, 17:04:49)


Meeting ended at 17:04:53 UTC (full logs).

Action items

  1. - skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we think are erroneous at this point) - https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit https://bugs.opendaylight.org/show_bug.cgi?id=5973
  2. - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution.
  3. - [IN PROGRESS] Bug 5923 - Ryan to followup with author on the status Will be solved with upgrade to karaf 3.0.7; an actual JCE problem in some environments
  4. - [IN PROGRESS] Bug 5923 - Ryan to followup with author on the status Will be solved with upgrade to karaf 3.0.7; an actual JCE problem in some environments
  5. - [IN PROGRESS] Bug 6152 - Ryan to followup with author on the status Added Tom P. as a watcher; he has taken the lead on CSS issues this release.
  6. - [IN PROGRESS] Bug 5099 - Igor still need more info on circumstances. Igor to followup with Ambika. Igor followed up, seems that more info is still needed to reproduce.
  7. - Robert follows up with team wrt API change [ gerrit id 40592 ]


People present (lines said)

  1. Sai__ (63)
  2. odl_meetbot (6)
  3. rovarga (5)


Generated by MeetBot 0.1.4.