#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai_ at 15:58:07 UTC (full logs).

Meeting summary

  1. - last-meeting-minutes (Sai_, 15:58:23)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-07-19-16.06.html (Sai_, 15:58:33)

  2. - Agenda (Sai_, 15:58:38)
    1. - 1. Call for any topics (Sai_, 16:00:15)
    2. - 2. Review Action Items (Sai_, 16:00:23)
    3. - 3. Review Blocking bugs (Sai_, 16:00:55)
    4. - 4. Review the new Dashboards - Core Patches Merged & Modified in last 7 days (Sai_, 16:01:38)

  3. - Call for any topics (Sai_, 16:04:38)
    1. - 1. Restconf draft 15 (Sai_, 16:05:12)
    2. - 2. Binding spec v2 review / opinions (Sai_, 16:05:37)
    3. - 3. netconf / restconf bugzilla is obselete in controller project. (Sai_, 16:06:12)
    4. ACTION: - TomP to followup with helpdesk to remove restconf/netconf bugs from bugzilla (Sai_, 16:07:13)
    5. - 4. Beryllium SR3 from An (Sai_, 16:07:56)

  4. - Review Action items (Sai_, 16:08:09)
    1. - [DONE] skitt (or somebody else if they have time in the next few weeks) to look at trying to purge some of these (which we think are erroneous at this point) - https://wiki.opendaylight.org/view/RelEng/Autorelease/Orbit https://bugs.opendaylight.org/show_bug.cgi?id=5973 (Sai_, 16:09:17)
    2. ACTION: - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution. (Sai_, 16:11:21)
    3. - DONE Bug 5923 - Ryan to followup with author on the status Will be solved with upgrade to karaf 3.0.7; an actual JCE problem in some environments (Sai_, 16:11:39)
    4. ACTION: - [IN PROGRESS] Bug 6152 - Ryan to followup with author on the status Added Tom P. as a watcher; he has taken the lead on CSS issues this release. (Sai_, 16:11:56)
    5. - [DONE] - Robert follows up with team wrt API change [ gerrit id 40592 ] (Sai_, 16:12:16)
    6. ACTION: - [IN PROGRESS] Bug 5099 - Igor still need more info on circumstances. Igor to followup with Ambika. Igor followed up, seems that more info is still needed to reproduce. (Sai_, 16:12:33)

  5. - Restconf Draft 15 (Sai_, 16:12:47)
    1. - In progress (Sai_, 16:12:51)
    2. we're currently working on draft 11, but there are supposedly no (or only minor) technical changes between 11 and 15 (colindixon, 16:13:13)
    3. - plan to support for yang 1.1 (switches xml to any data) (Sai_, 16:13:33)
    4. Martin Ciglan points out that YANG 1.1 is required to support draft 11/15 (colindixon, 16:13:34)
    5. the plan is to support YANG 1.1 as part of Carbon efforts (colindixon, 16:13:50)
    6. - colindixon presented this to advisory group and general consensus is to eventually migrate it. (Sai_, 16:14:31)
    7. - This includes difficult design decisions and there is a need to document the plan. (Sai_, 16:17:52)

  6. - Binding Spec v2 (Sai_, 16:18:28)
    1. the key point is that there are at least three layers: RESTCONF draft 11 or draft 15, YANG model 1.1 vs. 1.0, and NETCONF using YANG 1.0 or 1.1 (colindixon, 16:18:44)
    2. as an aside, it's pretty ridiculous that the IETF has tied RESTCONF to a particular version of YANG vs. having it be a transport and not caring, but I guess it's done (colindixon, 16:19:11)
    3. - Martin sent e-mail to md-sal dev / controller-dev and awaiting feedback (Sai_, 16:19:15)
    4. https://lists.opendaylight.org/pipermail/mdsal-dev/2016-July/000398.html (rgoulding, 16:19:51)
    5. - https://lists.opendaylight.org/pipermail/mdsal-dev/2016-July/000398.html (Sai_, 16:20:05)
    6. - colindixon suggests to present binding v2 spec in TWS call (Sai_, 16:20:56)
    7. ACTION: colindixon to work with martin ciglan to get a binding v2 spec TWS call (colindixon, 16:21:06)

  7. - Beryllium SR3 (Sai_, 16:21:41)
    1. - An says there are distribution test failures in AAA & Netconf for SR3. (Sai_, 16:22:28)
    2. ACTION: - Ryan / Tomas to look in to distribution test failures wrt Ber SR3 (Sai_, 16:23:00)

  8. - Weekly Sync IRC Meeting (Sai_, 16:23:13)
    1. - An says started from M5, 10 AM PST is likely (Sai_, 16:24:19)
    2. - colindixon suggests 7 AM PST (Sai_, 16:24:32)
    3. ACTION: - An to sent an e-mail regarding scheduled times of weekly sync IRC meeting (Sai_, 16:25:31)

  9. - DCL Removal plans (Sai_, 16:25:44)
    1. - Toaster doesn't have many children and it relatively easy to switch from DCL to DTCL (Sai_, 16:26:54)
    2. - Stephen says they haven't finished in ovsdb (Sai_, 16:27:15)
    3. - change in granularity / rework events / react in a different way are hurdles in ovsdb as of now (Sai_, 16:28:22)
    4. skitt says that the change in granularity of events means that you either don't get any speed benefit or you have to react ina substantively different way (colindixon, 16:28:42)
    5. - Since deprecated in Boron it can be removed in Carbon. But Ryan suggests NOT to remove in Carbon (Sai_, 16:28:59)
    6. - Consensus is NOT to remove in carbon cycle. (Sai_, 16:31:23)

  10. - Blocking bugs (Sai_, 16:32:51)
    1. - https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&list_id=46270&order=changeddate%20DESC%2Cbug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=aaa&product=controller&product=mdsal&product=netconf&product=odlparent&product=yangtools&query_based_on=&query_format=advanced&resolution=--- (Sai_, 16:33:03)
    2. - Bug 6271 (Sai_, 16:33:48)
    3. - Vrakto says there is possibility that it happens only in auto-release builds (Sai_, 16:34:56)
    4. - Bug 6209 (Sai_, 16:35:35)
    5. - Martin added comments (Sai_, 16:36:22)
    6. ACTION: - Ryan to look in to enhancement bug wrt Bug 6209 (Sai_, 16:38:07)
    7. - Bug 6152 (Sai_, 16:38:30)
    8. - Move it to topoprocessing project (Sai_, 16:41:11)
    9. - TomP says it is not config system error (Sai_, 16:41:29)
    10. - Bug 5923 (Sai_, 16:42:13)
    11. - Ryan built with auto release and see sporadic failures. (Sai_, 16:43:14)
    12. - Ryan plans to move karaf parent to odlparent (Sai_, 16:44:44)
    13. - In that case we don't need to bump karaf parent everytime (Sai_, 16:47:05)
    14. ACTION: - Ryan to followup with Mohammed wrt Bug 6148 (Sai_, 16:48:01)

  11. - Review the new Dashboards (Sai_, 16:48:23)
    1. - Core Patches Merged In Last 7 Days (Sai_, 16:48:35)
    2. - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merge (Sai_, 16:48:44)
    3. - Good thing to have bug Id for every gerrit (Sai_, 16:49:00)
    4. - checkstayle rules / Google Truth / PMD CPD are some of the important merged patches in odlparent (Sai_, 16:50:32)
    5. - patches include deprecations in yangtools (Sai_, 16:52:34)
    6. - increasing code coverage in mdsal (Sai_, 16:53:05)
    7. - place to store the xml files / change in auto-down feature (Sai_, 16:56:46)
    8. ACTION: - Sai to add change in auto-down feature to release notes (Sai_, 16:58:36)
    9. - Bug fixes for Be / Boron in netconf (Sai_, 17:00:32)
    10. - document fixes in AAA (Sai_, 17:00:44)

  12. - participants (Sai_, 17:00:49)
    1. - Sai / Ryan / An / Colin / Igor / Martin / Stephen / TomP / Tomas / Vaclav / Vratko (Sai_, 17:02:01)


Meeting ended at 17:02:06 UTC (full logs).

Action items

  1. - TomP to followup with helpdesk to remove restconf/netconf bugs from bugzilla
  2. - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution.
  3. - [IN PROGRESS] Bug 6152 - Ryan to followup with author on the status Added Tom P. as a watcher; he has taken the lead on CSS issues this release.
  4. - [IN PROGRESS] Bug 5099 - Igor still need more info on circumstances. Igor to followup with Ambika. Igor followed up, seems that more info is still needed to reproduce.
  5. colindixon to work with martin ciglan to get a binding v2 spec TWS call
  6. - Ryan / Tomas to look in to distribution test failures wrt Ber SR3
  7. - An to sent an e-mail regarding scheduled times of weekly sync IRC meeting
  8. - Ryan to look in to enhancement bug wrt Bug 6209
  9. - Ryan to followup with Mohammed wrt Bug 6148
  10. - Sai to add change in auto-down feature to release notes


Action items, by person

  1. colindixon
    1. colindixon to work with martin ciglan to get a binding v2 spec TWS call
  2. UNASSIGNED
    1. - TomP to followup with helpdesk to remove restconf/netconf bugs from bugzilla
    2. - [IN PROGRESS] Ryan to followup wrt bug 6148 and report back if it has cyclic dependencies and solution.
    3. - [IN PROGRESS] Bug 6152 - Ryan to followup with author on the status Added Tom P. as a watcher; he has taken the lead on CSS issues this release.
    4. - [IN PROGRESS] Bug 5099 - Igor still need more info on circumstances. Igor to followup with Ambika. Igor followed up, seems that more info is still needed to reproduce.
    5. - Ryan / Tomas to look in to distribution test failures wrt Ber SR3
    6. - An to sent an e-mail regarding scheduled times of weekly sync IRC meeting
    7. - Ryan to look in to enhancement bug wrt Bug 6209
    8. - Ryan to followup with Mohammed wrt Bug 6148
    9. - Sai to add change in auto-down feature to release notes


People present (lines said)

  1. Sai_ (80)
  2. colindixon (8)
  3. odl_meetbot (7)
  4. rgoulding (1)


Generated by MeetBot 0.1.4.