#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai_ at 16:01:50 UTC (full logs).

Meeting summary

  1. - last-meeting-minutes (Sai_, 16:02:32)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-08-02-15.57.html (Sai_, 16:02:34)

  2. - Agenda (Sai_, 16:02:39)
  3. - informal polling of offset projects (Sai_, 16:05:17)
    1. - An requests to speak up for readiness (Sai_, 16:05:37)
    2. - AAA is good, very minor changes expected. (Sai_, 16:06:29)
    3. - controller - small patches for clustering / infrastructure changes . All are minor. TomP says it is green and ready for go. (Sai_, 16:07:11)
    4. - MDSAL - Martin says binding spec work is not yet completely done. Yellow status. (Sai_, 16:08:52)
    5. - https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620 (Sai_, 16:09:06)
    6. - none are using binding spec v2 as of now, new piece of functionality shouldn't hold Boron release. (Sai_, 16:10:12)
    7. - Netconf - Tomas says it is green and only minor bug fixes are expected. (Sai_, 16:11:02)
    8. - odlparent - Stephen - ready with karaf 3.0.7 major change. (Sai_, 16:12:35)
    9. - yangtools - Igor - one bigger patch is pending - not sure if it can be fixed by thursday. (Sai_, 16:14:54)
    10. - weather item exists / API change may be necessary. MD-SAL might be affected. patches wrt Netconf / Restconf are yet to be merged. (Sai_, 16:16:43)
    11. - An feels it is worth sending API waiver change request. (Sai_, 16:17:02)
    12. ACTION: - Igor to send API waiver request for project yangtools. (Sai_, 16:17:21)

  4. - Bug6209 (Sai_, 16:18:30)
    1. - closed as invalid with valid reason (Sai_, 16:19:42)
    2. ACTION: - Ryan to followup with Martin wrt bug 6209 (Sai_, 16:20:10)

  5. - blocking bugs (Sai_, 16:20:40)
    1. - Bug 6316 (Sai_, 16:21:11)
    2. - Igor says i may not be a blocker. To be reviewedwith Robert next week . (Sai_, 16:22:09)
    3. - Bug 6325 (Sai_, 16:23:18)
    4. - it shouldn't affect negatively for Boron release. (Sai_, 16:24:52)
    5. - Bug 6256 (Sai_, 16:25:07)
    6. - it is targeted for carbon (Sai_, 16:25:43)
    7. - Bug 5923 (Sai_, 16:25:50)
    8. - Waiting for review (Sai_, 16:26:23)

  6. - core patches merged in last 7 days (Sai_, 16:26:39)
    1. - Martin already sent an e-mail regarding on going API changes in mdsal project (Sai_, 16:31:06)
    2. - controller project (Sai_, 16:34:17)
    3. - Ryan requests controller committers to send an e-mail / add weather item wrt major changes / removals / deprecations expected in Boron (Sai_, 16:35:48)
    4. ACTION: - Ryan to send an e-mail / add weather item wrt major changes / removals / deprecations expected in Boron for karaf project (Sai_, 16:36:28)

  7. - participants (Sai_, 16:38:14)
    1. - Sai / Phil / Ryan / An / Brinda / Carol / Colin / Igor / Martin / Stephen / TomP / Tomas (Sai_, 16:38:52)


Meeting ended at 16:38:56 UTC (full logs).

Action items

  1. - Igor to send API waiver request for project yangtools.
  2. - Ryan to followup with Martin wrt bug 6209
  3. - Ryan to send an e-mail / add weather item wrt major changes / removals / deprecations expected in Boron for karaf project


People present (lines said)

  1. Sai_ (40)
  2. odl_meetbot (5)
  3. colindixon (0)


Generated by MeetBot 0.1.4.