15:58:21 <Sai_> #startmeeting MD-SAL Interest Call
15:58:21 <odl_meetbot> Meeting started Tue Sep 20 15:58:21 2016 UTC.  The chair is Sai_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:58:21 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:58:21 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
15:58:50 <Sai_> #topic - last-meeting-minutes
15:59:09 <Sai_> #link - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-09-13-15.56.html
16:00:51 <Sai_> #topic - Agenda
16:02:27 <Sai_> #chair colindixon
16:02:27 <odl_meetbot> Current chairs: Sai_ colindixon
16:02:37 <Sai_> #info - Call for any topics to be added
16:02:47 <Sai_> #info - Review Action items
16:02:56 <Sai_> #info - Review the code change dashboards
16:03:16 <Sai_> #topic - Call for any topics to be added
16:04:02 <Sai_> #info - AnHo adds topic " Branding MD-SAL call as kernel utils call "
16:05:06 <Sai_> #info - colindixon / ryan / stephen +1
16:05:37 <Sai_> #info - Sai / Igor +1
16:05:50 <colindixon> #agreed we will change the name to the kernel projects weekly call
16:07:18 <Sai_> #Action - Ryan / colindixon / Sai_ to move wiki space for the new meeting "kernel projects weekly call" from existing MD_SAL weekly call (current link -  https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call)
16:07:31 <Sai_> #topic - Review Action items
16:07:58 <Sai_> #Action - Stephen to update bugs 5955 / 5966 with information discussed ert or.json licensing
16:08:08 <Sai_> #Action - TomP to release note "rapidly swapping candidate stuff"
16:08:28 <Sai_> #topic - Review dashboards
16:10:17 <Sai_> #info - Alexis moving netconf to blueprint
16:12:05 <colindixon> #info rgoulding asks if there's a plan to support YANG 1.1 in Carbon
16:12:06 <Sai_> #info - plan to support yang 1.1
16:12:14 <colindixon> #undo
16:12:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ac5150>
16:12:30 <colindixon> #info igor says there are plans to support part of YANG 1.1, but probably not all
16:12:51 <Sai_> #info - Ryan offers support for yang 1.1
16:13:57 <colindixon> #action martin to start a meeting arond YANG 1.1 and invite whoever else, there's also a topic for the DDF at the summit
16:14:51 <Sai_> #info - unit test failures in ayngtools is quite often
16:15:15 <anipbu> https://lists.opendaylight.org/pipermail/release/2016-September/008334.html
16:15:29 <Sai_> #Info - An says release note has these points noted.
16:15:38 <Sai_> #link -  https://lists.opendaylight.org/pipermail/release/2016-September/008334.html
16:15:46 <adetalhouet> sal-rest-docgen
16:15:53 <adetalhouet> 15:21:17 Failed tests:
16:15:53 <adetalhouet> 15:21:17   ApiDocGeneratorTest.testEdgeCases:226 null
16:16:04 <colindixon> #info adetalhouet says that thre are sal-rest-docgen failing unit tests too
16:17:01 <colindixon> #info does xsql work anymore? should we get rid of it?
16:18:04 <Sai_> #info - Sharon isn't responding for Alexis, TomP suggests to comment the part of code and move forward.
16:18:46 <colindixon> #action adetalhouet to deprecate xsql so that we can kill it later
16:18:55 <Sai_> #Action - Alexis to deprecate the xsql code.
16:18:58 <Sai_> #undo
16:18:58 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2859710>
16:19:59 <Sai_> #topic - carbon_dev_forum
16:20:10 <colindixon> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum look through the topics, add your name and/or new topics if you need them
16:22:02 <colindixon> #info adetalhouet asks about fast and/or phased, colindixon says that unless rovarga or edwarnicke (or somebody new) starts to drive it again, he suspects it will peter out
16:23:44 <Sai_> #info - Stephen says he is strong believer of fast phased release
16:24:06 <Sai_> #info - colindixon says we may need someone to take initiative and drive it.
16:24:06 <colindixon> #Undo
16:24:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2859950>
16:24:09 <colindixon> #undo
16:24:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2859c50>
16:24:17 <colindixon> #Info skitt says that he was never a strong believer in fast and/or phased
16:24:38 <colindixon> #info there's something else, namely semantic versioning, that he is, but it's not clear how far we can get in carbon
16:25:44 <Sai_> #info - colindixon says moving it to fixed version range would be an improvement.
16:27:47 <colindixon> #info colindixon says that moving from a fixed version for everything to a fixed version range, and then make merges produce a new micro every time so that we *could* decouple merge from release (or not) as we see
16:28:35 <colindixon> #info skitt adds that's closer to what he'd do, he'd also like to use the mvn release:release plugin to automate what we current do with autorelease, but one project at a time
16:28:37 <Sai_> thanks colindixon , today my wifi completely screwed up
16:29:04 <rovarga> skitt: we've had that in Hydrogen :-D
16:29:16 <rovarga> skitt: did not work well with properties, hence we went to autorelease
16:29:47 <rovarga> skitt: these days we should be able to move back ... but somebody needs to actually try it out
16:29:49 <colindixon> #info colindixon notes that we did it with hydrogen and we had issues, rovarga notes that it didn't work well with properties
16:30:35 <rovarga> as for semver -- yangtools is there, mdsal should be rather doable (still needs cleanup from the ayngtools splitup), controller is the same story
16:31:08 <rovarga> it is very much about projects committing to abiding by it
16:31:24 <Sai_> #info - colindixon points do we intend to do in carbon ?  Move to version ranges / build releasing other than workflow may be componeents of it
16:31:30 <rovarga> (and we desperately need jdiff to catch offenses)
16:32:52 <colindixon> #info moving to karaf 4 would be part of this
16:33:22 <Sai_> #info - Skitt offers to start it with odlparent
16:33:35 <colindixon> Sai_: I'm not sure he was offering
16:33:41 <colindixon> or just saying that's where you'd have to stop
16:35:12 <Sai_> #undo
16:35:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b01110>
16:35:30 <colindixon> #info skitt notes the problem is mostly in process and people, which requires that things coalesce and you need pretty big sticks or carrots
16:35:40 <colindixon> #Info skitt is doubtful, given that, that it could be done in carbon
16:36:44 <colindixon> #action colindixon to send out a mail about what we might be able to experiment with in Carbon w.r.t. phased releases, e.g., semantic version
16:37:25 <Sai_> #topic - participants
16:37:57 <Sai_> #info - Sai / Phil / Colin / Alexis / An / Igor / Martin / Ryan / Stephen / TomP / TOmas / Vaclav / Vratko
16:38:04 <colindixon> thanks Sai_
16:38:05 <Sai_> #endmeeting