16:04:26 <colindixon> #startmeeting MD-SAL interest call
16:04:26 <odl_meetbot> Meeting started Tue Oct  4 16:04:26 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:26 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:04:30 <colindixon> #topic agenda bashing
16:05:48 <colindixon> #link https://wiki.opendaylight.org/view/Kernel_Projects_Call this is the new wiki page
16:08:45 <colindixon> #topic existing action items
16:09:51 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=5995 and https://bugs.opendaylight.org/show_bug.cgi?id=5996 were updated by Stephen
16:10:53 <colindixon> #action colindixon to follow up with anipbu and TomP about how to deal with the fact that if you rapidly change the candidate list, you might end up with an owner that isn't a candidate
16:12:24 <colindixon> #info martin says that internal discussions about YANG 1.1 have started, but no upstream regular meeting has started
16:13:40 <colindixon> #info ryang says he'd like to help out if at all possible and points out that real end-users are asking for it on the bug ID now
16:13:44 <colindixon> #undo
16:13:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2adb9d0>
16:13:47 <colindixon> #info ryan says he'd like to help out if at all possible and points out that real end-users are asking for it on the bug ID now
16:19:07 <colindixon> #Info rovarga shares his current take on what needs to happen between YANG 1.0 and YANG 1.1
16:20:15 <colindixon> #info see the recording for the shared analysis major points that need to be done
16:21:31 <adetalhouet> #link https://tools.ietf.org/rfcdiff?url2=rfc7950&url1=rfc6020 RFCs differences between YANG 1.0 and YANG 1.1
16:23:30 <colindixon> #info the overall analysis seems to be that OpenDaylight migth be better served by doing piece-by-piece pulling in what people need
16:23:33 <colindixon> adetalhouet: thanks!
16:26:12 <colindixon> #info rovarga notes that there are going to be YANG 1.1 models that can't be expressed in the binding spec v1
16:26:45 <colindixon> #info rovarga says he's trying to make the meeting for YANG 1.1 public, but he says that he needs to talk to Vierra and will get back next week
16:27:47 <colindixon> #info rovarga notes that his curent list is really unlikely to be complete
16:29:23 <colindixon> #topic Boron-SR1
16:29:49 <colindixon> #info the cutoff is sunday 10/23 at 23:59 UTC, the release is planned for 10/27
16:30:01 <colindixon> #info anipbu notes that there are a lot of open patches that still need attention on stable/boron
16:31:12 <colindixon> #topic moving to mave 3.3.9+ for ODL
16:31:24 <colindixon> #info you now need it to build ODL, shoudln't matter much for people
16:31:36 <colindixon> #topic bug 6771 problem with typdefs nested in augment
16:31:49 <colindixon> #info does this need to bey cherry-picked to stable/beryllium
16:31:57 <colindixon> #info answer is yes, but it has a merge conflic
16:32:24 <colindixon> #action rgoulding or anyone else could cherry pick the patch back to stable/berylilum before SR4
16:33:26 <colindixon> #topic YANG 1.1
16:33:29 <colindixon> #Link https://bugs.opendaylight.org/show_bug.cgi?id=2305 this is the bug
16:33:49 <colindixon> #topic move sal-remote to sal-rest-connector
16:33:58 <colindixon> #info this is just cleanup from netconf splitout from the controller
16:34:15 <colindixon> #topic restconf draft 15 vs. 16
16:36:03 <colindixon> #info rgoulding asks if we need to support draft 15 because we shipped it in Boron?
16:37:16 <colindixon> #info colindixon says his take is that in this case common sense about replacing experimental things that weren't advertised with other experimental things that weren't advertised being legal
16:37:53 <colindixon> #info adetalhouet asks if there is a wiki about how to use the newer RESTCONF draft
16:38:31 <rgoulding> #link https://lists.opendaylight.org/pipermail/netconf-dev/2016-October/000649.html
16:38:45 <colindixon> #info martin ciglan says he's willing to help get that written up and also plans to send out an analysis of draft 11 => 15 => 16 => 17
16:39:16 <colindixon> #info rgoulding asks if it makes sense to produce lots of documentation and make it seem official before we've stabiliized things
16:42:07 <colindixon> #info colindixon notes that the wiki isn't seachable, so there's relatively little risk to generating docs there, also it's a bad sign if we can't even generate docs for ourselves, maybe adetalhouet and martin ciglan could get together and at least get little things
16:42:57 <colindixon> #info michael vorburger asks when it's reasonable to bring up individual patches here, colindixon says his take is yes after a while, and a while is probably something like a week
16:43:18 <colindixon> #info tomP says that tony plans to step down as PTL of controller and he plans to nominate himself as PTL when that happens
16:43:35 <colindixon> #info TomP has already sent out the declaring intent to participate for the controller
16:43:47 <rgoulding> #link https://lists.opendaylight.org/pipermail/release/2016-October/008404.html
16:43:53 <rgoulding> controller m0 status ^^
16:44:57 <colindixon> #undo
16:44:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x29f0b50>
16:44:59 <colindixon> #undo
16:44:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2af1a50>
16:45:00 <colindixon> #undo
16:45:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2af1a10>
16:45:01 <colindixon> #undo
16:45:01 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2af1b10>
16:45:10 <colindixon> #topic bringing up specific patches on this call
16:45:13 <colindixon> #info michael vorburger asks when it's reasonable to bring up individual patches here, colindixon says his take is yes after a while, and a while is probably something like a week
16:45:20 <colindixon> #topic controller PTL and future
16:45:27 <colindixon> #info tomP says that tony plans to step down as PTL of controller and he plans to nominate himself as PTL when that happens
16:45:34 <colindixon> #info TomP has already sent out the declaring intent to participate for the controller
16:45:49 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-October/008404.html controller M0 status (thanks rgoulding)
16:46:36 <colindixon> #Info TomP asks about what we need to do to deprecate and and clean up the controller so that it's not full of random abandoned code
16:48:01 <colindixon> #info adetalhouet mentions that he's trying to move the yangtools APIs out of mdsal
16:51:00 <colindixon> #Info it sounds like (listening to rovarga and TomP) there's some more planning needed to try to get rid of the MD-SAL implementations and APis in controlle
16:51:03 <colindixon> #undo
16:51:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b4fc50>
16:51:06 <colindixon> #Info it sounds like (listening to rovarga and TomP) there's some more planning needed to try to get rid of the MD-SAL implementations and APis in controller
16:52:15 <colindixon> #info rovarga says that he'd rather not move those to the MD-SAL project intead of just slowly deprecating and eventually remove them from controller
16:52:37 <colindixon> adetalhouet: that was a horrible burst of static from you
16:52:56 <adetalhouet> colindixon: sorry about that. I'm going to re-plug my mic
16:53:09 <colindixon> :p
16:54:55 <colindixon> #info adetalhouet, TomP, and rovarga talk about how that we would try to get rid of the stuff in controller as much as we can
16:57:17 <colindixon> #info rgoulding asks how the logistics might change depending on who was actually participating in carbon and when we'd get to know who was paticipating
16:57:51 <colindixon> #info colindixon says everyone should be in or out by 11/3, but in practice a week or two after that, so by thanksgiving, we should have a really good idea
16:58:36 <colindixon> #endmeeting