14:30:40 <anipbu> #startmeeting release
14:30:40 <odl_meetbot> Meeting started Wed Aug 10 14:30:40 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:40 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:40 <odl_meetbot> The meeting name has been set to 'release'
14:30:50 <anipbu> #topic roll call
14:31:09 <gdavid_comp> #info gdavid_comp for unimgr
14:31:23 <hideyuki> #info hideyuki for VTN
14:31:24 <anipbu> Welcome to the Boron Weekly Sync on IRC to discuss blocking bugs and red flags for the Boron Simultaneous Release
14:31:33 <anipbu> PTL please #info your projects so we can track and record your attendence
14:32:56 <colindixon> #info colindixon
14:33:03 <ChristineH> #info ChristineH for SNMP4SDN
14:33:09 <anipbu> #info anipbu for usc, nemo
14:33:43 <michal-cmarada|2> #info michal-cmarada for GBP
14:33:56 <anipbu> Any other folks please info your projects?
14:34:24 <kblagov|2> #info kblagov for GBP
14:35:15 <rovarga> #info rovarga for yangtools, mdsal, ...
14:35:51 <anipbu> Let's move on to agenda
14:35:55 <anipbu> #topic agenda
14:35:59 <anipbu> #info RC0
14:36:06 <anipbu> #info blocking bugs and red flags
14:36:11 <anipbu> Any other agenda topic folks would like to discuss in 30 minutes?
14:37:40 <anipbu> Seems there is no additional topics from folks.
14:37:42 <colindixon> I heard that we changed the response code for http put to restconf to be 201 instead of 200
14:38:05 <anipbu> #info restconf response code
14:38:11 <colindixon> And that may cause tests to fail
14:38:20 <anipbu> colindixon: okay, I added it to the agenda
14:38:30 <anipbu> Okay's get started
14:38:43 <anipbu> #topic RC0
14:38:55 <anipbu> #info The build for RC0 will start at 23:59:59 UTC on 8/11/2016
14:39:47 <anipbu> Hi gdavid_comp , what is unimgr project readiness (Green/Yellow/Red).  Is your project on track for successful release in Boron?  Are there any major big pending changes that have not been committed?
14:40:21 <anipbu> Hi hideyuki, what is VTN project readiness (Green/Yellow/Red).  Is your project on track for successful release in Boron?  Are there any major big pending changes that have not been committed?
14:40:26 <gdavid_comp> anipbu: we still have a few bug fixes to make, but nothing big.
14:40:46 <anipbu> gdavid_comp: so would you say it is green?
14:40:54 <gdavid_comp> yes :)
14:41:16 <anipbu> Hi ChristineH , what is SNMP4SDN project readiness (Green/Yellow/Red).  Is your project on track for successful release in Boron?  Are there any major big pending changes that have not been committed?
14:41:44 <anipbu> Hi michal-cmarada|2 , what is GBP project readiness (Green/Yellow/Red).  Is your project on track for successful release in Boron?  Are there any major big pending changes that have not been committed?
14:42:00 <hideyuki> anipbu: VTN project is on Green for Boron.
14:42:16 <anipbu> Hi kblagov|2 , what is GBP project readiness (Green/Yellow/Red).  Is your project on track for successful release in Boron?  Are there any major big pending changes that have not been committed?
14:42:17 <michal-cmarada|2> no major pending changes for us
14:42:26 <anipbu> hideyuki: thanks
14:42:38 <anipbu> michal-cmarada|2 would you say that your project us green?
14:42:48 <michal-cmarada|2> i think yes
14:43:04 <abhijitkumbhare> #info abhijitkumbhare for OpenFlow Plugin
14:43:04 <anipbu> michal-cmarada|2: thanks
14:43:21 <abhijitkumbhare> (Sorry was in other meeting)
14:43:28 <anipbu> Hi abhijitkumbhare , what is OpenFlow Plugin project readiness (Green/Yellow/Red).  Is your project on track for successful release in Boron?  Are there any major big pending changes that have not been committed?
14:44:54 <colindixon> I think openflow Plugin is just bug fixes at this point
14:45:01 <anipbu> Okay, thanks projects for sharing informal readiness.
14:45:10 <abhijitkumbhare> We have a bunch of pending commits/bug fixes which were high risk and we wanted to first merge them to master, let them bake for 2-3 days - the plan was to merge them Tuesday (but Tuesday there were major build failures). Not checked the status today.
14:45:19 <anipbu> We will continue to informally poll projects throughout the week
14:45:26 <ChristineH> anipbu: SNMP4SDN project readiness is Yellow. There’re two gerrits we hope to be in Boron but now is being fixed. After fixed, then can go on the action item in last week meeting: stop pulling in AD-SAL components from previous release.
14:45:36 <anipbu> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620   <--- Informal poll of project readiness for boron
14:45:49 <abhijitkumbhare> So we wanted them in time for the RC0 - but may be a day or two late for those
14:45:50 <anipbu> abhijitkumbhare: would you consider your project green or yellow?
14:46:09 <anipbu> ChristineH: okay, thanks
14:46:12 <abhijitkumbhare> At the moment yellow because of those bug fixes
14:46:21 <anipbu> abhijitkumbhare: okay thanks
14:46:33 <anipbu> Let's move on to restconf
14:46:39 <abhijitkumbhare> But should be green next week I think
14:46:59 <anipbu> #topic restconf response code
14:47:15 <anipbu> Let me try to find the email thread
14:47:27 <anipbu> but basically restconf response code may have changed
14:47:48 <jatoth> Hi,
14:48:11 <colindixon_> yeah, vishnoianil might know more, but it's early for him
14:48:41 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-August/007787.html   <--- Email thread for response code
14:48:58 <colindixon_> I think basically a PUT to RESTCONF used to return 200, but now returns 201 (which is correct according to the restconf spec, but used to be unspecified)
14:49:10 <colindixon_> the biggest risk is tests that expect a 200 back falsely failing
14:49:13 <anipbu> jatoth: could you share some thoughts on the changes for the response code?
14:49:15 <colindixon_> and thus giving us less test coverage
14:50:18 <jatoth> yes, there is change if you are creating data with PUT what means that return code will be 201, but if you update data, return code is still 201
14:50:19 <anipbu> #info colindixon says PUT to RESTCONF used to return 200, but now returns 201.  biggest risk is tests that expect a 200 back falsely failing
14:50:28 <colindixon> anyway, I don't know that it's a big deal, maybe LuisGomez or jamoluhrsen can comment later
14:50:37 <colindixon> they will know how many tests seem to be failing
14:50:40 <colindixon> just something to track
14:51:20 <anipbu> jatoth: at this point, do you know which projects may be affected?
14:52:09 <anipbu> #action anipbu to send followup email regarding restconf response code
14:52:28 <anipbu> any other comments from folks regarding restconf response code?
14:52:32 <hideyuki> anipbu: VTN project could be affected by the RESTCONF change. We will check that immidiately.
14:52:49 <anipbu> hideyuki: okay, thanks
14:53:31 <jatoth> anipbu: I think that projects, which use restconf can be affected
14:53:59 <anipbu> jatoth: okay
14:54:05 <anipbu> #topic blocking bugs and red flags
14:54:09 <anipbu> any blocking issues from projects?
14:54:36 <colindixon> #info infrastructure timeouts continue to be a drag on progress
14:55:48 <anipbu> colindixon: do you feel this may impact release of boron?
14:56:18 <anipbu> tykeal: zxiiro: any updates on the infrastructure timeouts?
14:56:24 <colindixon> anipbu: not right now, but it continues to impact our ability to move as quickly as we'd like
14:57:46 <colindixon> any other issues people are aware of?
14:59:02 <anipbu> #info We have 22 blocker bugs from atrium, cardinal, didm, eman, faas, vbd, netide, openflow, sdninterfaceapp, snmp, usecplugin, vpnservice, vtn, yangide, yangtools
14:59:08 <anipbu> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&list_id=62040&query_format=advanced&resolution=---   <--- Bugzilla Report on Blocking Bugs
14:59:20 <anipbu> projects please review your blocking bugs and provide fix, reassign to Carbon, or mark as invalid.
14:59:28 <anipbu> Any last minute topics to raise from folks?
14:59:45 <anipbu> open mic
15:01:22 <anipbu> We're past the hour.  Any last minute topics to raise from folks?
15:01:37 <anipbu> going once
15:01:44 <anipbu> going twice
15:01:51 <anipbu> Okay, thanks folks for joining.
15:01:58 <anipbu> #topic cookies
15:02:06 <anipbu> #endmeeting