14:30:10 <anipbu> #startmeeting release
14:30:10 <odl_meetbot> Meeting started Wed Aug 17 14:30:10 2016 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:10 <odl_meetbot> The meeting name has been set to 'release'
14:30:13 <anipbu> #topic roll call
14:30:22 <anipbu> Welcome to the Boron Weekly Sync on IRC to discuss blocking bugs and red flags for the Boron Simultaneous Release
14:30:29 <anipbu> PTL please #info your projects so we can track and record your attendence
14:30:49 <skitt> #info skitt for odlparent
14:30:57 <michal-cmarada|2> #info Michal Cmarada for GBP
14:31:19 <colindixon> #info colindixon for TTP, docs, and TSC
14:31:23 <yamahata> #info Isaku Yamahata for Neutron Northbound
14:31:36 <hideyuki> #info Hideyuki for VTN
14:32:00 <zxiiro> #info Thanh (releng)
14:32:26 <lori> #info lori for lispflowmapping
14:33:18 <gdavid_comp> #info gdavid_comp for unimgr
14:35:01 <anipbu> #info anipbu for usc, nemo
14:35:05 <anipbu> Any other folks please info your projects?
14:35:40 <anipbu> Let's move on to agenda
14:35:44 <anipbu> #topic agenda
14:35:48 <anipbu> #info RC0
14:35:52 <anipbu> #info blocking bugs and red flags
14:35:57 <anipbu> Any other agenda topic folks would like to discuss in 30 minutes?
14:36:51 <anipbu> Seems there is no additional topics from folks.
14:36:52 <colindixon> I wanted to ask about any projects seeing CSIT falures b/c of REST response code changes
14:36:59 <mciglan> #info mciglan for yangtools, mdsal, etc... on behalf of rovarga
14:37:08 <anipbu> #info CSIT falures b/c of REST response code changes
14:37:21 <anipbu> colindixon: okay, I added it to the agenda
14:37:28 <anipbu> Okay's get started
14:37:34 <anipbu> #topic RC0
14:37:57 <anipbu> Yay! we finally the first RC0 built
14:38:05 <anipbu> with only one day of testing =(
14:38:19 <anipbu> #info https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#RC_Download   <--- RC0 Available for testing
14:38:38 <anipbu> #action anipbu to send email notice regarding RC0 availability
14:38:58 <anipbu> The related autorelease job for it is: https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/218/
14:39:45 <anipbu> #info SFC build test failures in RC0: org.opendaylight.sfc.ofrenderer.SfcOfFlowProgrammerTest.configureVxlanGpeTransportEgressFlow
14:39:48 <colindixon> thanks anipbu!
14:40:11 <anipbu> also thanks to zxiiro!
14:40:26 <anipbu> any folks have questions regarding RC0?
14:40:43 <colindixon> what were the issues in getting a build?
14:40:48 <colindixon> just repeated compilation failures?
14:40:54 <colindixon> I can ask offline too
14:41:15 <anipbu> FAAS failures, NetIDE Failures.  Mostly due to compilation errors in using OpenFlowPlugin API.
14:41:57 <anipbu> colindixon: see comment above
14:42:06 <anipbu> Okay if there are no futhur questions, let's move on
14:42:17 <anipbu> #topic CSIT falures b/c of REST response code changes
14:42:48 <anipbu> Remind folks that restconf response has changed
14:42:59 <anipbu> from 200 to 201
14:43:14 <anipbu> This may affect your CSIT tests
14:43:30 <colindixon> is anyone seeing failures because of that?
14:43:30 <anipbu> https://lists.opendaylight.org/pipermail/release/2016-August/007924.html  <--- Thread describing the issues
14:43:35 <colindixon> it would be good to know
14:44:15 <anipbu> #info restconf response has changed from 200 to 201.  colindixon asks if folks have been seeing any failures as a result
14:44:26 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-August/007924.html  <--- Thread describing the issues
14:45:36 <colindixon> yeah, that's all I wanted to ask
14:45:39 <colindixon> i guess nobody is
14:46:44 <anipbu> Here is link to latest boron distribution test job: https://jenkins.opendaylight.org/releng/job/integration-distribution-test-boron/
14:47:01 <anipbu> and CSIT for all projects: https://jenkins.opendaylight.org/releng/view/CSIT-1node/
14:47:31 <colindixon> #action colindixon to ping jamoluhrsen to see if we can get a graph of CSIT test results over time and see what happened around the time the patch was merged to gague impact
14:47:44 <anipbu> #info not heard from projects regarding CSIT failures due to restconf changes.
14:48:17 <anipbu> Okay, do folks have any additional questions regarding restconf/CSIT?
14:49:48 <anipbu> #topic blocking bugs and red flags
14:49:53 <anipbu> any blocking issues from projects?
14:50:31 <anipbu> skitt: any updates to odlparent with regards to "karaf ungrade<mjaor> (risk is low - csit run on 3.0.7 [security fix] - looks okay); bug in singlefeature related to blueprint <minor>"  Are these tasks done?
14:51:05 <skitt> we're still waiting on a CSIT run in stable
14:51:32 <skitt> we haven't looked at SFT
14:51:38 <anipbu> colindixon: are there any big major changes still pending for TTP?  Would you say your project status is Green?
14:52:04 <anipbu> skitt: okay, so maybe we can still keep odlparent status as green?
14:52:17 <skitt> anipbu, yes, odlparent is green
14:52:22 <vrpolak> I have comment on restconf/CSIT: Initial impact on tests was considerable, bit the tests are easy to fix. There may be tests that are still failing because of it, but that is just because nobody is looking at why those tests are failing.
14:53:31 <anipbu> mciglan: any updates on "Binding Specification (preview unfinished)<major> (internal risk, not external risk-not blocking, not being used)".  Would you say your project is still in Yellow?
14:53:54 <mciglan> yes, still yellow, shooting for rc2 next Thursday to be merged
14:54:14 <anipbu> mciglan: any updates on "yangtools: Big patch pending - datatree <major>; removal or changes to the API that affects the removal (weather already exists) - mdsal will be affected; pending fixes for restconf, controller".  Would you say yangtools is still in yellow?
14:55:14 <mciglan> regarding API change
14:55:28 <mciglan> controller, restconf, mdsal and yangtools patches have been merged
14:55:41 <mciglan> there is still one more issue pending regarding EnumPair
14:56:02 <colindixon> these are all not beign consumed by anyone though, right?
14:56:13 <mciglan> that's under review, distribution check job failing
14:56:32 <mciglan> first issue I mentioned - all consumers fixed and merged
14:56:53 <mciglan> second issue (EnumPair) - looks like only mdsal consuming - patch merged
14:57:02 <anipbu> mciglan: with regards to your updates, would you agree that yangtools is still in yellow?
14:57:05 <mciglan> so, still yellow
14:57:17 <anipbu> okay, please update: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
14:57:18 <mciglan> just need to sort out distribution check failure for one patch
14:57:39 <anipbu> #info https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620   <--- Informal poll of project readiness
14:57:55 <anipbu> mciglan: thanks for the update
14:58:03 <anipbu> #info We have 23 blocker bugs from atrium, cardinal, didm, eman, faas, groupbasedpolicy, vbd, netide, openflow, sdninterfaceapp, snmp, usecplugin, vpnservice, yangide, yangtools
14:58:08 <anipbu> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&list_id=62040&query_format=advanced&resolution=---   <--- Bugzilla Report on Blocking Bugs
14:58:17 <mciglan> you're welcome
14:58:36 <anipbu> packtcable project: please fix your RC1 build failures: https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/219/org.opendaylight.packetcable$packetcable-emulator/
14:58:50 <anipbu> projects please review your blocking bugs and provide fix, reassign to Carbon, or mark as invalid.
14:59:08 <anipbu> Any last minute topics to raise from folks?
14:59:13 <anipbu> open mic
15:00:31 <zxiiro> I have a notification
15:00:39 <anipbu> vrpolak: okay thanks.  do we know which projects have failing tests related to restconf changes?
15:00:51 <zxiiro> if csit jobs are failing due to:
15:00:51 <zxiiro> SSH not responding on 10.29.12.161. Retrying in 10 seconds...
15:00:51 <zxiiro> SSH not responding on 10.29.12.254 after  tries. Giving up.
15:00:55 <anipbu> vrpolak: would it help to have a spreadsheet?
15:01:00 <zxiiro> we are aware and have rackspace engaged
15:01:42 <zxiiro> it's failing because sometimes a node comes online and isn't able to reach https://git.opendaylight.org to clone builder to run the jenkins init scripts so isn't able to fully come online
15:01:46 <zxiiro> we're not sure of the root cause yet
15:02:02 <anipbu> #info zxiiro says csit jobs may be failing because of "SSH" issues, infra team is aware and have engaged rackspace.  At this time, root cause is unknown.
15:02:54 <anipbu> We're past the hour.  Any last minute topics to raise from folks?
15:03:35 <kkershaw> sorry - late to this but how prevalent are CSIT failures?  We are seeing them in Packetcable too.
15:04:01 <jamoluhrsen> colindixon: saw your message above.  you mean something like this:  https://jenkins.opendaylight.org/releng/user/jluhrsen/my-views/view/BORON%20netvirt-csit%20or%20ovsdb-csit%20or%20openstack/job/ovsdb-csit-3node-clustering-only-boron/528/robot/graph?zoomSignificant=true&failedOnly=false&criticalOnly=false&maxBuildsToShow=0&hd=true
15:04:02 <anipbu> jensen_zhang: any big major changes for ALTO?  would you say your project is "Green" status?
15:04:29 <colindixon> jamoluhrsen: yes
15:04:38 <colindixon> that loks like things are more or less OK
15:04:41 <colindixon> is that your take?
15:04:45 <anipbu> #info kkershaw mentions seeing csit failures in packetcble as well.
15:05:04 <colindixon> I mea, the peaks recently seem to say that we don't have permanently failing tests everywhere
15:05:12 <jamoluhrsen> colindixon: that's just for a single job.
15:05:20 <jamoluhrsen> colindixon: for all the jobs, we don't have anything.
15:05:26 <jamoluhrsen> that would be nice.
15:05:26 <anipbu> kkershaw: any big major changes still pending for packetcable?  Would you say your project is in "Green" status?   https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620
15:05:42 <vrpolak> anipbu: I do not think separate spreadsheet for restconf/csit issue is needed. We will have a spreadsheet for test stability (where any failure should refer to a known Bug), which should cover this and similar issues at once.
15:06:53 <kkershaw> I would've before Aug 1. - since then, w/ no changes by the dev team, (most?) all our CSIT jobs have started failing.  At least one set points to the HTTP 200-201 return code that was discussed at some point.
15:08:28 <anipbu> kkershaw: okay
15:08:48 <anipbu> kkershaw: also there seems to be build errors in for RC1 related to packetcable-emulator: https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/219/org.opendaylight.packetcable$packetcable-emulator/
15:09:33 <anipbu> We're past the hour.  Any last minute topics to raise from folks?
15:10:04 <anipbu> going once
15:10:09 <anipbu> going twice
15:10:49 <anipbu> Okay, thanks folks for joining.
15:10:54 <anipbu> #topic cookies
15:10:58 <anipbu> #endmeeting