#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:06 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:00:11)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=41862#Agenda today's agenda (colindixon, 18:00:34)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-02-11-18.02.html last week's meeting minutes (colindixon, 18:00:44)
    3. colindixon (colindixon, 18:00:49)
    4. Daniel Farrell (dfarrell07, 18:00:55)
    5. abhijitkumbhare for ChrisPriceAB (abhijitkumbhare, 18:01:48)
    6. mohnish anumala (mohnish_, 18:01:58)
    7. jmedved (jmedved, 18:02:05)
    8. edwarnicke (edwarnicke, 18:03:15)
    9. ACTION: colindixon to keep boron planning on our minds (colindixon, 18:03:27)
    10. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 18:03:28)
    11. ACTION: colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future (colindixon, 18:03:29)
    12. ACTION: rovarga to follow up with a counter-proposal with the new workflow ;-) (colindixon, 18:03:30)
    13. ACTION: colindixon and phrobb to draft up a Boron release plan that looks like Beryllium and hits before the ODL Summit just in case (colindixon, 18:03:31)
    14. LuisGomez (LuisGomez, 18:05:04)
    15. gkaempfer (gkaempfer, 18:05:11)

  2. beryllium release (colindixon, 18:05:51)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/RC/Status#Status (anipbu, 18:06:00)
    2. jamoluhrsen says that there are failures, all projects have signed off on them, they look normal and par for the course (colindixon, 18:08:04)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-February/004663.html some NeXt concerns (colindixon, 18:09:37)
    4. gzhao says that he feels like NeXt is ready for release based on a release interview with them (colindixon, 18:11:18)
    5. zxiiro says they shouldn't include them in autorelease in the future, but we already do that for OpFlex, so that's fine (colindixon, 18:11:37)
    6. abhijitkumbhare asks how we show it on the website (colindixon, 18:13:45)
    7. colindixon says for VTN it's included in the Karaf distribution, for OpFlex it's documented how to download it, but not on the website (colindixon, 18:14:53)
    8. ACTION: colindixon to add better policies around how to release things like NeXt and OpFlex in the future—if only for sanity in terms of the number of downloads (colindixon, 18:15:45)
    9. LuisGomez says that we may need more time for bug fixing than a single month in a 6 month release (colindixon, 18:16:50)
    10. rovarga says that his take is that all functionality should be in at M3 and then only bug fixes after M5 (colindixon, 18:17:30)
    11. colindixon says he thinks everyone will agree that we're fixing way too many bugs too late in the release, and we should look at how to fix this (colindixon, 18:18:29)
    12. ACTION: colindixon to add the need to fix bugs earlier to the list of lessons learned (colindixon, 18:18:41)
    13. rovarga says better discipline and making testing happen earlier would likely help (colindixon, 18:18:59)
    14. VOTE: Voted on "shall the TSC release Beryllium with the artifacts here https://nexus.opendaylight.org/content/repositories/autorelease-1075/ ?" Results are, +1: 8 (colindixon, 18:21:34)
    15. AGREED: beryllium is released (colindixon, 18:22:07)

  3. TSC elections (colindixon, 18:23:31)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-February/004656.html (dfarrell07, 18:24:29)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-February/004656.html we can start an election if we want to (colindixon, 18:24:41)
    3. phrobb sent out candidate dates for nominations and an elections, are we willing to start an at-large election now (colindixon, 18:25:44)
    4. colindixon asks if we're ready to vote on this (colindixon, 18:25:58)
    5. colindixon says his one concern is whether the term will be a full year or shorter (colindixon, 18:31:03)
    6. edwarnicke says that this feels rushed to vote 7 hours after the e-mail was sent out (colindixon, 18:31:11)
    7. dfarrell07 says that this sounds like we need a quick writeup and then a next mailing list vote (colindixon, 18:35:43)
    8. ACTION: colindixon and phrobb to ensure TSC members are paying attention and can vote if we to quickly (colindixon, 18:37:29)
    9. the goal would to do this Friday or Monday at the latest (colindixon, 18:37:38)
    10. mohnish_ asks if we can do a condorcet vote among different options (colindixon, 18:38:05)
    11. colindixon says that sounds like a really good idea and would speed things up (colindixon, 18:39:11)
    12. ACTION: dfarrell07 to start the thread driving toward a vote to begin elections (colindixon, 18:39:27)
    13. https://lists.opendaylight.org/pipermail/tsc/2016-February/004648.html (colindixon, 18:40:24)

  4. events (colindixon, 18:40:44)
    1. https://www.opendaylight.org/global-events (colindixon, 18:41:03)
    2. lots of events, look there (colindixon, 18:41:16)
    3. dfarrell07 says that the SDN NFV China conference which is linked from OPNFV page, dfarrell07 has the only ODL talk there now (colindixon, 18:41:56)
    4. https://drive.google.com/file/d/0B_7IPKiQjuIZVFhUa1Y5YkphREE/edit China SDN/NFV CFP (dfarrell07, 18:42:50)
    5. dave neary says that there's a LF collaboration summit with a networking track, there is still one more slot if somebody wanted to get it (colindixon, 18:43:32)
    6. LF collab summit is in Lake Tahoe, 3/29-3/31 (colindixon, 18:43:56)

  5. boron (colindixon, 18:44:09)
    1. see the infra update (colindixon, 18:44:13)

  6. stable/lithium (colindixon, 18:44:18)
    1. Lithium-SR4 is coming, the cutoff date is 2/28 with a release on 3/3 (colindixon, 18:44:33)
    2. http://events.linuxfoundation.org/events/collaboration-summit (dneary, 18:44:45)

  7. infrastructure (colindixon, 18:45:03)
    1. Agenda: http://collabsummit2016.sched.org/overview/type/Networking (dneary, 18:45:21)
    2. zxiiro says that there was some infrastructure issues that were affecting (mostly) distribution jobs for all projects, it's been fixed (colindixon, 18:46:33)
    3. https://lists.opendaylight.org/pipermail/release/2016-February/005654.html the relevant mail (colindixon, 18:47:07)
    4. rovarga asks if we could automate the creation of images rather than the helpdesk needing to be involved (colindixon, 18:47:48)
    5. zxiiro says that this is the plan, but by getting nodepool deployed and move into the private cloud, targeted in boron (colindixon, 18:48:13)

  8. developer design forum (colindixon, 18:48:47)
    1. there was a CFP, but they got very few submissions (colindixon, 18:49:00)
    2. ACTION: phrobb_ will create a wiki page with those and asking for other topics (colindixon, 18:49:16)
    3. ACTION: the LF folks are going to send out a sched page to see what's already there (colindixon, 18:49:37)
    4. ACTION: please bring your topics to the developer design forum (colindixon, 18:50:00)
    5. https://www.opendaylight.org/events/2016-02-29-000000-2016-03-01-000000/opendaylight-developer-design-forum more info here (colindixon, 18:50:07)

  9. yang tools graduation review (colindixon, 18:50:39)
    1. https://wiki.opendaylight.org/view/YANG_Tools:Graduation_Proposal (colindixon, 18:51:03)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-February/004621.html requested on 2/2/2016 (colindixon, 18:51:19)
    3. yangtools has been around since the beginning, starting in the controller, then spun out into it's own project (colindixon, 18:51:39)
    4. have rewritten about 90% of their code base in the last 3 years (colindixon, 18:51:57)
    5. are now very serious about moving to semantic versioning and other ways to be the most stable project in OpenDaylight (colindixon, 18:52:37)
    6. mohnish_ asks if YANG tools can be used in other scenarios than OpenDaylight (colindixon, 18:53:04)
    7. rovarga says they try to be careful to avoid being directly tied to Karaf or OpenDaylight or OSGi or anything like that (colindixon, 18:53:32)
    8. colindixon notes that the TTP project uses YANG tools to create a standalone CLI jar that uses it to go from Java objects to/from JSON (colindixon, 18:55:29)
    9. david karr (I think) and edwarnicke confirm that it's used in an Eclipse plugin and in FD.io's honeycomb (colindixon, 18:55:55)
    10. LuisGomez asks if there's a standing weekly meeting (colindixon, 18:56:06)
    11. LuisGomez also asks if there's documentation for developers or contributors (colindixon, 18:56:26)
    12. rovarga says that mostly the APIs are hidden by the MD-SAL, but it's an area they're trying to fix (colindixon, 18:56:53)
    13. rovarga says there is no yangtools-specific weekly meeting, but they attend the weekly MD-SAL meeting and most interaction is via mailing lists and bugzilla (colindixon, 18:57:13)
    14. rovarga says if there's interest, they can set something up (colindixon, 18:57:24)
    15. mohnish_ asks what the future of yangtools looks like (colindixon, 18:57:48)
    16. colindixon notes (here in IRC, but will also say it next) that YANG tools is very good at adhering to schedules, and especially of late has been good about communicating possibly breaking changes and reverting them if need be (colindixon, 18:58:38)
    17. rovarga says that there's a binding v2 specification and support for YANG 1.1 are major things, but there's tons of enhancement bugs in bugzilla to look at (colindixon, 18:59:19)
    18. rovarga says that in boron they would like to prototype the takari lifecycle to help things (colindixon, 18:59:57)
    19. http://takari.io/book/40-lifecycle.html (rovarga, 19:00:23)
    20. VOTE: Voted on "shall the TSC graduate YANG Tools to being a mature project?" Results are, +1: 9 (colindixon, 19:01:09)
    21. colindixon notes that andy_vanko is not a TSC member so it's only 8 +1 votes (colindixon, 19:01:45)
    22. AGREED: YANG Tools is now a mature project (colindixon, 19:02:12)

  10. cookies (colindixon, 19:02:14)


Meeting ended at 19:02:17 UTC (full logs).

Action items

  1. colindixon to keep boron planning on our minds
  2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  3. colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
  4. rovarga to follow up with a counter-proposal with the new workflow ;-)
  5. colindixon and phrobb to draft up a Boron release plan that looks like Beryllium and hits before the ODL Summit just in case
  6. colindixon to add better policies around how to release things like NeXt and OpFlex in the future—if only for sanity in terms of the number of downloads
  7. colindixon to add the need to fix bugs earlier to the list of lessons learned
  8. colindixon and phrobb to ensure TSC members are paying attention and can vote if we to quickly
  9. dfarrell07 to start the thread driving toward a vote to begin elections
  10. phrobb_ will create a wiki page with those and asking for other topics
  11. the LF folks are going to send out a sched page to see what's already there
  12. please bring your topics to the developer design forum


Action items, by person

  1. colindixon
    1. colindixon to keep boron planning on our minds
    2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    3. colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
    4. colindixon and phrobb to draft up a Boron release plan that looks like Beryllium and hits before the ODL Summit just in case
    5. colindixon to add better policies around how to release things like NeXt and OpFlex in the future—if only for sanity in terms of the number of downloads
    6. colindixon to add the need to fix bugs earlier to the list of lessons learned
    7. colindixon and phrobb to ensure TSC members are paying attention and can vote if we to quickly
  2. dfarrell07
    1. dfarrell07 to start the thread driving toward a vote to begin elections
  3. phrobb
    1. colindixon and phrobb to draft up a Boron release plan that looks like Beryllium and hits before the ODL Summit just in case
    2. colindixon and phrobb to ensure TSC members are paying attention and can vote if we to quickly
  4. phrobb_
    1. phrobb_ will create a wiki page with those and asking for other topics
  5. rovarga
    1. rovarga to follow up with a counter-proposal with the new workflow ;-)
  6. UNASSIGNED
    1. the LF folks are going to send out a sched page to see what's already there
    2. please bring your topics to the developer design forum


People present (lines said)

  1. colindixon (102)
  2. odl_meetbot (15)
  3. dfarrell07 (12)
  4. abhijitkumbhare (9)
  5. phrobb_ (8)
  6. LuisGomez (7)
  7. gkaempfer (4)
  8. jmedved (4)
  9. edwarnicke (4)
  10. mohnish_ (4)
  11. anipbu (3)
  12. dneary (2)
  13. gzhao (1)
  14. andy_vanko (1)
  15. jamoluhrsen (1)
  16. Prem_ (1)
  17. rovarga (1)
  18. phrobb (0)


Generated by MeetBot 0.1.4.