#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:40 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 18:00:45)
    1. colindixon (colindixon, 18:00:52)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-02-25-18.01.html last week's meeting minutes (colindixon, 18:01:00)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=43219#Agenda the agenda in it's usual place (colindixon, 18:01:19)
    4. Ryan Goulding proxying for Luis Gomez (rgoulding, 18:01:55)
    5. Chris Price (ChrisPriceAB, 18:02:11)
    6. mohnish anumala (mohnish_, 18:02:23)
    7. ACTION: zxiiro will look more into maven central now that we're at least signing things (colindixon, 18:03:35)
    8. ACTION: phrobb to post the NeXt zip file to the downloads page (colindixon, 18:03:58)
    9. ACTION: zxiiro to sending an e-mail about decommissioning helium jobs (and locking the branches) to release and TSC at least (colindixon, 18:04:10)
    10. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 18:04:22)
    11. ACTION: colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future (colindixon, 18:04:28)
    12. Daniel Farrell (dfarrell07, 18:04:38)
    13. ACTION: phrobb to add the LF collab summit to the events list, it's end of march to beginning of april (colindixon, 18:04:43)
    14. colindixon says that the Energy Management Plugin creation review, will happen next week, the presenter has a fire going on at work, I hope the fire is in quotes (colindixon, 18:05:32)
    15. edwarnicke (edwarnicke, 18:05:57)

  2. TSC elections (colindixon, 18:06:42)
    1. CaseyODL says that phrobb wants to set up a meeting between the TSC, Board, and community about TSC elections (colindixon, 18:07:10)
    2. the board specifically wants to speak to this (colindixon, 18:07:28)

  3. events (colindixon, 18:08:46)
    1. https://www.opendaylight.org/global-events (colindixon, 18:08:54)
    2. the Open Networking Summit and co-located ODL mini-summit are in less than two weeks (colindixon, 18:09:27)

  4. stable/lithium (colindixon, 18:09:41)
    1. the final build for Lithium-SR4 with no blocking issues (colindixon, 18:10:03)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release/Lithium/SR4/Status <- Status (anipbu, 18:10:11)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Lithium_SR4_Download <- Download here (anipbu, 18:10:17)
    4. all the test failures from CSIT have been signed off on by projects (colindixon, 18:10:17)
    5. https://docs.google.com/spreadsheets/d/1ktL11ElNdf4D3RUeRNUd8SPnYO0to0DxzSZGst0KdMQ/edit#gid=1117594519 (colindixon, 18:10:51)
    6. VOTE: Voted on "shall the TSC release the Lithium-SR4 artifacts linked to above?" Results are, +1: 6 (colindixon, 18:11:48)
    7. AGREED: the TSC approves the Lithium-SR4 release, this is the last scheduled release of Lithium (colindixon, 18:12:08)

  5. stable/beryllium (colindixon, 18:13:02)
    1. Beryllium SR1 Release Date: March 17; Cutoff Date/Time UTC: March 13 at 11:59 pm (anipbu, 18:13:24)

  6. boron (colindixon, 18:13:53)
    1. no weather issues (colindixon, 18:14:16)
    2. anipbu notes that there were some autorelease breakages in AAA, but they've been fixed (colindixon, 18:14:31)
    3. there are no milestones yet on account of not having a release plan yet (colindixon, 18:14:44)

  7. system integration and testing (colindixon, 18:15:00)
    1. jamoluhrsen says there is going to be a performance-related group with Marcus leading the charge, look out for more information (colindixon, 18:15:24)
    2. autorelease build failure was due to api change in ofj that wasn't advertised to my knowledge. Fix was merged through https://git.opendaylight.org/gerrit/#/c/35655/ (rgoulding, 18:15:46)

  8. infrastructure (colindixon, 18:16:21)
    1. tykeal has no updates, things stayed mostly the same given the time at the DDF (colindixon, 18:16:57)
    2. blocking issue for moving to private cload was supposedly fixed whlie we were at the DDF (colindixon, 18:17:01)
    3. tykeal says that he hopes to have private cloud zuul and nodepool up in a the next couple of weeks, that's getting them aup assuming that we're in teh private cloud, and just getting them up not getting folks migrated (colindixon, 18:17:47)

  9. NIC committer actions (colindixon, 18:18:18)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-March/004746.html e-mail about committers on NIC (colindixon, 18:18:34)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-March/004753.html two commiters on NIC stepped down (colindixon, 18:19:10)
    3. ACTION: colindixon to ask NIC to reach out to helpdesk to get the two committers removed (colindixon, 18:20:00)
    4. colindixon notes two things here are potentially worth getting dicussions: (i) removing inactive committers, (ii) a new committer with not all +1s and less than a majority of votes (but no -1s) (colindixon, 18:22:04)
    5. Hello everyone, sorry I was late. I have started the recording on the WebEx (phrobb_, 18:23:55)
    6. ACTION: colindixon will send mail to follow up on the rest of the NIC committer actions (colindixon, 18:24:20)

  10. boron planning (colindixon, 18:24:39)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-March/004748.html recent thread on the mailing list (release and TSC) (colindixon, 18:25:02)
    2. https://wiki.opendaylight.org/view/Release_Plan/Fast_Phased_Boron proposed fast phase boron (colindixon, 18:25:16)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan proposed traditional boron (colindixon, 18:25:27)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-March/004765.html colin's thought on where we are (colindixon, 18:26:07)
    5. https://lists.opendaylight.org/pipermail/tsc/2015-May/003108.html (colindixon, 18:27:09)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-07-16-17.00.html (colindixon, 18:27:45)
    7. https://lists.opendaylight.org/pipermail/tsc/2015-May/003108.html (colindixon, 18:27:56)
    8. https://lists.opendaylight.org/pipermail/tsc/2015-May/003108.html <- Appears to only discuss branch cutting, which was a hot topic (edwarnicke, 18:31:28)
    9. it seems like we have three options now (a) pick that we go with a fast phased release plan, (b) pick that we go with a traditional release, (c) decide that we dont' have enough information or need more community involvement (colindixon, 18:32:14)
    10. https://lists.opendaylight.org/pipermail/release/2015-July/003119.html <- first discussion of stable features, 9 days before the vote on the Beryllium Plan (edwarnicke, 18:32:16)
    11. we have the summit on 9/27, to put on the best summit, I think we need at least ~2 weeks weeks to work on their stuff before that, so if we do a boron releas after 9/15 (thursday 12 days before the summit), we'll have push out past the summit, which is 10/6 or 10/13 (colindixon, 18:33:38)
    12. that would be 8 months after Beryllium (colindixon, 18:34:57)
    13. edwarnicke notes that having summits near to release seems to cause problems (colindixon, 18:35:44)
    14. abhijitkumbhare asks if we can have a few weeks where we assume that we're going with a traditional release while have have broader discussions, i.e., provisionally adopt the traditional release plan (colindixon, 18:36:23)
    15. edwarnicke asks if there are still issues we need to work through with the traditional plan (colindixon, 18:37:34)
    16. colindixon notes that there are two issues people wanted to talk about (a) that we don't start testing earlier enough, and (b) that we might want to have features be experimental without system test (colindixon, 18:38:17)
    17. we could also approve the normal release plan and make amendments to it if/when community finds things it wants to change (dfarrell07, 18:39:42)
    18. colindixon notes that dfarrell07 and abhijitkumbhare have suggested that we might provisionally accept the traditional release plan today (colindixon, 18:44:59)
    19. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule <- Traditional plans dates for bringing offset-0 projects predate the Developer Design Forum, and offset-0 project deadline is today (edwarnicke, 18:45:17)
    20. any new projects seeking to join offset 1 woudl have to do do so by the end of the day, offset 2 projects would still have a week (colindixon, 18:47:15)
    21. any new offset 0 projects to join now would require an exeption (colindixon, 18:47:21)
    22. Any new offset-0 projects would require an exception, any new offset-1 projects which do not get their project proposals in today would require an exception, any offset-2 projects after next week would require an exception (edwarnicke, 18:47:22)
    23. dfarrell07 has been talking to Int/*, RelEng/* and others about Fast Phased vs normal. Branch cutting and release tooling aren't ready for FP, but would be ready at Boron end. Everyone seems comfortable with normal release plan, no doubts expressed. (dfarrell07, 18:47:27)
    24. edwarnicke is concerned that not everyone knows exceptions are available, and thus we may discourage participation (edwarnicke, 18:47:58)
    25. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#note3 the exception (colindixon, 18:49:11)
    26. dfarrell07 notes that edwarnicke seems to have a lot of feedback about things we could do better, which is welcome and encouraged, but would be best delivered via async/archived lists and not now, since we need to vote ASAP. (dfarrell07, 18:49:50)
    27. ACTION: colindixon to send e-mails out making clear that projects coming out of the design forum are what the exceptions are for (colindixon, 18:50:26)
    28. edwarnicke feels that adopting a release plan announced only a week ago is to fast (edwarnicke, 18:51:39)
    29. edwarnicke is deeply concerned about the lack of community discussion of the plan (edwarnicke, 18:51:53)
    30. dfarrell07 and colindixon note that they don't share the above concern, that there has been broad community discussion about boron for many months (colindixon, 18:52:47)
    31. ChrisPriceAB says that as long as we have a predictable release cadence, this is fine, and having dates in the past is potentially fine (colindixon, 18:53:47)
    32. edwarnicke feels this is inappropriately rushed (edwarnicke, 18:56:06)
    33. and does not feel passing plans with dates in the past is appropriate (edwarnicke, 18:56:25)
    34. VOTE: Voted on "shall the TSC provisionally accept this release plan for Boron while we have discussions that might alter it https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan?" Results are, +1: 5, -1: 1 (colindixon, 18:57:43)
    35. AGREED: the TSC provisionally adopts the Boron release plan as while we have discussions that might alter it https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan (colindixon, 18:58:20)
    36. edwarnicke notes that he (a) thinks that we have only had 7 days to get feedback on this and (b) that that's not enough time to get community feedback (colindixon, 18:59:14)
    37. colindixon and dfarrell07 note that the they feel like feedback could have come back because the Beryllium release plan was the same and available for feedback, and that those have been discussed (colindixon, 18:59:59)
    38. dfarrell07 notes that he has been very deliberate about talking to the community about this b/c he wasn't sure himself. No one had concerns, people understand it because there have been discussions and they have worked through a copy+paste similar plan before. (dfarrell07, 19:00:37)
    39. mohnish_ asks what we could do in the future to make things bettek (colindixon, 19:00:40)
    40. edwarnicke says make sure the release plan has been out to be commented on for at least a month (colindixon, 19:00:56)
    41. there is a disagreement between edwarnicke (one one hand) and colindixon and dfarrell07 (on the other hand) about whether we really had community discussion about this release plan, both dfarrell07 and colindixon feel as though we have (colindixon, 19:04:47)
    42. phrobb notes that we have a charter to provide releases approx. twice per year, and that if we have to stop after releases and go through the new release plan for a month, would push us even further from that than we currently are (colindixon, 19:06:26)
    43. it seems like a concrete action plan moving forward is to make sure that we communicate the new release plan with salient differences and dates on or around M2 of the previous release (colindixon, 19:08:19)

  11. cookies (colindixon, 19:08:22)


Meeting ended at 19:08:24 UTC (full logs).

Action items

  1. zxiiro will look more into maven central now that we're at least signing things
  2. phrobb to post the NeXt zip file to the downloads page
  3. zxiiro to sending an e-mail about decommissioning helium jobs (and locking the branches) to release and TSC at least
  4. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  5. colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
  6. phrobb to add the LF collab summit to the events list, it's end of march to beginning of april
  7. colindixon to ask NIC to reach out to helpdesk to get the two committers removed
  8. colindixon will send mail to follow up on the rest of the NIC committer actions
  9. colindixon to send e-mails out making clear that projects coming out of the design forum are what the exceptions are for


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    2. colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
    3. colindixon to ask NIC to reach out to helpdesk to get the two committers removed
    4. colindixon will send mail to follow up on the rest of the NIC committer actions
    5. colindixon to send e-mails out making clear that projects coming out of the design forum are what the exceptions are for
  2. UNASSIGNED
    1. zxiiro will look more into maven central now that we're at least signing things
    2. phrobb to post the NeXt zip file to the downloads page
    3. zxiiro to sending an e-mail about decommissioning helium jobs (and locking the branches) to release and TSC at least
    4. phrobb to add the LF collab summit to the events list, it's end of march to beginning of april


People present (lines said)

  1. colindixon (96)
  2. edwarnicke (18)
  3. odl_meetbot (17)
  4. dfarrell07 (13)
  5. ChrisPriceAB (9)
  6. rgoulding (5)
  7. mohnish_ (3)
  8. anipbu (3)
  9. abhijitkumbhare (3)
  10. delta_days_betwe (1)
  11. phrobb_ (1)
  12. jamoluhrsen (1)


Generated by MeetBot 0.1.4.