18:00:06 <colindixon> #startmeeting tsc
18:00:06 <odl_meetbot> Meeting started Thu Mar 10 18:00:06 2016 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:06 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:10 <colindixon> #topic agenda bashing and roll call
18:00:16 <colindixon> TSC members pllease #info in
18:00:20 <colindixon> #info colindixon
18:00:34 <dfarrell07> #info Daniel Farrell
18:00:38 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=43651#Agenda the agenda in it's usual place
18:00:47 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-03-03-18.00.html last week's meeting minutes
18:01:32 <phrobb_> The recording on the WebEx has been started.
18:02:13 <gkaempfer> #info gkaempfer
18:02:15 <colindixon> gkaempfer: if you want to #info in
18:02:16 <colindixon> sweet
18:02:18 <ChrisPriceAB> #info Chris Price
18:02:22 <colindixon> zxiiro: you there?
18:02:30 <zxiiro> colindixon: yes
18:02:34 <zxiiro> colindixon: just joining the call now
18:02:45 <colindixon> zxiiro: I assume we're still waiting on #action zxiiro will look more into maven central now that we're at least signing things
18:02:47 <colindixon> #action zxiiro will look more into maven central now that we're at least signing things
18:02:52 <colindixon> #action phrobb to post the NeXt zip file to the downloads page
18:02:55 <colindixon> #action phrobb to add the LF collab summit to the events list, it's end of march to beginning of april
18:03:05 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
18:03:06 <colindixon> #action colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
18:03:21 <mohnish_> #info mohnish anumala
18:03:46 <tykeal> but he might strongly hint ;)
18:03:55 <mohnish_> colin: I am glad you made it :-)
18:04:10 <colindixon> mohnish_: me too
18:04:10 <ChrisPriceAB> not as glad as me mohnish_
18:04:18 <dfarrell07> LuisGomez: edwarnicke
18:04:33 <dfarrell07> 5 is my count too
18:04:35 <LuisGomez> calling now
18:05:03 * ChrisPriceAB will lose his IRC access for the next 20 minutes. (will vote audibly if needed)
18:05:16 <LuisGomez> #info LuisGomez
18:05:18 <colindixon> #topic TSC elections update
18:05:24 <colindixon> #chair anipbu phrobb phrobb_
18:05:24 <odl_meetbot> Current chairs: anipbu colindixon phrobb phrobb_
18:05:54 <colindixon> #info there was an informal meeting of several people from the board, from the TSC as well as community members yesterday
18:05:59 <colindixon> #info it was mostly information sharing
18:06:50 <edwarnicke> #info edwarnicke
18:06:57 <colindixon> #Info this was to talk about the fact that the board was curious if there was a faster way to remove platinum designates from the TSC, e.g., for *this* election as well as concerns about company caps
18:08:45 <colindixon> #info three options seemed surface: (1) have no election until after boron and remove platinum designates, (2) keep the paltinum designates in place and have 4 comitters-at-large elected untl the end of boron, after which use the new election and remove platinum designates (3) remove the platinum designates and have a committer-at-large-only election now, then have a new election after Boron
18:09:37 <colindixon> #info in general, people preferred 2 or 3 over 1, but it was a limited number of people attending
18:10:04 <edwarnicke> Did we capture the boards three principles here?
18:11:19 <colindixon> #info dmm had three principles he voiced: (1) no pay-to-play, (2) meritocracy, (3) simple systems
18:11:48 <colindixon> #Info dmm's take was that (1) meant no platinum designates, (2) meant no caps, (3) meant that it should be as simple as possible
18:13:45 <colindixon> #Info dfarrell07 notes that his recollection was that dmm (Dave Meyer) seemed not opposed to the election system we had proposed after the discussion
18:14:08 <gkaempfer> yes
18:15:37 <colindixon> #info colindixon notes that Anshu (board member from HP) expressed pretty strong opinions in favor of company caps
18:15:57 * colindixon notes that we have two creation reviews to do today too
18:16:46 <zxiiro> I think setting a uniform % on all groups (if we go that route) will also keep the rules simple and unconfusing
18:17:33 <edwarnicke> zxiiro: That is my view as well. But there *are* other viewpoints.
18:17:59 <colindixon> I think we're going to have to move on from this for today and put on the mailing list
18:18:15 <edwarnicke> colindixon: +1 we could talk about this all hour... and we have other business
18:19:33 <colindixon> #info abhijitkumbhare asked who gets to decide whether we have caps or not have caps, the answer is really the board votes at the end with input from the community and TSC being accepted at their discretion because TSC composition is defined in the bylaws
18:19:43 <colindixon> #topic events
18:19:50 <colindixon> #link https://www.opendaylight.org/global-events
18:19:54 <colindixon> #info ONS is next week
18:20:01 <colindixon> #topic boron
18:20:18 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Bug_4527_Security_Groups_:_For_.22Other_Protocol.22_rule.2C_NeutronSecurityRule.getSecurityRuleProtocol.28.29_is_set_to_NULL still waiting on that
18:20:31 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Karaf-parent_upgraded_to_use_karaf-plugin still waiting on that
18:20:39 <colindixon> #info waiting on USC to fix boron autorelease
18:20:40 <dfarrell07> colindixon phrobb we didn't cover this in elections system section and I thought we would, but we need to start 4-seat CAL election (as voted on already) ASAP
18:20:58 <colindixon> #info Boron offset 0 M1 is due today assuming the TSC doesn't adjust the dates
18:21:14 <colindixon> #topic stable beryllium
18:21:37 <colindixon> #info cutoff for Beryllium-SR1 is this Sunday at 11:59p UTC, get things in by then for a release on 3/17
18:22:04 <colindixon> #info anipbu says the RC will be around 12 noon on MOnday
18:22:20 <colindixon> #topic infrastructure
18:22:43 <LuisGomez> dfarrell07, did we decide on removing company cap for inmediate 4 seat CAL elections?
18:22:45 <colindixon> #info staring to migrate into the private cloud, static VM for job builder is in the private cloud as of this morning
18:22:54 <colindixon> #info staring to move build slaves next
18:23:10 <dfarrell07> LuisGomez: I think, as it stands, we've asked the board for the waver for that elections
18:23:27 <colindixon> #info furhter migration including the jenkins system and others will happen after that
18:23:39 <colindixon> #topic NIC committer adjustments
18:24:11 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-March/004746.html
18:24:43 <adetalhouet> sorry I had to drop, but I believe Raphael is on the call
18:24:51 <adetalhouet> if not, I can join quickly
18:25:02 <colindixon> #Info since that e-amil we're at +7 votes which is a majority and unaniumous for 3 of the 4 point
18:25:19 <colindixon> #link https://lists.opendaylight.org/pipermail/nic-dev/2016-February/001157.html contributions likted here
18:25:47 <colindixon> #link https://lists.opendaylight.org/pipermail/nic-dev/2016-February/001173.html the 4th of the 4 seems to have voluntarily dropped out
18:27:09 <colindixon> #startvote shall the TSC promote Icaro Camelo, Saket Mahajan, and Yrineu Rodrigues as committers on the NIC project? -1, 0, +1
18:27:09 <odl_meetbot> Begin voting on: shall the TSC promote Icaro Camelo, Saket Mahajan, and Yrineu Rodrigues as committers on the NIC project? Valid vote options are -1, 0, +1.
18:27:09 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:27:11 <dfarrell07> #vote +1
18:27:15 <colindixon> #vote +1
18:27:19 <edwarnicke> #vote +1
18:27:20 <LuisGomez> #vote +1
18:27:22 <gkaempfer> #vote +1
18:27:25 <uri_> #vote +1
18:27:33 <phrobb_> +1 from Chris Price
18:27:35 <mohnish_> #vote +1
18:27:41 <phrobb_> #vote +1
18:27:44 <colindixon> #endvote
18:27:44 <odl_meetbot> Voted on "shall the TSC promote Icaro Camelo, Saket Mahajan, and Yrineu Rodrigues as committers on the NIC project?" Results are
18:27:44 <odl_meetbot> +1 (8): gkaempfer, LuisGomez, dfarrell07, edwarnicke, uri_, colindixon, mohnish_, phrobb_
18:27:52 <colindixon> #Info note that phrobb_ was voting for ChrisPriceAB
18:28:01 <colindixon> #agree Icaro Camelo, Saket Mahajan, Yrineu Rodrigues are now committers on NIC
18:28:08 <dfarrell07> congrats all!
18:28:24 <adetalhouet> thanks
18:29:00 <colindixon> #action colindixon to make sure removing inactive committers for NIC to next week
18:29:13 <colindixon> #topic eneergy management creation review
18:29:22 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Eman
18:29:39 <colindixon> #likn https://lists.opendaylight.org/pipermail/project-proposals/2016-February/000397.html proposed on 2/3/2016
18:29:45 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2016-February/000397.html proposed on 2/3/2016
18:30:07 <colindixon> #link https://wiki.opendaylight.org/view/File:APSIS_and_OpenDaylight_-_light.pptx slides
18:32:21 * edwarnicke is hugely excited about this
18:32:35 * edwarnicke has wanted ODL to be able to manage power for *years* :)
18:32:43 <colindixon> #info this is the result of of a standards effor (by an ANSI certaified standards body) trying to build software tools do do better energy efficiency
18:33:19 <colindixon> #Info network usage is very high during the day and pretty much absent at night, they'd like to be able power down some of the network to reduce consumption along with the demand
18:34:09 <colindixon> #info there's been a bunch of promising work on how to mechanically do energy attenuation at the devices, so it seems like a good time to start working in ODL to help create complete solutions
18:34:45 <colindixon> #info Frank says that they're also working with the IETF to fit this into other frameworks for energy monitoring and control
18:35:35 <colindixon> #info uri_ asks if this is targeting compute or underlay or both, Frank says yes, but they're mostly targeting specific network gear in the access networks of the cable industry
18:36:07 <colindixon> #info uri_ asks if this project is looking to serve the cable industry or more broadly, Frank says more broadly based on using information models and other tools from the IETF that are more general
18:38:12 <colindixon> #info this project would use an abstract information model from APSIS (adaptive power systems something something) that was co-developed with the IETF, and then create software and APIs to be able to control and actuate it
18:40:00 <colindixon> #info colindixon has two questions from the project proposal scope: (1) is it just the model and southbound interfaces or is it also the energy management applications, (2) by "stand-alone", I'm assuming you mean that it's just a new set of plugins, not that it runs without the rest of OpenDaylight
18:41:10 <colindixon> #Info ChrisPriceAB asks if they plan to address multi-service overlay at this time, Frank says that they're focusing on cable use cases them selves, but trying not to let that leak into the tools in ODL
18:42:01 <colindixon> #info ChrisPriceAB points out that foucsing a lot on multi-writer stuff would matter a lot then
18:42:43 <dfarrell07> #info dfarrell07 has gotten feedback from RelEng-related folks that having only one committer for a project is something they would like to avoid. It creates more work for them to help the project through the release process, and it adds risk around not being able to get up with ppl in a timely manor (if they go on vacation, for example). Any way we can get
18:42:43 <dfarrell07> a second committer?
18:42:48 <dfarrell07> #undo
18:42:55 <colindixon> #chair dfarrell07
18:42:55 <odl_meetbot> Current chairs: anipbu colindixon dfarrell07 phrobb phrobb_
18:42:59 <dfarrell07> #undo
18:42:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c253d0>
18:43:07 <dfarrell07> #info dfarrell07 has gotten feedback from RelEng-related folks that having only one committer for a project is something they would like to avoid. It creates more work for them to help the project through the release process, and it adds risk around not being able to get up with ppl in a timely manor (if they go on vacation, for example).Second committer?
18:43:27 <colindixon> #info Frank says that colindixon's scope reading is correct that this is really just a plugin, but would not provide energy management applications on it's own
18:44:35 <colindixon> #Info Frank says he meant stand-alone as in it will be a plugin but that it won't likely use other plugins or services beyond the MD-SAL
18:47:19 <colindixon> #info colindixon asks if we should add a few other committers per dfarrell07's comments, he suggests Chris Luke and Derek
18:47:25 <colindixon> #Info Frank says at least Derik
18:47:28 <edwarnicke> colindixon: I think you've represented the points very well, and personally feel no need to expand on your comments ;)
18:47:39 <dfarrell07> Cool, let's go ahead and add Derik in this vote
18:47:48 * tykeal notes that it needs to be added to the proposal ;)
18:48:08 <colindixon> #startvote shall the TSC approve the energy management project as an incubation project with Derek as an additional committer? -1, 0, +1
18:48:08 <odl_meetbot> Begin voting on: shall the TSC approve the energy management project as an incubation project with Derek as an additional committer? Valid vote options are -1, 0, +1.
18:48:08 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:48:12 <dfarrell07> #vote +1
18:48:14 <mohnish_> #vote +1
18:48:14 <edwarnicke> #vote +1
18:48:15 <gkaempfer> #vote +1
18:48:16 <LuisGomez> #vote +1
18:48:18 <colindixon> #vote +1
18:48:30 <colindixon> uri_, ChrisPriceAB?
18:48:37 <colindixon> #endvote
18:48:37 <odl_meetbot> Voted on "shall the TSC approve the energy management project as an incubation project with Derek as an additional committer?" Results are
18:48:37 <odl_meetbot> +1 (6): gkaempfer, LuisGomez, edwarnicke, dfarrell07, colindixon, mohnish_
18:48:40 <uri_> #voote +1
18:48:48 <colindixon> #info ChrisPriceAB and uri_ also vote +1
18:48:55 <ChrisPriceAB> thanks
18:48:59 <colindixon> #agree energy monitoring is an incubation project
18:49:02 <mohnish_> congrats!
18:49:06 <dfarrell07> congrats emon!
18:49:06 <edwarnicke> ChrisPriceAB: Welcome to the party :)
18:49:09 * dfarrell07 likes that name
18:49:12 <ChrisPriceAB> hehe
18:49:14 <ChrisPriceAB> thanks
18:49:17 <colindixon> #topic OCP plugin creation review
18:49:48 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:OCP_Plugin
18:50:19 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-December/000389.html proposed on 12/30/2015
18:51:00 <dfarrell07> ^^very nice proposal
18:51:15 <colindixon> #info this is work originally done at FACA (Foxconn Advanced Communication Academy) focusing on Cloud RAN (Radio Area Network)
18:52:23 <colindixon> #link https://wiki.opendaylight.org/view/File:OCP_Project_Proposal_for_TSC_Review.pptx slides
18:52:53 <colindixon> #info OCP (ORI C&M Protocol) is an ETSI standard protocol for control and management of Remote Radio Head (RRH) equipment
18:54:48 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:OCP_Plugin#Scope the scope to review
18:55:23 <colindixon> #info for what it's worth it seems like there's *a lot* of information on the project proposal page
18:55:52 <colindixon> #info design is inspired by the OpenFlow plugin and OpenFlow java projects, but will be one project
18:55:55 <mohnish_> any openflow dependencies?
18:56:06 <colindixon> mohnish_: I think not, but good question, feel free to speak up
18:56:22 <colindixon> mohnish_: I think it's just using the architecture
18:56:42 <colindixon> mohnish_: openflow isn't mentioned once on the proposal page
18:57:56 <colindixon> #info mohnish_ asks if it has anything to do with openflow, answer is other than the architecture, no
18:59:43 <colindixon> having looked over the scope, committers, architecture, etc., this looks good to me assuming it passes IPR
19:00:13 <zxiiro> isn't it dependent on the opendaylight controller?
19:00:29 <zxiiro> and thus yangtools/mdsal/ etc...
19:00:33 <colindixon> zxiiro: yes
19:01:30 <colindixon> #startvote shall the TSC move the OCP plugin project to incubation pending IPR? -1, 0, +1
19:01:30 <odl_meetbot> Begin voting on: shall the TSC move the OCP plugin project to incubation pending IPR? Valid vote options are -1, 0, +1.
19:01:30 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:01:42 <edwarnicke> #vote +1
19:01:44 <gkaempfer> #vote +1
19:01:45 <colindixon> #vote +1
19:01:47 <ChrisPriceAB> #vote +1
19:01:48 <uri_> #vote +1
19:01:51 <dfarrell07> #vote +1
19:01:57 <mohnish_> #vote +1
19:01:59 <LuisGomez> #vote +1
19:02:00 <colindixon> #endvote
19:02:00 <odl_meetbot> Voted on "shall the TSC move the OCP plugin project to incubation pending IPR?" Results are
19:02:00 <odl_meetbot> +1 (8): gkaempfer, ChrisPriceAB, LuisGomez, dfarrell07, edwarnicke, uri_, colindixon, mohnish_
19:02:09 <colindixon> #agree OCP Plugin is now an incubation project
19:02:23 <dfarrell07> congrats OCP!
19:02:27 <dfarrell07> always nice to have more SBs
19:02:31 <colindixon> #topic cookies
19:02:34 <colindixon> #endmeeting