#opendaylight-meeting: tsc

Meeting started by colindixon at 17:34:31 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:01:26)
    1. gkaempfer (gkaempfer, 17:02:02)
    2. colindixon (colindixon, 17:02:04)
    3. Daniel Farrell (dfarrell07, 17:02:08)
    4. Chris Price (phone only) (colindixon, 17:02:09)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=45237#Agenda agenda (colindixon, 17:03:04)
    6. LuisGomez (LuisGomez, 17:03:10)
    7. edwarnicke (edwarnicke, 17:03:11)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-04-07-17.00.html last week's meeting minutes (colindixon, 17:03:17)
    9. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 17:03:37)
    10. ACTION: colindixon to reach out to tykeal else to write up and send an e-mail about signing commits in gerrit (colindixon, 17:04:03)
    11. ACTION: ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence (colindixon, 17:04:28)
    12. ACTION: colindixon to copy this into the TSC main page under processes and procedures: TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html (colindixon, 17:04:37)
    13. ACTION: anipbu or colindixon to send an announcement to the release@ list about removing inactive committers (colindixon, 17:04:57)
    14. https://lists.opendaylight.org/pipermail/tsc/2016-April/thread.html Phil's hackfest poll email (dfarrell07, 17:05:51)
    15. ACTION: colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest (colindixon, 17:05:54)
    16. ACTION: colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html (colindixon, 17:06:12)
    17. ACTION: colindixon to make sure there's a TWS on carbon planning w.r.t. fast and phased (colindixon, 17:06:31)
    18. mohnish anumala (mohnish_, 17:06:38)
    19. ACTION: abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation (colindixon, 17:06:51)
    20. ACTION: colindixon to start a thread on how split out projects inherit or don't their parent project's lifecycle state, but notes in this case (OVSDB) when ediscussed it before we had agreed it would be done this way (colindixon, 17:07:04)

  2. events (colindixon, 17:08:28)
    1. https://www.opendaylight.org/global-events (colindixon, 17:08:43)
    2. openstack is at the end of the month (colindixon, 17:09:05)
    3. the ODL mini summit's CFP at the OPNFV summit is still open until 4/18 (colindixon, 17:09:26)

  3. TSC mailing list votes and discussions (colindixon, 17:09:49)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-April/005007.html call for nominations for the short-term comittter-at-large elections (colindixon, 17:10:25)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-March/004956.html MPLS-TP service creation review on TSC (colindixon, 17:10:51)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-April/005033.html creation review for MPLS-TP solution (whcih is different from MPLS-TP service) (colindixon, 17:12:53)
    4. dfarrell07 says he worries about how similar the names (and mabye projects are) (colindixon, 17:15:21)
    5. colindixon says he thinks there scope is mildly overlapping, but even if that was the case the TSC explicitly allows incubation projects to have overlapping scope (colindixon, 17:15:57)
    6. colindixon and edwarnicke both say that the similar names and similar scope issues are independent (colindixon, 17:16:17)
    7. the similar names might be an issue (colindixon, 17:16:25)
    8. colindixon says he thinks the scopes are different, service works around providing MPLS-TP NB APIs that are then mapped to different SBs, solution focuses on providing a SB to control MPLS-TP enabled devices and some apps to control them (colindixon, 17:18:10)
    9. dfarrell07 agreees, that means the scope is mostly different (colindixon, 17:18:25)
    10. ACTION: colindixon to reach out to both projects to ask if it makes sense to change names for them and us (colindixon, 17:19:47)
    11. mohnish_ and colindixon and edwarnicke agree that asking if they're willing to change names makes sense (colindixon, 17:20:56)

  4. boron (colindixon, 17:22:31)
    1. TCPMD5 is dropping out of Boron and all required functionality is available in netty-native-trasport-epoll v. 4.0.33 and later. Dependent projects should migrate to using netty-provided functionality. (anipbu, 17:23:03)
    2. Projects who depend on features-ovsdb convenience feature to pull in netvirt and southbound plugins should pull in the new feature from the netvirt project. So far the affected projects we know of is VTN, VPNService, and Integration. (anipbu, 17:23:43)
    3. Currently missing the M2 status for 3 projects: aaa, controller, infrautils (anipbu, 17:25:26)
    4. Currently missing the M1 status for 6 projects: kafkaproducer, vbd, eman, didm, netvirt, epc (anipbu, 17:25:31)

  5. stable/beryllium (colindixon, 17:26:05)
    1. Beryllium SR2 is in two weeks on April 28, 2016 with a cutoff on Sunday, April 24, 2016 at 11:59PM UTC (anipbu, 17:26:23)

  6. system integration and test (colindixon, 17:26:40)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=258542574 (jamoluhrsen, 17:27:28)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-04-14-17.01.log.txt (colindixon, 17:27:36)
    3. jamoluhrsen notes that only 3 projects meet the requirements (colindixon, 17:28:28)
    4. ACTION: jamoluhrsen to send mail to projects about their system test status (colindixon, 17:29:00)

  7. infrastructure (colindixon, 17:29:24)
    1. required hardware maintainance in the private cloud happening this weekend (colindixon, 17:30:14)
    2. https://lists.opendaylight.org/pipermail/release/2016-April/006230.html more info here, jenkins will be down for 4 hours (colindixon, 17:30:48)
    3. we have yet to migrate sonar or jenkins, jenkins will happen after openstack summit when zxiiro is around (colindixon, 17:31:26)

  8. integration archive review (colindixon, 17:31:50)
    1. https://wiki.opendaylight.org/view/Archive_Proposals/Integration (colindixon, 17:32:16)
    2. this was proposed when we split the projct apart, and I think it was e-mailed a while ago (colindixon, 17:32:39)
    3. https://lists.opendaylight.org/pipermail/tsc/2015-October/003974.html <-- Original email for Termination Review/Archival Review of Integration (anipbu, 17:33:52)
    4. VOTE: Voted on "shall the TSC archive the integration project which has split into three sub-projects?" Results are, +1: 7 (colindixon, 17:35:13)
    5. AGREED: the integration project will be archived (colindixon, 17:35:24)

  9. Open DOVE archival review (colindixon, 17:35:52)
    1. https://wiki.opendaylight.org/view/Archive_Proposals/Open_DOVE (colindixon, 17:36:00)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-March/004953.html posted on 3/28/2016 (colindixon, 17:36:12)
    3. techincally b/c there has been no vote, we need to wait until next week when it will have been 18 months since the last commit (colindixon, 17:38:59)
    4. colindixon thinks we can vote on it next week, but there's some reason to believe we should wait until 2 weeks after 18 months for review, we'll bring this up in 3 weeks (colindixon, 17:40:58)
    5. ACTION: colindixon to schedule the Open DOVE archive review for 3 weeks from 4/14/2016 (colindixon, 17:41:12)

  10. carbon release plan (colindixon, 17:42:13)
    1. we would like to get a carbon release plan or something like it ready sooner rather than later (colindixon, 17:42:35)
    2. dfarrell07 points out that we need tooling to make that work (colindixon, 17:42:50)
    3. edwarnicke has pushed some tool up to autorelease (colindixon, 17:42:57)
    4. colindixon points out that last time we suggested maybe having a hackfst around fast and phased (colindixon, 17:44:20)

  11. cookies (colindixon, 17:44:43)


Meeting ended at 17:44:52 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  2. colindixon to reach out to tykeal else to write up and send an e-mail about signing commits in gerrit
  3. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
  4. colindixon to copy this into the TSC main page under processes and procedures: TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html
  5. anipbu or colindixon to send an announcement to the release@ list about removing inactive committers
  6. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest
  7. colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html
  8. colindixon to make sure there's a TWS on carbon planning w.r.t. fast and phased
  9. abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
  10. colindixon to start a thread on how split out projects inherit or don't their parent project's lifecycle state, but notes in this case (OVSDB) when ediscussed it before we had agreed it would be done this way
  11. colindixon to reach out to both projects to ask if it makes sense to change names for them and us
  12. jamoluhrsen to send mail to projects about their system test status
  13. colindixon to schedule the Open DOVE archive review for 3 weeks from 4/14/2016


Action items, by person

  1. anipbu
    1. anipbu or colindixon to send an announcement to the release@ list about removing inactive committers
  2. CaseyODL
    1. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
  3. ChrisPriceAB
    1. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
  4. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    2. colindixon to reach out to tykeal else to write up and send an e-mail about signing commits in gerrit
    3. colindixon to copy this into the TSC main page under processes and procedures: TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html
    4. anipbu or colindixon to send an announcement to the release@ list about removing inactive committers
    5. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest
    6. colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html
    7. colindixon to make sure there's a TWS on carbon planning w.r.t. fast and phased
    8. colindixon to start a thread on how split out projects inherit or don't their parent project's lifecycle state, but notes in this case (OVSDB) when ediscussed it before we had agreed it would be done this way
    9. colindixon to reach out to both projects to ask if it makes sense to change names for them and us
    10. colindixon to schedule the Open DOVE archive review for 3 weeks from 4/14/2016
  5. dfarrell07
    1. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest
  6. edwarnicke
    1. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest
  7. gzhao
    1. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
  8. jamoluhrsen
    1. jamoluhrsen to send mail to projects about their system test status


People present (lines said)

  1. colindixon (69)
  2. odl_meetbot (12)
  3. dfarrell07 (8)
  4. anipbu (6)
  5. edwarnicke (4)
  6. zxiiro (4)
  7. mohnish_ (3)
  8. CaseyODL (3)
  9. gkaempfer (2)
  10. ChrisPriceAB (2)
  11. LuisGomez (2)
  12. jamoluhrsen (2)
  13. gzhao (1)


Generated by MeetBot 0.1.4.