#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:33 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:38)
    1. gkaempfer (gkaempfer, 17:00:41)
    2. colindixon (colindixon, 17:00:45)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=45625#Agenda the agenda (colindixon, 17:00:59)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-04-14-17.01.html last week's minutes for action items (colindixon, 17:01:08)
    5. gkaempfer (gkaempfer_, 17:01:45)
    6. ACTION: colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest and a TWS (colindixon, 17:01:47)
    7. edwarnicke (edwarnicke, 17:02:05)
    8. LuisGomez (LuisGomez, 17:03:01)
    9. https://lists.opendaylight.org/pipermail/discuss/2016-April/006441.html planning the next TWS's including OpenFlow and Carbon planning (colindixon, 17:03:33)
    10. ACTION: abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation (colindixon, 17:04:33)
    11. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-04-21-17.00.log.txt (colindixon, 17:04:56)
    12. Daniel Farrell (dfarrell07, 17:05:29)
    13. ACTION: abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation (colindixon, 17:05:34)
    14. ACTION: colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html (colindixon, 17:05:43)
    15. ACTION: colindixon to reach out to tykeal else to write up and send an e-mail about signing commits in gerrit (colindixon, 17:05:50)
    16. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 17:05:55)
    17. abhijitkumbhare for ChrisPriceAB (abhijitkumbhare, 17:05:59)
    18. colindixon gkaempfer_ edwarnicke LuisGomez dfarrell07 abhijitkumbhare We have quorom (phrobb, 17:06:04)
    19. edwarnicke says he thinks he's been signing his commits for over a year now, and there's now something new for push signing which is what colindixon and tykeal are talking about (colindixon, 17:07:25)

  2. TSC mailing list vortes and discussions (colindixon, 17:07:52)
    1. there is a TSC commiitter-at-large election going on right now, if you think you should have a voting invite and don't, reach out to phrobb (colindixon, 17:08:27)
    2. mohnish anumala (mohnish, 17:11:12)
    3. AGREED: based on the 0s, and -1s for having a meeting next week, we will skip next week's TSC meeting as many people will be otherwise occupied (colindixon, 17:19:28)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-April/005085.html more frequent ODL releases (colindixon, 17:19:28)
    5. AGREED: based on the 0s, and -1s for having a meeting next week, we will skip next week's TSC meeting as many people will be otherwise occupied (colindixon, 17:19:33)
    6. ebrjohn, edwarnicke, dfarrell07, and colindixon talk about ways we could ship fixes faster than every 3 months to downstream, dfarrell07 metions autorelease-based rpms as one way (colindixon, 17:20:23)
    7. https://lists.opendaylight.org/pipermail/tsc/2016-April/005091.html split-out projects and lifecycle states (colindixon, 17:20:37)
    8. ACTION: colindixon and anipbu2 to make sure that we get e-mail votes to release Beryllium-SR2 despite having no TSC meeting and people being at OpenStack (colindixon, 17:22:52)

  3. events (colindixon, 17:23:26)
    1. https://www.opendaylight.org/global-events (colindixon, 17:23:34)
    2. openstack next week (colindixon, 17:23:38)
    3. https://wiki.opendaylight.org/view/Community/2016-openstack-summit-booth (CaseyODL, 17:23:50)
    4. info the CFP for the ODL summit in september closes May 6th (which is coming up very quilckly) (colindixon, 17:25:11)
    5. http://events.linuxfoundation.org/events/opendaylight-summit/program/cfp ODL summit in september's CFP (colindixon, 17:25:40)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-04-21-17.00.log.txt (colindixon, 17:26:25)

  4. boron (colindixon, 17:26:56)
    1. we would like projects to 1) review their pom files, 2) remove the <nexusproxy> property, and 3) update the nexus URL from *http://nexus.opendaylight.org* to *https://nexus.opendaylight.org* (anipbu2, 17:27:19)
    2. https://wiki.opendaylight.org/view/Weather#Nexus_URL_requires_HTTPS <--- Weather item for Nexus URL (anipbu2, 17:27:25)
    3. There are currently some breakages while building odlparent as described in Bug 5775. Thanh has submitted Patch 37980 and hopefully the autorelease build should pass tonight. (anipbu2, 17:27:52)
    4. Boron M2 Offset 1 is due today. Please send your status report. (anipbu2, 17:28:06)

  5. stable/beryllium (colindixon, 17:28:28)
    1. Beryllium SR2 cut off is this Sunday on April 24, 2016 at 11:59PM UTC with a release date of April 28, 2016 with a cutoff. Note that after cutoff, the Beryllium branches will be locked. (anipbu2, 17:28:55)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Schedule <--- Beryllium SR2 schedule (anipbu2, 17:29:00)
    3. There are test failures in the Beryllium Autorelease Build for groupbasedpolicy and tsdr. Those projects should address the issues before the cutoff. (anipbu2, 17:29:22)
    4. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-beryllium/133/testReport/ <--- Beryllium Autorelease Build Test Failures (anipbu2, 17:29:26)

  6. system integration and test (colindixon, 17:29:42)
    1. jamoluhrsen says everything he was going to say anipbu already covered (colindixon, 17:29:53)

  7. infrastructure (colindixon, 17:30:01)
    1. tykeal says that sonar was migrated in the private cloud yesterday, and now the jenkins plugin which created a short jenkins downtime (colindixon, 17:30:42)
    2. the only stuff that needs to be moved into the private cloud is releng and sandbox jenkins silos (colindixon, 17:31:03)
    3. tykeal says there are a few jenkins silos for semi-archived projects (colindixon, 17:31:20)
    4. ACTION: tykeal to e-mail the TSC with the list of semi-archived silos to figure out how to procede (colindixon, 17:31:39)

  8. JSON RPC 2.0 Plugin (colindixon, 17:32:31)
    1. https://wiki.opendaylight.org/view/Project_Proposals:JSON-RPC2.0-plugin (colindixon, 17:32:37)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2016-April/000473.html proposed on 4/7/2016 (colindixon, 17:32:56)
    3. ACTION: anton will post the slides immediately after the call (colindixon, 17:33:36)
    4. the goal is to have a way to put data, RPCs, and notifications in and out of ODL using JSON-RPC 2.0 (colindixon, 17:34:35)
    5. use IETF draft-netmod-json-yang to provide the conents of the RPCs (colindixon, 17:35:36)
    6. first transports for the JSON-RPC will be zero MQ, HTTP(s), and maybe more later (colindixon, 17:35:55)
    7. this will reuese as much as possible from ODL including using the JSON ser/des (colindixon, 17:37:48)
    8. one major targetted gap is working with YANG modeled data outside of the JVM and ODL propper (colindixon, 17:39:44)
    9. things brought on day zero: zero MQ transport, JSON RPC stack, BI extension supporting outbound data/rpcs/notifications, YANMG modeled data for applications outside java, e.g., for now Python (colindixon, 17:40:58)
    10. ed asks what JSON schema, they're using, anton says for now a simple custom one, edwarnicke notes that there is not a canonical one yet (colindixon, 17:43:21)
    11. anton clarifies that this is using YANG schemas to model the json, not something else new (colindixon, 17:44:48)
    12. phrobb notes that zero MQ might cause problems with licenses (colindixon, 17:47:25)
    13. rovarga says that we could package zero MQ outside of ODL to make that OK (colindixon, 17:49:42)
    14. going forward, they are looking into othe transports, other language bindings, and inbound ODL interfaces to have full-fledged YANG modules outside the JVM (colindixon, 17:50:36)
    15. gkaempfer_ asks if they have expectations for the performance of this, anton says that the performance of the message queues is very fast, but the the bottleneck tends to be in JSON ser/des (colindixon, 17:57:01)
    16. anton says performance goals are later, focusing on working now (colindixon, 17:58:35)
    17. anton does a demo where he imports the YANG generated python file starting with the toaster model (colindixon, 17:58:49)
    18. VOTE: Voted on "shall the TSC approve the jsonrpc project as an incubation project?" Results are, +1: 7 (colindixon, 17:59:37)
    19. AGREED: the jsonrpc project is now an incubation project (colindixon, 17:59:45)
    20. Please note this approval is based on successful passing of Inbound Code Review (phrobb, 18:00:37)
    21. VOTE: Voted on "shall the TSC allow the jsonrpc project to join boron at offset 2?" Results are, +1: 6 (colindixon, 18:01:47)
    22. AGREED: the JSON RPC project can join boron at offset 2 (colindixon, 18:02:08)
    23. edwarnicke would have voted +1 above but for IRC lag (edwarnicke, 18:04:52)
    24. anton continues the demo and show it working of zmq (colindixon, 18:05:14)

  9. cookies (colindixon, 18:05:32)


Meeting ended at 18:05:43 UTC (full logs).

Action items

  1. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest and a TWS
  2. abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
  3. abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
  4. colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html
  5. colindixon to reach out to tykeal else to write up and send an e-mail about signing commits in gerrit
  6. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  7. colindixon and anipbu2 to make sure that we get e-mail votes to release Beryllium-SR2 despite having no TSC meeting and people being at OpenStack
  8. tykeal to e-mail the TSC with the list of semi-archived silos to figure out how to procede
  9. anton will post the slides immediately after the call


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
    2. abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
  2. anipbu2
    1. colindixon and anipbu2 to make sure that we get e-mail votes to release Beryllium-SR2 despite having no TSC meeting and people being at OpenStack
  3. colindixon
    1. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest and a TWS
    2. colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html
    3. colindixon to reach out to tykeal else to write up and send an e-mail about signing commits in gerrit
    4. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    5. colindixon and anipbu2 to make sure that we get e-mail votes to release Beryllium-SR2 despite having no TSC meeting and people being at OpenStack
  4. dfarrell07
    1. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest and a TWS
  5. edwarnicke
    1. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest and a TWS
  6. tykeal
    1. colindixon to reach out to tykeal else to write up and send an e-mail about signing commits in gerrit
    2. tykeal to e-mail the TSC with the list of semi-archived silos to figure out how to procede


People present (lines said)

  1. colindixon (73)
  2. edwarnicke (12)
  3. odl_meetbot (12)
  4. anipbu2 (8)
  5. dfarrell07 (8)
  6. abhijitkumbhare (6)
  7. ebrjohn (4)
  8. gkaempfer_ (4)
  9. LuisGomez (3)
  10. zxiiro (3)
  11. mohnish (3)
  12. tykeal (2)
  13. phrobb (2)
  14. CaseyODL (1)
  15. gkaempfer (1)
  16. anipbu (1)


Generated by MeetBot 0.1.4.