#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:23 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:27)
    1. gkaempfer (gkaempfer, 17:00:33)
    2. Chris Price (ChrisPriceAB, 17:00:38)
    3. colindixon (colindixon, 17:00:39)
    4. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=47492#Agenda the agenda in it's usual place (colindixon, 17:00:48)
    5. Tony Tkacik (ttkacik, 17:00:52)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-06-23-17.00.html last week's meeting minutes (colindixon, 17:01:09)
    7. Daniel Farrell (dfarrell07, 17:01:48)
    8. Anil Vishnoi (vishnoianil, 17:02:37)
    9. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 17:02:44)
    10. ACTION: phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?) (colindixon, 17:02:54)
    11. ACTION: vishnoianil, phrobb and abhijitkumbhare to schedule a meeting to discussion the project categorization, so that it can be helpful for users who wants to propose a project proposal and looking for all the relevant projects in that scope. (colindixon, 17:03:20)
    12. Prem (for Abhijit K) (Prem_, 17:03:25)
    13. mohnish anumala (mohnish__, 17:03:36)
    14. ACTION: skitt or colindixon to work on removing the ancient org.eclipse dependencies in controller (and elsewhere?) (colindixon, 17:03:54)
    15. ACTION: phrobb to work on having a policy for how attendance to design forums works going forward with community involvement (colindixon, 17:04:44)
    16. ACTION: phrobb or colindixon to figure out how to communicate the fact that not just people with commits can attend the design forum (colindixon, 17:04:56)

  2. TSC mailing list votes and discussions (colindixon, 17:05:45)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-June/005407.html Asking the Board to Remove the Singularity Principle (colindixon, 17:06:11)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-June/005428.html Fast and/or Phased Planning for the Carbon Release (colindixon, 17:06:34)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-June/005377.html Additional questions in the Project Proposal Template (colindixon, 17:06:52)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-June/005475.html OpenDaylight has a new Director of Ecosystem Development: Lisa Caywood (@RealLisaC on twitter) (colindixon, 17:07:40)
    5. https://lists.opendaylight.org/pipermail/tsc/2016-July/005539.html escalation process we have in OpenDaylight (colindixon, 17:08:16)
    6. https://lists.opendaylight.org/pipermail/tsc/2016-July/005538.html better understanding the wiki search engine whitelist (colindixon, 17:08:38)
    7. https://lists.opendaylight.org/pipermail/tsc/2016-July/005540.html removing "draft" from committer promotion process (colindixon, 17:09:02)
    8. https://wiki.opendaylight.org/view/TSC:Committer_Promotion_Process#Nomination_for_committer_promotion the actual document (colindixon, 17:09:35)
    9. colindixon asks if anyone objects to taking draft off of the process (colindixon, 17:10:21)
    10. AGREED: the committer promotion process here is no long a draft: https://wiki.opendaylight.org/view/TSC:Committer_Promotion_Process#Nomination_for_committer_promotion (colindixon, 17:10:50)
    11. ACTION: colindixon to remove draft from the committer promotion process (colindixon, 17:11:00)
    12. https://lists.opendaylight.org/pipermail/tsc/2016-July/005499.html having one TSC meeting a month at an APAC-friendly time (colindixon, 17:11:17)
    13. https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=3&min=30&sec=0&p1=771&p2=33&p3=283&p4=263&p5=37 9a India, 11:30a China, 8:30p pacific, 11:30p eastern, and 5:30a central Europe (colindixon, 17:12:28)
    14. https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=8&min=0&sec=0&p1=771&p2=33&p3=283&p4=263&p5=37 1:30p India, 4p China, 1a pacific, 4a eastern, 10a central Europe (colindixon, 17:13:02)
    15. https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=2&min=0&sec=0&p1=771&p2=33&p3=283&p4=263&p5=37 7:30a India, 10a China, 7p pacific, 10p eastern, 4a in CET (colindixon, 17:15:13)
    16. Prem_ points out we need to also look at DST and how it affects things (colindixon, 17:16:10)
    17. vishnoianil asks if anyone is asking for this, Prem_ says it would help people he knows, colindixon notes that it's come up on his trips Chia (colindixon, 17:16:43)
    18. davidmichaelkarr points out that we should ask peole in the time zones where this sucks if it helps them or not (colindixon, 17:17:09)
    19. ACTION: colindixon to set up a condorcet election with PTLs and TSC members as voters and the 3 options + don't have an alternate meeting as options (colindixon, 17:18:01)
    20. colindixon also notes that having a home office is not as common in India and China, which means asking them to attend is asking them to be *in the office* at that time (colindixon, 17:20:16)
    21. vishnoianil points out we need to make sure we get a quorum of TSC members (colindixon, 17:20:44)
    22. ACTION: colindixon to make sure there's a place for feedback with the vote (colindixon, 17:22:23)
    23. mohnish__ asks aout as-need basis, colindixon and Prem_ point out that as-needed ususally winds up meaning it doesn't happen (colindixon, 17:22:55)
    24. anipbu asks if we've polled APAC members, colindixon says no, but he doesn't even know who to poll because they mostly don't attend, ttkacik notes that for the TSC we probably do know: it's PTLs, TSC members, and maybe committers, for TWS it might make more sense to be broader (colindixon, 17:25:40)

  3. events (colindixon, 17:26:06)
    1. https://www.opendaylight.org/global-events (colindixon, 17:26:15)
    2. https://www.opendaylight.org/events/linuxcon-japan linuxcon japan in Tokyo next week (colindixon, 17:26:41)
    3. dfarrell07 has a talk and a keynote panel in LinuxCon Tokyo (dfarrell07, 17:27:21)
    4. the OpenDaylight summit in September (colindixon, 17:27:38)
    5. the CFP for OpenStack Barcelona closes on 7/13 (that's next week) (colindixon, 17:28:16)
    6. https://www.opendaylight.org/events/opendaylight-forum-india November 16, 2016 OpenDaylight Forum India Bengaluru (colindixon, 17:28:33)
    7. CFP for India ODL forum closes 8/3 (colindixon, 17:29:09)
    8. gkaempfer asks if we have CFPs for developer design forums, colindixon says we haven't in the past, we've done it out-of-band via e-mail/wiki (colindixon, 17:29:55)
    9. ACTION: phrobb to create a wiki page with topics for the September DDF (colindixon, 17:30:12)

  4. boron (colindixon, 17:30:27)
    1. The Boron Autorelease job is currently failing to build bgp-rib-impl. (anipbu, 17:31:03)
    2. https://git.opendaylight.org/gerrit/#/c/41354/ <--- Patch Fixing (anipbu, 17:31:05)
    3. Reminder to Offset 0 projects that code freeze was last week and to please send in the M5 Status: aaa, controller, infrautils, mdsal, netconf, yangtools (anipbu, 17:31:34)
    4. We will be upgrading ietf-{inet,yang}-types with the plan to merge independent patches first, obtain +2 for dependant patches, obtain TSC approval for superpowers to merge all together during an IRC working session. (anipbu, 17:32:16)
    5. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=778533050 (anipbu, 17:32:24)
    6. bgpcep patch merged (ttkacik, 17:33:18)
    7. colindixon points out that this is a trade-off either way, we leave it there and stay behind the standard for another six months or we try to push forward and fix any unexpected breakages, there has been some testing (colindixon, 17:36:15)
    8. VOTE: Voted on "shall the TSC allow the release team to +2 (if needed) and submit patches that have already been +1ed or +2ed by the a committer of that project to help migrate to the new ieft types?" Results are, +1: 8 (colindixon, 17:41:02)
    9. AGREED: the release engineering team can +2 (if needed) and submit patches that have already been +1ed or +2ed by the a committer of that project to help migrate to the new ieft types (colindixon, 17:41:32)
    10. ttkacik and colindixon say that in the future, we shoudl try to make this +2 and not +1 or +2 (colindixon, 17:41:52)
    11. ACTION: anipbu to send an e-mail explaining the plan for merging patches concerning the ietf types upgrade to release (and thus all PTLs) (colindixon, 17:42:21)
    12. anipbu asks if 7a pacific, on wednesday 7/13 would be a good time to do the process on IRC, noboy objects, jamoluhrsen won't be able to join until 8:30a (colindixon, 17:43:48)

  5. stable/beryllium (colindixon, 17:44:12)
    1. there are autorelease build test failures in bgpcep. Kindly request to fix before the Beryllium SR3 Cutoff (anipbu, 17:44:35)
    2. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-beryllium/211/ <--- BGPCEP Autorelease Build Test Failures (anipbu, 17:44:41)
    3. tpanteli says that it might be the same as master, jamoluhrsen says they look different (colindixon, 17:45:29)

  6. system integration and test (colindixon, 17:45:54)
    1. jamoluhrsen and anipbu would like to remind people to get system tests in order or risk being labeld experimental (colindixon, 17:46:14)

  7. infrastructure (colindixon, 17:46:18)
    1. https://lists.opendaylight.org/pipermail/release/2016-July/007108.html Ongoing issues with the migration to the private cloud (colindixon, 17:46:50)
    2. migration to the private cloud finished on 6/25 and 6/26, we've been seeing some pain, but it's been decreasing (colindixon, 17:47:17)
    3. there is no way to move back sanely at this point, or we would have (colindixon, 17:47:28)
    4. build minions are all single-use instances to avoid losing hung jobs, this has helped the queue a lot (colindixon, 17:47:52)
    5. all jobs now have a 6 hour timeout by default, but it's adjustable, times that had different timeouts should still have them (colindixon, 17:48:31)
    6. we're adjusting our instances and types of instances to keep the queue reasonable (colindixon, 17:48:56)
    7. tykeal is working with rackspace to redesign how we use the public cloud so that we can burst into the public cloud, we would then to performance, integration, and long-running testing back into the public cloud to alleviate burden (colindixon, 17:49:36)
    8. we have lots of tests failing because we have less CPU available, people are trying to fix it for some places where it's just timeouts (colindixon, 17:51:03)
    9. right now, we can't change the CPU per job or per-project, but zxiiro is working on our JJB templates to make that possible (colindixon, 17:51:34)
    10. we are seeing some timeouts to nexus and that's being investigated now (colindixon, 17:51:48)
    11. colindixon asks if there's a reason to the private cloud is resource constrained, and is there a way to fix it? (colindixon, 17:52:39)
    12. tykeal says when we asked rackspace to build a private cloud for us, our budget limited us to 192 CPUs in the private cloud, which was theoretically unlimited (colindixon, 17:53:26)
    13. solutions: 1.) get board approval to get more h/w in our private cloud, 2.) enable bursting into the public cloud (colindixon, 17:54:52)
    14. tykeal is hoping to have the public cloud up and working by the end of next week, but it's not certain (colindixon, 17:55:17)
    15. CaseyODL asks for local meetup leaders to respond to his e-mail (colindixon, 18:01:30)

  8. cookies (colindixon, 18:01:38)


Meeting ended at 18:01:48 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  2. phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?)
  3. vishnoianil, phrobb and abhijitkumbhare to schedule a meeting to discussion the project categorization, so that it can be helpful for users who wants to propose a project proposal and looking for all the relevant projects in that scope.
  4. skitt or colindixon to work on removing the ancient org.eclipse dependencies in controller (and elsewhere?)
  5. phrobb to work on having a policy for how attendance to design forums works going forward with community involvement
  6. phrobb or colindixon to figure out how to communicate the fact that not just people with commits can attend the design forum
  7. colindixon to remove draft from the committer promotion process
  8. colindixon to set up a condorcet election with PTLs and TSC members as voters and the 3 options + don't have an alternate meeting as options
  9. colindixon to make sure there's a place for feedback with the vote
  10. phrobb to create a wiki page with topics for the September DDF
  11. anipbu to send an e-mail explaining the plan for merging patches concerning the ietf types upgrade to release (and thus all PTLs)


Action items, by person

  1. anipbu
    1. anipbu to send an e-mail explaining the plan for merging patches concerning the ietf types upgrade to release (and thus all PTLs)
  2. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    2. skitt or colindixon to work on removing the ancient org.eclipse dependencies in controller (and elsewhere?)
    3. phrobb or colindixon to figure out how to communicate the fact that not just people with commits can attend the design forum
    4. colindixon to remove draft from the committer promotion process
    5. colindixon to set up a condorcet election with PTLs and TSC members as voters and the 3 options + don't have an alternate meeting as options
    6. colindixon to make sure there's a place for feedback with the vote
  3. dfarrell07
    1. phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?)
  4. vishnoianil
    1. vishnoianil, phrobb and abhijitkumbhare to schedule a meeting to discussion the project categorization, so that it can be helpful for users who wants to propose a project proposal and looking for all the relevant projects in that scope.
  5. UNASSIGNED
    1. phrobb to work on having a policy for how attendance to design forums works going forward with community involvement
    2. phrobb to create a wiki page with topics for the September DDF


People present (lines said)

  1. colindixon (88)
  2. odl_meetbot (12)
  3. anipbu (9)
  4. ChrisPriceAB (7)
  5. dfarrell07 (7)
  6. gkaempfer (5)
  7. ttkacik (4)
  8. mohnish__ (3)
  9. Prem_ (3)
  10. lori (2)
  11. vishnoianil (2)
  12. tykeal (1)
  13. jamoluhrsen (1)


Generated by MeetBot 0.1.4.