17:00:22 <colindixon> #startmeeting tsc
17:00:22 <odl_meetbot> Meeting started Thu Jul 21 17:00:22 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:22 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:28 <colindixon> #topic agenda bashing and roll call
17:00:33 <colindixon> TSC members please #info in
17:00:38 <gkaempfer> #info gkaempfer
17:00:44 <colindixon> #info colindixon
17:00:50 <Chrisy> #info Chris Luke for Ed Warnicke
17:00:54 <ttkacik> #info ttkacik
17:00:56 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=47803 agenda in the usual place
17:01:04 <vishnoianil> #info Anil Vishnoi
17:01:06 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-07-14-17.00.html last week's meeting minutes
17:01:18 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005594.html vishnoianil, phrobb and abhijitkumbhare started a discussion the project categorization, so that it can be helpful for users who wants to propose a project proposal and looking for all the relevant projects in that scope.
17:01:25 <colindixon> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2016-July/005525.html colindixon to reached out to openflowplugin devs about whether we could at least keep them through the Boron release
17:01:34 <abhijitkumbhare> #info abhijitkumbhare
17:01:36 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-July/007250.html distribution size is fixed for now, but some attention is needed in the longer run
17:01:47 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-July/007288.html Thanh started a thread on changes in releng/builder and jenkins jobs
17:01:54 <colindixon> #info Chrisy reached to to edwarnicke about fast and/phased carbon, but didn't hear anything
17:02:08 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005614.html thread on committing to a Carbon release outline by 7/28 (with links to sample Carbon release plan and tentative dates)
17:02:16 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan sample carbon release plan (with tentative dates)
17:02:25 <snackewm> #info snackewm for Uri
17:02:28 <colindixon> #action anipu to follow up with relevant projects about distribution size: https://lists.opendaylight.org/pipermail/release/2016-July/007250.html
17:03:10 <colindixon> #action skitt or colindixon to work on removing the ancient org.eclipse dependencies in controller (and elsewhere?)
17:03:13 <colindixon> #action colindixon and phrobb to set up a poll of committers, PTLs and TSC members to see if there's a desire to have one TSC meeting a month at an APAC-friendly time
17:03:22 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon?
17:03:24 <rovarga> #info rovarga for jmedved
17:03:53 <colindixon> phrobb to work on having a policy for how attendance to design forums works going forward with community involvement
17:03:56 <colindixon> #action phrobb to work on having a policy for how attendance to design forums works going forward with community involvement
17:03:59 <tykeal> on would think that as often I have to type the access code I would have it memorized...
17:04:39 <colindixon> #action phrobb and dfarrell07 to drive forward tooling and planning for the next TSC election (TWS?)
17:04:49 <dfarrell07> #info Daniel Farrell
17:04:52 <mohnish__> #info mohnish anumala
17:05:07 <anipbu> https://lists.opendaylight.org/pipermail/release/2016-July/007369.html
17:05:30 <phrobb> #linkhttps://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum <- pointer to Carbon DDF Topics wiki page
17:05:34 <colindixon> #undo
17:05:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2597f50>
17:05:45 <colindixon> #info mohnish__ is attending
17:06:05 <phrobb> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum <- pointer to Carbon DDF Topics wiki page
17:06:06 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-July/007369.html mail asking projects for input on how infrastructure issues have affected them and will affect their release
17:07:21 <colindixon> #topic mailing list discussions
17:07:32 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005499.html  having one TSC meeting a month at an APAC-friendly time
17:07:44 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005539.html  escalation process we have in OpenDaylight
17:07:57 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005538.html  better understanding the wiki search engine whitelist
17:09:07 <colindixon> #info the current way it works, is with NOFOLLOW, anything that's on the homepage and anything that's in the project list are on the list of "follow" pages, that are easy to search for
17:10:05 <colindixon> #info this does seem to be working better than before, but there are some bugs
17:10:29 <colindixon> #info the current process for updating it is to basically ask for a page to be added to the list of follow pages, but it has to be linked to from a follow list
17:10:43 <colindixon> #action colindixon to follow up on the whitelist (follow/nofollow) thread with this information
17:11:16 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-June/005377.html  Additional questions in the Project Proposal Template
17:11:37 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-June/005428.html  Fast and/or Phased Planning for the Carbon Release (may be moot at this point)
17:11:46 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-June/005407.html  Asking the Board to Remove the Singularity Principle
17:11:57 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005594.html  Categorizing projects, both on the wiki and for new projects to browse
17:12:12 <colindixon> #action colindixon to try to drive some/all of these ongoing discussions to completion
17:12:38 <colindixon> #topic events
17:12:44 <colindixon> #link https://www.opendaylight.org/global-events
17:13:12 <colindixon> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum <- pointer to Carbon DDF Topics wiki page
17:13:21 <colindixon> #topic boron
17:13:25 <colindixon> #chair phrobb anipbu
17:13:25 <odl_meetbot> Current chairs: anipbu colindixon phrobb
17:13:42 <anipbu> #info We will be introducing changes the deviation statement API in yangtools, affecting DeviateDefinition.  The only impacted projects should be mdsal.
17:13:47 <anipbu> #link https://wiki.opendaylight.org/view/Weather#Change_of_deviation_statement_API_in_yangtools   <--- Weather item for deviation statement API
17:14:08 <anipbu> #info We will be cutting branches and version bumping all the projects in unison at M5-Offset2
17:14:13 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-July/007354.html   <--- Notification email regarding branch cutting
17:14:32 <anipbu> #info The Boron Autorelease job was failing this week due to compilation errors in centinel-streamhandler.  It has been fixed with patch 41969.
17:14:37 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/187/org.opendaylight.centinel$centinel-streamhandler/   <--- Autorelease failure in centinel
17:14:40 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/41969/   <--- Patch fixing boron autorelease
17:14:55 <anipbu> #info Boron M5 Offset 1 are due today 7/21/2016.  Projects should take a moment to send their status.
17:15:06 <anipbu> #info We are missing M5 Status from three projects: controller (Tony Tkacik), infrautils (Guy Sela), netconf (Tomas Cere)
17:15:22 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-July/007379.html   <--- Status Email Template
17:15:40 <anipbu> #info We would like to request feedback from projects if recent issues affected your schedule or project readiness in Boron
17:15:45 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-July/007369.html   <--- Polling projects on readiness
17:18:08 <colindixon> #info rovarga says that we're going to need tcpmd5 in Boron until sndinterface app drops it's dependence on tcpmd5, but we don't know when to expect that
17:18:24 <colindixon> #action anipbu to reach out to sdninterfaceapp about removing dependency on tcpmd5
17:19:06 <colindixon> #info colindixon adds that in the past, we've allowed people to pull in release versions from prior versions, but rovarga says that this might not work with some config subsystem changes
17:20:01 <colindixon> #info vishnoianil asks how to solve this problem generally, if projects drop that others need
17:20:52 <colindixon> #info colindixon says that this is usually handled out-of-band, for example we were able to convince snmp to participate to prevent problems
17:21:29 <colindixon> #info anipbu and rovarga note that they reached out to the people depending on tcpmd5 to migrate away from it, and sdninterfaceapp hasn't engaged there
17:22:16 <anipbu> https://lists.opendaylight.org/pipermail/sdninterfaceapp-dev/2016-April/000121.html
17:22:58 <colindixon> #link https://lists.opendaylight.org/pipermail/sdninterfaceapp-dev/2016-April/000121.html this was there response on 4/12: "SDNINTERFACEAPP is primarily dependent on BGPCEP project. There is no impact on SDNINTERFACEAPP  functionality."
17:23:56 <colindixon> #info rovarga says that's not true, it's actually a complete copy of BGPCEP code in sndinterfaceapp
17:24:30 <colindixon> #info vishnoianil asks what's the next steps, colindixon says it's basically drop the dependency or they will be dropped from the release
17:25:34 <colindixon> #topic stable/beryllium
17:25:38 <anipbu> #info Beryllium SR3 is in one week with a release on July 28, 2016 with a cutoff on Sunday July 24 11:59PM UTC
17:25:50 <anipbu> #info We have Beryllium Autorelease issues related to bgpcep and vpnservice
17:26:00 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-beryllium/224/testReport/   <--- Beryllium Build Test Failures
17:26:15 <anipbu> #info We have Beryllium Distribution Test issues in aaa, bgpcep, netconf, nic, ovsdb, snmp, sxp, topoprocessing, usc
17:26:25 <anipbu> #link https://jenkins.opendaylight.org/releng/job/integration-distribution-test-beryllium/458/   <--- Beryllium Distribution Test Failures
17:28:06 <colindixon> #info zxiiro says the branch won't be frozen for this, but any pushed patches won't be included unless we respin, any new features (e.g., non-fixes) will have to be reverted before respins
17:29:05 <colindixon> #info anipbu asks if we should only allow fixes for blocking fixes
17:29:42 <colindixon> #Info colindixon and anipbu think that's probably the best idea to keep stability and lower-risk in case of respin before we release
17:30:37 <colindixon> #agree at least for now, the TSC says that only fixes for blocking issues should be submitted to stable/beryllium between the first cut and the formal release, other fixes will be reverted
17:30:58 <colindixon> #topic system integration and test
17:31:08 <colindixon> #info jamoluhrsen says everything so far has been covered
17:32:10 <colindixon> #action jamoluhrsen to send out a list of projects that would currently be labeled as experimental (the data will be from a few months ago) and ask projects to update it if they think they're no longer there
17:32:52 <colindixon> #topic infrastructure
17:33:23 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005613.html e-mail from rovarga (and follow-ups from others) about the implications of infrastructure issues on the release
17:33:53 <colindixon> #info tykeal stopped working on the LDAP replica, when he was unblocked on getting public cloud instances so that we can migrate jobs back into the public cloud
17:34:08 <colindixon> #info zxiiro is working on moving integration jobs back into the public cloud as we speak
17:34:39 <colindixon> #info tykeal is now back to working on an LDAP replica that would be in the private cloud to see if it fixes Nexus timeouts and other issues
17:35:02 <colindixon> #info tykeal says he hopes to have the LDAP replica up by the end of this week, and desperately hopes it will be up by early next week
17:35:23 <colindixon> #info if this doesn't fix the issue, we'll have to start a new round of debugging, which nobody is looking forward to
17:36:16 <colindixon> #info the failures to clone seem to be due to a large number of jobs that come in all at the same time (these are typically from matrix jobs, i.e., verify jobs) and then hurting gerrit which slows to a crawl, gerrit is already tuned as best they can figure
17:37:08 <colindixon> #info the fix to this is slowly migrating its way out zxiiro and our new release engineer are converting matrix jobs out into normal jobs, which should relieve pressure on gerrit, and help with cloning
17:37:26 <rovarga> zxiiro: btw. yangtools and coretutorials have those patches +1'd
17:37:50 <colindixon> #info rovarga notes that coretutorials and yangtools have already +1ed their move away from matrix jobs
17:38:04 <zxiiro> rovarga: thanks, i'll ping some folks to get it merged since releng/builder has a non-author check
17:39:16 <colindixon> #info SNAPSHOTs disappearing shouldn't happen because we have periodic merge jobs, but if they fail there's nothing for it, projects need to pay attention
17:40:13 <colindixon> #info colindixon says we've set up our infrastructure to be resilient to delinquent projects, this is an example of a place where we aren't resilient to that
17:40:28 <colindixon> #info rovarga asks if we could get a dashboard of this, tykeal says we have an "all merge jobs" tab in jenkins
17:41:28 <colindixon> #link https://jenkins.opendaylight.org/releng/view/Merge-Jobs/ the link tykeal was talking about for all merge jobs
17:42:39 <colindixon> #info rovarga notes that this page includes for all releases and projects that aren't in boron
17:43:33 <colindixon> #info colindixon asks if we can have failed periodic merge jobs e-mail release@lists.opendaylight.org
17:44:00 <colindixon> #action colindixon to start a thread on how we can better track projects which haven't merged in a while
17:44:55 <colindixon> #info tykeal says that we should be able to resolve OutOfMemory errors by asking for a larger instance size based on zxiiro's work to split apart all of our jobs, so they should be fix-able if not fixed
17:46:15 <colindixon> #info zxiiro notes that things run by default with 8G of ram and LuisGomez says that OOM errors are often not really that
17:46:58 <colindixon> #info rovarga says that the SingleFeatureTest caps heap size at 2G, which is where this is coming from, which worries him that we have single features that can't be installed with 2G of heap
17:47:26 <colindixon> #info LuisGomez says OOM in SingleFeatureTest is often something being wrong in the feature dependencies
17:51:20 <colindixon> #info rovarga asks about the bottom line, will we miss the deadline, tykeal said that the only remaining issue would be nexus timeouts that should be going away when the replica is live by early next week
17:53:33 <colindixon> #info colindixon says his take is that he's gone from ~95% sure we wouldn't slip a few weeks back to 70-80% sure that we won't slip now, but he's still optimistic if things continue to improve
17:56:12 <colindixon> #Info vishnoianil asks for utilization stats to figure out if we can understand where we are now and will be as we move to testing, tykeal says he can't right now, but there's an open issue with rackspace
17:56:36 <colindixon> #info colindixon suggests that looking at jenkins queue depth, even on an hourly basis, would be really helpful
17:56:53 <mohnish__> Have to drop off because of another meeting.
17:58:17 <colindixon> #topic carbon release plans
17:58:39 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005614.html mail stating that we need an outline by 7/28 (next week)
17:58:57 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan sample release plan (with tentative)
18:00:16 <colindixon> #Info colindixon says his intuition is that we should approve this outline next week to get some clarity to projects, unless there's a really compelling reason not to
18:00:34 <colindixon> #info please, please get feedback so we can vote in the next meeting, to keep the deadline we set for ourselves
18:00:43 <Chrisy> (have to run, ttyl)
18:00:51 <colindixon> #topic cookies
18:00:55 <colindixon> #endmeeting