17:40:18 <colindixon> #startmeeting tsc
17:40:18 <odl_meetbot> Meeting started Thu Jul 28 17:40:18 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:40:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:40:18 <odl_meetbot> The meeting name has been set to 'tsc'
17:40:45 <vishnoianil> #info Anil Vishnoi
17:40:46 <abhijitkumbhare> #vote +1
17:40:58 <colindixon> #agree the TSC authorizes zxiiro, tykeal, and anipbu to release SR3 if the bug In NIC is found to be non-blocking, otherwise we will vote on the mailing list no later than Monday (there were 9 +1s so consensus)
17:41:04 <ChrisPriceAB> lol
17:41:10 <colindixon> #topic carbon
17:41:35 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-07-28-17.00.html this is actually a continouation of the TSC meeting here
17:41:56 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005614.html we agreed that we would set tentavie dates for Carbon by today
17:42:13 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan  sample carbon release plan (with tentative dates)
17:42:40 <gkaempfer> Question: Why is the release 8 months after Boron while the cadence is 6 months?
17:42:51 <colindixon> gkaempfer: we've never gotten donwn 6 months
17:43:06 <Chrisy> "nominally" 6 months
17:43:11 <colindixon> we with RCs we and offsets, we pretty much always have an 8-month cadence
17:45:10 * ChrisPriceAB thinks if we plan ahead the "slack" may not be needed for a time based release.
17:45:24 <colindixon> #info gkaempfer asks Why is the release 8 months after Boron while the cadence is 6 months?
17:45:37 <gkaempfer> Understood the explanation. Tnx. I was just wondering if it wouldn't be nice to keep a fixed offset from OpenStack releases (especially in the NetVirt context)...
17:46:27 <colindixon> #Info colindixon explains that we basically have 6 4 week periods (M1-M5 and then RCs), the we have 4 weeks from offsets, and then a few weeks of slack in there
17:47:02 <anipbu> Lunar New Year is January 28, which falls into the M3 Offset 2 timeframe (recall that M3 is the toughest Milestone).
17:47:30 <colindixon> #info vishnoianil asks if we could cut it down to 6 months, some ideas would be to cut one milestone (M1?) or to cut the distance betwen milestones down to 3 weeks
17:47:48 <colindixon> #info anipbu notes that Lunar New Year is January 28, which falls into the M3 Offset 2 timeframe (recall that M3 is the toughest Milestone)
17:48:30 <colindixon> #info abhijitkumbhare asks if we're trying to target a specific month for this release (or the next one), do we have an ODL summit 2017 date yet
17:49:11 <gkaempfer> For companies that want to release products based on ODL, an 8 month cycle seems a bit long (and implies irregularity with respect to release dates within the year)
17:50:25 <colindixon> #info colindixon says he'd rather not tie things to the summit and that would be Nitrogen not Carbon, also as our releases calm down a bit, having the release coincide with the summit, might not be required
17:51:45 <ChrisPriceAB> It would really help consumers of ODL if we released based on dates.  Both other communities and commercial vendors.
17:52:13 <colindixon> #info ChrisPriceAB and gkaempfer both say that it woudl help a lot of if we could hit a date-based release process, where we shipped twice a week
17:52:33 <gkaempfer> Agree with ChrisPriceAB
17:52:39 <ChrisPriceAB> Year ^^
17:52:52 <ChrisPriceAB> twice a week might be tough colindixon
17:53:02 <colindixon> #undo
17:53:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2495050>
17:53:05 <colindixon> #info ChrisPriceAB and gkaempfer both say that it woudl help a lot of if we could hit a date-based release process, where we shipped twice a year
17:59:02 <colindixon> #info colindixon says that his feeling and based on past discussion, the M1 milestone is the one that has the least value, and then if we moved M1 to M0 and then dropped the 2 week gap between the Boron release and M0, that would put the release at 3/30, which would be a lot closer to every 6 months
17:59:14 <colindixon> #topic shuva as a committer on openflow plugin
17:59:35 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005645.html  Shuva Jyoti Kar as OpenFlow Plugin committer
17:59:52 <colindixon> #startvote shall the TSC approve Shuva Jyoti Kar as an OpenFlow plugin committer? -1,0,+1
17:59:52 <odl_meetbot> Begin voting on: shall the TSC approve Shuva Jyoti Kar as an OpenFlow plugin committer? Valid vote options are -1, 0, +1.
17:59:52 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:00:14 <vishnoianil> #vote +1
18:00:15 <colindixon> #info he has more than 50 merged patches
18:00:17 <colindixon> #vote +1
18:00:22 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/owner:shuva.jyoti.kar%2540ericsson.com+status:merged
18:00:23 <adetalhouet> #vote +1
18:00:25 <gkaempfer> #vote +1
18:00:32 <abhijitkumbhare> #vote +1
18:00:33 <Chrisy> #vote +1
18:00:34 <snackewm> #vote +1
18:00:35 <ChrisPriceAB> #vote +1
18:00:37 <colindixon> #endvote
18:00:37 <odl_meetbot> Voted on "shall the TSC approve Shuva Jyoti Kar as an OpenFlow plugin committer?" Results are
18:00:37 <odl_meetbot> +1 (8): gkaempfer, adetalhouet, Chrisy, ChrisPriceAB, colindixon, abhijitkumbhare, snackewm, vishnoianil
18:00:44 <colindixon> #agreed Shuva is committer on OpenFlow plugin
18:00:45 <dfarrell07> #info dfarrell07 also votes +1
18:00:52 <colindixon> #topic carbon
18:01:02 <ChrisPriceAB> hehe, I almost missed it too dfarrell07
18:01:16 <dfarrell07> ChrisPriceAB: we're getting fast ;)
18:01:42 <vishnoianil> ChrisPriceAB, irc bot seems to favor you :), dfarrell07 time to hack the bot now :P
18:02:28 <ChrisPriceAB> the benefits of a personal optical link from Sweden.  challenging the speed of light...
18:02:54 <ChrisPriceAB> ack, agree with Mr Luis
18:03:14 <abhijitkumbhare> yes ChrisPriceAB :) - speed of light or sound? :)
18:04:09 <abhijitkumbhare> +1 ChrisPriceAB
18:04:27 <colindixon> #info rovarga says he thought he remember saying that the incoming TSC should approve the Carbon release, colindixon says that he remembered us talking about it but deciding that we wouldn't do that because it causes issues either way, either a new TSC inheriting a release plan, or a new one overseeing the final bits of a release
18:04:47 <colindixon> #info ChrisPriceAB poitns out that the TSC can change the release plan if they need to, so it seems like a non-issue
18:06:12 <colindixon> #startvote would you like to (1) approve the current tentative dates (8 months), (2) wait until next week to vote, (3) approve the tentative dates with a caveat that we might try to make 6 months with minimum changes? 1,2,3
18:06:12 <odl_meetbot> Begin voting on: would you like to (1) approve the current tentative dates (8 months), (2) wait until next week to vote, (3) approve the tentative dates with a caveat that we might try to make 6 months with minimum changes? Valid vote options are 1, 2, 3.
18:06:12 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:06:26 <ChrisPriceAB> #vote 3
18:06:30 <colindixon> #vote 1
18:06:31 <gkaempfer> #vote 2
18:06:33 <abhijitkumbhare> #vote 2
18:06:36 <colindixon> #info a vote for 1 is also a vote for 3
18:06:37 <adetalhouet> #vote 2
18:06:41 <snackewm> #vote #2
18:06:41 <odl_meetbot> snackewm: #2 is not a valid option. Valid options are 1, 2, 3.
18:06:50 <snackewm> #vote 2
18:06:52 <Chrisy> #vote 2
18:06:52 <vishnoianil> #vote 3
18:06:53 <dfarrell07> #vote 3
18:07:09 <Chrisy> (yes, I deferred it to when i don't have to vote)
18:07:21 <colindixon> #endvote
18:07:21 <odl_meetbot> Voted on "would you like to (1) approve the current tentative dates (8 months), (2) wait until next week to vote, (3) approve the tentative dates with a caveat that we might try to make 6 months with minimum changes?" Results are
18:07:21 <odl_meetbot> 1 (1): colindixon
18:07:21 <odl_meetbot> 3 (3): dfarrell07, ChrisPriceAB, vishnoianil
18:07:21 <odl_meetbot> 2 (5): Chrisy, snackewm, gkaempfer, abhijitkumbhare, adetalhouet
18:07:46 <colindixon> #action colindixon to send out a mail with possible trying to shift to 6 months
18:08:24 <gkaempfer> point taken
18:08:31 <colindixon> #topic cookies
18:08:34 <dfarrell07> thanks all:)
18:08:34 <colindixon> #endvote
18:08:38 <colindixon> #endmeeting