17:00:14 <colindixon> #startmeeting tsc
17:00:14 <odl_meetbot> Meeting started Thu Aug 18 17:00:14 2016 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:14 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:20 <colindixon> #topic roll call and agenda bashing
17:00:28 <colindixon> TSC members please #info in
17:00:31 <colindixon> #info colindixon
17:00:43 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=48426#Agenda the agenda in it's usual place
17:00:53 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-08-11-17.00.html last week's meeting minutes
17:01:04 <gkaempfer> #info gkaempfer
17:01:09 <colindixon> #chair phrobb anipbu
17:01:09 <odl_meetbot> Current chairs: anipbu colindixon phrobb
17:01:32 <colindixon> #link https://wiki.opendaylight.org/view/Wiki_gardening#Search_Engine_Indexing_of_the_wiki information on search engine indexing of the wiki
17:01:59 <colindixon> #link https://www.opendaylight.org/global-events LinuxCon North America and Europe are in the events list
17:02:04 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_Toolkit:Main https://wiki.opendaylight.org/view/Archive_Proposals/OpenDaylight_Toolkit#Archive_Vote_and_Date colindixon added the relevant bits on the wiki to archive toolkit
17:02:10 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-August/005836.html thread on whether we should only allow blocking bug fixes during RCs
17:02:13 <abhijitkumbhare> #info abhijitkumbhare
17:02:15 <ChrisPriceAB> #info Chris Price
17:02:21 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2016-August/007953.html it seems like the HTTP response codes from RESTCONF is likely to be reasonable
17:02:25 <adetalhouet> #info adetalhouet
17:02:43 <mohnish__> #info mohnish anumala
17:02:43 <colindixon> #info making sure that we can set the the nexus file size back to 512 MB again is being tracked on integration calls
17:03:16 <snackewm> #info snackewm (for uri)
17:03:27 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-August/005842.html phrobb's mail to projects to note that who the PTL is at the end of boron has implications for the TSC election, so figure it out if you have to
17:03:28 <colindixon> #action colindixon to e-mail out results of the APAC-time-zone poll
17:03:57 <colindixon> #Info so far we only have 5 responses, so please vote if you want to, it closes in 7 hours
17:04:03 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon?
17:04:09 <colindixon> #action colindixon to try to drive some/all of the ongoing TSC discussions to completion
17:04:21 <vishnoianil> #info Anil Vishnoi
17:04:29 <colindixon> #action anipbu to make sure we release note the change in HTTP RESTCONF RESPONSE codes
17:04:39 <colindixon> #action colindixon and edwarnicke to try to work through the corner cases and process of the TSC elections
17:04:49 <colindixon> #action everyone to review the other bits of the TSC elections, most notably the the representing multiple groups or projects and picking represented groups
17:05:10 <colindixon> #undo
17:05:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x264df90>
17:05:11 <colindixon> #undo
17:05:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x264db10>
17:05:30 <colindixon> #action colindixon and edwarnicke to try to work through the corner cases and process of the TSC elections https://wiki.opendaylight.org/view/TSC:Election_Proposal
17:05:38 <colindixon> #action everyone to review the other bits of the TSC elections, most notably the the representing multiple groups or projects and picking represented groups https://wiki.opendaylight.org/view/TSC:Election_Proposal
17:06:47 <jamoluhrsen> #info jamoluhrsen
17:06:56 <colindixon> #topic TSC mailing list votes and discussions
17:07:06 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-August/005809.html Policy on who can attend DDFs
17:07:16 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-August/005836.html only allow blocking bug fixes after RCs start in Carbon
17:07:28 <colindixon> #info older ones can be found in the agenda link above
17:08:13 <colindixon> #topic events
17:08:20 <colindixon> #link https://www.opendaylight.org/global-events
17:08:44 <colindixon> #info LinuxCon NA and OpenStack Days Easy coming up next week
17:09:05 <colindixon> #info we've finished the CFP for OpenDaylight Forum India, committee being formed
17:09:33 <colindixon> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum we really need topics for the Carbon DDF at the summit
17:10:25 <abhijitkumbhare> Muted :)
17:10:34 <colindixon> #topic Boron
17:10:49 <anipbu> #info We had build failures in FAAS and NETIDE but those issues have been fixed and resolved.
17:11:02 <anipbu> #info We had a TWS to discuss the MDSAL Binding Spec V2
17:11:10 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-August/007909.html <--- Recoding for MDSAL Binding Spec V2
17:11:16 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-August/007941.html <--- PowerPoint Presentation for MDSAL Binding Spec V2
17:11:23 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2016-August/007916.html <--- Email Thread Discussion for MDSAL Binding Spec V2
17:12:01 <anipbu> #info We continue the migration from AsciiDocs to reStructuredText. Request folks to review relevant patches and +1. Projects may also elect to opt out by informing the documentation team at documentation@lists.opendaylight.org
17:12:06 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:adoc2rst <--- Documentation Migration Patches
17:12:34 <anipbu> #info 6 projects affected by Restconf Response Migration. Projects should review the impact of the changes to Restconf Response.
17:12:48 <anipbu> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1846323581 <--- Tracking Restconf Response Impact
17:15:01 <anipbu> #info Projects please test and report blocking issues with Boron RC0.
17:15:07 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#RC0 <--- RC0 Download Information
17:15:11 <anipbu> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620 <--- RC0 Tracking Spreadsheet
17:15:22 <anipbu> #info The build for RC1 will start at 23:59:59 UTC on 8/18/2016
17:15:42 <anipbu> #info Projects PTL should sign up for timeslots for the Boron Release Review and provide links to their release notes and release review template
17:15:55 <anipbu> #link Sign Up Sheet: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020
17:16:04 <anipbu> #link Release Note: https://wiki.opendaylight.org/view/Sample_Release_Notes
17:16:10 <anipbu> #link Release Review Template: https://wiki.opendaylight.org/view/Sample_Release_Review
17:16:28 <anipbu> #info 9 projects have made changes to their yang files since RC0 Cutoff: groupbasedpolicy, netvirt, genius, openflowplugin, bgpcep, yangtools, aaa, of-config, sfc
17:16:33 <anipbu> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=RC+Status&Yang+File+Changes+Since+RC0=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2016-08-11
17:17:59 <edwarnicke> anipbu: Looking at these, quite a few look like blueprint migrations
17:18:04 <edwarnicke> (though not all)
17:18:35 <colindixon> #info ChrisPriceAB says things like the HTTP response codes should probably focus at least as much externally as internally, in particular, most of them will see no idea of whether this change is coming
17:18:41 <anipbu> edwarnicke: thanks for helping to review the yang files changes
17:18:51 <edwarnicke> anipbu: It was curious :)
17:19:04 <edwarnicke> anipbu: Overall, I very very much appreciate the query link
17:20:08 <colindixon> #info ChrisPriceAB says he doesn't think we should stop things over this, but says "we may make this change and have the world hate us for it, but that would be fine as long as we learn"
17:20:48 <colindixon> #info edwarnicke says that his take is that if we're going to fix this, we shoudl fix it now, not kick the can down the road
17:21:09 <abhijitkumbhare> edwarnicke: for the OFP changes two of them are requested by other projects - and we requested an API waiver - will follow up about the third one
17:21:43 <colindixon> #info one appraoch would be to deprecate it, set off alarms, etc. for one release (per ChrisPriceAB)
17:24:04 <colindixon> #action colindixon to ask how hard it woudl be to add a knob that was off-by-default that when enabled reverted HTTP response codes to the Beryllium values and if we can do in Boron
17:24:26 <abhijitkumbhare> edwarnicke: that was what I asked last meeting - whether we needed the knob to revert to the previous behavior
17:24:46 <edwarnicke> abhijitkumbhare: I never claimed to be the first expresser of smart ideas ;)
17:25:31 <colindixon> #info mohnish__ asks if we should do new (right) behavior by default or old (wrong) behavior by default, the latter would allow people to move without interruption
17:25:45 <abhijitkumbhare> edwarnicke :) . I meant it as a +1 :)
17:26:04 * edwarnicke finds it plausible that you expressed the idea first ;)
17:26:21 <colindixon> #info colindixon says that edwarnicke was suggesting the former to make sure people were actively aware that things were changing and not just replay things 6 months from now
17:26:53 <ChrisPriceAB> I think if we can do something that would be beneficial, if not I wouldn't see it as blocking but something to improve for the future.
17:28:06 <colindixon> #info vrpolak will involve changes in a YANG model that changes RESTCONF behavior, which will involve an API change, and to actually flip the switch, you'll need to edit an XML file
17:28:19 <colindixon> #topic system integration and test
17:28:32 <colindixon> #info all covered in infra
17:28:35 <colindixon> #topic infrastructure
17:29:10 <colindixon> #info zxiiro says that there's an issue we're aware of with rackspace public cloud where some CSIT nodes don't come online and we can't ssh to them, seems to happen about 1 time in 6 or 7
17:29:34 <colindixon> #Info jamoluhrsen says that this will affect distrirbution-test jobs, which is how we evaluate releases
17:30:40 <colindixon> #Info colindixon asks if CSIT will make it through that, jamoluhrsen says that we have many jobs which bring up 4+ nodes, that menas it fails with p=0.5 or so, which makes it a huge amount of busy
17:31:26 <colindixon> #info rackspace is working on it, we don't know of an ETA yet
17:31:59 <colindixon> #info colindixon notes that we're still seeing some Nexus timeouts, but much, much less
17:32:24 <colindixon> #info colindixon says he's seen 1 example and run something like 200 verifiy jobs yesterday
17:32:33 <colindixon> #info zxiiro says he's see 3 reports so far
17:32:50 <colindixon> #topic An Ho as committer on releng/autorlease
17:32:57 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-August/005833.html
17:33:05 <colindixon> #link https://lists.opendaylight.org/pipermail/dev/2016-August/002620.html votes
17:33:07 <abhijitkumbhare> Shall I autovote +1 :) ?
17:33:22 <edwarnicke> #vote +1
17:33:24 <vishnoianil> #vote +1
17:33:27 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/project:releng/autorelease+owner:%22A+H+%253Can.ho%2540huawei.com%253E%22
17:33:46 <adetalhouet> #vote +1
17:34:01 * ChrisPriceAB is waiting
17:34:07 <gkaempfer> #vote +1
17:34:11 <jamoluhrsen> #vote +1
17:34:13 <colindixon> #startvote shall the TSC approve An Ho as a committer on releng/autorelease? -1,0,+1
17:34:13 <odl_meetbot> Begin voting on: shall the TSC approve An Ho as a committer on releng/autorelease? Valid vote options are -1, 0, +1.
17:34:13 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:34:15 <ChrisPriceAB> #vote +1
17:34:17 <adetalhouet> #vote +1
17:34:18 <jamoluhrsen> #vote +1
17:34:18 <snackewm> #vote +1
17:34:19 <edwarnicke> #vote +1
17:34:19 <colindixon> #vote +1
17:34:19 <vishnoianil> #vote +1
17:34:20 <mohnish__> #vote +1
17:34:22 <abhijitkumbhare> #vote +1
17:34:26 <colindixon> #endvote
17:34:26 <odl_meetbot> Voted on "shall the TSC approve An Ho as a committer on releng/autorelease?" Results are
17:34:26 <odl_meetbot> +1 (9): mohnish__, adetalhouet, edwarnicke, ChrisPriceAB, snackewm, colindixon, vishnoianil, abhijitkumbhare, jamoluhrsen
17:34:40 <colindixon> #agreed An Ho is a committer on releng/autorelease? -1,0,+1
17:34:42 <colindixon> #Undo
17:34:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x24c31d0>
17:34:42 <adetalhouet> Congrats anipbu :)
17:34:44 <colindixon> #agreed An Ho is a committer on releng/autorelease
17:34:54 <jamoluhrsen> cool anipbu !
17:34:55 <abhijitkumbhare> Congrats anipbu
17:34:57 <edwarnicke> Congratulations An! Well deserved :)
17:35:08 <CaseyODL> Congrats, An! :)
17:35:25 <anipbu> Many Thanks Everyone!
17:35:35 <colindixon> congrats anipbu
17:35:43 <zxiiro> congrats An!
17:35:56 <colindixon> #topic TSC elections
17:36:16 <colindixon> #Info colindixon asks about people's readiness to discuss it
17:36:45 <colindixon> #info consensus seems like people need to catch up with the e-mail thread, but we could cover it for a bit
17:36:55 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Election_Proposal
17:37:43 <abhijitkumbhare> Probably jump to https://wiki.opendaylight.org/view/TSC:Election_Proposal#Represented_Group_Proposals ?
17:37:47 <colindixon> #info the two major remaining topics are (1) dealing with corner cases, (2) how we will mechanically use CIVS or something else to run the elctions, (3) picking represented groups
17:38:07 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Election_Proposal#All_Types.2C_Mature_Lifecycle_States this is the represented group option which seemed to get consensus, but there others above/below it
17:41:54 <colindixon> #info abhijitkumbhare asks why we have mature seats here if all the projects have to be mature, colindixon answers it's just to give extra representation to mature projects and an incentive to move to mature
17:43:10 <colindixon> #link colindixon notes that having 1/3 (5 seat) cap on mature projects, will probalby be a problem as the number of mature projects grows from where we are now with 8 mature projects: https://wiki.opendaylight.org/view/Category:Mature_Projects
17:43:45 <colindixon> #Info abhijitkumbhare aks if we really need caps for project categories at all, edwarnicke says that caps are trick and can be bad
17:44:20 <edwarnicke> #info to clarify... edwarnicke favors either no caps on any RG (including company caps) or uniform caps
17:44:57 <edwarnicke> #info edwarnicke 's point was that even company caps are *already* producing distortions where strong community members are being bumped
17:45:22 <colindixon> #Info ChrisPriceAB says he worries about how complicated this is and that it might make people have a disconnection between their vote and their results
17:46:50 <colindixon> #info in particular ChrisPriceAB notes that this would seem to potentially punish projects for becoming core and/or mature
17:47:02 <colindixon> #info some rehashing of the RG caps discussion
17:47:55 <ChrisPriceAB> lol
17:48:41 <colindixon> #info colindixon notes that we're not sure how and if CIVS actually supports scaled popularity and the like
17:49:30 <colindixon> #info also, we need to decide if somebody can be elected to the TSC twice in two different elections? also if somebody is the PTL of two projects in a group, do they get 2 votes?
17:52:43 <abhijitkumbhare> what’s the 17th amendment? :)
17:52:57 <colindixon> #info edwarnicke says his take is that PTLs are voting on behalf of the project, mohnish__ says that in that case, the PTL might have to poll the project, colindixon notes that in general, we let PTLs vote their conscience without having to consult the project on every issue
17:53:33 <colindixon> #info vishnoianil says it's not clear if PTLs are voting for themselves or voting for their project, if it's the latter, the PTL should probably get a number votes equal to the number of projects they're leading
17:55:56 <colindixon> #info vishnoianil asks how we solve this for committers-at-large, colindixon says that's an election over committers and not projects, so it's one person one vote
17:57:07 <colindixon> abhijitkumbhare: https://en.wikipedia.org/wiki/Seventeenth_Amendment_to_the_United_States_Constitution
17:58:40 <colindixon> #Info vishnoianil asks if you could vote two different ways with your two votes, phrobb and colindixon say that you might really want to allow that, phrobb also says that if somebody was PTL of projects in 2 different RGs, he would get one vote in each, so maybe he should get 2 votes in one RG
18:00:33 <adetalhouet> I have to drop to attend another meeting - I'll catch up IRC/mails for this topic
18:01:01 <colindixon> #info another corner case would be if the votes are open
18:01:20 <colindixon> #topic cookies
18:01:28 <colindixon> #endmeeting