#opendaylight-meeting: tsc

Meeting started by anipbu at 16:59:16 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (anipbu, 16:59:24)
    1. gkaempfer (gkaempfer, 17:00:08)
    2. rovarga for jmedved (rovarga, 17:00:15)
    3. anipbu for colindixon (anipbu, 17:02:19)
    4. Anil Vishnoi (vishnoianil, 17:02:36)
    5. lori for edwarnicke (lori, 17:02:44)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=48426#Agenda <--- TSC Meeting Agenda (anipbu, 17:02:47)
    7. mohnish anumala (mohnish__, 17:02:57)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-08-11-17.00.html <--- Last Week's Meeting Minutes (anipbu, 17:03:00)
    9. Prem (for Chris Price) (Prem_, 17:03:19)
    10. https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Release_Notes <--- TODO added to the Boron Release Notes for HTTP RESTCONF RESPONSE (anipbu) (anipbu, 17:03:23)
    11. https://lists.opendaylight.org/pipermail/netconf-dev/2016-August/000592.html <--- Email Notification for NETCONF team to add Boron Release Notes for HTTP RESTCONF RESPONSE (anipbu, 17:03:58)
    12. Daniel Farrell (dfarrell07, 17:04:07)
    13. https://lists.opendaylight.org/pipermail/tsc/2016-August/005853.html <--- Results of the APAC-time-zone poll (colindixon) (anipbu, 17:04:09)
    14. APAC-time-zone poll received 5 responses with the winning option: "We should hold one TSC per month at an APAC-friendly time" (anipbu, 17:04:17)
    15. ACTION: colindixon send out link to the actual APAC-time-zone poll to vote (anipbu, 17:05:21)
    16. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon? (anipbu, 17:05:53)
    17. ACTION: dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion (anipbu, 17:06:21)
    18. https://lists.opendaylight.org/pipermail/tsc/2016-August/005874.html <--- Work Through the Corner Cases and Process of the TSC elections (dfarrell, colindixon, edwarnicke) (anipbu, 17:06:35)
    19. LuisGomez standing for Abhijit (LuisGomez, 17:07:10)
    20. ACTION: colindixon to ask how hard it would be to add a knob that was off-by-default that when enabled reverted HTTP response codes to the Beryllium values and if we can do in Boron (anipbu, 17:07:10)

  2. TSC mailing list votes and discussions (anipbu, 17:07:38)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-August/005838.html <--- escalation process we have in OpenDaylight (anipbu, 17:07:48)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-August/005839.html <--- Additional questions in the Project Proposal Template (anipbu, 17:07:58)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-August/005827.html <--- Fast and/or Phased elements in Carbon (anipbu, 17:08:10)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-August/005809.html <--- Policy on who can attend DDFs (anipbu, 17:08:21)
    5. https://lists.opendaylight.org/pipermail/tsc/2016-August/005836.html <--- only allow blocking bug fixes after RCs start in Carbon (anipbu, 17:08:37)
    6. https://lists.opendaylight.org/pipermail/tsc/2016-August/005806.html <--- Categorizing projects, both on the wiki and for new projects to browse (anipbu, 17:08:52)
    7. older ones can be found in the agenda link above (anipbu, 17:09:06)

  3. events (anipbu, 17:09:39)
    1. https://www.opendaylight.org/global-events <--- OpenDaylight Events (anipbu, 17:09:51)
    2. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum <--- Carbon Dev. Design Forum Topics (anipbu, 17:10:04)
    3. Please fill in topics for the upcoming Carbon Dev. Design Forum on the wiki page (anipbu, 17:10:10)
    4. During the DDF we will have a joint session with the OPNFV project developers to discuss ways of collaborating better for our next upcoming releases. (anipbu, 17:10:23)
    5. https://www.opendaylight.org/events/2016-09-27-000000-2016-09-29-000000/opendaylight-summit-2016 <--- OPENDAYLIGHT SUMMIT 2016 Tuesday, September 27, 2016 to Thursday, September 29, 2016 (anipbu, 17:10:47)
    6. Reminder for the community to register for the summit and DDF (anipbu, 17:10:58)

  4. Boron (anipbu, 17:11:35)
    1. https://wiki.opendaylight.org/view/Weather#Table_features_off_by_default <--- The table-features has been turned off by default in the stable/boron branch. For those who require it, follow the instructions on the user guide listed on the weather page item. (anipbu, 17:12:03)
    2. https://wiki.opendaylight.org/view/Weather#Distribution_Size <--- Distribution size limit will be set back to 512 (anipbu, 17:12:17)
    3. size has been set to 512 <done> (anipbu, 17:12:52)
    4. https://git.opendaylight.org/gerrit/#/c/44602/ <--- We had build failures in NETVIRT but those issues have been fixed and resolved. (anipbu, 17:13:07)
    5. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#RC1 <--- RC1 Download Information (anipbu, 17:13:22)
    6. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620 <--- Projects Please Test and Report Blocking Issues with Boron RC1 (anipbu, 17:13:32)
    7. The build for RC2 will start at 23:59:59 UTC on 8/25/2016 (anipbu, 17:14:00)
    8. Following the same process as Beryllium, only blocking bugs after RC2. One week until final build RC3. As per the Simultaneous Release Plan, the RC3 build will be released if it is found to be free of blocking bugs. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule (anipbu, 17:14:40)
    9. Projects PTL should provide links to their release notes and release review template for the Release Review (anipbu, 17:14:54)
    10. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020 <--- Boron Release Review Schedule (anipbu, 17:15:10)
    11. https://wiki.opendaylight.org/view/Sample_Release_Notes <--- Release Note (anipbu, 17:15:14)
    12. https://wiki.opendaylight.org/view/Sample_Release_Review <--- Release Review Template (anipbu, 17:15:20)
    13. 6 projects have made changes to their yang files since RC1 Cutoff: groupbasedpolicy, openflowplugin, faas, netvirt, honeycomb/vbd, aaa (anipbu, 17:16:51)
    14. https://git.opendaylight.org/gerrit/#/dashboard/?title=RC+Status&Yang+File+Changes+Since+RC1=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2016-08-18 (anipbu, 17:17:03)

  5. system integration and test (anipbu, 17:18:37)
    1. integration team will check system tests to see if expectations are met. (anipbu, 17:19:06)
    2. we will remove the lithium jobs soon. (anipbu, 17:19:37)
    3. https://wiki.opendaylight.org/view/Integration/Test/Test_Case_Expectations <-- system test expectations we will check for during project release reviews (jamoluhrsen, 17:19:51)
    4. rovarga says we should only remove jobs only after the release (anipbu, 17:20:40)
    5. we will remove lithium jobs only after boron is released (anipbu, 17:20:56)

  6. infrastructure (anipbu, 17:21:22)
    1. still experiencing timeout. root cause unknown. (anipbu, 17:22:37)
    2. routing issues still a problem (may be resolved, but not confirmed). Further testing will be done. (anipbu, 17:22:40)
    3. rovarga asks if there any plans for infra changes in m1 (anipbu, 17:23:28)
    4. may change how we bring up subnodes for the tests. may use openstack. (anipbu, 17:24:02)
    5. get board approval to increase private cloud (anipbu, 17:24:24)
    6. folks should let infra team if there are anythings that the community would like to have (anipbu, 17:24:59)
    7. rovarga asks for jira, group management, and user provisioning. (anipbu, 17:26:16)
    8. ACTION: rovarga will follow up with jira, group management, and user provisioning. (anipbu, 17:26:48)

  7. Yakir Dorani and Bartosz Michalik as committers on unimgr (anipbu, 17:27:23)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-August/005857.html (anipbu, 17:27:33)
    2. https://git.opendaylight.org/gerrit/#/q/owner:yakir.dorani%2540hpe.com+status:merged+project:unimgr <--- Yakir Dorani Commits (anipbu, 17:27:39)
    3. https://git.opendaylight.org/gerrit/#/q/project:unimgr+reviewer:%22Yakir+Dorani+%253Cyakir.dorani%2540hpe.com%253E%22 <--- Yakir Dorani Reviews (anipbu, 17:27:44)
    4. https://git.opendaylight.org/gerrit/#/q/owner:bartosz.michalik%2540amartus.com+status:merged+project:unimgr <--- Bartosz Michalik Commits (anipbu, 17:27:48)
    5. https://git.opendaylight.org/gerrit/#/q/project:unimgr+reviewer:bartosz.michalik%2540amartus.com <--- Bartosz Michalik Reviews (anipbu, 17:27:52)
    6. https://lists.opendaylight.org/pipermail/unimgr-dev/2016-August/000214.html <--- Vote 5 of 5 (anipbu, 17:27:56)
    7. TSC voted 6 +1, which is enough to approve. (anipbu, 17:29:09)
    8. AGREED: Yakir Dorani and Bartosz Michalik as committers on unimgr (anipbu, 17:29:35)

  8. George Adam as committers for eman (anipbu, 17:29:49)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-August/005873.html (anipbu, 17:29:58)
    2. https://git.opendaylight.org/gerrit/#/q/project:eman+owner:george_adam%2540comcast.com <--- George Adam Commits (anipbu, 17:30:03)
    3. https://lists.opendaylight.org/pipermail/eman-dev/2016-August/000020.html <--- Vote 1 of 1 (anipbu, 17:30:17)
    4. VOTE: Voted on "shall the TSC approve George Adam as committers for eman?" Results are, +1: 9 (anipbu, 17:31:27)
    5. AGREED: George Adam is committers for eman (anipbu, 17:31:58)
    6. dfarrell07 thanks eman project for adding a second committer, as we encourage projects to have more than one (dfarrell07, 17:32:05)

  9. Wojciech Dec as committer for honeycomb/vbd (anipbu, 17:32:13)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-August/005878.html (anipbu, 17:32:19)
    2. https://git.opendaylight.org/gerrit/#/q/wdec%2540cisco.com+project:honeycomb/vbd <--- Wojciech Dec Contributions (anipbu, 17:32:24)
    3. https://lists.opendaylight.org/pipermail/vbd-dev/2016-August/000014.html and https://lists.opendaylight.org/pipermail/vbd-dev/2016-August/000012.html <--- Vote 3 of 6 (anipbu, 17:32:31)
    4. rovarga missed the vote on the mailing list, for the record my vote is +1 for the promotion (rovarga, 17:34:12)
    5. VOTE: Voted on "shall the TSC approve Wojciech Dec as committer for honeycomb/vbd?" Results are, +1: 8 (anipbu, 17:35:10)
    6. AGREED: Wojciech Dec is committer for honeycomb/vbd (anipbu, 17:35:24)

  10. Southbound_plugin_to_the_OpenContrail_platform Archive Review (anipbu, 17:35:58)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-May/005309.html (anipbu, 17:36:10)
    2. https://wiki.opendaylight.org/view/Archive_Proposals/Southbound_plugin_to_the_OpenContrail_platform <--- Archival Proposal (anipbu, 17:36:32)
    3. https://git.opendaylight.org/gerrit/#/q/project:plugin2oc+status:merged (anipbu, 17:37:18)
    4. VOTE: Voted on "shall the TSC archive Southbound_plugin_to_the_OpenContrail_platform?" Results are, +1: 9 (anipbu, 17:39:37)
    5. AGREED: Southbound_plugin_to_the_OpenContrail_platform is approved by TSC to be archived (anipbu, 17:40:04)

  11. TSC Elections (anipbu, 17:40:57)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-August/005874.html <--- Corner Cases for TSC Election (anipbu, 17:41:11)
    2. we found a corner case in the TSC Election: A single person may meet the voter description for a Represented Group for more than one reason. (anipbu, 17:42:11)
    3. solution is to make CAL RG elections vote-per-person, and Project RG elections vote-per-interest. (anipbu, 17:43:22)
    4. rovarga would like to wait to next week. (anipbu, 17:50:23)
    5. Kindly ask TSC to please review the proposal and provide comments on the mailing list (anipbu, 17:50:51)
    6. plan of action is to preferably close corner case and RG at next TSC meeting after discussion on mailing list. (anipbu, 17:52:22)

  12. cookies (anipbu, 17:54:13)
    1. well-run meeting, anipbu :) (dfarrell07, 17:54:17)


Meeting ended at 17:54:24 UTC (full logs).

Action items

  1. colindixon send out link to the actual APAC-time-zone poll to vote
  2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon?
  3. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
  4. colindixon to ask how hard it would be to add a knob that was off-by-default that when enabled reverted HTTP response codes to the Beryllium values and if we can do in Boron
  5. rovarga will follow up with jira, group management, and user provisioning.


Action items, by person

  1. dfarrell07
    1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
  2. rovarga
    1. rovarga will follow up with jira, group management, and user provisioning.
  3. UNASSIGNED
    1. colindixon send out link to the actual APAC-time-zone poll to vote
    2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron/Carbon?
    3. colindixon to ask how hard it would be to add a knob that was off-by-default that when enabled reverted HTTP response codes to the Beryllium values and if we can do in Boron


People present (lines said)

  1. anipbu (104)
  2. odl_meetbot (17)
  3. dfarrell07 (6)
  4. rovarga (5)
  5. mohnish__ (4)
  6. gkaempfer (4)
  7. LuisGomez (4)
  8. lori (4)
  9. Prem_ (4)
  10. jamoluhrsen (3)
  11. vishnoianil (3)
  12. CaseyODL (1)


Generated by MeetBot 0.1.4.