#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:46 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:50)
    1. colindixon (colindixon, 17:00:56)
    2. Chris Luke for Ed Warnicke (Chrisy, 17:01:05)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-09-15-17.00.html last week's meeting minutes (colindixon, 17:01:12)
    4. Prem_ for Chris Price (Prem_, 17:01:17)
    5. adetalhouet (adetalhouet, 17:01:21)
    6. gkaempfer (gkaempfer, 17:01:44)
    7. colindixon is also adding APAC time TSC meeting to today's agenda (colindixon, 17:01:50)
    8. ACTION: adetalhouet to find the link for the dicussion about committer activity and project liveness and make sure we talk about it today or next week (colindixon, 17:03:23)
    9. https://lists.opendaylight.org/pipermail/release/2016-September/008306.html (adetalhouet, 17:03:37)
    10. https://lists.opendaylight.org/pipermail/release/2016-September/008306.html the discussion of active committers and projects and how to do a better job tracking inactive ones in the future (colindixon, 17:04:07)
    11. ACTION: dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion (colindixon, 17:04:28)
    12. ACTION: colindixon to add topics to the carbon dev forum around modifying the RC process a bit, and maybe also fast and/or phased (colindixon, 17:04:39)
    13. Anil Vishnoi (vishnoianil, 17:05:11)
    14. ACTION: abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device (colindixon, 17:05:27)
    15. Daniel Farrell (dfarrell07, 17:05:30)
    16. ACTION: phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process (colindixon, 17:06:01)
    17. ACTION: dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework (colindixon, 17:07:08)
    18. ACTION: colindixon to start a thread on when projects/committers need to be approvied to participate how in elections (colindixon, 17:07:20)

  2. TSC discussions (colindixon, 17:07:55)
    1. see the agenda link above for the current mailing list discussions (colindixon, 17:08:06)
    2. abhijitkumbhare (abhijitkumbhare, 17:08:08)

  3. events (colindixon, 17:08:16)
    1. https://www.opendaylight.org/global-events (colindixon, 17:08:23)
    2. rovarga for jmedved (rovarga, 17:09:20)
    3. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum developer forum topics (colindixon, 17:09:22)
    4. https://opendaylightsummit2016.sched.org/ the summit (colindixon, 17:09:50)
    5. there will be GPG key singing at the summit, tykeal is planning to hold office hours on Thursday moring, cut off will be noon thursday (a week from today) to get Andy key fingerprints (you have to do it again even if you did it before) so that you can particiate in the keysinging stuff (colindixon, 17:11:07)
    6. it will be in the same room as the board town hall immediately following it (colindixon, 17:11:29)
    7. phrobb asks if the TSC wants to make this a bigger priority in Carbon (colindixon, 17:12:00)
    8. colindixon punts that tykeal and zxiiro, zxiiro says we current sign our rleases, but we do it as the LF not as the developers (colindixon, 17:12:42)
    9. tykeal says that it would be better if each project released it's own stuff and signed them by themselves (e.g., the PTL or a set of the committers) (colindixon, 17:13:20)
    10. colindixon asks about signing release tags, tykeal and zxiiro say that we can't sign tags except when they're created and only one person can sign the tag then (colindixon, 17:14:39)
    11. tykeal says his take on this is that what we should really be doing is that we should force that committers on projects to sign their commits as a first step (colindixon, 17:15:32)
    12. ACTION: tykeal to create a DDF topic on how we can start to incrementally use our web of trust (colindixon, 17:16:07)

  4. boron (colindixon, 17:16:22)
    1. Boron-SR1 is on 10/27/2016, cut off will be on Sunday, 10/22 at 23:59 UTC (colindixon, 17:17:08)

  5. Beryllum (colindixon, 17:17:29)
    1. Beryllium-SR4 is on 10/20/2016, cut off on 10/16 at 23:59 UTC (colindixon, 17:17:50)

  6. Carbon (colindixon, 17:17:56)
    1. https://lists.opendaylight.org/pipermail/release/2016-September/008349.html <--- Carbon M0: Declare Participation. Projects should declare their intent to participate in the Carbon Simultaneous Release (anipbu, 17:18:04)
    2. https://lists.opendaylight.org/pipermail/release/2016-September/008345.html <--- For Carbon YANG Tools we will only support maven-3.3.9 or later and have already disabled 3.2.x verify-carbon jobs. (anipbu, 17:18:39)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release/Carbon/Changes <--- Tracking Carbon Cross Project Changes: YANG Tools Maven 3.3.9 (anipbu, 17:19:05)
    4. https://lists.opendaylight.org/pipermail/release/2016-September/008331.html <--- Releng has migrated to now use freestyle jobs with roughly 30 minutes saving time, but there are still some issues and concerns being investigated with regards to this migration effort. There may be impact to our autorelease build picking up latest code. (anipbu, 17:19:48)
    5. https://lists.opendaylight.org/pipermail/dev/2016-September/002766.html <--- Some issues with autorelease odlparent being up-to-date (anipbu, 17:19:53)
    6. https://lists.opendaylight.org/pipermail/release/2016-September/008352.html <--- Carbon Autorelease Build Failures in sal-rest-docgen (anipbu, 17:20:03)
    7. zxiiro says that the autorelease version being up-to-date seems to be a bug in gerrit with the master branch only (colindixon, 17:22:32)

  7. system integration and test (colindixon, 17:23:00)
    1. nothing this week (colindixon, 17:23:01)

  8. infrastructure (colindixon, 17:23:05)
    1. we seem to have finally fixed the Nexus timeout issues (colindixon, 17:23:32)
    2. there was an outage issue with nexus earlier this morning, but it's fixed (colindixon, 17:23:55)
    3. there is a request to see what we can do to get at bigger F5 devices to fix our bottleneck (colindixon, 17:24:10)
    4. we are plannig to do system upgrades starting the week after the summit (colindixon, 17:24:36)
    5. nexus upragdes, gerrit upgrades, jenkins upgrades, and along down the line (colindixon, 17:24:54)
    6. https://lists.opendaylight.org/pipermail/tsc/2016-September/006052.html some converastion on moving to JIRA (colindixon, 17:25:07)
    7. tykeal also says that there is a request to the board to think about funding doubling our compute resources with somewhat cheaper hardware, we would then have two availability zones and could use the new one ODL forge and also using it as excess capacity for everything (colindixon, 17:26:24)
    8. tykeal says that one of the mandates for ODL forge was to keep it separate and this would make that easier (colindixon, 17:27:25)
    9. this would prevent ODL forge from interfering with our other resources (colindixon, 17:28:09)
    10. phrobb asks if we could steal all (or most) of ODL forge for non-forge stuff so that we could use it for releasing, tykeal says that we could do that (colindixon, 17:29:14)
    11. phrobb asks if the current plan is to still run CSIT in the public cloud, tykeal says that his view is that we could maybe put CSIT into the 2nd availability zone as well (colindixon, 17:30:06)
    12. LuisGomez says the public cloud still has some issues, so this might help (colindixon, 17:30:20)
    13. ACTION: LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon (colindixon, 17:30:38)
    14. LuisGomez says that he's see still seeing a high rate of VM failures in the public cloud, still about 1 in 3 cluster jobs in the public cloud fails in infrastructure issues, LuisGomez remembers those being much more stable in the private cloud (colindixon, 17:32:03)

  9. TSC Elections (colindixon, 17:35:02)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-September/005980.html Successful Mailing List Vote to have the following TSC RGs: Kernel, Protocol/Services, App, Support, Committer at Large (CAL) (colindixon, 17:36:46)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-September/005971.html Successful Mailing List Vote to have CAL votes be vote-per-committer, and other RGs be one vote-per-interest (colindixon, 17:36:58)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-September/006030.html Results of Condorcet vote on allocation of seats to RGs: 5 Seats to committers-at-large, 2 seats to all others (13 seats total) (colindixon, 17:37:11)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-September/006031.html discussion on options to vote on for company caps (colindixon, 17:37:47)
    5. Abhijit proposed to simply say only one person per company in each RG as a simpler alternative (all elections are this independent with no over-max resolution) (colindixon, 17:38:00)
    6. Colin feels that this might fail to meet our key requirement to avoid people not running for fear of ousting others in their company, there a key difference in his mind between caps of exactly 1 vs. caps of 2+. In the first case, it's clear who's fault somebody being knocked out is. In the second case, there is more than one person and reason for the cause. (colindixon, 17:38:14)
    7. abhijitkumbhare came back suggesting instead to resolve over-max by first repeated removing the lowest ranked person in RGs where there are 2 or more representatives from the same capped group (or company) and then using scaled popularity if there is only one person from each capped group in each RG. (colindixon, 17:39:38)
    8. colindixon asks what the reason is to do that vs. just scaled popularity? abhijitkumbhare says basically the issue is whether you want pick the person who won the most of the vote (as a percent) vs. the person who got the most votes (e.g., a smaller fraction of a larger electorate) (colindixon, 17:41:31)
    9. colindixon says the he's not sure if the proposal from abhijitkumbhare actually strikes a balance between the two, it seems like a third alternative that favors an entirely orthogonal thing which is minimizing over-representation by a single group (colindixon, 17:43:46)
    10. abhijitkumbhare says the advantage of his proposal is that in a somewhat fair way it minimizes the number of times you would have have to resolve issues in a cross-RG manner, which is where the comparison between % vs. votes comes in (colindixon, 17:45:28)
    11. ACTION: colindixon to post abhijitkumbhare's alternative to the wiki, and then start a vote (colindixon, 17:50:50)
    12. rovarga notes that abhijitkumbhare's proposal above would potentially hurt companies that invest most heavily in a small number of RGs vs. spreading out (colindixon, 17:53:53)
    13. colindixon also notes that we would have to have a way to pick bertween RGs if there were 2+ reps from the same company in more than one RG when you need to resolve it (colindixon, 17:54:24)
    14. rovarga says that committer-at-large is likely to see more diversity than the RGs, which means that would be less likely to be hit in abhijitkumbhare's scheme (colindixon, 17:56:57)
    15. instead, rovarga says maybe first dropping CAL's since they might have less concerte value to the TSC than RGs (colindixon, 17:57:35)

  10. do we want to have a TSC meeting (during the DDF) next week? (colindixon, 17:59:06)
    1. colindixon asks if there's anything going on at the same time? (colindixon, 18:00:13)
    2. rovarga and dfarrell07 suggests that we could have an open room (colindixon, 18:00:30)
    3. ACTION: colindixon to work with phrobb to have TSC meeting during the DDF (colindixon, 18:01:41)
    4. VOTE: Voted on "does the TSC want to have a town-hall/open TSC meetnig during the DDF at roughly this time?" Results are, +1: 8 (colindixon, 18:02:23)
    5. AGREED: phrobb and colindixon will work to have an open TSC meeting during the DDF (colindixon, 18:02:36)

  11. cookies (colindixon, 18:03:00)
    1. AGREED: (from earlier) colindixon will send a summary of the eletion discussion here to the mailing list and start a vote 24 horus from now to end roughly a week from now so that we can give the results to the board for their meeting a week from tomorrow and get elections going (colindixon, 18:03:41)


Meeting ended at 18:03:44 UTC (full logs).

Action items

  1. adetalhouet to find the link for the dicussion about committer activity and project liveness and make sure we talk about it today or next week
  2. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
  3. colindixon to add topics to the carbon dev forum around modifying the RC process a bit, and maybe also fast and/or phased
  4. abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
  5. phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process
  6. dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
  7. colindixon to start a thread on when projects/committers need to be approvied to participate how in elections
  8. tykeal to create a DDF topic on how we can start to incrementally use our web of trust
  9. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
  10. colindixon to post abhijitkumbhare's alternative to the wiki, and then start a vote
  11. colindixon to work with phrobb to have TSC meeting during the DDF


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
    2. colindixon to post abhijitkumbhare's alternative to the wiki, and then start a vote
  2. adetalhouet
    1. adetalhouet to find the link for the dicussion about committer activity and project liveness and make sure we talk about it today or next week
  3. colindixon
    1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
    2. colindixon to add topics to the carbon dev forum around modifying the RC process a bit, and maybe also fast and/or phased
    3. colindixon to start a thread on when projects/committers need to be approvied to participate how in elections
    4. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
    5. colindixon to post abhijitkumbhare's alternative to the wiki, and then start a vote
    6. colindixon to work with phrobb to have TSC meeting during the DDF
  4. dfarrell07
    1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
    2. dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
  5. LuisGomez
    1. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
  6. phrobb
    1. abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
    2. phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process
    3. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
    4. colindixon to work with phrobb to have TSC meeting during the DDF
  7. tykeal
    1. abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
    2. tykeal to create a DDF topic on how we can start to incrementally use our web of trust
    3. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon


People present (lines said)

  1. colindixon (89)
  2. odl_meetbot (10)
  3. dfarrell07 (7)
  4. anipbu (7)
  5. rovarga (3)
  6. tykeal (3)
  7. adetalhouet (3)
  8. Chrisy (2)
  9. zxiiro (2)
  10. lori (2)
  11. abhijitkumbhare (2)
  12. Prem_ (2)
  13. vishnoianil (2)
  14. gkaempfer (1)
  15. vrpolak (1)
  16. LuisGomez (1)
  17. phrobb (0)


Generated by MeetBot 0.1.4.