#opendaylight-meeting: tsc

Meeting started by colindixon at 15:29:35 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 15:29:40)
    1. colindixon (colindixon, 15:29:41)
    2. adetalhouet (adetalhouet, 15:29:59)
    3. rovarga for jmedved (rovarga, 15:32:50)
    4. abhijitkumbhare (abhijitkumbhare, 15:33:12)
    5. gkaempfer (gkaempfer, 15:33:35)
    6. Anil Vishnoi (vishnoianil, 15:34:00)
    7. https://lists.opendaylight.org/pipermail/tsc/2016-November/006271.html vote on ALTO committers on the TSC list (colindixon, 15:34:09)
    8. https://lists.opendaylight.org/pipermail/discuss/2016-November/006925.html we have TSC elections ongoing, vote if you have e-mail(s), let us know if you don't and think you should (colindixon, 15:34:33)

  2. BIER creation review (colindixon, 15:35:28)
    1. https://wiki.opendaylight.org/view/Project_Proposals:BIER_Plugin (colindixon, 15:35:47)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2016-October/000551.html proposed on 10/18/2016 (colindixon, 15:35:59)
    3. https://wiki.opendaylight.org/view/File:Presentation-bier-proposal-review.pdf presentation already on the wiki (colindixon, 15:36:31)
    4. https://meetings.webex.com/collabs/meetings/join?uuid=M68VZJQC0YAL19U603O1YGP1WE-9VIB (adetalhouet, 15:37:34)
    5. this is work to bring the IETF draft on BIER (a new way to do multicast) with support from ZTE and China Telecom (colindixon, 15:37:44)
    6. https://www.webex.com/pdf/tollfree_restrictions.pdf (adetalhouet, 15:37:59)
    7. https://tools.ietf.org/html/draft-ietf-bier-architecture-05 the IETF draft (colindixon, 15:38:13)
    8. https://datatracker.ietf.org/wg/bier/ the IETF working group (colindixon, 15:38:55)
    9. Daniel Farrell (dfarrell07, 15:39:54)
    10. BIER (Bit-Indexed Explicity Multicast Replication) assigns a unique bit position in a bitstring for each edge router, each edge router floods their bit position to ID mapping, then packets are forwarded using IGP paths looked up based on the bitstring (colindixon, 15:40:49)
    11. why use BIER: simpler multicast approach since the non-edge devices in the network need not have state except per-edge-device (colindixon, 15:41:55)
    12. chris price (ChrisPriceAB, 15:43:02)
    13. scope is basically around taking NB configuration of how the BIER should configure underlying devices and a SB plugin to reach out to devices participating in a BIER region (colindixon, 15:44:03)
    14. in carbon the BIER flow manager will not be automatically calculating bit strings, but will use static configuration (colindixon, 15:45:33)
    15. for now the SB plugin will be over NETCONF (colindixon, 15:46:01)
    16. rovarga asks if he's right in understanding that the NB interface is really a BIER topology as in OpenFlow and NETCONF today (colindixon, 15:46:38)
    17. the answer appears to be yes, the NB is to receive the multcast flow information to configure things (colindixon, 15:49:01)
    18. dfarrell07 rovarga notice that the set of commiters is the the same as the set of contributors, maybe not best strategy (dfarrell07, 15:50:12)
    19. rovarga and dfarrell07 ask if the project really needs 12 committers, does the project consider this right? (colindixon, 15:50:48)
    20. dfarrell07 suggests maybe reducing the number of committers down to something like 3–5 might help (colindixon, 15:52:32)
    21. phrobb asks if there is inbound code to review, answer seems to be no (colindixon, 15:53:54)
    22. VOTE: Voted on "shall the TSC approve the BIER Plugin project as an incubation project?" Results are, +1: 7 (colindixon, 15:55:05)
    23. colindixon notes that while he agrees dfarrell07 and rovarga that having a smaller number of people as committers who will be actively involved in reviewing code as it comes in will make sense, if these 12 people are the right ones for that, fine, but it's worth reviewing it (colindixon, 15:56:22)
    24. AGREED: the BIER plugin project is an incubation project (colindixon, 15:56:36)
    25. VOTE: Voted on "shall the TSC allow the BIER project to enter the carbon release as an offset 1 or 2 project as their choice?" Results are, +1: 8 (colindixon, 15:58:14)
    26. AGREED: the BIER plugin can join the carbon release at either offset 1 or offset 2 (colindixon, 15:58:24)
    27. abhijitkumbhare, vishnoianil, adetalhouet, colindixon, and others all suggest offset 2 (colindixon, 15:58:40)


Meeting ended at 15:59:10 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. colindixon (45)
  2. adetalhouet (32)
  3. odl_meetbot (11)
  4. rovarga (8)
  5. dfarrell07 (4)
  6. ChrisPriceAB (4)
  7. abhijitkumbhare (4)
  8. vishnoianil (4)
  9. gkaempfer (2)
  10. anipbu (2)


Generated by MeetBot 0.1.4.