#opendaylight-meeting: tsc

Meeting started by anipbu at 18:00:10 UTC (full logs).

Meeting summary

  1. Agenda Bashing and Roll Call (anipbu, 18:00:28)
    1. https://wiki.opendaylight.org/view/TSC:Main#Agenda <--- TSC Agenda (anipbu, 18:00:40)
    2. all TSC members, please #info in (anipbu, 18:00:50)
    3. rovarga (rovarga, 18:01:00)
    4. edwarnicke (edwarnicke, 18:01:01)
    5. anipbu (anipbu, 18:01:05)
    6. Vratko Polak for Jamo Luhrsen (vrpolak, 18:01:07)
    7. Hideyuki (hideyuki, 18:01:09)
    8. Shuva Jyoti Kar for Abhijit Kumbhare (shuva, 18:01:25)
    9. adetalhouet (adetalhouet, 18:01:42)
    10. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-12-01-18.00.html <--- Last Week's Meeting Minutes (anipbu, 18:01:58)
    11. Anil Vishnoi (vishnoianil, 18:02:10)
    12. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (anipbu, 18:02:16)
    13. LuisGomez (LuisGomez, 18:02:17)
    14. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (anipbu, 18:02:44)
    15. ACTION: colindixon to try to drive some/all of the ongoing TSC discussions to completion (anipbu, 18:02:53)
    16. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better (anipbu, 18:03:07)
    17. Daniel Farrell for Stephen Kitt (dfarrell07, 18:03:49)
    18. the jobs already do some analysis for failures. There is some updates on it (anipbu, 18:03:52)
    19. Thanh Ha (zxiiro, 18:04:06)
    20. ACTION: phrobb to kick of an election for TSC Chair (anipbu, 18:04:51)
    21. ACTION: phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit (anipbu, 18:05:09)
    22. shague (shague, 18:05:17)
    23. ACTION: phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future (anipbu, 18:05:33)
    24. ACTION: colindixon to remove many current discussions which are now closed, which is a lot of them (anipbu, 18:05:43)
    25. ACTION: phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit (anipbu, 18:05:53)
    26. https://lists.opendaylight.org/pipermail/tsc/2016-December/006396.html <--- Thread to get candidate times and then figure out how to vote after that (anipbu, 18:06:15)

  2. TSC Mailing List Votes and Discussions (anipbu, 18:07:06)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-November/006368.html projects with few/no active committers (anipbu, 18:07:19)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-November/006298.html Delivering to consumer project off-cadence (ODP & OPNFV collaboration) (anipbu, 18:07:29)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-December/006388.html Categorizing projects (please add your project type to your project facts sidebar) (anipbu, 18:07:53)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-December/006427.html escalation process we have in OpenDaylight has been added to the TSC page (object now if you want to) (anipbu, 18:08:06)
    5. suggestions to post on docs.opendaylight.org and Main_Page (anipbu, 18:08:14)
    6. https://lists.opendaylight.org/pipermail/tsc/2016-December/006428.html only allow blocking bug fixes after RCs start in Carbon (anipbu, 18:08:32)

  3. events (anipbu, 18:08:56)
    1. https://www.opendaylight.org/global-events (anipbu, 18:09:03)
    2. https://www.opendaylight.org/events/2016-12-05-000000-2016-12-09-000000/opnfv-plugfest <--- December 5, 2016 OPNFV Plugfest Durham, New Hampshire (anipbu, 18:09:18)
    3. dfarrell07 opnfv happy to work with odl. Ash says about adding more CII core infra initiative. Use ODL as example for infra tools. (anipbu, 18:11:29)
    4. https://www.opendaylight.org/events/2016-12-07-000000-2016-12-09-000000/global-network-technology-conference <--- December 7, 2016 Global Network Technology Conference Beijing, China (colindixon is speaking) (anipbu, 18:11:41)
    5. https://www.opendaylight.org/events/2016-12-12-000000-2016-12-16-000000/odl-china-city-tour <--- December 12, 2016 ODL China City Tour Nanjing, Beijing, Shenzhen and Shanghai (at least phrobb, Lisa Caywood, Neela are all going) (anipbu, 18:11:50)

  4. boron (anipbu, 18:12:29)
    1. https://lists.opendaylight.org/pipermail/release/2016-December/008829.html <--- Boron SR2 Release Date: December 15; Cutoff Date on December 11 at 23:59 UTC (anipbu, 18:12:44)
    2. Boron Autorelease Build Successfully (anipbu, 18:12:55)
    3. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=67733&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- <--- Two blocker bug in openflowplugin, (anipbu, 18:13:09)
    4. https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/boron <--- 38 patches pending for stable/boron (anipbu, 18:14:50)
    5. https://git.opendaylight.org/gerrit/#/dashboard/?title=Boron+Status&Yang+File+Changes+Since+Boron+SR1=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2016-10-27 <--- 28 patches modifying yang files without API Freeze Waiver between Boron SR1 and Boron SR2 (anipbu, 18:15:08)

  5. carbon (anipbu, 18:15:44)
    1. https://wiki.opendaylight.org/view/Weather#Neutron_Northbound:_rename_tenant-id_to_project-id <--- Rename tenant-id member to project-id in yang model (anipbu, 18:15:56)
    2. https://lists.opendaylight.org/pipermail/release/2016-December/008868.html <--- Email Thread Discussion for changes to Neutron Northbound (anipbu, 18:16:52)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#M2:_Final_Release_Plan <--- Carbon M2 Offset 2 Status is due Today 12/8. (anipbu, 18:17:19)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2016/release/opendaylight-meeting-release.2016-12-07-15.30.html <--- Meeting Minutes for Release IRC Sync Up: Carbon M2 Working Session (anipbu, 18:17:42)
    5. https://lists.opendaylight.org/pipermail/release/2016-December/008864.html <--- There was Carbon Autorelease Failure in NIC but it has been fixed. (anipbu, 18:17:56)

  6. system integration and testing (anipbu, 18:18:17)
    1. no updates for test (anipbu, 18:18:34)

  7. infrastructure (anipbu, 18:18:42)
    1. no infra updates (anipbu, 18:18:58)

  8. TSC Chair (anipbu, 18:19:14)
    1. TSC Chair Nominations: nominations close at 23:59 UTC on Wednesday 12/7 (anipbu, 18:19:24)
    2. TSC Chair Voting: voting will start on 12/8 and close at 23:59 UTC on 12/14 (anipbu, 18:19:36)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-December/006415.html <--- TSC Chair Candidate(s): Colin Dixon (anipbu, 18:19:45)
    4. anipbu asks if we should follow our agreed upon process of giving one week to vote or should we vote today? (anipbu, 18:20:05)
    5. tsc will follow the process and wait until next week to vote. (anipbu, 18:21:44)

  9. Committer-at-Large Board Member (anipbu, 18:22:16)
    1. https://wiki.opendaylight.org/view/Committer_Members_Board_Representation <--- Process for committer-at-large representavies on the board (anipbu, 18:22:23)
    2. https://linuxfoundation.echosign.com/public/hostedForm?formid=AI3XA256U2H44Y <--- Link to form to become a committer member (anipbu, 18:22:29)
    3. phrobb will open the nominations for comitter-at-large board representatives this week. 2 week nominations ~12/7 to ~12/21, voting will be in the new year ~1/2 to ~1/16 (anipbu, 18:22:34)

  10. APAC TSC Call (anipbu, 18:23:21)
    1. Option #1: 9a India, 11:30a China, 12:30p Japan, 8:30p Pacific, 11:30p Eastern, 5:30a Central Europe (anipbu, 18:23:33)
    2. Option #2: 12:30p India, 3p China, 4p Japan, 12a Pacific, 3a Eastern, 9a Central Europe https://www.timeanddate.com/worldclock/meetingdetails.html?year=2016&month=7&day=21&hour=7&min=0&sec=0&p1=771&p2=33&p3=248&p4=283&p5=263&p6=37 (anipbu, 18:23:47)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-December/006410.html <--- Email Thread Discussing Time Zone (anipbu, 18:23:55)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-December/006418.html <--- Feedback from our European Friends (anipbu, 18:24:02)
    5. Option #1 was 5:30 with CEST -- now it is 4:30a (rovarga, 18:25:04)
    6. vratko prefer options #2, but fine with option #1 (anipbu, 18:26:26)
    7. please please please make sure the ODL Google calendar is updated to reflect (edwarnicke, 18:26:59)
    8. ACTION: CaseyODL dfarrell07 to follow up on updating calandar (anipbu, 18:27:53)
    9. VOTE: Voted on "Shall the TSC hold APAC TSC Call using option #1 (8:30PM Pacific) or Option #2 (12:00AM Pacific) on a routine basis?" Results are, 1: 8, 0: 3, 2: 2 (anipbu, 18:29:32)
    10. AGREED: The TSC will hold APAC TSC Calls using option #1 (8:30PM Pacific) (anipbu, 18:29:42)
    11. ACTION: colindixon to follow up on picking date to host APAC TSC Call (anipbu, 18:30:38)

  11. RC Blocking Bugs Timeframe (anipbu, 18:30:56)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-December/006428.html <--- Mailing list discussion on modifying carbon release plan to only allow fixes for blocking bugs during RCs? (anipbu, 18:31:07)
    2. rovarga says then it would not make RC really a release candidate (anipbu, 18:42:37)
    3. vishnoianil suggests RC1 for cutoff on blocking bug (anipbu, 18:43:10)
    4. anipbu says there is suggestion to introduce additional time between m5 and RC0 (anipbu, 18:44:00)
    5. Apps TSC Rep says: one week is not enough to fix all the bugs between M5 and RC0. Suggestion of RC1. (anipbu, 18:46:16)
    6. rovarga suggests we can have better release review of how projects follow release plan (did they deliver feature by m4) and identify red flags (anipbu, 18:47:27)
    7. Support TSC Rep says: support team is not really affected too much. test point of view says we need to respect M5 and make sure only testing after M5 not working of features. The sooner the better for locking the branches. (anipbu, 18:51:33)
    8. Kernal TSC Rep says: transition period would be nice. (anipbu, 18:56:16)
    9. TSC needs more time to think through the options and feedback. Will continue this discussion on mailing list. (anipbu, 18:57:15)

  12. internship (anipbu, 18:57:54)
    1. Just a reminder to sign up to be a mentor! (anipbu, 18:57:57)
    2. please sign up for project (anipbu, 18:58:04)
    3. https://wiki.opendaylight.org/view/Interns <--- Sign up sheet for internship (anipbu, 18:58:49)
    4. dfarrell07 says we need better vetting of candidates (anipbu, 18:59:06)

  13. cookies (anipbu, 18:59:23)


Meeting ended at 18:59:29 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  3. colindixon to try to drive some/all of the ongoing TSC discussions to completion
  4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
  5. phrobb to kick of an election for TSC Chair
  6. phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit
  7. phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future
  8. colindixon to remove many current discussions which are now closed, which is a lot of them
  9. phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit
  10. CaseyODL dfarrell07 to follow up on updating calandar
  11. colindixon to follow up on picking date to host APAC TSC Call


Action items, by person

  1. CaseyODL
    1. CaseyODL dfarrell07 to follow up on updating calandar
  2. dfarrell07
    1. CaseyODL dfarrell07 to follow up on updating calandar
  3. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  4. UNASSIGNED
    1. colindixon to try to drive some/all of the ongoing TSC discussions to completion
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
    3. phrobb to kick of an election for TSC Chair
    4. phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit
    5. phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future
    6. colindixon to remove many current discussions which are now closed, which is a lot of them
    7. phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit
    8. colindixon to follow up on picking date to host APAC TSC Call


People present (lines said)

  1. anipbu (92)
  2. odl_meetbot (12)
  3. dfarrell07 (6)
  4. rovarga (5)
  5. adetalhouet (5)
  6. edwarnicke (4)
  7. kkershaw (2)
  8. shague (2)
  9. shuva (2)
  10. vrpolak (2)
  11. zxiiro (2)
  12. LuisGomez (2)
  13. hideyuki (2)
  14. CaseyODL (2)
  15. vishnoianil (2)


Generated by MeetBot 0.1.4.