#opendaylight-meeting: tsc

Meeting started by colindixon at 04:30:35 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 04:30:39)
    1. jamoluhrsen (jamoluhrsen, 04:30:39)
    2. colindixon (colindixon, 04:30:49)
    3. anipbu (anipbu, 04:30:56)
    4. Thanh (zxiiro, 04:31:12)
    5. iyamahat on behalf of tai (iyamahat, 04:31:16)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52393#Agenda agenda in it's usual place (colindixon, 04:31:17)
    7. aswinsuryan for shague (aswinsuryan, 04:31:21)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-12-15-18.01.html last week's meeting minutes (colindixon, 04:31:30)
    9. LuisGomez (LuisGomez, 04:32:21)
    10. CaseyODL updated the relevant calendars and wiki pages about the new times for TSC calls (colindixon, 04:32:35)
    11. Anil Vishnoi (vishnoianil, 04:32:38)
    12. https://lists.opendaylight.org/pipermail/tsc/2016-December/006474.html Boron-SR2 was released (colindixon, 04:32:41)
    13. https://wiki.opendaylight.org/view/TSC:Main#Developer_Design_Forum_Attendance_Policy developer design forum attendance policy archived here (colindixon, 04:32:46)
    14. the list of current TSC discussions/votes in the agenda is now much cleaner (colindixon, 04:33:11)
    15. https://meetings.webex.com/collabs/meetings/join?uuid=M8U23SHB6WH2X6FIJ6CR6G8G8N-9VIB (jamoluhrsen, 04:33:37)
    16. https://meetings.webex.com/collabs/meetings/join?uuid=M8U23SHB6WH2X6FIJ6CR6G8G8N-9VIB (anipbu, 04:33:39)
    17. https://meetings.webex.com/collabs/#/meetings/detail?uuid=IESIBUH8X75NF27VETDKRSBSHR-9VIB&rnd=579832.79191 (CaseyODL, 04:33:46)
    18. https://wiki.opendaylight.org/view/Project_list#Current_Projects now using project type from the project facts template to auto-categorize projects here, please fill it out (colindixon, 04:34:11)
    19. phrobb is building a wiki page for the TSC mixer (across LF projects) at the LF leadership summit, this will Feb 14-16 in Lake Tahoe, CA http://events.linuxfoundation.org/events/open-source-leadership-summit (colindixon, 04:35:52)
    20. https://lists.opendaylight.org/pipermail/discuss/2016-December/006979.html possible hackfest on/around offset 0 M5 and whether we want to do this, the time frame would be late Feb, early March, please chime in here if you want to attend or host, LF will still pick up food and drink, but doesn't want to reserve a hotel (colindixon, 04:38:12)
    21. phrobb notes that the last hackfest was low 20s in attendance with about half of that being integration, jamoluhrsen says his recollection was that the integration folks wanted to meet in a smaller thing without having to have it be the time (colindixon, 04:40:21)
    22. phrobb notes, lest people be confused, the LF is planning to NOT do a big hackfest event in betwen releases, all ideas about other things are welcome (colindixon, 04:40:49)

  2. events (colindixon, 04:41:40)
    1. phrobb will be putting an Event tracker wiki page that makes this easier to use (colindixon, 04:42:02)
    2. http://events.linuxfoundation.org/events/open-source-leadership-summit LF open source leadership summit with a cross LF projct TSC mixer in the works Feb 14-16 (colindixon, 04:43:04)
    3. http://opennetsummit.org/ the open networking summit will be April 3-6, the CFP will be out soon and we'll annonce that here as soon as possible, looking for more solutions than technology talks (colindixon, 04:43:39)
    4. there may also be a tutorial day where we're looking for 4ish people to come and run those (colindixon, 04:44:11)
    5. http://events.linuxfoundation.org/events/opnfv-summit OPNFV summit in Beijing June 12-15, we will have an ODL mini-summit (colindixon, 04:44:42)
    6. the next week, there will be what used to be LinuxCon, but is now Open Source Con, and will have a networking track, but no mini summit, also in Beijing (colindixon, 04:45:28)
    7. the next DDF would be 3ish weeks after Carbon release, e.g., last week in may for first week in June (colindixon, 04:46:09)
    8. the LF is still planning to have a big-ish even for that DDF (colindixon, 04:46:20)

  3. TSC mailing list votes and discussions (colindixon, 04:46:56)
    1. https://lists.opendaylight.org/pipermail/discuss/2016-December/006979.html possible mid-release hackfest (colindixon, 04:47:04)
    2. abelur (abelur, 04:47:05)
    3. ACTION: add the hackfest to the list of ongoing discussions on the TSC list (colindixon, 04:47:23)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-November/006368.html projects with few/no active committers (colindixon, 04:47:44)
    5. https://lists.opendaylight.org/pipermail/tsc/2016-November/006298.html Delivering to consumer project off-cadence (ODP & OPNFV collaboration) (colindixon, 04:47:57)

  4. boron (colindixon, 04:48:49)
    1. https://lists.opendaylight.org/pipermail/release/2016-December/008966.html <--- Boron SR2 Released (anipbu, 04:48:59)
    2. Boron Autorelease Build is running successfully. Previously failing due to issues in artifact versions in MDSAL, but fixed by patch 49690. (anipbu, 04:49:04)

  5. carbon (colindixon, 04:49:35)
    1. https://lists.opendaylight.org/pipermail/release/2016-December/008990.html <--- Carbon Autorelease Build is failing due to issues in SFC/NETVIRT. Fixed by patch 49740. (anipbu, 04:49:52)
    2. https://lists.opendaylight.org/pipermail/release/2016-December/008975.html <--- We have added sdninterfaceapp and usecplugin back into autorelease as they have merge their fixes. (anipbu, 04:50:17)
    3. https://lists.opendaylight.org/pipermail/release/2016-December/008994.html <--- Carbon M3 Offset 0 Status is due today (12/22). Two additional questions on updating projects facts and acknowledging RC Blocking Bug Timeframe. (anipbu, 04:50:41)
    4. https://wiki.opendaylight.org/view/Weather#Upgrade_to_Karaf_4 <--- There is currently work in progress to upgrade OpenDaylight to Karaf 4. Join Kernal call (Tuesday 9AM Pacific) for more discussion. (anipbu, 04:51:37)
    5. ACTION: colindixon to send mail asking about flagship features for Carbon (colindixon, 04:52:47)

  6. system integration and test (colindixon, 04:53:57)
    1. all is quiet on this holiday week (colindixon, 04:54:12)

  7. infrastructure (colindixon, 04:54:18)
    1. nothing this week, we're trying not to break things (colindixon, 04:54:29)

  8. next week's TSC meeting (colindixon, 04:54:44)
    1. there will be no TSC meeting on Thursday, December 29th b/c Chirstmas and New Years (colindixon, 04:55:05)
    2. we'll meet again on Thrusday, January 5th at the normal time of 10a pacific (colindixon, 04:55:20)

  9. committer-at-large board member elections (colindixon, 04:55:58)
    1. https://wiki.opendaylight.org/view/Committer_Members_Board_Representation Process for committer-at-large representavies on the board (colindixon, 04:56:10)
    2. https://linuxfoundation.echosign.com/public/hostedForm?formid=AI3XA256U2H44Y Link to form to become a committer member (colindixon, 04:56:19)
    3. phrobb opened the nominations for comitter-at-large board representatives on 12/20. The nominations will run through 23:59 UTC on Monday, 1/9 with 2 weeks of voting following that. (colindixon, 04:56:36)
    4. there will be a brief time in between the 9th and when voting starts for the board to review and approve the candidates (colindixon, 04:57:55)

  10. networking-odl in Ocata (colindixon, 04:58:32)
    1. iyamahat says that we're safe in Ocata (colindixon, 04:58:41)
    2. phrobb notes that we should not slow down, and keep our pressure up in OpenStack (colindixon, 04:58:53)
    3. huge tanks to iyamahat and team for keeping things going (colindixon, 04:59:00)

  11. future meetings at APAC-friendly timess (colindixon, 05:00:34)
    1. vishnoianil points out that we need to do a better job getting ht emessage out (colindixon, 05:00:50)
    2. ACTION: vishnoianil will start to help advertize things in India (colindixon, 05:01:43)
    3. ACTION: colindixon to keep working on China with help from gzhao (colindixon, 05:01:56)
    4. vishnoianil suggests using ODLUGs as well to promote it (colindixon, 05:02:45)
    5. ACTION: colindixon and anipbu to work with project that have PTLs in Asia to make sure they know (colindixon, 05:03:43)
    6. is may turn that other meetings, e.g., release reviews, TWS, etc., are more important to move around than the TSC since they have broader audiences (colindixon, 05:04:18)

  12. China ODL tour (colindixon, 05:04:59)
    1. http://www.china-odl.com/ (colindixon, 05:05:00)
    2. http://georgezhao.org/blog gzhao wrote a blog post on the china odl tour summarizing what happened (colindixon, 05:06:14)
    3. if people are interested, he can comment or connect people with presentations, get slides or recordings (colindixon, 05:06:29)
    4. biggest concerns/topics were clustering, yang models, and stability (colindixon, 05:06:54)
    5. gzhao says that he thought that people had a much more thorough understanding of how OpenDaylight worked than we expected, slides were retooled to have deeper dives and technical details than introductions (colindixon, 05:08:30)
    6. gzhao says that there was a lot of people saying they had internally fixed a lot of ODL issues, but not contributed things, back—colindixon adds that fixing that will be hard and important (colindixon, 05:09:54)
    7. gzhao goes into how each of the 3 major Chinese carriers are using OpenDaylight, some interesting observations, e.g., that SDN made things more closed (less interop between s/w and h/w than before SDN) and so having to build their own SDN controller (based on ODL) to help (colindixon, 05:10:50)
    8. phrobb got a lot of 1:1 feedback that wriing cluster-aware apps was harder than expected and could use better docs (colindixon, 05:11:40)

  13. interns (colindixon, 05:12:08)
    1. CaseyODL says that we have only 1 intern application so far (colindixon, 05:12:34)
    2. https://wiki.opendaylight.org/view/Interns the deadline to submit is January 6th, hoping to send out notifications for acceptance by January 17th (colindixon, 05:13:11)
    3. CaseyODL asks people to make sure people apply before the 6th, and try to get people to apply if you know others (colindixon, 05:15:05)

  14. cookies (colindixon, 05:15:45)


Meeting ended at 05:15:59 UTC (full logs).

Action items

  1. add the hackfest to the list of ongoing discussions on the TSC list
  2. colindixon to send mail asking about flagship features for Carbon
  3. vishnoianil will start to help advertize things in India
  4. colindixon to keep working on China with help from gzhao
  5. colindixon and anipbu to work with project that have PTLs in Asia to make sure they know


Action items, by person

  1. anipbu
    1. colindixon and anipbu to work with project that have PTLs in Asia to make sure they know
  2. colindixon
    1. colindixon to send mail asking about flagship features for Carbon
    2. colindixon to keep working on China with help from gzhao
    3. colindixon and anipbu to work with project that have PTLs in Asia to make sure they know
  3. gzhao
    1. colindixon to keep working on China with help from gzhao
  4. vishnoianil
    1. vishnoianil will start to help advertize things in India


People present (lines said)

  1. colindixon (82)
  2. anipbu (9)
  3. odl_meetbot (6)
  4. jamoluhrsen (5)
  5. zxiiro (4)
  6. aswinsuryan (2)
  7. vishnoianil (2)
  8. gzhao (1)
  9. phrobb (1)
  10. vrpolak (1)
  11. LuisGomez (1)
  12. iyamahat (1)
  13. CaseyODL (1)
  14. abelur (1)


Generated by MeetBot 0.1.4.