#opendaylight-meeting: tws

Meeting started by colindixon at 17:04:45 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 17:04:49)
    1. zxiiro will cover the maven site infrastructure and using it to set up (among other things) javadoc (colindixon, 17:05:19)

  2. maven sites in OpenDaylight (colindixon, 17:05:53)
    1. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.odlparent/boron/maven-site.html Maven site docs (zxiiro, 17:06:26)
    2. https://nexus.opendaylight.org/content/sites/site/ ODL Sites location (zxiiro, 17:06:27)
    3. https://git.opendaylight.org/gerrit/37609 an example patch (with Javadoc fix) (skitt, 17:07:10)
    4. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.lispflowmapping/boron/ example of the lisp flow mapping maven site that zxiiro uses to demonstrate (colindixon, 17:07:57)
    5. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.lispflowmapping/boron/checkstyle-aggregate.html you can get lots of things in maven sites, e.g., checkstyle (colindixon, 17:08:41)
    6. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.lispflowmapping/boron/apidocs/index.html possibly most important thing is Javadoc (colindixon, 17:09:06)
    7. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.odlparent/boron/maven-site.html the maven site that documents how to enable maven sites (colindixon, 17:09:39)
    8. zxiiro notes that the artifactId in the deploy-site.xml doesn't matter, only the group ID (colindixon, 17:09:58)
    9. zxiiro notes that you need to fix the maven site URL since we don't follow the standard maven directory structure it expects for sites (colindixon, 17:11:11)
    10. zxiiro points out that for all pom files but the root are just copy and pasting the example from the documentation here (colindixon, 17:11:36)
    11. for the root pom, you need to remove the one line for the <url>, this is the root pom.xml in the project by directory, not necessarily by the parent relationship in pom files (colindixon, 17:12:55)
    12. zxiiro notes that you can do lots of things here including generating AsciiDoc, markdown, or static html documentaiton (colindixon, 17:13:43)

  3. Javadoc (colindixon, 17:14:51)
    1. enabling aggregated Javadoc is described, you just need to past the maven-site profile from the maven sites docs above, into your root pom (again by directory, not parent) (colindixon, 17:15:02)
    2. you also have to create a site.xml under src/site/site.xml (colindixon, 17:15:22)
    3. you want to generate things locally, you need to do maven site:deploy -Dstream=boron, but it will be done by merge jobs and uploaded automatically (colindixon, 17:16:01)

  4. other things maven sites can do (colindixon, 17:16:30)
    1. colindixon says he knows you can get version convergence/skew information, it's part of "reports" in maven sites (colindixon, 17:17:02)
    2. zxiiro notes that reporting is just like a build section, but aimed at creating reports, you can add for example dependency-convergence (colindixon, 17:17:46)
    3. https://maven.apache.org/plugins/maven-site-plugin/examples/configuring-reports.html maven-site reporting (zxiiro, 17:17:53)
    4. colindixon asks if we can enable dependency-convergence reporting on autorelease to give us an idea of when we have version skew and where in an official, supported capacity (colindixon, 17:19:53)
    5. zxiiro says we could, but it and several other plugins will siginficantly affect build time (colindixon, 17:20:06)
    6. skitt says there are lots of little gotchas, lots of projects already have a <url> field in their pom, those need to be removed (colindixon, 17:20:38)
    7. not lots, just a couple :-) (skitt, 17:20:52)
    8. skitt also says that when you enable javadoc, errors in your javadoc will break your build, so you need to fix them (colindixon, 17:21:07)
    9. zxiiro says he's seen random things where enabling maven sites causing checkstyle to start working, but only twice, you can either fix the problems or disable it (which is a bad idea) (colindixon, 17:21:54)
    10. zxiiro notes that this is all now in the archetype, so it will come for all new projects by default (colindixon, 17:23:18)
    11. lori asks if there's a way disable it by default, zxiiro says you need to disable maven-site generation locally, zxiiro says that you can do it by passing -P!maven-site to your local build to disable that profile (colindixon, 17:24:24)
    12. rovarga asks if we can have it disabled by default and then enabled in jenkins (colindixon, 17:25:08)
    13. zxiiro says there's no way to do that and have conditional activation by file and have it disabled by default (colindixon, 17:26:19)
    14. ACTION: zxiiro to send an e-mail about how to disable maven-sites locally in one-time and semi-permanent ways (colindixon, 17:26:49)
    15. colindixon suggests either through the MAVEN_OPTS environment variable (colindixon, 17:27:55)
    16. or maybe via settings.xml (but that might not override pom files) (colindixon, 17:29:04)

  5. next week's TWS (colindixon, 17:29:31)
    1. colindixon asks if we should have a TWS next week or everyone will be at OpenStack (colindixon, 17:29:49)
    2. VOTE: Voted on "should we have a TWS next week?" Results are, 0: 6, -1: 1 (colindixon, 17:31:35)
    3. we are violently neutral with one conflict (colindixon, 17:31:44)
    4. https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Project_layout current pom file best practices (colindixon, 17:35:38)
    5. ACTION: zxiiro and/or rovarga should probably fold that into the maven sites info or vice versa (colindixon, 17:36:08)
    6. colindixon says probably carbon planning would be the most important thing to do next week if we have the meeting (colindixon, 17:36:29)
    7. ACTION: colindixon to send an e-mail asking if we can get presenters for carbon planning for next week (colindixon, 17:36:44)


Meeting ended at 17:37:02 UTC (full logs).

Action items

  1. zxiiro to send an e-mail about how to disable maven-sites locally in one-time and semi-permanent ways
  2. zxiiro and/or rovarga should probably fold that into the maven sites info or vice versa
  3. colindixon to send an e-mail asking if we can get presenters for carbon planning for next week


Action items, by person

  1. colindixon
    1. colindixon to send an e-mail asking if we can get presenters for carbon planning for next week
  2. zxiiro
    1. zxiiro to send an e-mail about how to disable maven-sites locally in one-time and semi-permanent ways
    2. zxiiro and/or rovarga should probably fold that into the maven sites info or vice versa


People present (lines said)

  1. colindixon (46)
  2. odl_meetbot (9)
  3. skitt (3)
  4. zxiiro (3)
  5. phrobb (2)
  6. adetalhouet (1)
  7. LuisGomez (1)
  8. hideyuki (1)
  9. lori (1)


Generated by MeetBot 0.1.4.