17:00:34 <colindixon> #startmeeting tws
17:00:34 <odl_meetbot> Meeting started Mon Aug  1 17:00:34 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:34 <odl_meetbot> The meeting name has been set to 'tws'
17:00:38 <colindixon> #topic agenda bashing
17:00:44 * dfarrell07 is here
17:01:11 * colindixon is getting on webex
17:02:03 <colindixon> #info dfarrell07 and phrobb will talk about TSC elections today
17:04:18 <dfarrell07> #link https://wiki.opendaylight.org/view/TSC:Election_Proposal Elections Proposal wiki, main source of truth
17:05:12 <colindixon> #topic TSC elections
17:05:12 <dfarrell07> #info Wiki describes: background, principles, Framework, Represented Group proposals
17:07:11 <dfarrell07> #topic Background
17:07:28 <dfarrell07> #info ODL didn't have community of experienced ppl to draw TSC from initially, so bootstrapped with Platinum Designates
17:08:32 <dfarrell07> #info Wanted to move from Platinum Designates to community-elected ppl
17:08:37 <dfarrell07> #info Need to change election system made more pressing by Board's refusal to give waver for bad feature of system caused by PDs
17:09:25 <dfarrell07> #topic Principles
17:09:33 <dfarrell07> #info Representation of Constituencies: There are systemically competing groups in ODL community, they should be represented
17:11:01 <dfarrell07> #info Protection from Dominance by a Constituency: There should be systematic protections from dominance by a group, especially a company
17:11:56 <dfarrell07> #info Fairness of Exclusion: Caps, which are necessary for other properties, can cause people to be excluded. This should be fair/clear, to mitigate hard feelings
17:12:35 <dfarrell07> #info Modern Election Tools: Elections are complex, we should use modern best practices
17:13:22 <dfarrell07> #info Flexibility over Time: We need a framework that change change as ODL changes, and as we learn
17:13:53 <dfarrell07> #topic Framework
17:14:08 <dfarrell07> #info Fixed portion stays the same election to election, RGs swapped out to allow Flexibility over Time
17:14:35 <dfarrell07> #info Multi-election, multi-winner - one election for each RG, no less than Min Seats winners, no more than Max Seats winners
17:14:47 <dfarrell07> #info Key concept: Represented Groups - group of ODL community members with similar interest, that complete with other community groups
17:14:59 <dfarrell07> #info RGs defined by: min seats, max seats, candidates, voters
17:21:57 <colindixon> #info abhijitkumbhare asks how represented groups work in terms of who votes, the answer is that the candidates and the electorate are the same, usually that is PTLs of the relevant projects
17:22:21 <colindixon> #info the exception is comitters-at-large where the electorate and the voters are both all committers of OpenDaylight
17:22:44 <colindixon> #info for project categories, that's one vote per project, for committer-at-large it's one vote per committer
17:23:51 <colindixon> #info dfarrell07 notes that isn't set in stone, but it's how it's written now
17:24:52 <colindixon> #info rovarga asks how things work if you're the PTL of multiple projects in the same class, e.g., mdsal and controller, the answer is they'd get two votes at least now and that would need two e-mails
17:25:07 <colindixon> #action dfarrell07 to make having multiple votes in the same election more explicit
17:28:14 <colindixon> #info dfarrell07 goes into the election mechanics
17:28:30 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Election_Proposal#Election_Mechanics
17:32:03 <colindixon> #info dfarrell07 explains over-max resolution and scaled popularity
17:36:18 <colindixon> #info colindixon asks how this mechanically will work if we have to trigger over-max resolution
17:37:20 <colindixon> #info dfarrell07 says right now, the figuring out who to drop would be done manually, that math is generally easy
17:40:54 <colindixon> #info after that you basically just elimnate that person and then see what happens
17:41:32 <colindixon> #info colindixon asks about very specific low-level details like how you get scaled-popularity to work, e.g., is i the number of people who picked that person as the first choice, or the number of people who prefered the first choice over the second choice?
17:43:20 <colindixon> #info colindixon asks if we even get raw votes, phrobb says that he thinks you can as one of the settings
17:43:32 <colindixon> #action phrobb to make sure we can get raw votes out of CIVS
17:45:05 <phrobb> #info, yes we do get raw output that can be easily transplanted to a google spreadsheet
17:46:47 <colindixon> #undo
17:46:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24b6450>
17:46:48 <colindixon> #Undo
17:46:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x24b6310>
17:47:04 <colindixon> #info phrobb confirms we get raw data that can be easiliy exported to google spreadsheet
17:48:03 <colindixon> #Info abhijitkumbhare asks about mins and maxes, the basic idea is that min is the number of seats that come out of an election, max is the number of people who meet that "description" who are allowed to win seats in *any* election
17:54:43 <colindixon> #info abhijitkumbhare asks if we really need max caps on things other than companies, dfarrell07 and colindixon say that generally, its for fairness and edwarnicke is the biggest advocate for it
17:55:08 <colindixon> #Info the idea is that if you're afraid of a company dominating, then you should also be afraid of other groups dominating
17:59:41 <colindixon> #info vishnoianil thinks he'd rather see committers vote than just PTLs, rovarga and abhijitkumbhare seem to think PTLs would be better
18:00:47 <abhijitkumbhare> #info rovarga and abhijitkumbhare think PTLs should be better because to avoid gaming the system
18:00:53 <colindixon> #Info rovarga points out that we want to make sure we can't game the system with incubation projects and comitters there
18:00:54 <abhijitkumbhare> feel free to undo
18:01:24 <colindixon> #Info colindixon notes that most RG sets we look at don't include incubation, which is probably a good thing for that reason among others
18:05:47 <dfarrell07> #info Discussion about Integration RG having value, def have different interest/needs than mature projects, good to have their voice, not always looking for most experience, also need various views on TSC
18:05:50 <dfarrell07> #endmeeting