13:59:47 <anipbu> #startmeeting carbon release review
13:59:47 <odl_meetbot> Meeting started Wed May 17 13:59:47 2017 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
13:59:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:47 <odl_meetbot> The meeting name has been set to 'carbon_release_review'
13:59:53 <anipbu> #topic roll call
14:00:00 <anipbu> #info PTL and TSC members please #info in
14:00:08 <anipbu> Good Morning folks
14:00:12 <anipbu> Let's start the release reviews
14:00:15 <katie> hi morning
14:00:19 <anipbu> #info anipbu
14:00:26 <anipbu> Good morning katie
14:00:28 <AnZa> #info AnZa
14:00:31 <xingjun> #info xingjun
14:00:41 <anipbu> #chair zxiiro colindixon
14:00:41 <odl_meetbot> Warning: Nick not in channel: colindixon
14:00:41 <odl_meetbot> Current chairs: anipbu colindixon zxiiro
14:00:43 <katie> good morning an
14:00:54 <zxiiro> #info Thanh
14:01:09 <anipbu> Let's give a minute for Colin Dixon to arrive
14:01:15 <anipbu> We'll begin shortly
14:01:18 <zxiiro> FYI I'm aware of the docs patches build failures and just fixed them a few minutes ago. I think we just need to rebase patches
14:01:52 <anipbu> Anybody hear from colindixon?
14:02:54 <katie> before we formally started, want to send a message from casey to every PTLs here:
14:02:58 <katie> Would you please provide a short video (few minutes would be fine) to introduce your project? Give a brief introduction, what service of your project can provide. Are there any new features  of your project in Carbon release? what is it? When you have the video ready , please fill the video link to the release notes tracking sheet  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit?us
14:03:32 <anipbu> thanks katie for relaying the message
14:03:59 <anipbu> If colindixon does not show up, we'll start in a minute.
14:04:01 <gkaempfer> #info gkaempfer
14:04:22 <katie> This will really help our project advertise ourself
14:04:25 <AnZa> Well I am afraid that I will not get time slot for video from my emploeyer, so I can't do any promise... Regarding features, there are no new features in Carbon
14:04:56 <katie> ok, got it AnZa
14:05:15 <anipbu> Okay let's begin.
14:05:19 <anipbu> #topic TOPOPROCESSING
14:05:25 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57222   <-- Release Notes
14:05:39 <anipbu> #info AnZa is representing TOPOPROCESSING
14:05:40 <anipbu> Anything you would like to add?
14:05:48 <anipbu> 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:05:54 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:06:01 <AnZa> nothing special from my side
14:06:19 <anipbu> #info odl-topoprocessing-framewrok is experimental as started on the release notes
14:06:24 <AnZa> I just tested agains RC1 and its working. We have no blockers
14:06:46 <AnZa> No tests need to be ignored, no tests failures
14:06:55 <anipbu> AnZa:  can you update the spreadsheet:
14:07:00 <anipbu> https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:07:11 <anipbu> its currently saying blank for topoprocessing
14:07:36 <AnZa> Strange, I fill it some time ago. When I open link I see it filled
14:07:52 <anipbu> AnZa, you ahve to fill it out again for RC1
14:08:06 <AnZa> Ok, I will try
14:08:07 <anipbu> you filled it out for RC0, but we just finished for RC1
14:08:09 <anipbu> Thanks
14:08:24 <anipbu> If you can fill it our now, we can approve your project
14:08:42 <AnZa> But I filled RC1 no RC0. I see it there
14:08:50 <anipbu> #info CSIT jobs are here: https://jenkins.opendaylight.org/releng/view/topoprocessing/job/topoprocessing-csit-1node-topology-operations-all-carbon/
14:08:50 <katie> an, I see it too
14:09:01 <anipbu> Okay thanks
14:09:44 <anipbu> topoprocessing looks good to me.
14:09:48 <anipbu> it is a maintenance project
14:09:53 <anipbu> no real changes in this release
14:09:53 <katie> but on the same sheet, RC0 part is not filled
14:09:57 <katie> it is ok?
14:10:08 <AnZa> We didn't test RC0
14:10:14 <katie> ok, got it
14:10:15 <anipbu> Do folks have any additional comments?
14:10:35 <anipbu> zxiiro: anything you want to raise additionally?
14:10:42 <zxiiro> I do not
14:10:55 <katie> just want to confirm, no way you are going to have a short video for us? Anza?
14:11:39 <AnZa> I just don't promise that, but I will ask about it...
14:11:42 <anipbu> Okay let's move on.
14:11:51 <anipbu> #info TOPOPROCESSING approved for Carbon.  Congratulations!
14:11:53 <katie> that is great, thanks Anza
14:11:56 <anipbu> #topic USC
14:11:57 <zxiiro> There's some minor formatting issues in topo processing's release docs but I can fix it. Thanks!
14:12:03 <anipbu> #link https://git.opendaylight.org/gerrit/57205    <-- Release Notes
14:12:08 <anipbu> #info anipbu is representing USC
14:12:40 <anipbu> zxiiro: you're gonna have to review me
14:12:47 <katie> Zxiiro can you please review USC?
14:13:01 <zxiiro> alright
14:13:16 <zxiiro> 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:13:23 <zxiiro> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:13:42 <anipbu> zxiiro: yes to 1, updates
14:14:11 <zxiiro> #info usc is experimental as stated in the release notes
14:14:12 <anipbu> zxiiro: yes to 2) have signed off on failures
14:14:29 <anipbu> #undo
14:14:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1dc63d0>
14:14:36 <anipbu> zxiiro: usc is not experimental
14:14:46 <anipbu> int eh release notes, it's listed as nonexperimental
14:14:53 <anipbu> we have test coverage for our features
14:15:05 <zxiiro> woops was lokoing at the wrong ling
14:15:06 <zxiiro> link
14:15:15 <anipbu> zxiiro: no worries
14:15:24 <zxiiro> #info usc is non-experimental as stated in the release notes
14:15:32 <anipbu> USC is in maintenance mode, so no changes in this release
14:15:49 <zxiiro> #info USC is in maintenance mode, so no changes in this release
14:16:03 <zxiiro> Anything additional comments?
14:16:34 <anipbu> If there are no other comments from folks, can you approve my project?
14:17:10 <zxiiro> #info USC approved for Carbon.
14:17:14 <zxiiro> congrats
14:17:28 <katie> an are you going to provide the short video I mentioned for your project?
14:17:36 <anipbu> katie, no video
14:17:37 <anipbu> #topic NEMO
14:17:42 <anipbu> #link https://git.opendaylight.org/gerrit/57204    <-- Release Notes
14:17:46 <anipbu> #info anipbu is representing NEMO
14:18:00 <zxiiro> 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:18:07 <zxiiro> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:18:22 <anipbu> 1) yes, we have tested RC1 and found no issues.  spreadsheet has been updated
14:18:35 <zxiiro> #info NEMO is non-experimental as stated in the release notes.
14:18:55 <anipbu> 2) We have signed off on test failures
14:19:07 <anipbu> nemo is in maintenance mode.  no changes in this release
14:19:17 <zxiiro> #info nemo is in maintenance mode.  no changes in this release
14:19:31 <zxiiro> Any other comments?
14:19:41 <zxiiro> I'm assuming no video for nemo either.
14:19:51 <katie> I guess so
14:19:55 <anipbu> katie: no video for nemo
14:20:03 <katie> thanks Zxiiro for asking
14:20:11 <zxiiro> #info NEMO approved for Carbon.
14:20:12 <zxiiro> congrats
14:20:32 * zxiiro passes the ball back to An :)
14:20:38 <anipbu> okay let's move on
14:20:44 <anipbu> #topic DLUXAPPS
14:20:50 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57208/    <-- Release Notes
14:20:57 <anipbu> #info Daniel Malachovsky is representing DLUXAPPS
14:21:05 <anipbu> dmalachovsky good morning
14:21:06 <dmalachovsky> i'm here
14:21:12 <anipbu> Anything you would like to add?
14:21:18 <anipbu> 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:21:24 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:21:59 <anipbu> #info all dluxapps features are experimental
14:22:05 <dmalachovsky> 1. tested against RC1, no blocker bugs so far, some minor bugs, nothing huge
14:22:47 <anipbu> Could you update the spreadsheet please
14:23:06 <dmalachovsky> it's updated for RC1
14:23:17 <dmalachovsky> 2. this should be ignored https://jenkins.opendaylight.org/releng/view/dluxapps/job/dluxapps-csit-1node-yangman-all-carbon/
14:23:21 <anipbu> #info DLUXAPPS CSIT have some failures but not blocker issues: https://jenkins.opendaylight.org/releng/job/dluxapps-csit-1node-yangman-all-carbon/
14:23:32 <anipbu> #info dluxapps have tested RC1 and found no blocker issues
14:23:48 <anipbu> #info dluxapps tests can be ignored: https://jenkins.opendaylight.org/releng/view/dluxapps/job/dluxapps-csit-1node-yangman-all-carbon/
14:24:06 <dmalachovsky> we know the reason of the error in CSIT, this should fix it https://git.opendaylight.org/gerrit/#/c/54772/, but have verify errors
14:24:31 <anipbu> dmalachovsky: could you update the spreadsheet to reflect that you IGNORE that test case: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:24:53 <dmalachovsky> reason isn't any incompatibility with other features
14:25:04 <dmalachovsky> just need one mmore step for that test
14:25:13 <anipbu> dmalachovsky: any big changes in carbon or was your project in maintenance mode?
14:25:41 <dmalachovsky> dluxapps is new project in carbon, we split dlux into two projects
14:25:55 <anipbu> #info dmalachovsky says dluxapps is new project in carbon, we split dlux into two projects
14:26:14 <anipbu> dmalachovsky: any major changes to the codebase since the split?
14:26:16 <dmalachovsky> but changes were mostly in infrastructure, not in applications itself
14:26:38 <anipbu> #info dmalachovsky says changes were mostly in infrastructure, not in applications itself
14:26:47 <dmalachovsky> we changed feature names - from odl-dlux to odl-dluxapps
14:26:47 <anipbu> okay, dluxapps looks good to me
14:26:59 <anipbu> do folks have any other comments?
14:27:11 <katie> daniel , would you please provide the video for your project?
14:27:22 <dmalachovsky> katie, no video right now
14:27:23 <anipbu> #info dluxapps feature name changes: odl-dlux to odl-dluxapps
14:27:35 <katie> ok, got it
14:28:26 <anipbu> Okay let's move on
14:28:53 <anipbu> #info DLUXAPPS approved for Carbon.  Congratulations!
14:28:57 <dmalachovsky> thanks
14:28:59 <anipbu> #topic FEDERATION
14:29:04 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57207/<-- Release Notes
14:29:14 <gkaempfer> good morning
14:29:20 <anipbu> #info Gideon Kaempfer is representing DLUXAPPS
14:29:23 <anipbu> #undo
14:29:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cd11d0>
14:29:27 <anipbu> #info Gideon Kaempfer is representing FEDERATION
14:29:33 <anipbu> Anything you would like to add?
14:29:40 <anipbu> 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:29:47 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:29:56 <anipbu> 3) katie: do you have any videos?
14:30:14 <katie> Thanks An for asking
14:30:40 <katie> the video is :
14:30:41 <gkaempfer> unfortunately no good news. The entire team working on Federation has recently been let go by HPE.
14:30:41 <anipbu> #info all federation features are experimental
14:30:51 <katie> Would you please provide a short video (few minutes would be fine) to introduce your project? Give a brief introduction, what service of your project can provide. Are there any new features  of your project in Carbon release? what is it? When you have the video ready , please fill the video link to the release notes tracking sheet  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit?us
14:31:06 <anipbu> gkaempfer: so sorry to hear that
14:31:37 <katie> sorry to hear it
14:31:49 <gkaempfer> federation is tested only by means of NetVirt (via the NetVirt federation plugin) and should be OK but I wasn't able to positively establish testing status before this review.
14:31:53 <gkaempfer> tnx
14:32:09 <anipbu> gkaempfer: did federation get a test waiver?
14:32:35 <gkaempfer> I don't think that there is a formal waiver.
14:33:11 <anipbu> gkaempfer: in future releases, please request test waiver since it is tested by NetVirt
14:33:31 <anipbu> gkaempfer: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:34:00 <anipbu> #info federation is tested only by means of NetVirt (via the NetVirt federation plugin) and should be OK but I wasn't able to positively establish testing status before this review.
14:34:11 <anipbu> gkaempfer: any blocker in RC1?
14:34:12 <gkaempfer> no testing against RC2 (as mentioned above)
14:34:17 <gkaempfer> no known blockers
14:34:35 <anipbu> #info FEDERATION has rested against RC1 and found no blocker
14:34:35 <zxiiro> s/RC2/RC1/g
14:34:52 <gkaempfer> same for RC1
14:34:53 <anipbu> gkaempfer: could you update the spreadsheet please
14:35:16 <anipbu> gkaempfer: the row for federation is currently blank on the spreadsheet
14:35:42 <gkaempfer> will do once I receive positive feedback from the NetVirt federation people.
14:36:06 <colindixon> sorry running late
14:36:09 <colindixon> here now
14:36:10 <gkaempfer> (they are under the same unfortunate status as mentioned above)
14:36:30 <anipbu> #action gkaempfer will follow up on RC1 testing with release team once receive positive feedback from the NetVirt federation people
14:37:09 <anipbu> gkaempfer: could you let us know once the spreadsheet is updated.  Thanks
14:37:22 <anipbu> i  mean after you confirm with netvirt
14:37:57 <gkaempfer> sure
14:38:17 <anipbu> For federation, we'll wait for testing to complete before we approve the project.
14:38:42 <anipbu> Once gkaempfer updates the spreadsheet, we can review their project again and analyze it for approval
14:38:49 <anipbu> Any other comments form folks?
14:40:09 <colindixon> Nope. Thanks.
14:40:18 <anipbu> Okay.  Let's move on
14:40:36 <anipbu> #info FEDERATION is pending.  Waiting on completion of action items as stated above.
14:40:55 <anipbu> #topic FAAS
14:41:01 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57212/<-- Release Notes
14:41:07 <anipbu> #info xingjun chu is representing FAAS
14:41:20 <anipbu> Anything you would like to add?
14:41:28 <xingjun> No, nothing special to add
14:41:35 <anipbu> 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:41:41 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:41:50 <xingjun> Yes, we have tested against RC1, no issues found.
14:42:15 <xingjun> we have updated the RC1 track speadsheet
14:42:31 <anipbu> 3) Do you have any short video to introduce your project? Give a brief introduction, what service of your project can provide. Are there any new features  of your project in Carbon release? what is it? When you have the video ready , please fill the video link to the release notes tracking sheet
14:42:31 <anipbu> https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit?us
14:42:45 <anipbu> #info FAAS has tested RC1 and found no blocker issues
14:42:59 <xingjun> We have one, but  I may have to reduce its size a bit
14:43:12 <katie> that is great xingjun,
14:43:29 <anipbu> #info FAAS has video, which will be reduced in size
14:43:31 <katie> when you have it , please fill the video link to the table and let us know
14:43:56 <anipbu> xingjun: any CSIT tests to ignore?
14:43:57 <xingjun> Sure, I need to post to youtube ? or somewhere?
14:44:07 <xingjun> no CSIT failures
14:44:10 <katie> youbube is fine
14:44:25 <colindixon> I have some minor feedback on the release notes patch.
14:44:36 <xingjun> ok
14:44:38 <katie> sorry, I mean youtube
14:44:52 <xingjun> ok
14:45:05 <anipbu> #info all FAAS features are experimental as stated on the release notes
14:45:22 <xingjun> I will fix it Colin
14:45:45 <xingjun> thanks
14:45:53 <anipbu> colindixon, did you publish the minor feedback?  i don't see your comments on the patch
14:46:32 <colindixon> anipbu: just now
14:46:33 <colindixon> yes
14:46:40 <anipbu> #info FAAS performs only manual testing as stated on the release notes
14:46:58 <anipbu> xingjun: please request test waiver in the future since your project has no CSIT tests
14:47:08 <colindixon> the only one of note is that FaaS says it supports migration, but gives no steps how, the only way I can imagine that being true is if it is stateless in the data store
14:47:10 <colindixon> is that true?
14:47:33 <anipbu> xingjun: ^^^
14:47:43 <colindixon> and that can be answered offline
14:48:00 <xingjun> no, it is not stateless. but we don't have configuration change this release
14:48:26 <xingjun> so it should be compatbile from previous release
14:48:36 <colindixon> yes, but there's no out-of-the-box way to migrate from Boron to Carbon with data in the data store unless you've tested that and it works
14:48:46 <anipbu> #info xingjun says that faas is not stateless, but don't have configuration change this release.
14:48:53 <colindixon> so, at the very least, users would need to somehow get all the data out and put it all back in
14:49:27 <xingjun> In theory yes. but we haven't tested it
14:50:00 <colindixon> OK. So, I think you need to change that either migration isn't supported or give steps for peole to export and re-import their data.
14:50:11 <xingjun> OK, will do that
14:50:18 <anipbu> #info colindixon raised concerns on compatibility and migration.  at the very least, users would need to somehow get all the data out and put it all back in
14:50:41 <anipbu> #action xingjun will update the release notes on the migration and compatibility as per colindixon's comments
14:50:48 <colindixon> I don't think that should be blocking though
14:50:54 <anipbu> #action xingjun to respond to docs feedback on the release notes patch
14:50:55 * colindixon starts reading GBP
14:50:58 <colindixon> sorry BGP
14:51:09 <cgasparini> Hi everyone
14:51:11 <anipbu> xingjun: could you please follow up?
14:51:18 <xingjun> yeah, do it now
14:51:27 <anipbu> FAAS looks good to me
14:51:32 <anipbu> Any other comments form folks?
14:51:50 <anipbu> If not, let's move on.
14:51:55 <anipbu> #info FAAS approved for Carbon pending action items and follow up.  Congratulations!
14:52:00 <anipbu> #topic BGPCEP
14:52:02 <xingjun> Thanks
14:52:06 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57244/   <-- Release Notes
14:52:11 <anipbu> #info Claudio D. Gasparini is representing BGPCEP
14:52:16 <anipbu> Anything you would like to add?
14:52:28 <cgasparini> no additional info
14:52:34 <anipbu> cgasparini: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:52:41 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:52:50 <cgasparini> both already  updated
14:53:10 <anipbu> cgasparini: any of those tests you want us to IGNORE?
14:53:18 <cgasparini> no
14:53:31 <anipbu> otherwise we woudl ahve to ask that you sign off on them again in RC2, RC3, etc =(
14:54:10 <cgasparini> I ll prefer in that way
14:54:18 <anipbu> #info odl-bgpcep-bgp/bmp/pcep are nonexperimental as stated on the release notes
14:55:15 <anipbu> #info bgpcep has extensive test coverage: https://jenkins.opendaylight.org/releng/view/bgpcep/ but several are failing in CSIT
14:55:32 <anipbu> #info bgpcep has tested RC1 and found no blocker bugs
14:56:03 <anipbu> cgasparini: gerat job on the test coverage =)
14:56:09 <colindixon> #info colindixon provided some (mostly minor) feedback on the release notes patch, the only one of note is asking if it makes sense to point out that MD5 is believed broken, so presumably TCP-MD5 authentication is as well
14:56:22 <cgasparini> thank you :D
14:56:46 <katie> Claudio would you provide a short video to introduce your project? Give a brief introduction, what service of your project can provide. Are there any new features  of your project in Carbon release? what is it? When you have the video ready , please fill the video link to the release notes tracking sheet
14:57:27 <colindixon> also, there may be some formatting issues with the patch, not sure yet since it hasn't passed verify yet
14:57:34 <cgasparini> I ll review the notes and provide feedback, regarding the video I ll what can be done
14:57:43 <cgasparini> *see
14:57:46 <katie> thanks
14:58:06 <anipbu> #action cgasparini will follow up on colindixon feedback for the release notes
14:58:53 <anipbu> cgasparini: were there any major changes in bgpcep this release?
14:59:15 <cgasparini> no
15:00:39 <anipbu> #info BGPCEP had no major changes in this release
15:00:55 <anipbu> so i take it you are also in maintenance mode
15:01:05 <anipbu> BGPCEP looks good to me
15:01:14 <anipbu> Any other additional comments from folks?
15:01:38 <colindixon> none beyond what I said above
15:02:16 <anipbu> cgasparini: please follow up on your actions
15:02:29 <anipbu> Okay let's move on
15:02:32 <anipbu> #info BGPCEP approved for Carbon pending action items and follow up.  Congratulations!
15:02:37 <anipbu> #topic GROUPBASEDPOLICY
15:02:42 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57243/   <-- Release Notes
15:02:48 <anipbu> #info Vladimir Lavor is representing GROUPBASEDPOLICY
15:02:52 <vlavor> Hello everyone
15:02:53 <anipbu> Anything you would like to add?
15:03:07 <anipbu> vlavor: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:03:14 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
15:03:30 <vlavor> 1) RC1 was tested, no major issues were found
15:03:51 <anipbu> #info groupbasedpolicy has tested RC1 and found no blocker bugs
15:04:33 <anipbu> vlavor: could you please sign off on your your RC1 test failures?
15:04:58 <vlavor> 2) CSIT failures will be fixed soon, so I suppose they should be mark ignored for now
15:05:29 <anipbu> #info vlavor notes test failures that can be ignored.
15:05:48 <vlavor> done
15:05:55 <colindixon> #Info colindixon provded some feedback on the patch with the only one of note being that the migration should probably say that migration isn't supported since it seems like it's not
15:05:56 <anipbu> vlavor: thanks
15:06:19 <anipbu> #action vlavor to follow up on feedback on the release notes patch
15:06:49 <anipbu> vlavor: can you please follow up on feedback on patch after the meeting?
15:06:57 <vlavor> ok
15:07:10 <colindixon> none of it is blocking, just trying to get the information right for when others come to look at it
15:07:16 <anipbu> #info all groupbasedpolicy features are experimental as stated on the release notes
15:07:38 <anipbu> vlavor: any major changes in gbp in this release?
15:07:45 <anipbu> or is your project in maintenance mode as well?
15:08:17 <jamoluhrsen> anipbu, colindixon: checking in.
15:08:28 <colindixon> welcome jamoluhrsen
15:08:29 <vlavor> no it is not, some features are under development
15:09:20 <anipbu> #info groupbasedpolicy has some CSIT for some features (which are all experimental).  The current set of CSIT test failures can be ignored.
15:09:55 <anipbu> #info groupbasedpolicy is currently an active project with some features still under development
15:10:26 <anipbu> #info groupbasedpolicy has some API changes in this release:    https://git.opendaylight.org/gerrit/#/c/49041/ https://git.opendaylight.org/gerrit/#/c/49190/
15:10:26 <katie> vlavor: would you provide a short video to introduce your project? Give a brief introduction, what service of your project can provide. Are there any new features  of your project in Carbon release? what is it? When you have the video ready , please fill the video link to the release notes tracking sheet
15:10:59 <vlavor> we don't have any video for now but we will talk about it
15:11:17 <katie> great thanks
15:11:46 <anipbu> GROUPBASEDPOLICY looks good to me
15:11:58 <anipbu> Any additional comments from folks?
15:14:01 <jamoluhrsen> i'm good.
15:14:09 <anipbu> Okay lets move on
15:14:22 <anipbu> vlavor: please follow up on your action items
15:14:27 <katie> somehow the release review spreadsheet has no video on all later project today
15:14:37 <katie> I guess I don't need to ask anymore today
15:14:43 <anipbu> and respond to the feedback
15:14:47 <anipbu> of the patch form colindixon
15:14:52 <anipbu> Oaky Let's move on
15:14:54 <colindixon> thanks
15:14:59 <anipbu> #info GROUPBASEDPOLICY approved for Carbon pending action items and follow up.  Congratulations!
15:15:03 <anipbu> #topic HONEYCOMB/VBD
15:15:08 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57250   <-- Release Notes
15:15:15 <anipbu> #info Michal Cmarada is representing HONEYCOMB/VBD
15:15:19 <michal-cmarada|2> Hi
15:15:20 <anipbu> Anything you would like to add?
15:15:32 <michal-cmarada|2> no, nothing
15:15:32 <anipbu> Good morning michal-cmarada|2
15:15:47 <anipbu> michal-cmarada|2:  1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:15:53 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
15:15:54 <vlavor> colindixon: i have replied to your comment
15:16:32 <michal-cmarada|2> Yes, RC1 was tested. no blockers found. dockument should be up to date
15:17:13 <michal-cmarada|2> We don`t have any CSITs running yet
15:17:15 <anipbu> #info VBD has tested RC1 and found no blocker
15:17:26 <anipbu> #info VBD does not run any CSIT tests
15:18:01 <anipbu> michal-cmarada|2 did you project request a test waiver?
15:18:25 <anipbu> #info All VBD features are experimental as stated in the release notes
15:19:10 <anipbu> michal-cmarada|2 VBD seems to be missing documentation.  Any plans to create READTHEDOCS documentation?
15:19:29 <michal-cmarada|2> No, we didn`t. However we are running some aditional automated tests as part of Fast Data Stacks (FDS) testing suites
15:20:13 <michal-cmarada|2> There is only documentation on our wiki page.
15:20:28 <colindixon> #info colindixon notes that he has feedback on the patch with the only major part being getting clarification on migratoin
15:20:28 <jamoluhrsen> michal-cmarada|2, do you have a link to that FDS automation? or you can put it on your wiki, if not already there.
15:20:40 <colindixon> it's already there I think
15:20:52 <colindixon> see the QA section
15:20:59 <colindixon> lines 53-58
15:21:06 <michal-cmarada|2> the link is provided in release notes but I can add it to wiki too.
15:21:07 <colindixon> http://testresults.opnfv.org/reporting/functest/release/danube/index-status-apex.html
15:21:42 <jamoluhrsen> got it, thanks.
15:22:14 <michal-cmarada|2> Currently there is ongoing migration for these test so they are not showing results now but should be ready next week
15:22:23 <anipbu> #info VBD running some aditional automated tests as part of Fast Data Stacks (FDS) testing suites
15:23:14 <anipbu> #action michal-cmarada|2 to follow up on feedback from colindixon on release notes patch regarding clarification on migration
15:23:34 <xingjun> #info colindixon, for the FaaS project release notes, I have just replied to all your comments and pushed a new patch. thx
15:23:51 <anipbu> xingjun: thanks
15:24:11 <michal-cmarada|2> Yes, I will follow up on comments by Colin
15:24:30 <xingjun> no problem.
15:24:44 <anipbu> jamoluhrsen: thoughts on VBD tests?  All features are experimental, but they did not get test waiver.
15:25:32 <jamoluhrsen> anipbu, vbd is not going to be the only one without a waiver and no csit, I think. I can't parse the FDS results yet.
15:25:50 <jamoluhrsen> anipbu, but if all features are going experimental, then not worth digging too deep I guess
15:26:12 <anipbu> jamoluhrsen: okay, do you think this is blocker or can we approve?
15:26:42 <jamoluhrsen> i'm fine to approve
15:26:53 <anipbu> VBD looks good to me
15:27:01 <anipbu> Any additional comments from folks?
15:27:48 <colindixon> not from me
15:27:53 <anipbu> Okay let's move on
15:27:56 <colindixon> same feedback about migratoin
15:28:06 <colindixon> AAA is next
15:28:12 <anipbu> #info HONEYCOMB/VBD approved for Carbon pending action items and follow up.  Congratulations!
15:28:18 <anipbu> #topic AAA
15:28:23 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57286   <-- Release Notes
15:28:29 <anipbu> #info Ryan Goulding is representing AAA
15:28:35 <anipbu> Anything you would like to add?
15:28:38 <rgoulding> no
15:28:52 <anipbu> rgoulding: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:28:58 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
15:29:31 <colindixon> I looked through everything and it looked good other than minor reST formatting stuff that I can fix later if rgoulding doens't
15:29:57 <rgoulding> the test failures are expected to my knowledge
15:30:10 <rgoulding> RC1 looks good
15:30:42 <anipbu> #info AAA has tested RC1 and found no blocker
15:30:52 <vlavor> colindixon: i've updated gbp release notes according to your comments
15:30:54 <rgoulding> i put all as “IGNORE”
15:31:10 <rgoulding> the idmlight test suite never worked well (JamO is fixing parts of it for master)
15:31:15 <rgoulding> the other test suite i have no idea never seen it
15:31:19 <anipbu> #info AAA has three CSIT test failures but they have been updated as "IGNORE" on the spreadsheet
15:31:19 <rgoulding> i think it was contributed this release
15:31:26 <rgoulding> no idea who did it or why
15:31:45 <anipbu> rgoulding: any major changes in this release or is AAA in maintenance mode?
15:31:54 <rgoulding> this release no huge changes
15:31:57 <jamoluhrsen> I didn't see the IGNORE?
15:32:05 <rgoulding> i just put it on the sheet?
15:32:38 <jamoluhrsen> oh. we should mark OKAY and put a note on the bugs that are causing the failures.
15:32:50 <rgoulding> oh ok
15:32:52 <rgoulding> lol
15:33:02 <jamoluhrsen> proabably one more bug coming :) today I hope
15:33:03 <anipbu> #info rgoulding says no major changes in this release
15:33:16 <rgoulding> whatever works for me… this stuff has been baked in for years…
15:33:24 <jamoluhrsen> anipbu, features are experimental. csit has some value, it's being worked on
15:33:47 <jamoluhrsen> there are bugs, but I guess none are blockers
15:33:54 <anipbu> #info All AAA features are experimental as stated on the release notes
15:34:21 <colindixon> is that true?
15:34:24 <rgoulding> yeah
15:34:28 <anipbu> jamoluhrsen: you mentioned on more bug coming?  is this a blocker bug?  do you ahve bug ID?
15:34:33 <colindixon> presumably we test the heck out of odl-aaa-shiro, right?
15:34:40 <rgoulding> yeah its probably pretty good
15:34:42 <rgoulding> lol
15:35:02 <rgoulding> i dont know what a non experimetnal feature requires at this point
15:35:26 <colindixon> is it tested by CSIT either directly or indirectly and would we recommend using it in production
15:35:27 <colindixon> bascially
15:35:37 <rgoulding> okay well this is in production all around the world
15:35:38 <colindixon> I _think_ the answer is yes to both
15:35:44 <colindixon> yeah…
15:35:47 <rgoulding> and it is tested by the authn test suite...
15:35:52 <rgoulding> so that one is probably stable
15:35:55 <rgoulding> i can update that
15:35:59 <colindixon> the cert store strikes me as more experimental, psosibly, but maybe not even that
15:36:18 <rgoulding> it is experimental no test suite
15:36:20 <rgoulding> just unit tests
15:36:46 <jamoluhrsen> by the book, it's all experimental.
15:36:56 <rgoulding> cool with me
15:37:08 <jamoluhrsen> authn is ok, but has a sporadically failing test (with a bug) and pretty thin at that.
15:37:15 <anipbu> So do we have consensus on this?
15:37:15 <jamoluhrsen> any other csit just plain fails right now
15:37:28 <rgoulding> yeah that bug is in the dependent library
15:37:33 <rgoulding> just grab another token
15:37:42 <colindixon> jamoluhrsen: shiro gets tested by pretty much every CSIT project, right? or do we not use authn?
15:37:42 <rgoulding> but ill call it experimental if we want
15:38:04 <colindixon> anipbu: let's take this offline
15:38:44 <anipbu> #action rgoulding to follow up and update the patch if necessary on the "experimental/nonexperimental" state of AAA's features
15:39:18 <colindixon> jamoluhrsen: I'll ping you in releng
15:39:37 <anipbu> AAA looks good to me
15:39:43 <colindixon> +1
15:39:44 <anipbu> Any additional comments from folks?
15:39:48 <rgoulding> yeah its pretty aight
15:39:48 <jamoluhrsen> +1
15:39:57 <anipbu> Oaky Let's move on
15:40:10 <anipbu> #info AAA approved for Carbon.  Congratulations!
15:40:15 <anipbu> #topic CONTROLLER
15:40:22 <anipbu> #info Tom Pantelis is representing CONTROLLER
15:40:42 <anipbu> tom, Do you have link to release notes?
15:40:49 <pantelis> I don't have nay RN
15:41:29 <pantelis> Not sure if Pantheon folks have anything to RN
15:41:36 <colindixon> OK. We should probably reschedule for a later slot when we have something that summarized the controller project's release information.
15:41:49 <colindixon> Note that the RN isn't just release notes, but a summary of the major funcitonality, etc.
15:41:49 <pantelis> what release info do you nwat?
15:42:05 <colindixon> this is the example of the AAA document: https://git.opendaylight.org/gerrit/#/c/57286
15:42:13 <anipbu> #action pantelis to generate release notes and upload to the docs repo and notify the release team once the release notes are available.
15:42:34 <anipbu> #action pantelis to reschedule the release review for a later timeslot once release notes are available
15:42:50 <pantelis> what is the template?
15:42:56 <pantelis> is there a template?
15:43:08 <colindixon> pantelis: yes
15:43:10 <colindixon> let me go grab it
15:43:12 <zxiiro> pantelis: yes it's in the same directory as the patch. called sample-template
15:43:37 <zxiiro> pantelis: docs/getting-started-guide/project-release-notes/sample...
15:43:38 <pantelis> controller is basically just internal impls of MD_SAL APIs - not sur wwhat needs to be RN
15:43:44 <colindixon> https://github.com/opendaylight/docs/blob/master/docs/getting-started-guide/project-release-notes/sample-release-notes.rst
15:43:52 <anipbu> pantelis: there also a guide to help you https://wiki.opendaylight.org/view/Simultaneous_Release/Guides/Release_Notes
15:44:19 <colindixon> pantelis: it should be fast an take ~15-20 minutes
15:44:37 <anipbu> are folks okay with moving on while we wait for tom to finish uploading a patch?
15:44:40 <pantelis> fine. What else?
15:45:18 <pantelis> let's finish this
15:45:22 <colindixon> it's hard to say without the links to things like CSIT results, known issues, etc.
15:45:45 <pantelis> This was all discussed yesterday on keral acll
15:45:51 <pantelis> kernel call
15:46:08 <pantelis> Pantheon has several blockers
15:46:25 <pantelis> they'ew ding the CSIT tests
15:46:30 <pantelis> and testing
15:46:40 <colindixon> OK. Are they being tracked here: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511
15:46:45 <pantelis> I'm not in the loop on what they're doing
15:47:08 <rovarga> ugh, sorry for missing this
15:47:17 <jamoluhrsen> I sent an email on controller-dev asking about csit. most everything is cluster testing
15:47:22 <rovarga> we have a very proto release notes aet https://wiki.opendaylight.org/view/OpenDaylight_Controller:Carbon:Release_Notes
15:47:59 <anipbu> rovarga: release notes should be submitted as patch in this release.   https://wiki.opendaylight.org/view/Simultaneous_Release/Guides/Release_Notes
15:48:47 <rovarga> anipbu: oh I see
15:48:59 <anipbu> pantelis: rovarga: let's circle back on controller after we cover SXP.
15:49:19 <anipbu> pantelis: rovarga: should only take five minutes to upload a patch for the release notes
15:49:34 <anipbu> pantelis: rovarga: the content is roughly the same
15:49:56 <anipbu> pantelis: rovarga: sound good to you folks?
15:50:42 <anipbu> #topic SXP
15:50:48 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57047/   <-- Release Notes
15:50:54 <anipbu> #info Martin Mihálek is representing SXP
15:50:56 <mamihale> Hi everyone
15:50:59 <anipbu> Anything you would like to add?
15:51:05 <mamihale> Nothing
15:51:12 <anipbu> mamihale: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:51:19 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
15:51:36 <mamihale> 1) RC1 was tested without any major issues
15:51:51 <anipbu> #info SXP has tested RC1 and found no blocker bugs
15:52:20 <mamihale> 2) CSIT failures have been signed off and provided brief description to them in https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
15:52:27 <anipbu> #info SXP has CSIT test failures, but they have signed off on the test failures as "OKAY" on the spreadsheet.
15:53:06 <anipbu> #info All SXP features are experimental as stated on the release notes
15:55:13 <anipbu> mamihale: were there any major changes in SXP in this release, or is SXP in maintenance mode?
15:55:16 <colindixon> #info colindixon left feedback on the patch, but the only major one is asking how the SXP protocol is secured
15:56:02 <anipbu> mamihale: could you please follow up on feedback on your patch?
15:56:22 <anipbu> #action mamihale to follow up on the feedback on the release notes patch
15:56:30 <mamihale> yes will do
15:56:37 <jamoluhrsen> mamihale, I'll get that test patch merged for you.
15:56:39 <anipbu> mamihale: were there any major changes in SXP in this release, or is SXP in maintenance mode?
15:57:27 <mamihale> one new experimental feature was proposed otherwise no big changes
15:57:41 <anipbu> mamihale: any comments on how you keep the interface secure on port 64999?
15:57:56 <anipbu> mamihale: is this a security hole that end users should be aware of?
15:58:05 * colindixon has to go to another meeting for ~30 minutes, it seems like things are under control
15:58:27 <anipbu> #info mamihale states that in this release, SXP provided one new experimental feature proposed otherwise no big changes
15:58:42 <colindixon> anipbu, mamihale: the key point is that we should provide information an operator/user would want to understand about opening/securing that port
15:58:47 <anipbu> colindixon: okay, see you in 30 minutes
15:59:00 <colindixon> I should still be able to scan this is the background a bit
15:59:17 <colindixon> but it seems like I'll only miss iotdm
15:59:17 <colindixon> let me see if I can review the patch before I leave
15:59:38 <mamihale> for security on port 64999 it is used MD5
15:59:57 <anipbu> #info mamihale states that for security on port 64999 it is used MD5
16:00:13 <mamihale> if needed I will add that to notes into security issues
16:00:52 <anipbu> #action mamihale to update the release notes on the security issues
16:01:10 <anipbu> #action jamoluhrsen to follow up and merge the test patch for SXP
16:01:45 <anipbu> mamihale: great job on the test coverage.  very extensive CSIT tests =)
16:01:57 <anipbu> SXP looks good to me (pending the action items)
16:02:06 <anipbu> Any additional comments from folks?
16:02:34 <jamoluhrsen> good with me.
16:03:04 <anipbu> Oaky let's move on
16:03:10 <anipbu> #info SXP approved for Carbon pending action items and follow up.  Congratulations!
16:03:15 <anipbu> #topic IOTDM
16:03:17 <mamihale> Thanks
16:03:22 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57120/   <-- Release Notes
16:03:27 <anipbu> #info Tomas Janciga is representing IOTDM
16:03:32 <anipbu> Anything you would like to add?
16:03:36 <tjanciga> hello
16:03:40 <tjanciga> no, thanks
16:03:51 <anipbu> tjanciga: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:03:59 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:04:09 <tjanciga> yes, I've already tested and filled the sheet
16:04:40 <jamoluhrsen> tjanciga, thanks for opening bugs on your csit failures. non blocking?
16:04:50 <tjanciga> no any blockers
16:04:51 <anipbu> tjanciga: you have two test failures that need you to sign off
16:05:19 <jamoluhrsen> anipbu, tjanciga if bug 7990 is non-blocking we can move the status to OKAY
16:05:32 <anipbu> tjanciga: could you mark this has "OKAY" or "IGNORE"
16:05:42 <tjanciga> yes, sure
16:06:09 <anipbu> tjanciga: please mark them as IGNORE so we can move on with the review https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:07:06 <tjanciga> done
16:07:07 <anipbu> #info All IOTDM features are experimental as stated on the release notes
16:07:13 <anipbu> tjanciga: thanks
16:07:14 <tjanciga> yes
16:07:26 <anipbu> #info IOTDM has tested RC1 and found no blockers
16:07:54 <anipbu> #info IOTDM has two CSIT test failures and have signed off on them as IGNORE
16:08:44 <anipbu> tjanciga: do you have known issues or open bugs?  that section seems to have been left blank
16:09:34 <tjanciga> We have some bugs open but they will not be fixed in Carbon release
16:10:42 <anipbu> tjanciga: okay, please update the relevant sections in the release notes, since they seem to have been left blank such as "known bugs" etc.
16:11:06 <anipbu> #action tjanciga to follow up and update the release notes on the sections that have been left blank
16:11:21 <tjanciga> okay
16:11:34 <anipbu> tjanciga: any plans to move IOTDM documentation to RST?
16:11:47 <anipbu> I notice it is still on the wiki and should be migrated to the docs repo.
16:12:38 <tjanciga> Not yet, we don't have enough resources to do that and we have planed some changes which will lead to update of documentation
16:13:26 <anipbu> #info tjanciga states that for the documentation there are no plans to migrate to RST until after the planned changes to features which will lead to update of documentation
16:15:01 <anipbu> tjanciga: any major changes in this release, or is IOTDM in maintenance mode?
16:16:07 <tjanciga> all changes done in experimental features
16:16:16 <anipbu> What are the big changes in this release?
16:16:17 <tjanciga> some experimental features added
16:16:54 <tjanciga> Added plugin infrastructure features which allows easy implementation of new device plugins
16:17:23 <anipbu> #info IOTDM has some major changes in this release with adding new experimental features: Added plugin infrastructure features which allows easy implementation of new device plugins
16:17:58 <anipbu> Okay IOTDM looks good to me
16:18:06 <anipbu> Any additional comments from folks?
16:19:14 <anipbu> jamoluhrsen: IOTDM has some CSIT test failures, but since all features are experimental, that should not be blocking.  Those failures have been marked has OKAY/IGNORE.  Any other concerns you want to raise for IOTDM?
16:20:00 <jamoluhrsen> anipbu, all good with it.
16:20:01 <anipbu> Okay, looks like there are no additional comments form folks, so let's move on.
16:20:17 <anipbu> #info IOTDM approved for Carbon pending action items and follow up.  Congratulations!
16:20:25 <anipbu> Thanks tjanciga
16:20:38 <anipbu> tjanciga: Please follow up on your actions items.
16:20:59 <tjanciga> sure, thank you
16:22:15 <anipbu> pantelis: rovarga: are you guys ready with the release notes for controller, or should we reschedule for tomorrow?
16:22:58 <anipbu> pantelis: rovarga: if you are planning on rescheduling, please sign up for a new timeslot on the spreadsheet: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1746681968
16:24:03 <anipbu> I guess we'll take a break until the netconf team timeslot at 9:40
16:24:24 <jamoluhrsen> ack
16:24:56 <zxiiro> anipbu: jamoluhrsen: I need to step out for an hour. I'll miss the next 2 reviews.
16:25:00 <colindixon> I'll be there
16:31:33 <jamoluhrsen> colindixon, anipbu I'll be here.
16:36:39 <colindixon> back
16:38:37 <anipbu> jmorvay_ are you online?
16:39:04 <jmorvay_> hi, yeah I am here
16:39:19 <anipbu> #topic NETCONF
16:39:25 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57249/   <-- Release Notes
16:39:30 <anipbu> #info Jakub Morvay is representing NETCONF
16:39:34 * colindixon reads
16:39:35 <anipbu> Anything you would like to add?
16:39:43 <jmorvay_> not really
16:39:56 <anipbu> jmorvay_: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:40:03 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:40:16 <jmorvay_> I have already done 1)
16:40:38 <jmorvay_> And I've checked 2) and there are no netconf CSIT failures
16:41:10 <anipbu> jmorvay_ it says that you did not download RC1 to test in column E
16:41:37 <anipbu> jmorvay_: Have you download the RC1 zip/tar file and test NETCONF?
16:41:45 <jmorvay_> yeah I haven't tested RC1 manually
16:42:29 <jmorvay_> that's why I put no in that column
16:42:33 <anipbu> Any chance you can verify RC1 testing?
16:42:50 <anipbu> Is there any other way you can validate RC1 testing?
16:43:00 <jmorvay_> I have checked our releng jobs and they all passed on RC1
16:43:22 <anipbu> #info jmorvay_ says NETCONF team has checked releng jobs and they all passed on RC1
16:43:32 <anipbu> #info NETCONF has tested RC1 and found no blockers
16:43:41 <jamoluhrsen> netconf csit appears stable. yes
16:43:50 <anipbu> #info NETCONF has reviewed CSIT test failures and found no blocker issues
16:44:21 <colindixon> a few minor comments on the patch
16:44:22 <jamoluhrsen> jmorvay_, are all your features in the release plan marked as not experimental covered in CSIT
16:44:38 <jmorvay_> yes they are
16:45:02 <colindixon> it was weird that odl-mdsal-apidocs, and odl-yanglib are here…
16:45:43 <jmorvay_> I'll take a look on that and I can remove them from notes
16:45:54 <anipbu> #action jmorvay_ to update the release to remove  odl-mdsal-apidocs, and odl-yanglib
16:46:02 <colindixon> should they be there?
16:46:29 <colindixon> also, is there no migration needed because you don't store data in the datastore?
16:46:30 <jmorvay_> Well they are not major features
16:46:42 <colindixon> is apidocs produced from netconf?
16:46:45 <jmorvay_> but they are user facing
16:46:57 <colindixon> OK
16:46:59 <colindixon> no worries then
16:47:04 <colindixon> just mismapped in my brain
16:47:04 <anipbu> #undo
16:47:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1dc91d0>
16:47:14 <anipbu> Okay, I removed that action item
16:47:19 <jmorvay_> about the migration I will have a look at that too
16:47:31 <anipbu> jmorvey_: please keep the two features
16:47:33 <colindixon> jmorvay_: thanks
16:47:34 <jmorvay_> but I am not aware of anything that has to migrated
16:47:38 <colindixon> OK
16:47:45 <colindixon> I mean wouldn't topoloyg mounts not migrate?
16:47:49 <colindixon> because they're stored in the datastore
16:47:52 <anipbu> jmorvay_: did you get a test waiver for RESTCONF?  Seems it is missing CSIT according to the release notes but is marked as nonexperimental.
16:47:53 <colindixon> and we don't have a clean way to migrate that
16:48:03 <colindixon> so people would have to export and re-import the topology nodes, right?
16:48:10 <colindixon> that's what I was asking
16:48:25 <jmorvay_> yeah mountpoints configuration is stored in config DS
16:48:32 <jmorvay_> ok I will update it then
16:48:56 <jmorvay_> restconf is tested in all CSIT jobs that are using restconf
16:49:07 <anipbu> #action jmorvay_ will update the release notes on the migration
16:50:18 <colindixon> otherwise, this looks good
16:50:41 <anipbu> #info colindixon states netconf doesn't have a clean way to migrate.  jmorvay_ states mountpoints configuration is stored in config DS.  Will update the release notes on migration aspects
16:51:05 <anipbu> jmorvay_: please follow up on the feedback on the release notes after the meeting.
16:51:26 <anipbu> jmorvay_: any major changes in this release or is netconf in maintenance mode?
16:51:43 <jmorvay_> no major changes
16:51:58 <jmorvay_> apart from experimental call-home feature we are in maintenance mode
16:52:02 <anipbu> #info netconf features in the release plan marked as not experimental covered in CSIT
16:52:30 <anipbu> #info for netconf in carbon, no major changes apart from experimental call-home feature
16:52:40 <anipbu> NETCONF looks good to me
16:52:46 <anipbu> Any additional comments from folks?
16:53:03 <rovarga> anipbu: re: controller, I prefer to reschedule (sorry, too much churn :-()
16:53:55 <anipbu> rovarga: okay, lets reschedule.  Please sign up for a new timeslot on the spreadsheet: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1746681968
16:53:56 <colindixon> thanks!
16:54:02 <jmorvay_> So anything else guys?
16:54:02 <anipbu> Okay  Let's move on
16:54:05 <colindixon> jmorvay_: netconf looks good
16:54:07 <anipbu> #info NETCONF approved for Carbon pending action items and follow up.  Congratulations!
16:54:12 <anipbu> #topic MDSAL
16:54:16 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57287/   <-- Release Notes
16:54:17 <jmorvay_> ok thanks
16:54:21 <anipbu> #info Martin Ciglan is representing MDSAL
16:54:25 <anipbu> Anything you would like to add?
16:54:29 <mciglan> hello
16:54:37 <anipbu> mciglan: 1) Have you tested against RC1 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:54:43 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:55:19 <mciglan> 1) there are no blockers at the moment, one was fixed last week
16:55:39 <mciglan> 2) one test has been marked as IGNORED on Tuesday
16:55:49 <mciglan> per our discussion on kernel projects call
16:56:41 <mciglan> for RC0 build
16:56:46 <jamoluhrsen> mciglan, I don't see the mdsal csit marked as ignored.
16:57:07 <anipbu> mciglan: coudl you update this spreadsheet for RC1 so we can move forward with the review: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
16:57:11 <jamoluhrsen> mciglan, when you do mark it, please put some description on why it should be ignored? known bug, but non-blocking
16:57:13 <jamoluhrsen> ?
16:57:35 <anipbu> mciglan: thanks for providing feedback on RC0, but we also need you to update the spreadsheet again for RC1
16:58:05 <colindixon> the release review document looks good to me
16:58:08 <mciglan> sure, will do so
16:59:03 <anipbu> mciglan: would it be possible for you to update the spreadsheet now columns C through H: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
17:01:19 <mciglan> ok, it's done
17:01:25 <mciglan> will update RC1 testing too ASAP
17:02:15 <colindixon> thanks!
17:02:19 <anipbu> #info MDSAL has tested RC1 and found no blockers.
17:02:54 <anipbu> #info MDSAL has one CSIT test failures.  mciglan says it can be ignored, but will provide more details after the meeting
17:03:09 <anipbu> #action mciglan to follow up on the CSIT test failures on the spreadsheet
17:03:35 <anipbu> #info MDSAL has system test waiver
17:04:35 <anipbu> #info odl-mdsal-binding is nonexperimental and all other features are experimental as stated on the release notes
17:05:36 <anipbu> #info MDSAL's nonexperimental feature (odl-mdsal-binding) has CSIT coverage but it currently failing.  mciglan will follow up with the test team.
17:05:59 <anipbu> mciglan: any major changes in this release, or is MDSAL in maintenance mode?
17:06:58 <mciglan> not any
17:08:02 <anipbu> #info mciglan states there are no major changes in this release
17:08:23 <mciglan> got the explanation from testing about unstable test, so I will go ahead and update RC1 testing sheet
17:08:43 <colindixon> anipbu: I've now provided feedback on all release review patches from today
17:08:53 <anipbu> colindixon: thanks
17:09:15 <anipbu> mciglan: please follow up on the feedback on the release notes patch
17:09:16 <colindixon> I'll try to keep following up
17:09:35 <anipbu> #action mciglan to follow up on the feedback for the release notes patch
17:09:43 <anipbu> MDSAL looks good to me
17:09:49 <anipbu> Any additional comments from folks?
17:10:05 <mciglan> and will update release notes patch
17:10:18 <anipbu> Any additional comments from folks?
17:10:57 <anipbu> Okay Let's move on.
17:11:00 <anipbu> #info MDSAL approved for Carbon pending action items and follow up.  Congratulations!
17:11:16 <anipbu> Okay Thanks it.  We've covered all the projects for today.
17:11:27 <anipbu> See folks again tomorrow morning 7-10 PT
17:11:47 <anipbu> We're done for today.
17:12:02 <anipbu> Thanks colindixon jamoluhrsen zxiiro
17:12:09 <anipbu> #topic cookies
17:12:20 <anipbu> #endmeeting