13:59:27 <anipbu> #startmeeting carbon release review
13:59:27 <odl_meetbot> Meeting started Fri May 19 13:59:27 2017 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
13:59:27 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:27 <odl_meetbot> The meeting name has been set to 'carbon_release_review'
13:59:32 <anipbu> #topic roll call
13:59:38 <anipbu> #info PTL and TSC members please #info in
13:59:48 <anipbu> #chair zxiiro colindixon
13:59:48 <odl_meetbot> Current chairs: anipbu colindixon zxiiro
14:00:01 <colindixon> #Info colindixon for docs, ttp, and TSC
14:00:04 <anipbu> #info anipbu
14:00:13 <anipbu> Good morning folks
14:00:19 <anipbu> our last day =)
14:00:25 <colindixon> anipbu: I'm likely to be cone from 7:20-9:20 :-(
14:00:31 <colindixon> I'm trying to get feedback on all patches as fast as I can
14:00:43 <skitt> #info skitt
14:00:43 <zxiiro> morning
14:00:44 <anipbu> sure no problem colindixon
14:00:51 <anipbu> Okay Let's begin
14:00:58 <anipbu> #topic ODLPARENT
14:01:05 <anipbu> #link https://git.opendaylight.org/gerrit/57349    <-- Release Notes
14:01:09 <anipbu> #info Stephen Kitt is representing ODLPARENT
14:01:14 <anipbu> Anything you would like to add?
14:01:22 <skitt> Not that I can think of
14:01:22 <colindixon> btw, the HTML links I get by taking this url: https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/255/archives/docs/_build/html/getting-started-guide/project-release-notes/
14:01:29 <anipbu> skitt: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:01:30 <colindixon> and replacing the 255 with the successful build run
14:01:44 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:01:56 <skitt> it's still downloading, I just tested RC0
14:01:59 <colindixon> I read through odlparent and I'm happy to even just merge the patch
14:02:39 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/273/archives/docs/_build/html/ Current ODLParent Generated Release Notes
14:03:32 <skitt> I'll push an update to fix the issues noted by colindixon
14:03:51 <colindixon> skitt: I think one of them is a bug in sphinx or I don't understand what's going on
14:03:56 <anipbu> skitt: Did you find any blocker in RC0?
14:03:56 <skitt> anipbu, re test failures, we don't have any
14:04:01 <skitt> anipbu, no
14:04:05 <skitt> anipbu, no blocker in RC0
14:04:22 <anipbu> #info ODLPARENT has tested RC0 and found no blocker bugs
14:04:33 <anipbu> #info odlparent has no CSIT test failures
14:04:49 <anipbu> #info odlparent has system test waiver
14:04:50 <skitt> odlparent has no CSIT tests ;-)
14:04:52 <zxiiro> I can look into the formatting issue later
14:05:03 <zxiiro> if it matters
14:05:38 <colindixon> zxiiro: when/if you have time
14:05:39 <anipbu> #info odlparent has no user-facing features to declare experimental/nonexperimental
14:05:40 <colindixon> we can fix it later
14:06:04 <anipbu> #action skitt to follow up on feedback on release notes regarding formatting, etc.
14:06:16 <anipbu> ODLPARENT looks good to me
14:06:24 <anipbu> Any additional comments from folks?
14:06:40 <skitt> none from me
14:06:47 <zxiiro> Looks great to me
14:07:03 <anipbu> skitt: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:07:40 <skitt> anipbu, the main changes were improved single feature tests, and Karaf 4 support
14:07:47 <skitt> anipbu, nothing user-visible
14:07:57 <anipbu> #info odlaprent major changes were in improved single feature tests, and Karaf 4 support
14:08:00 <anipbu> #undo
14:08:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cc4c10>
14:08:04 <skitt> anipbu, actually there is one change
14:08:11 <skitt> anipbu, we fixed the randomness issue with SSH
14:08:21 <skitt> anipbu, but I think that went into Boron SR2 as well
14:08:24 <anipbu> #info odlparent major changes were: improved single feature tests, and Karaf 4 support, fixed the randomness issue with SSH
14:08:29 <anipbu> Okay let's move on
14:08:34 <anipbu> #info ODLPARENT approved for Carbon pending action items and follow up.  Congratulations!
14:08:41 <anipbu> #topic NEUTRON
14:08:43 <skitt> thanks :-)
14:08:45 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57197    <-- Release Notes
14:08:50 <anipbu> #info Isaku Yamahata is representing NEUTRON
14:08:55 <anipbu> Anything you would like to add?
14:09:06 <yamahata> No
14:09:07 <anipbu> iyamahat: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:09:37 <yamahata> RC2 is not tested yet. RC1 was tested. No blockers is found with RC1.
14:09:41 <yamahata> Today I'll test RC2
14:09:49 <yamahata> https://review.openstack.org/#/c/465189/
14:10:00 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/304/archives/docs/_build/html/getting-started-guide/project-release-notes/neutron-northbound.html.gz Neutron Generated Release Notes
14:10:00 <anipbu> iyamahat: could you update the spreadsheet so we can move forward with the review?
14:10:38 <yamahata> which column should I update?
14:10:59 <anipbu> iyamahat: C through H
14:11:11 <yamahata> sure
14:11:23 <anipbu> you can pick Carbon-RC1-20170516 for the version type in Column C
14:11:49 <colindixon> anipbu, yamahata: I provided a lot of mostly style and formatting changes on the patch, the one set of mentionable notes are that i think some of the features could be non-experimental if CSIT in OpenStack passes consistently, right?
14:12:06 <yamahata> done to update the sheet.
14:12:19 <yamahata> Yes. I'll update the release notes.
14:12:33 <yamahata> Today I'll update it to fix format too.
14:12:46 <colindixon> anipbu: the high-level summary of my review on patches at the top should be all you need to read, not the individual comments when I'm gone
14:12:55 <colindixon> we'll ask jamoluhrsen to confirm that change to non-experimental
14:12:56 <anipbu> #action yamahata to follow up on the feedback for the release notes patch, including formatting, etc
14:13:06 <anipbu> colindixon: ack
14:13:28 <anipbu> yamahata: could you follow up with JamO on the experimental/nonexperimental tag for Neutron?
14:13:38 <yamahata> anipbu: sure, will do.
14:13:59 <anipbu> #action yamahata and jamoluhrsen to follow up with Neutron on experimental/nonexperimental tag for features
14:14:11 <anipbu> yamahata: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:14:37 <yamahata> new features are, trunk API support, hostconfig for vpp, ovs-dpdk, keystone v3 support
14:14:52 <yamahata> I'm not sure if they're cool or not.
14:15:00 <anipbu> yamahata: can you update the spreadsheet right now on RCX testing.
14:15:04 <anipbu> https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
14:15:31 <anipbu> #info NEUTRON cool new features: trunk API support, hostconfig for vpp, ovs-dpdk, keystone v3 support
14:16:52 <yamahata> Updated.
14:17:05 <anipbu> #info NEUTRON has tested RC1 and found no blocker bugs
14:17:11 <yamahata> Once I have RC2 results, I'll update it again.
14:17:22 <anipbu> #info NEUTRON has no CSIT test failures in int-dist-test job
14:18:06 <anipbu> #info All NEUTRON features are marked as experimental for now, but will update the tag after follow up with JamO
14:18:17 <anipbu> NEUTRON looks looks good to me
14:18:22 <anipbu> Any other comments from folks?
14:19:34 <yamahata> none from me.
14:19:57 <anipbu> Okay Let's move on
14:19:58 <anipbu> #info NEUTRON approved for Carbon pending action items and follow up.  Congratulations!
14:20:02 <anipbu> #topic INFRAUTILS
14:20:06 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57403/    <-- Release Notes
14:20:08 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/318/archives/docs/_build/html/getting-started-guide/project-release-notes/infrautils.html.gz Infrautils Generated Release Notes
14:20:11 <anipbu> #info Ravit Peretz is representing INFRAUTILS
14:20:15 <anipbu> Anything you would like to add?
14:20:23 <ravit_> no, I'm good
14:20:30 <anipbu> ravit_: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:20:47 <ravit_> No blockers found
14:20:51 <ravit_> will do
14:21:16 <zxiiro> I think infrautils has to be listed as Experimental since there's no CSIT tests?
14:21:25 <anipbu> ravit_: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:21:49 <ravit_> I hope they are cool :-)
14:21:50 <ravit_> job coordinatore refactoring in infrautils, testutils with JUnit, upcoming system services diagnostics
14:22:07 <ravit_> the last one is due in the following SRs
14:22:40 <anipbu> #info INFRAUTILS has tested RC2 and found no blocker bugs
14:22:54 <anipbu> #info INFRAUTILS cool new features: job coordinatore refactoring in infrautils, testutils with JUnit, upcoming system services diagnostics
14:23:44 <colindixon> anipbu: OK, I've made it through l2switch, hopefully I'll be back by 9a, but if not, I'll miss packet cable and eman :-/
14:23:45 <colindixon> sorry
14:23:52 <anipbu> #action ravit_ to change the features to "Experimental: Yes"
14:24:01 <ravit_> and why is that?
14:24:31 <ravit_> anipbu:?
14:24:35 <anipbu> ravit_: infrautils does not have CSIT coverage and it did not receive approval for system test waiver in this release from Int/Test team
14:24:53 <ravit_> but it should.
14:24:53 <ravit_> infrautils provides low-level technical framework utilities therefore infrautils should get a system test waiver - just like in boron
14:25:32 <anipbu> #undo
14:25:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19c1910>
14:25:53 <ravit_> this was communicated to Xueke Li and Katie
14:25:55 <anipbu> #action ravit_ and jamoluhrsen to follow up on the "Experimental" tag for infrautils project
14:26:17 <ravit_> ok, NP
14:26:18 <anipbu> ravit_: after the meeting could you please follow up with JamO on the system tests and experimental tag?
14:26:25 <ravit_> yes.
14:26:28 <ravit_> thank you
14:26:35 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:26:52 <ravit_> we do not have no csit tests at all
14:27:13 <anipbu> #info infrautils has no CSIT tests (and therefor no test failures)
14:28:17 <anipbu> INFRAUTILS looks good to me
14:28:24 <anipbu> Any additional comments from folks?
14:29:22 <zxiiro> none from me
14:30:11 <anipbu> Okay Let's move on
14:30:15 <anipbu> #info INFRAUTILS approved for Carbon pending action items and follow up.  Congratulations!
14:30:19 <ravit_> great, thank you guys
14:30:22 <anipbu> #topic SNMP4SDN
14:30:27 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/314/archives/docs/_build/html/getting-started-guide/project-release-notes/snmp4sdn.html.gz SNMP4SDN Generated Release Notes
14:30:29 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57395/    <-- Release Notes
14:30:34 <anipbu> #info Yi-Ling Hsieh is representing SNMP4SDN
14:30:38 <anipbu> Anything you would like to add?
14:30:47 <Christine> No
14:31:01 <anipbu> Christine: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:31:09 <Christine> #info Christine for snmp4sdn
14:31:50 <Christine> R1 tested, no blocker. R2 not yet, will do in the morning
14:31:54 <anipbu> #info Release Notes comments: Mostly formatting. Substantive comment is that the features are (I think) all experimental.
14:32:24 <anipbu> Christine: could you update the spreadsheet so we can move forward with the release
14:32:55 <anipbu> Christine: Columns C through H: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:33:16 <Christine> Ok wait a minute thanks
14:36:15 <Christine> anipbu: done thanks
14:36:42 <anipbu> Christine: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:37:18 <anipbu> #info SNMP4SDN has tested RC2 and found no blocker bugs
14:37:28 <Christine> It's maintenance mode
14:37:58 <anipbu> #info SNMP4SDN has no CSIT test failures as reported by int-dis-test
14:38:18 <anipbu> #info SNMP4SDN has no new major features in this release and is in maintenance mode
14:38:58 <anipbu> Christine: please follow up with colindixon on the comments from the release notes patch: Mostly formatting. Substantive comment is that the features are (I think) all experimental.
14:39:09 <anipbu> #action Christine to follow up on the release notes patch
14:39:31 <Christine> No problem
14:39:41 <anipbu> Christine: SNMP4SDN features should be marked as experimental
14:40:04 <anipbu> #action Christine and jamoluhrsen to follow up with SNMP4SDN on the experimental tag.
14:40:24 <Christine> due to no csit? okay
14:40:46 <zxiiro> yes to be non-experimental you need csit tests
14:41:05 <Christine> I see, thanks
14:41:23 <anipbu> SNMP4SDN looks good to me
14:41:31 <anipbu> Any additional comments from folks?
14:41:46 <anipbu> Oaky Let's move on
14:41:52 <anipbu> #info SNMP4SDN approved for Carbon pending action items and follow up.  Congratulations!
14:41:56 <anipbu> #topic LACP
14:42:00 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57422/    <-- Release Notes
14:42:04 <anipbu> #info Ravi Sabapathy is representing LACP
14:42:09 <anipbu> Anything you would like to add?
14:43:16 <anipbu> Ravi__: Ping
14:43:38 <anipbu> Is there anybody from LACP today?
14:43:41 <anipbu> Ravi__: Ping
14:43:51 <lalit> lacp changes didn't merge in carbon branch
14:43:52 <Ravi_> hi
14:43:53 <anipbu> Ravi__: Good Morning
14:44:01 <Ravi_> Good morning
14:44:21 <anipbu> Ravi_: lalit: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:44:47 <Ravi_> OK we will update
14:45:21 <anipbu> Ravi_: could you update it right now so we can move forward with the review?
14:46:14 <anipbu> Ravi_: let me know if you have trouble accessing the google docs (i can ask the questions on IRC instead for you)
14:46:21 <Ravi_> We have not done any testing after SR2
14:46:28 <Ravi_> after SR1
14:46:57 <anipbu> Ravi_: we cannot review and approve LACP until you fill out the spreadsheet for Carbon-RCX testing
14:48:05 <Ravi_> We understand. For this release you can take a call on LACP
14:48:22 <Ravi_> Our testing will take a day
14:48:38 <Ravi_> It's ok if LACP is left out of this release
14:48:58 <anipbu> Okay, please take one day to test and let us know.
14:49:10 <Ravi_> ok sure
14:49:32 <anipbu> Ravi_: could your team email me the results of RCX once it is complete?
14:50:04 <anipbu> #action LACP will follow up on RCX testing and report back the results.
14:50:10 <Ravi_> Sure
14:50:23 <anipbu> #info LACP review is PENDING until follow up on action items above
14:50:31 <anipbu> Okay let's move on
14:51:20 <Ravi_> just a sec the karaf4 changes did not merge into stable/carbon
14:51:24 <Ravi_> for LACP
14:51:30 <anipbu> Ravi_: you will also need to update this spreadsheet to mark the CSIT test failures as ignored https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:51:46 <Ravi_> It might not be possible to test in stable/carbon
14:51:49 <anipbu> Ravi_: we dropped karaf 4 from Carbon.  So no need to karaf 4 anymore
14:52:04 <Ravi_> ok
14:52:30 <anipbu> Only need to test karaf 3 just like in Boron, Beryllium, and Lithium
14:52:42 <anipbu> Ravi_: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:52:59 <Ravi_> no new features or changes for carbon
14:53:07 <anipbu> Ravi_: your project features should be marked as experimental=yes because the CSIT tests are failing
14:53:11 <Ravi_> It is in maintanence mode
14:53:21 <anipbu> #info LACP has no new feature in Carbon and is in maintenance mode
14:53:40 <anipbu> #action LACP will change the release notes patch to say that the features are experimental
14:54:24 <anipbu> #action Ravi_ to follow up on the release notes patch comments
14:54:54 <anipbu> Ravi_: we'll also need you to send email to lacp-dev to vote GO/NO-GO next week.
14:55:08 <Ravi_> ok
14:55:19 <anipbu> Okay that's it for LACP
14:55:28 <anipbu> Ravi_: please follow up on your action items above
14:55:35 <Ravi_> Sure
14:55:49 <anipbu> Ravi_: after following up, we can review your project over email and approve your project.  Thanks greatly for all your help and contribution in this release
14:55:55 <anipbu> Let's move on to the next project now
14:56:01 <anipbu> #topic INTEGRATION/DISTRIBUTION
14:56:06 <anipbu> #link https://git.opendaylight.org/gerrit/57434   <--- Release Notes
14:56:10 <anipbu> #info Vratko Polak is representing INTEGRATION/DISTRIBUTION
14:56:15 <anipbu> Anything you would like to add?
14:56:15 <vrpolak> Hello.
14:56:26 <zxiiro> no link for distribution generated RN yet.
14:56:26 <anipbu> vrpolak: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
14:56:31 <anipbu> 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
14:56:39 <anipbu> 3) Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
14:56:58 <vrpolak> I feel we are missing bunch of *-guides in docs, we have many non-karaf features.
14:57:27 <vrpolak> 1) Yes tested (except manual testing), no blockers, updated.
14:57:39 <vrpolak> 2) No CSIT failures.
14:58:19 <vrpolak> 3) Yes, Karaf 4, but it is still highly experimental. Otherwise no user visible changes (just code cleanup).
15:00:09 <vrpolak> In release notes I only mentioned "major" features to keep it short. Otherwise I think we are late to report but otherwise good.
15:00:24 <anipbu> #info INT/DIS has tested RCX and found no blocker bugs.
15:00:35 <anipbu> #info INT/DIS has no test failures
15:00:57 <anipbu> #info INT/DIS cool new features in this release: Karaf 4, but it is still highly experimental
15:01:37 <anipbu> #action <vrpolak>  to follow up on feedback on the release notes patch
15:01:44 <vrpolak> As for manual testing, I do not expect it would find anything not visible from other projects' manual testing. Most interesting tests are automated already.
15:01:53 <anipbu> <vrpolak>  please follow up on the formatting comments on the release notes
15:02:15 <franks_> Hello. Frank here for eman carbon release planning
15:02:21 <anipbu> #info INT/DIS manual testing: do not expect it would find anything not visible from other projects' manual testing. Most interesting tests are automated already.
15:02:43 <anipbu> franks_: see you at 9:10AM (your scheduled time slot)
15:02:55 <anipbu> INT/DIS looks good to me
15:03:02 <anipbu> Any additional comments from folks?
15:03:08 <zxiiro> none from me
15:03:14 <anipbu> Okay lets move on
15:03:20 <anipbu> #info INTEGRATION/DISTRIBUTION approved for Carbon pending action items and follow up.  Congratulations!
15:03:25 <anipbu> #topic BIER
15:03:30 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57234/    <-- Release Notes
15:03:35 <anipbu> #info Quan Xiong is representing BIER
15:03:39 <anipbu> Anything you would like to add?
15:04:02 <anipbu> Anybody from BIER project online?
15:04:08 <Xiong> Yes,I am here.
15:04:15 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/311/archives/docs/_build/html/getting-started-guide/project-release-notes/bier.html.gz BIER Generated Release Notes
15:04:21 <anipbu> Xiong: good morning
15:04:29 <anipbu> Xiong: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:04:41 <anipbu> Xiong: 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
15:04:51 <anipbu> Xiong: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:06:04 <Xiong> No blockers and updated.
15:06:31 <anipbu> Xiong: please update this spreadsheet: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
15:06:43 <anipbu> Xiong: columns C through H
15:06:58 <anipbu> Xiong: could you update the spreadsheet right now so we can move forward with the release
15:07:07 <Xiong> Ok.
15:07:50 <Xiong> Wait a moment.Downloading.
15:10:34 <Xiong> Ok. I finished.
15:10:59 <anipbu> Xiong: coould you mark your test failures as IGNORE on this spreadhseet: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
15:11:30 <anipbu> Xiong: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:12:30 <anipbu> #info BIER has tested RC2 and found no blocker bugs
15:12:41 <anipbu> #info BIER has marked CSIT test failures as IGNORE
15:13:26 <Xiong> New Features
15:13:51 <anipbu> Xiong: your project features should be "experimental=yes".  Please see comments on your release review patch for explainations
15:14:14 <anipbu> #action Xiong to update the release review to show experimental=yes for features as per the comments
15:14:22 <Xiong> Ok
15:14:47 <anipbu> #info BIER features are currently experimental=yes until follow up with jamoluhrsen
15:15:11 <anipbu> Xiong: please also follow up with colindixon et al an your comments on the release notes
15:15:25 <Xiong> Ok.I will discuss with Jamo.
15:15:29 <anipbu> #action Xiong to follow up on the release notes patch comments: Only note of concern is failing CSIT tests.
15:15:44 <Xiong> Ok.I will fix the notes release patch.
15:16:01 <anipbu> BIER looks good to me
15:16:11 <anipbu> Any additional comments from folks?
15:16:17 <Xiong> Yes,only CSIT test.I have fixed the bug but not reviewed.
15:16:23 <zxiiro> none from me
15:16:39 <anipbu> Xiong: please complete the action items.  Great job on the first release!  You're project is doing really great for a new project =)
15:16:47 <anipbu> #info BIER approved for Carbon pending action items and follow up.  Congratulations!
15:16:52 <anipbu> Okay let's move on
15:16:56 <anipbu> #topic OF-CONFIG
15:17:00 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57320/    <-- Release Notes
15:17:05 <anipbu> #info Wei Meng is representing OF-CONFIG
15:17:07 <Xiong> Thank you!
15:17:09 <anipbu> Anything you would like to add?
15:17:11 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/255/archives/docs/_build/html/getting-started-guide/project-release-notes/of-config-release-notes.html.gz OFCONFIG Generated Release Notes
15:17:20 <anipbu> wei_: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:18:04 <wei_> hi
15:18:13 <anipbu> wei_: good morning
15:18:24 <anipbu> wei_: could you please update the spreadsheet?
15:18:24 <wei_> Morining, An
15:18:31 <anipbu> wei_: Columns C through H
15:18:31 <wei_> no problem
15:18:52 <anipbu> wei_: please update the spreadsheet right now so we can move forward with the review
15:19:09 <wei_> ok
15:20:31 <wei_> Can we move on first. i think there might be sth wrong with my network
15:21:25 <anipbu> Okay Let me ask the questions here:
15:21:45 <anipbu> 1) Have you tested RC1?
15:21:56 <anipbu> 2) What version dis you test with?
15:22:07 <wei_> yes
15:22:26 <anipbu> 2) Which version did you test with?
15:22:55 <anipbu> 3) What is the status of your project?  Green means there are no issues, ready to release.
15:23:06 <anipbu> 4) Have you download the RC2 zip/tar file and tested your projects features?
15:23:08 <wei_> Green
15:23:32 <anipbu> 5) Have you reviewed your integration distribution test failures?
15:23:36 <wei_> yes
15:23:40 <anipbu> 6) Do you have any blocking bugs?  If so, please list any blocking bugs.
15:23:54 <wei_> no blocking bugs
15:24:21 <anipbu> 7) Do you have additional comments you would like to share?
15:24:37 <wei_> no
15:24:39 <anipbu> 8) Can we IGNORE this CSIT test failure? https://jenkins.opendaylight.org/releng/job/of-config-csit-1node-basic-all-carbon/284/
15:25:23 <anipbu> 8) Can we IGNORE this CSIT test failure? https://jenkins.opendaylight.org/releng/job/of-config-csit-1node-basic-all-carbon/284/
15:25:25 <wei_> yes
15:25:38 <anipbu> Okay Thanks
15:25:46 <anipbu> 9) Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:25:57 <wei_> no new features
15:26:07 <anipbu> #info OF-CONFIG has tested RC2 and found no blocker bugs
15:26:20 <anipbu> #info OF-CONFIG has marked the CSIT test failures as IGNORE
15:26:39 <anipbu> #info All OF-CONFIG features are marked as experimental as stated in the release notes
15:27:06 <anipbu> wei_: please follow up on the release notes patch comments: Only note of consequence is clarifying migration.
15:27:24 <wei_> ok
15:27:31 <anipbu> #action wei_ to follow up with colindixon et al on the comments from the release notes patch: Only note of consequence is clarifying migration.
15:27:53 <anipbu> #info Comments from the release notes patch: Only note of consequence is clarifying migration.
15:28:21 <anipbu> #info OF-CONFIG has no new feature in this release.  It is in maintenance mode.
15:28:32 <anipbu> OF-CONFIG looks good to me
15:28:39 <anipbu> Any additional comments from folks?
15:28:51 <zxiiro> none from me
15:29:08 <anipbu> wei_: please follow up on your action items from above after the meeting.
15:29:17 <anipbu> Okay Let's move on
15:29:26 <wei_> ok
15:29:26 <anipbu> #info OF-CONFIG approved for Carbon pending action items and follow up.  Congratulations!
15:29:31 <anipbu> #topic YANGTOOLS
15:29:34 <ifoltin> Hi, Igor from Yangtools here
15:29:35 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57264/    <-- Release Notes
15:29:42 <anipbu> #info Peter Kajsa, Igor Foltin is representing YANGTOOLS
15:29:42 <wei_> Thanks.
15:29:46 <anipbu> Anything you would like to add?
15:29:48 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/246/archives/docs/_build/html/getting-started-guide/project-release-notes/yangtools.html.gz YangTools Generated Release Notes
15:29:50 <ifoltin> nope
15:30:00 <anipbu> ifoltin: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:30:17 <ifoltin> Yes, RC2 was tested. No blockers found.
15:30:29 <ifoltin> spreadsheet already updated
15:30:32 <anipbu> ifoltin: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:31:15 <anipbu> #info YANGTOOLS has tested RC2 and found no blocker bugs
15:31:35 <ifoltin> yes 2 new features: YANG statement parser now supports parsing YANG 1.1 models. The second new feature is - deviation statements are resolved during the parsing process
15:31:38 <anipbu> #info YANGTOOLS has marked the CSIT test failures in int-dis-test as IGNORE
15:31:53 <anipbu> #info YANGTOOLS cool new features in this release: YANG statement parser now supports parsing YANG 1.1 models. The second new feature is - deviation statements are resolved during the parsing process
15:32:37 <anipbu> ifoltin: odl-yangtools-yang-parser should be nonexperimental since it has CSIT tests it the tests pass
15:33:44 <anipbu> #info YANGTOOLS has test waiver since it is consumed by other projects.  Features are currently marked as experimental, but odl-yangtools-yang-parser should be nonexperimental.  Will follow up with jamoluhrsen later on the experimental tag.
15:34:04 <anipbu> #action ifoltin to follow up on experimental tag for odl-yangtools-yang-parser
15:34:27 <anipbu> #info Release Notes Patch Comments: Only formatting issues except the details about system tests waivers and features being experimental or not.
15:34:40 <anipbu> #action ifoltin to follow up on release notes patch comments
15:34:43 <ifoltin> ok
15:34:46 <anipbu> YANGTOOLS look good to me
15:35:21 <anipbu> ifoltin:  we kindly request that you follow up on your action items as stated above, especially the comments from the release notes patch
15:35:32 <anipbu> Any additional comments from folks?
15:35:35 <ifoltin> ok, will follow up on those
15:35:38 <anipbu> Otherwise let's move on
15:35:43 <anipbu> #info YANGTOOLS approved for Carbon pending action items and follow up.  Congratulations!
15:35:47 <anipbu> #topic SDNINTERFACEAPP
15:35:52 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57236/    <-- Release Notes
15:35:58 <anipbu> #info Sirisha Sangam is representing SDNINTERFACEAPP
15:36:00 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/313/archives/docs/_build/html/getting-started-guide/project-release-notes/odl-sdni-release-notes.html.gz SDNI Generated Release Notes
15:36:02 <anipbu> Anything you would like to add?
15:36:15 <anipbu> Sirisha: Good Morning
15:36:28 <Sirisha> Hi, Sirisha representing sdninterfaceapp
15:36:33 <Sirisha> Good morning
15:36:41 <anipbu> Sirisha: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:37:07 <Sirisha> RC2 tested, no blockers found. Updates spreadsheet.
15:37:16 <anipbu> Sirisha: 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
15:38:32 <Sirisha> Yes, we can ignore
15:38:45 <anipbu> Sirisha: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:39:01 <Sirisha> No new features developed
15:39:35 <anipbu> #info SDNINTERFACEAPP has tested RC2 and found no blocker bugs
15:39:47 <anipbu> #info SDNINTERFACEAPP has marked CSIT test failures from int-dis-test job as IGNORE
15:40:04 <anipbu> #info All SDNINTERFACEAPP features are experimental as stated on the release notes
15:40:12 <Sirisha> Yes
15:40:27 <anipbu> #info Release Notes Comments: Needs a migration section and some security discussion of how to secure BGP (or not) if you use it.
15:40:56 <anipbu> Sirisha: can you please follow up on the comments from the release notes after the meeting?
15:41:07 <Sirisha> Sure
15:41:15 <anipbu> Sirisha: specifically we need you to update the following: Needs a migration section and some security discussion of how to secure BGP (or not) if you use it.
15:41:32 <Sirisha> Sure, I will foloow up
15:41:43 <anipbu> #action Sirisha to follow up with colindixon et al on the comments from the release notes patch: Needs a migration section and some security discussion of how to secure BGP (or not) if you use it.
15:42:30 <anipbu> Sirisha: we will need you to help vote GO/No-GO next week on the release of Carbon, please make sure you follow the email thread once we send it out to you.
15:42:43 <Sirisha> OK
15:42:43 <anipbu> SDNINTERFACEAPP looks good to me
15:42:50 <anipbu> Any additional comments from folks?
15:42:55 <zxiiro> none
15:43:01 <anipbu> Okay let's move on
15:43:08 <anipbu> #info SDNINTERFACEAPP approved for Carbon pending action items and follow up.  Congratulations!
15:43:12 <anipbu> #topic L2SWITCH
15:43:18 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57401/    <-- Release Notes
15:43:21 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/316/archives/docs/_build/html/getting-started-guide/project-release-notes/l2switch.html.gz l2switch Generated Release Notes
15:43:23 <anipbu> #info Sai MarapaReddy is representing L2SWITCH
15:43:28 <anipbu> Anything you would like to add?
15:43:58 <anipbu> Sai_: Good Morning
15:44:14 <Sai_> An: Good morning!!
15:44:20 <anipbu> Sai_: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:46:49 <Sai_> anibu: Updated the sheet
15:46:55 <colindixon> back
15:47:12 <anipbu> Sai_: thanks
15:47:25 <anipbu> Sai_: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:47:55 <Sai_> no major changes, it is in maintenance mode.
15:48:39 <colindixon> I think there are security issues we need to at least note, e.g., that hosts can move by people spoofing ARPs
15:48:41 <anipbu> Sai_: Please follow up on release notes patch comments: only major issue is talking about what customized interfaces there are (if any) and also if there are any security issues. At some point there were, e.g., hosts being able to be spoofed and moved, that are still unresolved.
15:48:56 <colindixon> thanks anipbu
15:49:09 <anipbu> colindixon: welcome back
15:49:15 <Sai_> yes will address the comments
15:49:40 <anipbu> #info L2SWITCH has tested RC2 and found no blockers
15:50:10 <anipbu> #info L2SWITCH has no CSIT test failure in int-dis-test job
15:50:48 <anipbu> #info L2SWITCH has nonexperimental feature: odl-l2switch-release (Jamo's comments: csit is decent, but some sporadic failures that are tracked as part of bug 6654. Good to go)
15:51:13 <anipbu> #info L2SWITCH has release notes patch comments: only major issue is talking about what customized interfaces there are (if any) and also if there are any security issues. At some point there were, e.g., hosts being able to be spoofed and moved, that are still unresolved.
15:51:45 <anipbu> #action Sai_ to follow up with colindixon on the release notes patch comments for L2SWITCH
15:52:20 <anipbu> #info L2SWITCH has no new major changes in this release.  It is in maintenance mode.
15:52:30 <anipbu> L2SWITCH looks good to me
15:52:42 <anipbu> Any additional comments from folks?
15:52:47 <zxiiro> none from me
15:52:57 <colindixon> nope
15:53:13 <anipbu> Sai_: please follow up on the action items above for L2SWITCH and remember to vote GO/No-GO next week when you receive the email
15:53:17 <anipbu> Oaky let's move on
15:53:25 <anipbu> #info L2SWITCH approved for Carbon pending action items and follow up.  Congratulations!
15:53:29 <anipbu> #topic PACKETCABLE
15:53:33 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/57218/    <-- Release Notes
15:53:36 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/306/archives/docs/_build/html/getting-started-guide/project-release-notes/packetcable.html.gz PacketCable Generated Release Notes
15:53:38 <anipbu> #info Kevin Kershaw is representing PACKETCABLE
15:53:40 <Sai_> anibu: Sure. thanks
15:53:42 <anipbu> Anything you would like to add?
15:53:56 <kkershaw> No, not at this moment
15:54:08 <anipbu> kkershaw: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
15:54:41 <kkershaw> No - we tested against RC1 yesterday and had no blockers.  I have someone following up on test w/ RC2 this morning
15:55:03 <anipbu> kkershaw: could you please update the spreadsheet right now so we can move forward with the review?
15:55:19 <anipbu> Just use indicate that the tests were against RC1
15:56:59 <kkershaw> Not sure how you want me to fill out all the RC2 columns now.  RC1 info is already there but I'm happy to do what you'd like.
15:57:21 <anipbu> What you did is good enough
15:57:42 <colindixon> kkershaw: also, it would be good to know if there's a pcmm/cops connection the plugin uses and if so, how can it be secured or what security issues are there?
15:57:58 <colindixon> kkershaw: at the very least say that it should be secured and that is beyond the scope of the project
15:58:29 <anipbu> kkershaw: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
15:58:43 <kkershaw> I think we'd have to say that.  I don't think we've got a lot of security wrapper in place.
15:59:12 <kkershaw> I added a list of new project features for Carbon - they didn't change existin REST APIs but fleshed out function
15:59:26 <kkershaw> #link https://wiki.opendaylight.org/view/PacketCablePCMM:Release_Plan_Carbon#Other
15:59:35 <colindixon> kkershaw: that's fine, just call it out so that people know they need to look if they care
15:59:46 <kkershaw> OK - will do.
15:59:57 <anipbu> #info PACKETCABLE has tested RC1 and found no blocker bugs
16:00:10 <anipbu> #info PACKETCABLE has no CSIT test failures in int-dis-test job.
16:01:00 <kkershaw> Jamo has suggested we roll back to experimental status as CSIT tests are not very comprehensive
16:01:42 <colindixon> that's unless the 3rd party testing is more extensive, we just don't have visibility into it
16:02:44 <anipbu> #info PACKETCABLE feature odl-packetcable-policy-server-all should be mark as experimental=yes as per JamO comments on the release notes patch
16:02:51 <kkershaw> Agreed.  I can try and get deeper information from the party that did the testing.  I'm not sure how well-structured it is.
16:03:22 <anipbu> #action kkershaw and jamoluhrsen to follow up on the experimental tag
16:03:52 <anipbu> kkershaw: would you mind following up with jamoluhrsen after the meeting to come to a consensus on the experimental tag for your project's features?
16:04:02 <anipbu> kkershaw: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:04:26 <kkershaw> I can follow up w/ JamO
16:04:42 <anipbu> #info PACKETCABLE has comments on the release notes patch: major issue is figuring out if this plugin talks to devices over some protocol and how/if that needs to be secured.
16:04:54 <kkershaw> New features are as noted in link I gave above.  It was not just maintenance mode this release.
16:05:11 <anipbu> #action kkershaw to follow up with colindixon on the comments on the release notes patch: major issue is figuring out if this plugin talks to devices over some protocol and how/if that needs to be secured.
16:06:20 <anipbu> #info PACKETCABLE has the following cool new feature in the carbon release: https://wiki.opendaylight.org/view/PacketCablePCMM:Release_Plan_Carbon#Other
16:06:22 <kkershaw> I can do that too.  COPS protocol is VERY old.  Question of cost/benefit for old protocols.
16:07:00 <anipbu> PACKETCABLE looks good to me
16:07:42 <anipbu> kkershaw: please follow up on the action items stated above and remember to vote GO/No-GO next week when you receive the email
16:07:49 <anipbu> Any additional comments from folks?
16:07:53 <anipbu> Otherwise, let's move on
16:07:54 <zxiiro> none
16:08:02 <kkershaw> Will do.  Thanks.
16:08:04 <anipbu> #info PACKETCABLE approved for Carbon pending action items and follow up.  Congratulations!
16:08:07 <anipbu> #topic EMAN
16:08:11 <anipbu> #link https://git.opendaylight.org/gerrit/57219    <-- Release Notes
16:08:13 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/307/archives/docs/_build/html/getting-started-guide/project-release-notes/eman.html.gz EMAN Generated Release Notes
16:08:15 <anipbu> #info Frank Sandoval is representing EMAN
16:08:20 <anipbu> Anything you would like to add?
16:09:02 <anipbu> Anyone from EMAN online?
16:10:00 <anipbu> franks_: Ping
16:11:28 <anipbu> Frank was online earlier in the morning.
16:11:46 <anipbu> franks_: Good Morning
16:11:46 <colindixon> OK…
16:11:49 <colindixon> there we go
16:11:59 <franks_> Hello team
16:12:10 <anipbu> franks_: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:13:00 <franks_> I have not added automated tests
16:13:24 <colindixon> The comments on the patch I have are all style and formatting.
16:13:47 <franks_> Colin, I've seen you're comments and will update doc
16:14:23 <colindixon> thanks
16:14:42 <anipbu> franks_: could you update the spreadsheet right now so we can move forward with the release?
16:14:52 <anipbu> franks_: Columns C through H
16:15:00 <anipbu> franks_: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
16:15:11 <franks_> updating now
16:16:52 <franks_> I have not downloaded the build zip and tested, I will do so today
16:17:44 <anipbu> We cannot approve EMAN until it has tested at least one of the RC: RC0, RC1, or RC2
16:17:55 <franks_> Im not clear on column F. I'm not aware of int test failures. Can I mark this yes or NA?
16:18:30 <anipbu> eman has no test failures, so "Yes"
16:18:38 <franks_> I was not aware of the need to download a zip and test. I'll do so
16:19:33 <anipbu> franks_: which build did you verify that there were no blocker bugs?
16:20:21 <anipbu> franks_: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:20:25 <franks_> again, I've not downloaded a build from gerrit to test. I've test loally
16:21:34 <anipbu> franks_: after the meeting please go https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#RC2_Download to download the latest RC build and test with the zip file and confirm if there are any blocker bugs.
16:22:04 <franks_> 'cool new feature"  - This release provides more coverage of our energy management information model.
16:22:06 <anipbu> #action franks_ and EMAN team will follow up on RC2 testing by downloading the zip distribution and confirming if there are blocker bugs.
16:22:20 <anipbu> #info EMAN has no CSIT test failures in int-dis-test job.
16:22:42 <anipbu> #info All EMAN features are marked as experimental as stated on the release notes
16:23:04 <anipbu> #info EMAN comments on the release notes patch: Mostly just formatting an style. It would be good to say that it's the first release instead of just "NA" in a bunch of places.
16:23:30 <anipbu> #action franks_ to follow up with colindixon on the comments on the release notes  patch.
16:23:34 <franks_> Yes, I will update
16:24:15 <anipbu> #info EMAN cool new features in this release: more coverage of our energy management information model
16:25:02 <anipbu> At this time we cannot approve EMAN until it has completed filling out the spreadsheet on RC Status: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948
16:25:20 <anipbu> #info EMAN review is PENDING.  There are required action items to follow up as stated above.
16:25:29 <anipbu> Any additional comments from folks?
16:25:52 <anipbu> Okay let's move on.
16:26:02 <franks_> and filling out spreadsheet includes updating release doc and verifying no blocking bugs - right?
16:26:34 <anipbu> Filling out the spreadsheet is just column C through H on the spreadsheet: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:27:15 <anipbu> Specifically, you need to download one of the RC, test against it, and update the Columns C though H based on your tests.
16:28:17 <anipbu> franks_: Thanks for your contributions in Carbon.  Please follow up on the action items stated above.  You can send us an email once the issues are resolved and we can review your project over email after the meeting.  Thanks
16:28:19 <anipbu> Okay Let's move on.
16:28:24 <anipbu> #topic NIC
16:28:26 <franks_> thanks - bye
16:28:28 <anipbu> #link https://git.opendaylight.org/gerrit/57214    <-- Release Notes
16:28:32 <anipbu> #info Yrineu Rodrigues is representing NIC
16:28:35 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/324/archives/docs/_build/html/getting-started-guide/project-release-notes/nic.html.gz NIC Generated Release Notes
16:28:36 <anipbu> Anything you would like to add?
16:29:35 <anipbu> Anyone from NIC online?
16:30:32 <abhijitkumbhare> Hi
16:30:47 <abhijitkumbhare> Just in time :)
16:30:48 <anipbu> abhijitkumbhare: we're little bit behind right now
16:30:54 <abhijitkumbhare> OK
16:31:00 <abhijitkumbhare> how late?
16:31:12 <zxiiro> only 1 project review
16:31:18 <abhijitkumbhare> OK
16:31:19 <zxiiro> although NIC does not appear to be here. so maybe move on?
16:31:26 <anipbu> yeah let's move on
16:31:44 <anipbu> #info NIC review is PENDING.  No representative showed up for release review.
16:31:54 <anipbu> #topic OPENFLOWPLUGIN
16:31:58 <anipbu> #link https://git.opendaylight.org/gerrit/57365    <-- Release Notes
16:31:59 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/317/archives/docs/_build/html/getting-started-guide/project-release-notes/openflowplugin.html.gz OpenFlowPlugin Generated Release Notes
16:32:02 <anipbu> #info Abhijit Kumbhare is representing OPENFLOWPLUGIN
16:32:06 <anipbu> Anything you would like to add?
16:32:19 <abhijitkumbhare> Nothing much - the new features are:
16:32:19 <anipbu> abhijitkumbhare: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:32:45 <abhijitkumbhare> I understand the test is ongoing
16:33:02 <abhijitkumbhare> I don’t think there are new blockers
16:33:22 <anipbu> abhijitkumbhare: could you fill out the spreadsheet right now so we can move forward with the review?
16:33:26 <abhijitkumbhare> There are no new blockers
16:33:29 <abhijitkumbhare> OK
16:34:00 <abhijitkumbhare> what should I fill?
16:34:03 <anipbu> abhijitkumbhare: columns C through H.
16:34:22 <anipbu> abhijitkumbhare: you can mark Column C as using Carbon-RC1-20170516
16:34:56 <colindixon> I'm going through the release notes now.
16:35:34 <colindixon> LuisGomez: do you have comments on CSIT and experimental or not?
16:35:51 <LuisGomez> I will update RC2 status for OpenFlow later today
16:36:05 <LuisGomez> No blockers afaik
16:36:23 <LuisGomez> FRS is experimental yes
16:36:32 <LuisGomez> and that is documented like that
16:36:37 <anipbu> LuisGomez: coudl you update it for RC1 (since I'm sure opnflowplugin tested RC1).  We just need the spreadsheet filled out so we can move forward with the review
16:36:55 <LuisGomez> yes RC1 comments were set
16:37:03 <LuisGomez> ok
16:37:15 <colindixon> abhijitkumbhare: the security section will need updating
16:37:24 <abhijitkumbhare> OK
16:37:46 <LuisGomez> you got it
16:38:11 <anipbu> LuisGomez: just update the spreadsheet Columnc C through H
16:38:44 <anipbu> abhijitkumbhare: LuisGomez: For RC1, What is the status of your project?  Green means there are no issues, ready to release.
16:38:45 <abhijitkumbhare> colindixon: Is it that issue earlier?
16:39:05 <anipbu> abhijitkumbhare: LuisGomez:  For RC1, Have you download the zip/tar file and tested your projects features?
16:39:10 <LuisGomez> i think the OF user guide is not updated for a while…
16:39:18 <anipbu> abhijitkumbhare: LuisGomez: Have you reviewed your integration distribution test failures?
16:39:25 <abhijitkumbhare> Green: pending no new blocker issues
16:39:32 <LuisGomez> anipbu, we have all test automated
16:39:54 <LuisGomez> i just checked for RC1 but not for RC2
16:40:04 <colindixon> abhijitkumbhare: yes, I just gave feedback, but I think saying that OFP opens connections to OF devices and describing effots needed to secure them as well as listing known security issues around topology spoofing and DoS is needed
16:40:06 <anipbu> abhijitkumbhare: LuisGomez: For RC1, Do you have any blocking bugs left?  If so, please list any blocking bugs for RC1
16:40:33 <anipbu> abhijitkumbhare: LuisGomez: For RC1, Do you have additional comments you would like to share?
16:40:48 <abhijitkumbhare> OK colindixon
16:41:24 <abhijitkumbhare> No additional comments
16:41:29 <LuisGomez> i think i got confused with RC0 and RC1
16:41:47 <anipbu> abhijitkumbhare: LuisGomez: Okay, based on your comments in this meeting, I have updated the spreadsheet on your behalf
16:41:52 <abhijitkumbhare> There are no blocking bugs
16:42:00 <abhijitkumbhare> OK anipbu
16:42:30 <anipbu> Okay, now we can move forward with the review
16:42:33 <LuisGomez> blocking bugs for sure not, i just need to check and comment RC1/RC2 test results
16:42:39 <anipbu> abhijitkumbhare: 2) have you signed off on any CSIT test failures?  Are there any tests that needs to be IGNORED?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:42:59 <anipbu> abhijitkumbhare: 3) Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:43:15 <abhijitkumbhare> yes LuisGomez - pending RC1/RC2 results
16:43:26 <abhijitkumbhare> New features:
16:43:50 <anipbu> #info OPENFLOWPLUGIN has tested RC1 and found no new blocker bugs (besides the ones already fixed earlier in the week).
16:44:03 <abhijitkumbhare> 1) Single Model Layer Implementation: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Implementation_For_Single_Model_Layer
16:44:25 <anipbu> #info OPENFLOWPLUGIN has several CSIT failures which they review and follow up on: https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1568731761
16:44:42 <abhijitkumbhare> 2) Split connection layer from core: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Split_connection_layer
16:44:44 <anipbu> #action abhijitkumbhare to follow up on CSIT test failures
16:45:34 <anipbu> LuisGomez jamoluhrsen: so are we approving the noneexperimental tag for openflowplugin features?
16:46:00 <anipbu> #info OPENFLOWPLUGIN has release notes comments: Biggest issue is around security.
16:46:03 <LuisGomez> there is 1 or 2 experimental i think, but core features are not
16:46:27 <anipbu> #action abhijitkumbhare to follow up with colindixon on release notes comments: Biggest issue is around security.
16:46:58 <anipbu> abhijitkumbhare: please follow up and update the release notes patch based on the comments
16:47:09 <abhijitkumbhare> OK
16:47:11 <LuisGomez> btw, OF TLS wiki is obsolete, i could probably update that too
16:47:20 <anipbu> #info OPENFLOWPLUGIN cool new features: Single Model Layer Implementation, Split connection layer from core
16:47:40 <abhijitkumbhare> OK LuisGomez
16:47:52 <anipbu> #info OPENFLOWPLUGIN has a mix of experimental and nonexperimental features.  core features are nonexperimental.
16:48:14 <anipbu> OPENFLOWPLUGIN looks good to me
16:48:19 <anipbu> Any additional comments from folks?
16:48:31 <colindixon> no, I think that's good
16:48:37 <colindixon> my comments were above
16:48:40 <abhijitkumbhare> OK thanks anipbu , colindixon & LuisGomez
16:48:49 <anipbu> abhijitkumbhare: thanks for your support in Carbon.  please follow up on the action items above after the meeting.
16:48:54 <anipbu> #info OPENFLOWPLUGIN approved for Carbon pending action items and follow up.  Congratulations!
16:48:59 <LuisGomez> i update the spread sheet right away
16:49:00 <abhijitkumbhare> Sure
16:49:02 <anipbu> Okay let's move on
16:49:06 <anipbu> #topic OCPPLUGIN
16:49:10 <anipbu> #link https://git.opendaylight.org/gerrit/57238    <-- Release Notes
16:49:14 <anipbu> #info Chinning Lai is representing OCPPLUGIN
16:49:18 <anipbu> Anything you would like to add?
16:49:23 <Chinning> Hi
16:49:32 <anipbu> Chinning: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:50:02 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/309/archives/docs/_build/html/getting-started-guide/project-release-notes/ocpplugin-release-notes.html.gz OCPPLUGIN Generated Release Notes
16:50:51 <colindixon> this all looked good, I only had a few random nits in the patch
16:51:06 <anipbu> Chinning: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:51:15 <colindixon> jamo said he'd like to see more extensive CSIT but was fine with non-experimental labels
16:51:39 <anipbu> #info OCPPLUGIN has tested RC2 and found no blocker bugs
16:51:49 <Chinning> No major feature, only maintenance mode
16:51:54 <anipbu> #info OCPPLUGIN has no CSIT test failures as reported by latest iint-dis-test job
16:52:09 <anipbu> #info OCPPLUGIN has no new major changes in this release.  It is in maintenance mode
16:52:35 <anipbu> #info OCPPLUGIN has two nonexperimental features: odl-ocpplugin-southbound and odl-ocpplugin-app-ocp-service
16:52:39 <anipbu> #undo
16:52:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1db4950>
16:53:00 <Chinning> ok, we will try to add more extened CSITs
16:53:16 <anipbu> #info OCPPLUGIN has two nonexperimental features: odl-ocpplugin-southbound and odl-ocpplugin-app-ocp-service as stated on the release notes.  (jamoluhrsen comments: like to see more extensive CSIT but was fine with non-experimental labels)
16:53:45 <anipbu> #info OCPPLUGIN has comments on the release notes: Mostly minor things
16:54:06 <colindixon> Chinning: I think that's a polite ask, not a criticism or demand just to be clear
16:54:17 <anipbu> #action Chinning to follow up with colindixon on the release notes patch comments: Mostly minor things
16:54:49 <anipbu> Chinning: we kindly request that you follow up on the comments on your release notes patch and upload a new update addressing comments.
16:55:42 <anipbu> OCPPLUGIN looks good to me
16:55:51 <anipbu> Any additional comments form folks?
16:55:59 <zxiiro> none
16:56:00 <anipbu> Otherwise, I would like to move on
16:56:07 <colindixon> nope, I was super pleased, thanks Chinning
16:56:07 <anipbu> #info OCPPLUGIN approved for Carbon pending action items and follow up.  Congratulations!
16:56:12 <anipbu> #topic OPFLEX
16:56:15 <Chinning> thanks
16:56:24 <anipbu> #link https://git.opendaylight.org/gerrit/57199    <-- Release Notes
16:56:25 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/310/archives/docs/_build/html/getting-started-guide/project-release-notes/opflex.html.gz OpFlex Generated Release Notes
16:56:28 <anipbu> #info Rob Adams is representing OPFLEX
16:56:32 <anipbu> Anything you would like to add?
16:56:40 <anipbu> readams: Good Morning
16:56:49 <readams> Hey guys
16:56:51 <anipbu> readams: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
16:57:45 <readams> should be updated now
16:57:50 <readams> sort of N/A :-)
16:57:52 <anipbu> readams: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
16:58:01 <readams> we're the odd duck :-)
16:58:15 <colindixon> readams: I gave some feedback on the patch. high-level, just give short descriptions of the major functionality (moral equivalent of karaf features) and security issues people need to think about
16:58:20 <colindixon> readams: that you are :-)
16:58:31 <readams> new features
16:58:36 <readams> Improved robustness against configuration problems
16:58:42 <readams> Support for neutron-style security groups
16:58:49 <readams> Support for load balanced L3/L4 services
16:59:22 <readams> For developers: C++11 support
16:59:43 <anipbu> readams: Next week, we will ask you to provide us a link to the opflex artifacts so that releng team and upload to nexus.  Please kindly reply to that email.  Alos Next week, we will ask you to vote Go/No-Go on the release of Carbon.  Please kindly reply to that email as well.
17:00:08 <readams> OK; artifacts will just be the result of the latest merge task for carbon
17:00:50 <anipbu> #info OPFLEX has tested RC2 and found no blocker bugs
17:01:05 <anipbu> #info OPFLEX has no CSIT test failures in int-dis-test job.
17:02:23 <anipbu> #action readams to add description on opflex features (the non karaf features)
17:02:41 <anipbu> #action readams to add link to testing mechanism in the release notes
17:03:13 <readams> I didn't see the comments on the release notes until now.  I couldn't find the release plan for carbon so presumably I just forgot to ever do one
17:03:15 <anipbu> #info OPFLEX cool new features in this release: Improved robustness against configuration problems, Support for neutron-style security groups, Support for load balanced L3/L4 services, For developers: C++11 support
17:03:50 <anipbu> #info OPFLEX has release notes comments: Just asking for more info and/or missing sections. I think at least you need:
17:03:50 <anipbu> moral equivalent of karaf features described (we've done this in the past)
17:03:50 <anipbu> security considerations
17:03:50 <anipbu> release mechanics
17:03:50 <anipbu> some more links
17:04:02 <anipbu> #undo
17:04:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19551d0>
17:04:18 <anipbu> Just asking for more info and/or missing sections: moral equivalent of karaf features described (we've done this in the past), security considerations, release mechanics, some more links
17:04:35 <anipbu> #info OPFLEX has release notes comments: Just asking for more info and/or missing sections: moral equivalent of karaf features described (we've done this in the past), security considerations, release mechanics, some more links
17:05:14 <anipbu> #action readams to follow up with colindixon on the release notes comments as stated above.
17:05:40 <anipbu> Okay OPFLEX looks good to me
17:05:46 <anipbu> Any additional comments from folks?
17:05:46 <colindixon> same here
17:06:02 <zxiiro> none
17:06:06 <zxiiro> looks good thanks!
17:06:09 <colindixon> cool thanks readams
17:06:21 <anipbu> readams: please follow up on your action items.  There are a few missing sections that needs your attention
17:06:27 <anipbu> Okay let's move on
17:06:31 <anipbu> #info OPFLEX approved for Carbon pending action items and follow up.  Congratulations!
17:06:35 <anipbu> #topic TTP
17:06:40 <anipbu> #link https://git.opendaylight.org/gerrit/57442   <--- Release Notes
17:06:41 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/327/archives/docs/_build/html/getting-started-guide/project-release-notes/ttp.html.gz TTP Generated Release Notes
17:06:44 <anipbu> #info Colin Dixon is representing TTP
17:06:49 <anipbu> Anything you would like to add?
17:06:53 * colindixon waves
17:06:54 <colindixon> nope
17:07:00 <anipbu> colindixon: 1) Have you tested against RC2 and were there any blockers.  Can you update this sheet with your testing?  https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948?
17:07:07 <colindixon> already done, no blockers
17:07:30 <colindixon> (and by already I mean, ~90 seconds ago, but whatever)
17:08:00 <anipbu> #info TTP has tested RC2 and found no blocker bugs
17:08:13 <anipbu> #info TTP does not have CSIT failures as reported by int-dis-test job
17:08:31 <anipbu> #info All TTP are marked as experimental as stated on the release notes
17:08:34 <colindixon> that is largely because we have no CSIT jobs
17:08:37 <colindixon> yes
17:09:31 <anipbu> colindixon: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
17:09:45 <colindixon> no, literally no code changes except as mandated by upstream proejccts
17:10:31 <anipbu> colindixon: Is there s system test plan describing the manual testing for TTP?
17:10:48 <colindixon> no, but I could create one if it matters
17:10:52 <anipbu> #info TTP has no new major features or changes in this release.  It is in maintenance mode.
17:11:25 <anipbu> #action colindixon to follow up with jamoluhrsen in providing description of manual testing in TTP System Test Plan
17:11:52 <anipbu> #info TTP has release notes comments: minor formatting.  Nothing serious.
17:12:00 <anipbu> Okay TTP looks good to me
17:12:09 <anipbu> Any additional comments from folks?
17:12:32 <anipbu> Otherwise let's move on.
17:12:39 <colindixon> thanks!
17:12:40 <anipbu> #info TTP approved for Carbon pending action items and follow up.  Congratulations!
17:12:44 <anipbu> #topic DOCS
17:12:48 <anipbu> #link https://git.opendaylight.org/gerrit/57429   <--- Release Notes
17:12:53 <anipbu> #info Colin Dixon is representing DOCS
17:12:57 <anipbu> Anything you would like to add?
17:13:22 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/docs-verify-rtd-nitrogen/323/archives/docs/_build/html/getting-started-guide/project-release-notes/docs.html.gz Docs Generated Release Notes
17:13:28 <anipbu> colindixon: Did your project develop any "Cool New Features" or major changes in this release, or is your project in maintenance mode?
17:13:32 <colindixon> nope, I should probably update known issues and bugs fixed to represent reality, but OpenDaylight users probably don't care about them, so it wasn't a high priority
17:13:47 <colindixon> no new cool things unless zxiiro remembers something I don't
17:14:02 <zxiiro> Sphinx, although that was probably considered last release?
17:14:12 <anipbu> i think that was last release
17:14:20 <colindixon> yeah
17:14:22 <zxiiro> In that case yeah none
17:14:30 <anipbu> #info DOCS RC testing does not apply.
17:14:37 <anipbu> #info DOCS CSIT does not apply.
17:15:29 <colindixon> I guess the only cool new "feature" would be reST per-project release notes
17:15:33 <colindixon> vs. wiki
17:15:34 <anipbu> #info DOCS features (producing the documentation literature) is nonexperimental in the sense that folks can consume it and it is up to date.
17:15:46 <colindixon> :p
17:15:55 <anipbu> #info DOCS new cool features is per-project release notes
17:16:28 <anipbu> #action colindixon to follow up on the release notes comments: Minor formatting.  Nothing serious.
17:16:35 <anipbu> Okay DOCS looks good to me.
17:16:39 <anipbu> Let's move on.
17:16:51 <colindixon> thanks!
17:16:56 <anipbu> Oh sorry, any additional comments from folks?
17:17:05 <anipbu> #info DOCS approved for Carbon pending action items and follow up.  Congratulations!
17:17:08 <zxiiro> none
17:17:09 <colindixon> I think that's a wrap, thanks so much for running this the last three days anipbu
17:17:11 <anipbu> #topic Missing Projects
17:17:17 <anipbu> one more thing colindixon
17:17:18 <colindixon> seriously a huge round of applause
17:17:21 <colindixon> anipbu: sure
17:17:22 <anipbu> for the missing projects
17:17:23 <colindixon> yeah
17:17:27 <anipbu> we'll do it over email
17:17:35 <zxiiro> Cardinal and NIC unless either is around now
17:17:38 <anipbu> a few missed their review or did not sign up
17:17:44 <colindixon> OK, I think that works, or even over the gerrit patches
17:17:49 <colindixon> that makes sense
17:17:52 <anipbu> colindixon: question, what happens when a project does not complete the release review?
17:18:12 <colindixon> technically, they can't be released, e.g., would have to be taken out
17:18:28 <colindixon> more realistically, probably we remove all references to them in the documentation/marketing
17:19:08 <anipbu> Okay that sounds reasonable
17:19:10 <anipbu> Okay.  We're done with release reviews.  Thanks to colindixon zxiiro jamoluhrsen and all the project PTLs and proxies for making this yet a another successful release.
17:19:11 <colindixon> we haven't had that happen yet
17:19:15 <anipbu> Have a great day folks
17:19:19 <anipbu> #topic cookies
17:19:24 <colindixon> THANKS SO MUCH anipbu!!!!!!!
17:19:28 <anipbu> #endmeeting