15:03:04 <edavsua> #startmeeting genius
15:03:04 <odl_meetbot> Meeting started Thu Feb 16 15:03:04 2017 UTC.  The chair is edavsua. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:03:04 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:04 <odl_meetbot> The meeting name has been set to 'genius'
15:03:15 <edavsua> #info Hello
15:03:35 <vorburger> #topic everyone info in (#info <your-nick>)
15:03:58 <skitt> #info skitt
15:04:08 <edavsua> #info edavsua
15:05:46 <vthapar> #info Vishal Thapar
15:06:27 <vorburger> #info vorburger
15:06:40 <faseelak> #info faseelak
15:06:53 <shague> #info shague
15:07:07 <vorburger> #topic last meeting's action
15:07:13 <vorburger> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/genius/opendaylight-meeting-genius.2017-02-09-15.04.html
15:07:55 <skitt> BTW vorburger you're not a chair so your #topics aren't being picked up
15:08:19 <skitt> edavsua, could you #chair vorburger?
15:08:38 <vorburger> edavsua: can you chair everyone? #chair faseelak
15:09:00 <edavsua> #chair faseela
15:09:00 <odl_meetbot> Warning: Nick not in channel: faseela
15:09:00 <odl_meetbot> Current chairs: edavsua faseela
15:09:15 <vorburger> edavsua: #chair vthapar
15:09:23 <vthapar> #chair faseelak
15:09:26 <vorburger> edavsua: Faseela is faseelak not faseela
15:09:37 <edavsua> Ok
15:09:49 <edavsua> #chair faseelak
15:09:49 <odl_meetbot> Current chairs: edavsua faseela faseelak
15:11:11 <faseelak> #chair shague vorburger
15:11:11 <odl_meetbot> Current chairs: edavsua faseela faseelak shague vorburger
15:11:50 <vorburger> #action vorburger to send email to genius-dev re. AbstractDataBroker
15:13:15 <vorburger> #topic DCN Deprecation Weather item
15:13:51 <vthapar> #info faseelak sent out mail and created weather page
15:14:37 <vthapar> #link https://wiki.opendaylight.org/view/Weather#Genius_AbstractDataChangeListener_clean-up
15:14:57 <vthapar> #link Genius patch for deprecation https://git.opendaylight.org/gerrit/#/c/51876/
15:16:20 <vorburger> can someone link to the propose netvirt change ?
15:17:08 <vorburger> #action shague to review netvirt patches (which?) and merge to unblock https://git.opendaylight.org/gerrit/#/c/51876/
15:17:39 <edavsua> #topic AsyncListenerBase scale issues - track progress on netvirt
15:18:41 <vorburger> #info various people are putting in patches in netvirt re. this topic
15:25:03 * vthapar is having some connection issues
15:25:58 <vthapar> I'll take up the DCL changes in netvirt
15:26:29 <vthapar> change will be to go from AsyncDataChangeBase to AsyncDataTreeChangeBase
15:27:35 <shague> vthapar: can you add the action's for the flow ?
15:27:43 <vthapar> #action vthapar to prepare netvirt patches for removing use of AsyncDataChangeListeners
15:28:56 <vorburger> vthapar: did you mean s/removing use of AsyncDataChangeListeners/replacing use of AbstractDataChangeListener by AsyncDataTreeChangeListenerBase/ ? ;-)
15:29:21 <vthapar> vorburger: yes, it is a shorthand I understand ;)
15:30:52 <vorburger> #topic blueprint migration
15:31:04 <vorburger> #info 3 modules in genius are pending
15:31:49 <vthapar> vorburer, faseelak: can you info in the pending modules?
15:32:03 <vthapar> edavsua: ^^^
15:32:47 <faseelak> #info interfacemanager mdsalutil fcaps
15:35:15 <edavsua> #action edavsua will try to solve the circular dependency in mdsal-impl
15:36:21 <edavsua> #info if breaking that dependency is possible (time-wise) I'll continue with the blueprint migration
15:38:39 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/51927/
15:42:34 <vorburger> #action edavsua to check fcap blueprint migration status
15:45:13 <vorburger> #topic Checkstyle
15:46:12 <vorburger> #info missing CS compliance: (1) interfacemanager-impl, (2) mdsal-impl, (3) itm-impl
15:46:33 <vorburger> #topic patches for review merge
15:46:41 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
15:58:53 <vthapar> #action edavsua to get https://git.opendaylight.org/gerrit/51270 reviewed by SFC
16:00:55 <vorburger> #action faseelak review https://git.opendaylight.org/gerrit/#/c/51909/
16:06:57 <vorburger> #topic overdue patches
16:07:12 <vorburger> #action viveks to check with respective owners
16:07:18 <vorburger> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Genius+abandonment+review&Send+email+warning+due+to+3+weeks+inaction=project:genius+status:open+age:21d+-age:31d&Close+due+to+4+weeks+inaction=project:genius+status:open+age:31d
16:07:27 <vorburger> #endmeeting