17:08:55 <skitt> #startmeeting Kernel call
17:08:55 <odl_meetbot> Meeting started Tue Nov  7 17:08:55 2017 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:08:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:08:55 <odl_meetbot> The meeting name has been set to 'kernel_call'
17:09:04 <skitt> #chairs vorburger rovarga_ zxiiro
17:09:14 <vorburger> #topic Agenda Bashing
17:09:28 <skitt> #info Feature freeze in odlparent
17:09:54 <vorburger> #link https://wiki.opendaylight.org/view/Kernel_Projects_Call#Upcoming_Agenda_Topics
17:10:31 <vorburger> #topic Feature freeze in odlparent
17:10:42 <skitt> #link Open patches in odlparent: https://git.opendaylight.org/gerrit/#/q/project:odlparent+status:open
17:14:10 <skitt> #info Bump Jacoco, bump Surefire etc.
17:14:17 <skitt> #info downstreams can downgrade if necessary
17:14:27 <skitt> #info JUnit and PowerMock likewise
17:15:06 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/48710/ ?
17:16:22 <skitt> #info Run a proper autorelease build in 48710 to make sure there’s no huge breakage
17:16:40 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/50908/ Fail build if classpath contains duplicates
17:22:46 <zxiiro> Can use the Sandbox to custom build a autorelease job that tests the patch
17:24:54 <vorburger> #action vorburger change https://git.opendaylight.org/gerrit/#/c/50908/ to opt in, via skip property default to true, not a new profile
17:25:50 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/65277/
17:26:57 <vorburger> #action rovarga_ merge https://git.opendaylight.org/gerrit/#/c/65277/
17:27:52 <vorburger> #topic error-prone
17:28:03 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/65151/
17:29:52 <vorburger> #topic Q: Why using a MDSAL RPC between say e.g. genius IdManager and LockManager instead of just an OSGiService?
17:49:44 <vorburger> #topic Thread Dump (series) analyzers
17:50:04 <vorburger> #link http://fastthread.io
17:50:50 <vorburger> #topic Q: Are the 450-470 up to OOM 537 Threads seen in a jstack of https://jira.opendaylight.org/browse/GENIUS-97 a lot, too many?
17:53:13 <vorburger> #info someone is spawning threads like there is no tomorrow.. we should find out what
17:53:23 <vorburger> #action vorburger will look more at threads creating
17:55:14 <skitt> #endmeeting