#opendaylight-meeting: kernel_projects

Meeting started by Sai_ at 16:57:46 UTC (full logs).

Meeting summary

  1. - previous-meeting-minutes (Sai_, 16:58:11)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2017/kernel_projects/opendaylight-meeting-kernel_projects.2017-01-17-16.58.html (Sai_, 16:58:27)

  2. - Agenda (Sai_, 16:59:09)
    1. 1. Call for any topics to be added (Sai_, 16:59:29)
    2. 2. Review action items (Sai_, 17:00:05)
    3. 3. NETCONF call home patch status (Sai_, 17:00:15)
    4. 4. Bug 7522 (Sai_, 17:00:27)
    5. 4. FindBugs that has runtime impact (Sai_, 17:01:02)
    6. 5. Move from mockito-all => mockito-core (Sai_, 17:01:26)
    7. 6. Bug 7663 - FindBugs :jsr305 (Sai_, 17:01:48)
    8. 7. End goals discussion (Sai_, 17:02:22)

  3. - Call for any topics to be added (Sai_, 17:03:04)
    1. - karaf 4 update (Sai_, 17:04:35)

  4. - Review action items (Sai_, 17:05:17)
    1. - [DONE] PTL of controller to send M3 status (Sai_, 17:05:32)
    2. - [DONE] Vratko to open a bug to avoid future breakage of cluster tests wrt cluster script. (Sai_, 17:05:41)
    3. - [DONE] Stephen to file bug in each project pertaining to karaf upgrade (Sai_, 17:05:52)
    4. - [DONE] Ryan to start generating a bug query useful to view related bugs. (Sai_, 17:06:20)

  5. - NETCONF call home patch status (Sai_, 17:07:01)
    1. - https://git.opendaylight.org/gerrit/#/c/49253/ (Sai_, 17:07:15)
    2. - colindixon expects feedback from committers for above mentioned patch (Sai_, 17:08:04)

  6. - Bug 7522 (Sai_, 17:08:53)
    1. - https://bugs.opendaylight.org/show_bug.cgi?id=7522 (Sai_, 17:09:00)
    2. - This bug is closed as won't fix, Colin thinks Avi may start working on this. (Sai_, 17:10:19)
    3. - Martin says that we can start discussion through email thread, not sure about the deadlines. (Sai_, 17:11:42)
    4. - Robert thinks it has nothing much to do with yangtools / mdsal (Sai_, 17:13:43)
    5. - Robert says APIs required for this are already exposed (Eg:- NetconfSchema) (Sai_, 17:14:15)
    6. - Robert asks the use case underlying bug 7522 (Sai_, 17:15:20)
    7. the use case is basically to be able to load a model into ODL and then be able to get the access to the various tools around YANG validation and storage in ODL (colindixon, 17:16:34)
    8. rovarga notes that you won't get binding APIs for the model loaded this way unless it's also loaded by a jar via the normal mechanism (colindixon, 17:17:24)
    9. Avi notes and rovarga confirms that REST should still work b/c it's all Binding Independent (colindixon, 17:17:40)
    10. rovarga notes there may be complexities for things like augmentations where another person reading/writing using the binding APIs might accidentlaly lose data from the newly loaded models (colindixon, 17:19:02)
    11. rovarga notes that a lot of these things will likely be augmentations to topology, which means you're likely to hit this (colindixon, 17:19:40)
    12. ACTION: Avi to write up some simple set of use cases and constraints (colindixon, 17:19:57)
    13. rovarga notes that if it's really just to get REST access to a model, but not actually to share it to the rest of the MD-SAL, one option would be to essentially build a new shard with it's own SchemaContext (colindixon, 17:22:09)
    14. avi asks if there's a pointer, rovarga says not off the top of his head (colindixon, 17:22:19)
    15. ACTION: colindixon to schedule a TWS on this issue (colindixon, 17:24:58)

  7. - FindBugs runtime impact (Sai_, 17:25:32)
    1. - Michael found jar305 is still being used (Sai_, 17:26:14)
    2. - Robert thinks annotations are provided by karaf (Sai_, 17:26:30)
    3. - Michael thinks odlparent might be the right place (Sai_, 17:28:11)
    4. ACTION: - Michael to create a bug in odlparent wrt FindBugs runtime impact. (Sai_, 17:30:10)

  8. - mockito-all (Sai_, 17:30:18)
    1. - FYI mockito-all => mockito-core, see https://bugs.opendaylight.org/show_bug.cgi?id=7662 and https://git.opendaylight.org/gerrit/#/q/topic:bug/7662 (Sai_, 17:30:27)
    2. - mockito-all is a big mistake and everyone should use mockito-core (Sai_, 17:31:27)
    3. - Michael has a patch that makes sure to use mockito-core (Sai_, 17:31:54)

  9. - FindBugs :jsr305 (Sai_, 17:32:07)
    1. - FYI FindBugs :jsr305 => (full) :annotation, see https://bugs.opendaylight.org/show_bug.cgi?id=7663 and https://git.opendaylight.org/gerrit/#/q/topic:bug/7663 (Sai_, 17:32:16)
    2. - once all patches regarding findBugs & mockito-all are merged it helps in end goals and guarantees future non-regression (Sai_, 17:33:55)

  10. - end goals (Sai_, 17:34:03)
    1. - FYI end goals, exploratory, but once everything is clean this will make sense, and guarantee future non-regression: 1. https://git.opendaylight.org/gerrit/#/c/50844/ 2. https://git.opendaylight.org/gerrit/#/c/50905/ 3. https://git.opendaylight.org/gerrit/#/c/50908/ 4. https://git.opendaylight.org/gerrit/#/c/50851/ (Sai_, 17:34:14)
    2. - including annotations makes sure that singleTest works, but we need to find out the reason behind it. (Sai_, 17:41:06)
    3. ACTION: - Michael to create bug wrt annotations usage (Sai_, 17:45:25)

  11. - karaf 4 update (Sai_, 17:45:40)
    1. - Stephen started merging patches (mdsal/controller done), next phase is AAA. (Sai_, 17:46:40)
    2. - Stephen encountered issues with AAA (gerrit - 50304), requests help from AAA (Sai_, 17:47:12)
    3. ACTION: - Ryan to look in to gerrit 50304, which unblocks Stephen's work on karaf 4 (Sai_, 17:48:06)
    4. - Stephen says controller patch might be ready by tomorrow (Sai_, 17:48:27)
    5. - infrautils / netconf patches are ready to go (Sai_, 17:49:01)

  12. - guava upgrade (Sai_, 17:49:23)
  13. - Review dashboards (Sai_, 17:50:51)
    1. - yangtools moving ahead with 1.1 (Sai_, 17:52:04)
    2. - support in binding spec 2 in mdsal (Sai_, 17:54:17)
    3. - upgrade to netty 4.1 in netconf (Sai_, 17:54:29)
    4. - clean up related work in AAA (Sai_, 17:55:41)

  14. - participants (Sai_, 17:57:07)
    1. - Sai / Ryan / An / Avi / Colin / Igor / Martin / Michael / Robert / Stephen / TomP / Vratko (Sai_, 17:57:49)


Meeting ended at 17:58:03 UTC (full logs).

Action items

  1. Avi to write up some simple set of use cases and constraints
  2. colindixon to schedule a TWS on this issue
  3. - Michael to create a bug in odlparent wrt FindBugs runtime impact.
  4. - Michael to create bug wrt annotations usage
  5. - Ryan to look in to gerrit 50304, which unblocks Stephen's work on karaf 4


Action items, by person

  1. colindixon
    1. colindixon to schedule a TWS on this issue
  2. UNASSIGNED
    1. Avi to write up some simple set of use cases and constraints
    2. - Michael to create a bug in odlparent wrt FindBugs runtime impact.
    3. - Michael to create bug wrt annotations usage
    4. - Ryan to look in to gerrit 50304, which unblocks Stephen's work on karaf 4


People present (lines said)

  1. Sai_ (67)
  2. colindixon (9)
  3. odl_meetbot (7)


Generated by MeetBot 0.1.4.