#opendaylight-meeting: kernel_projects

Meeting started by Sai_ at 16:56:45 UTC (full logs).

Meeting summary

  1. - previous-meeting-minutes (Sai_, 16:57:26)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2017/kernel_projects/opendaylight-meeting-kernel_projects.2017-02-07-16.57.html (Sai_, 16:57:31)

  2. - Agenda (Sai_, 16:57:37)
    1. 1. Call for any topics (Sai_, 16:58:51)
    2. 2. Review existing action items (Sai_, 16:59:09)
    3. 3. Review dashboards (Sai_, 17:01:37)

  3. - Call for any topics (Sai_, 17:01:49)
    1. - no topics added. (Sai_, 17:04:27)

  4. - Review dashboards (Sai_, 17:04:36)
    1. - [DONE] vorburger projects that haven't merged https://git.opendaylight.org/gerrit/#/q/topic:bug/7662 to be removed from autorelease on Monday 13th (Sai_, 17:05:06)
    2. - [DONE] Stephen to review https://git.opendaylight.org/gerrit/#/c/47337/ (Sai_, 17:05:55)
    3. ACTION: - Stephen to reach out Jamie on CSS / Netconf patches. (Sai_, 17:06:19)
    4. - Robert says AAA is out of picture wrt change in how features are resolved (Sai_, 17:09:30)
    5. - Ryan says code corresponding to activators in AAA is no more used, should we consider removing it ? (Sai_, 17:11:01)
    6. - Robert thinks removing unused code might be better way (after resolving dependencies) by trial and error approach. (Sai_, 17:12:18)
    7. - Ryan thinks cleaning up of AAA should be done by this week. (Sai_, 17:13:44)
    8. - Michael thinks removing felix dependency manager would be of more importance than cleaning the code in AAA. (Sai_, 17:14:34)
    9. ACTION: - Ryan to clean up unused code / activators in AAA (Sai_, 17:16:52)
    10. - [DONE] vorburger projects that haven't merged https://git.opendaylight.org/gerrit/#/q/topic:bug/7662 to be removed from autorelease on Monday 13th (Sai_, 17:18:04)

  5. - Review dashboards (Sai_, 17:18:36)
    1. - Core Patches Merged In Last 7 Days (Sai_, 17:20:08)
    2. - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:mer (Sai_, 17:20:17)
    3. - yang 1.1 is in progress (Sai_, 17:21:29)
    4. - Patch wrt updating restconf models by RFC 8040 is merged (Sai_, 17:23:46)
    5. ACTION: - Ryan to deprecate shiro.ini in AAA project (Sai_, 17:32:10)
    6. - Michael asks if we can have a pluggable service in ODL instead of configuration as shiro.ini (Sai_, 17:35:37)
    7. - Theoretically, people wanna choose one of them rather than writing their own . (Sai_, 17:37:00)
    8. - Core Patches Modified In Last 7 Days (Sai_, 17:37:59)
    9. - https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+ag (Sai_, 17:38:09)

  6. - participants (Sai_, 17:39:14)
    1. - Sai / Ryan / Igor / Jakub / Michael / Robert / Stephen / Tomas / Viera / Vratko / Xueke (Sai_, 17:40:37)


Meeting ended at 17:40:41 UTC (full logs).

Action items

  1. - Stephen to reach out Jamie on CSS / Netconf patches.
  2. - Ryan to clean up unused code / activators in AAA
  3. - Ryan to deprecate shiro.ini in AAA project


People present (lines said)

  1. Sai_ (33)
  2. odl_meetbot (3)
  3. vorburger (1)


Generated by MeetBot 0.1.4.