16:05:22 <colindixon> #startmeeting kernel projects
16:05:22 <odl_meetbot> Meeting started Tue May  9 16:05:22 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:05:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:22 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:05:26 <colindixon> #topic agenda
16:05:47 <colindixon> #link https://wiki.opendaylight.org/view/Kernel_Projects_Call#Upcoming_Agenda_Topics
16:06:40 <colindixon> #info colindixon will cover karaf 3 vs. karaf 4 in Carbon
16:06:51 <colindixon> #topic karaf 3 vs. karaf 4
16:07:21 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-May/010765.html all other links can be found from here
16:09:49 <colindixon> #LInk https://meetings.opendaylight.org/opendaylight-meeting/2017/carbon_release_sync/opendaylight-meeting-carbon_release_sync.2017-05-09-15.01.html longer summary here
16:12:07 <colindixon> #info rovarga asks does this mean that starting day 1 in nitrogen we can kill off karaf 3 and push on Karaf 4
16:14:01 <colindixon> #info colindixon says his take is that we should make nitrogen about paying down our techincal debt as far as it goes around Karaf 4 and bundle/feature lifecycle management, including non-leaf bundles/features supporting refresh/shutdown/reload
16:14:29 <colindixon> #info skitt asks if the right thing to do is to drop everyone from the release and then not add them back until they meet their requirements
16:17:27 <colindixon> #info is this a way to force projects to take on technical debt earlier
16:20:14 <colindixon> #info robert also suggests looking at mliestones to drop projects if they don't meet them
16:21:40 <colindixon> #info colindixon also brings up the idea of having failures on autorelease blocking that branch until it's fixed
16:24:32 <colindixon> #info there some opposition to this, it may make the problem worse by requiring a small set of people to sign off on the patches to fix things
16:25:23 <colindixon> #info colindixon notes that otherwise, we haven't had much succes in keeping our autorlease, e.g., the validation that what we have works, working to keep us honest
16:26:03 <colindixon> #info skitt also talks about and rovarga asks if what happens next should be starting to get odlparent to release a non-snapshot version and then adding people in only as they work with that
16:26:35 <colindixon> #info after that we release everything else based on that and keep working
16:32:49 <colindixon> #info there is a long talk about how we would go about this approach possibly at the beginning of Nitrogen or Oxygen
16:35:26 <colindixon> #info vorburger asks how this would start, what's the next step? skitt and rovarga say that the basic strategy is to put what we feel we need into odlparent for the next release, then release it and tell everyone to move to that.
16:37:59 <colindixon> #info there is some back and forth about hoping that we get more than six month cadence out fo this for new features and functionality
16:38:43 <colindixon> #Info skitt also notes that this might help with deprecation and things since you don't need a flag day, you can clearly fork the timeline
16:45:22 <colindixon> #info vorburger asks what's next concretely, skitt answers: nitrogen release plan, then odlparent's changes, then release odlparent and make people move to it
16:47:40 <rovarga> skitt: are you up for taking the AI to draw up the release plan?
16:47:56 <skitt> rovarga, yes, it's similar to the previous one ;-)
16:49:48 <skitt> https://wiki.opendaylight.org/view/ODL_Parent:Carbon_Release_Plan
16:52:43 <rovarga> skitt: we probably want to push for 4.1.2 :)
16:52:50 <skitt> rovarga, ideally yes
16:52:59 <rovarga> we need either 4.0.10 or 4.1.2
16:53:08 <skitt> rovarga, but my first stabs at running that were ... weird
16:54:52 <colindixon> #action colindixon to work with skitt to figure out what the timeline might look like for nitrogen and what feautres need to go in and start shipping
16:55:39 <colindixon> #topic vorburger started working on infrautils.ready (to tell when things are up)
16:55:46 <colindixon> #info actual propsl later
16:56:57 <colindixon> #topic open patches
16:57:07 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/54965/ can we merge this, rovarga?
16:57:17 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8226 fixes that bug
16:58:53 <colindixon> #Info rovarga says that they're down to 3 issues, at least one of which needs more informatin
16:59:50 <colindixon> #info vorburger asks why so averse to suppress warnings all, rovarga says it's caught real issues in the past
17:00:29 <colindixon> #info vorburger says, "desptie not saying it, rovarga, you are -2ing that patch and asking to get it resolved on the bug." rovarga says yes.
17:01:27 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/topic:bumpCheckstyle when can we do this? rovarga says in nitrogen, but we need to fix it
17:01:30 <rovarga> #info correction: I am -1ing the patch. I am not actively telling other committers not to merge it :)
17:02:24 <colindixon> #info rovarga says we are broken in nitrogen and need to fix that
17:02:42 <colindixon> #action colindixon, vorburger will try to remove snmp4sdn from nitrogen for now
17:03:07 <colindixon> #endmeeting