16:01:29 <colindixon> #startmeeting kernel projects
16:01:29 <odl_meetbot> Meeting started Tue Jun 13 16:01:29 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:29 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:01:33 <colindixon> #topic agenda bashing
16:03:43 <colindixon> #info BUG-8413 NETCONF times out with large RPC responses from devices
16:03:50 <colindixon> #info NETONF password encryption
16:04:03 <colindixon> #info Boron-SR4
16:04:05 <colindixon> #info Karaf 4
16:04:49 <colindixon> #info NETCONF committer status?
16:04:52 <colindixon> #topic Boron-SR4
16:05:07 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Boron_SR4_Download
16:05:33 <anipbu> https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=119564471
16:05:38 <colindixon> anipbu: feel free to #link things
16:05:54 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Boron_SR4_Download downlad and info
16:06:08 <colindixon> #link sign-offs for test failure status
16:06:11 <colindixon> #Undo
16:06:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1e26690>
16:06:13 <colindixon> #link sign-offs for test failure status https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=119564471
16:07:13 <colindixon> #info nobody says they have any Boron-SR4 issues at this time
16:07:30 <colindixon> #topic Karaf 4
16:08:01 <colindixon> #Info the plan is to move to using odlparent version 1.9.0 today, should be done the rest of today by releng staff
16:08:18 <colindixon> #info we plan to move to odlparent 2.0.0 on Monday, June 19th and that will result in their being no Karaf 3
16:10:07 <colindixon> #info rgoulding says there are some features that we might want to move into odlparent, will that require another stage release like this?
16:10:25 <zxiiro> is the fact that parent poms cannot have ranges a potential concern?
16:10:41 <colindixon> #info colindixon says in theory not because projects should depend on [2.0.0,2.1), but we haven't tried it
16:11:33 <colindixon> #info skitt and anipbu ask if we can please hold off on doing things that aren't directly Karaf 4 related for now
16:11:51 <colindixon> #info rgoulding says it's mostly migrationg jolokia from controller to odlparent
16:12:11 <anipbu> https://wiki.opendaylight.org/view/Karaf_4_migration
16:12:16 <colindixon> #info anipbu explains that projects will be expected to migrate to odlparent 2.0.0 on their own, patches will not be provided becuase it isn't mechanical
16:12:24 <colindixon> #link https://wiki.opendaylight.org/view/Karaf_4_migration these are the instructions
16:12:26 <anipbu> https://bugs.opendaylight.org/show_bug.cgi?id=8682
16:12:33 <anipbu> https://bugs.opendaylight.org/show_bug.cgi?id=8622
16:12:43 <colindixon> #info two blocking bugs assigned to kernel projects for karaf
16:12:43 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8682 (AAA)
16:13:00 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8622 (odlparent)
16:13:19 <colindixon> #Info vorburger and rgoulding says that the AAA issue has been fixed with a revert
16:18:28 <colindixon> #info skitt says that after talking with upstream Karaf devs and they seem to think that it's not dependency resolution that's the issue, it's that we have unnecessary refreshes which shouldn't be happening
16:18:47 <colindixon> #info feature:install -v will tell you what it intends to refresh and why
16:19:13 <colindixon> #Info skitt says that org.json is part of the problem becuase it's interaction with jackson causes both to be refreshed
16:22:18 <rovarga_> skitt: https://git.opendaylight.org/gerrit/58835 should kill the import section (if it passes verify, that is)
16:22:32 <skitt> rovarga_, OK
16:22:45 <skitt> rovarga_, I'll push my Jackson port too once it builds locally and passes the tests
16:23:16 <rovarga_> rgoulding: why is that explicit import needed?
16:23:26 <rgoulding> web.xml references those packages
16:23:29 <rgoulding> it is a compile time concept
16:23:34 <colindixon> #info skitt says that feature:install X twice should work without a refresh
16:23:35 <rovarga_> *sigh*
16:23:40 <rgoulding> yeah when we get to jersey 2
16:23:45 <rgoulding> we can get rid of it
16:23:46 <rgoulding> :(
16:23:52 <rovarga_> yeah, WHEN?!?! :)
16:24:02 <colindixon> #info the way to avoid this is (in theorgy) that we need avoid bundle wirlng loops
16:25:07 <colindixon> #Info skitt notes that netconf/restconf + org.json issues might explain most of it
16:25:19 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf#Karaf_4_Coordinators
16:25:41 <anipbu> https://lists.opendaylight.org/pipermail/odlparent-dev/2017-June/001075.html
16:26:10 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf#Karaf_4_Coordinators
16:26:16 <colindixon> #link https://lists.opendaylight.org/pipermail/odlparent-dev/2017-June/001075.html
16:26:46 <rovarga_> rgoulding: I have updated it to just remove the maven exclusions then
16:27:46 <colindixon> #info the plan is to try to get all projects moved toward having a karaf 4 distribtuion building locally by 6/21 and 6/28 to have things merged in distribution
16:29:07 <colindixon> #Info the netvirt project is tentativelly on board with that, but also notes they are basing that on the hope that it becomes possible to bring Karaf 4 up
16:29:17 <colindixon> #topic BUG-8413
16:30:05 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8413
16:31:37 <colindixon> #info rgoulding asks if we have keeplaive enabled, maybe disabling that would help?
16:33:15 <colindixon> #info rovarga_ asks how long does the device take to respond? colindixon says they'll look it.
16:33:49 <colindixon> #topic NETCONF password encryption (and indirectly NETCONF committers)
16:34:23 <colindixon> #link https://lists.opendaylight.org/pipermail/netconf-dev/2017-June/001178.html
16:34:44 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/52528/
16:36:01 <colindixon> #info rovarga_ says that he worries about the Blueprint switchover since last time it broke things
16:36:18 <colindixon> #info rovarga_ says that jakub and tomas are busy in the controller, and haven't been able to devote much time to netconf
16:38:26 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/57368/ the netconf blueprint patch
16:38:49 <colindixon> #Info TomP and rovarga_ talk about the possible issues with this patch for a bit
16:41:23 <colindixon> #info colindixon and rgoulding ask if we need more committers, rovarga_ asks if there are people who know the code and are willing
16:41:42 <colindixon> #info colindixon suggests maybe rgoulding
16:42:55 <colindixon> #action rovarga_ to send mail to the netconf mailing list about how rgoulding (and others) might be able to
16:43:16 <colindixon> #Info rgoulding says he'd really like a clear path to being a comitter before he sinks a lot of time into it
16:44:11 <colindixon> #info TomP adds that getting more comitters on netconf matters becuase we currently only have 2 active committers and both from one company
16:45:29 <colindixon> #info anipbu also notes that netconf hasn't sent intent to participate in nitrogen (rovarga_ notes that yangtools and mdsal haven't either)
16:45:45 <colindixon> #topic recently merged patches
16:45:57 <colindixon> #link
16:45:58 <colindixon> https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merg
16:45:59 <colindixon> OT+age:7d
16:46:56 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/54981/ checkstyle bump might cause some issues with migration to 1.9.0
16:47:34 <colindixon> #info rovarga_ says that two spaces between import and package, and final keywords being used in abstract classes
16:48:19 <skitt> rovarga_, https://git.opendaylight.org/gerrit/58839
16:49:22 <colindixon> #info rovarga_ notes that aside from the EffectiveSchemaContext movement, all the patches are moving the internal parser implementation (for yangtools and mdsal)
16:50:11 <colindixon> #info there is some improvement in parsing booleans, this is blocking on a bad ALTO model
16:50:24 <rovarga_> #link https://git.opendaylight.org/gerrit/58761
16:50:40 <rovarga_> #info example of changes uncovered by the checkstyle bump
16:54:23 <colindixon> #Info TomP calls out some really old code in controller which we're trying to remove and hopefully it won't break anything, but it shouldn't
16:55:24 <colindixon> #topic upcoming patches
16:55:34 <colindixon> #link
16:55:35 <colindixon> #link
16:55:36 <colindixon> #link
16:55:37 <colindixon> #link
16:55:39 <colindixon> #link
16:55:40 <colindixon> #link
16:55:42 <colindixon> #link
16:55:43 <colindixon> #link
16:55:45 <colindixon> #link
16:55:46 <colindixon> #link
16:55:48 <colindixon> #link
16:55:49 <colindixon> #link
16:55:51 <colindixon> #link
16:55:52 <colindixon> #link
16:55:54 <colindixon> #link
16:55:55 <colindixon> #link
16:55:57 <colindixon> #link
16:55:58 <colindixon> #link
16:56:00 <colindixon> #link
16:56:01 <colindixon> #link
16:56:03 <colindixon> #link
16:56:04 <skitt> colindixon, there's something wrong there
16:56:04 <colindixon> sjdofja
16:56:06 <colindixon> https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age
16:56:07 <colindixon> #link
16:56:09 <colindixon> #link
16:56:10 <colindixon> #link
16:56:12 <colindixon> #link
16:56:13 <colindixon> #link
16:56:15 <colindixon> #link
16:56:16 <colindixon> #link
16:56:17 <colindixon> #link
16:56:18 <colindixon> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d
16:56:23 <colindixon> the line was too long for my client
16:56:31 <colindixon> so I was testing if it was still up
16:56:31 <skitt> oops
16:57:16 <colindixon> oh wow
16:58:14 <colindixon> I didn't realize I did #link appeared like 40 times for people
16:58:54 <colindixon> my client doesn't show that
16:59:56 <colindixon> I should move away from Colloquy
17:00:29 <colindixon> #endmeeting