16:03:45 <colindixon> #startmeeting kernel projects
16:03:45 <odl_meetbot> Meeting started Tue Jun 20 16:03:45 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:45 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:03:49 <colindixon> #topic agenda bashing
16:04:00 <colindixon> #info anipbu asks to cover cover Karaf 4 again
16:06:26 <colindixon> #topic clustering split-brain behavior
16:07:00 <colindixon> #Info skitt says he and others were wondering what the split-brain behavior in OpenDaylight with clustering
16:07:26 <colindixon> #info skitt says his understanding was that things should stop if there are less than half of the nodes on one half
16:08:26 <colindixon> #Info rovarga says that according to RAFT new transactions should fail on the minority side and so the data store will "stop", but nothing else will change, e.g., applications will stil run
16:11:57 <colindixon> #Info rovarga says that it's all Raft, so go read it, colindixon and TomP add additional comments that some things have been added on top of and aroudn Raft that may change some of the behavior, but still it generally applies
16:13:17 <colindixon> #topic Karaf 4
16:13:23 <colindixon> anipbu: feel free to #info in things
16:13:41 <anipbu> https://lists.opendaylight.org/pipermail/release/2017-June/011221.html
16:13:46 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011221.html
16:19:25 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
16:19:37 <anipbu> https://bugs.opendaylight.org/show_bug.cgi?id=7891
16:20:21 <colindixon> #info the plan is to release odlparent 2.0.0 sometime in the next 48 hours and then bump to that in yangtools (and break the world) early on Thursday morning
16:20:23 <anipbu> https://bugs.opendaylight.org/show_bug.cgi?id=8571
16:20:28 <anipbu> https://bugs.opendaylight.org/show_bug.cgi?id=8622
16:22:06 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011221.html   <--- This is the current plan for Karaf 4 Migration
16:23:34 <anipbu> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2017-June/004775.html   <-- Netvirt running into karaf 4 issues and requesting 24 hour delay in odlparent 2.0.0 migration
16:23:38 <colindixon> #link http://karaf.922171.n3.nabble.com/Understanding-features-and-dependencies-td4050692.html#a4050698 upstream Karaf's comments on our issues
16:23:50 <anipbu> #info Kernal projects should delay migration by 24 hours
16:23:51 <colindixon> #info for what it's worth, feautre:install shoudn't refresh bundles just because
16:24:25 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/nitrogen_release_sync/opendaylight-meeting-nitrogen_release_sync.2017-06-19-15.02.html this meeting has some more notes on the refresh issues
16:24:27 <anipbu> #info Stephen agrees to release Emergency Release of ODLPARENT 2.0.1 if critical error is found
16:25:01 <anipbu> #link There exists blocker bugs in Karaf 4: https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
16:25:30 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=7891   <--- rovarga to look into Netconf Karaf 4 Blocker Bug
16:26:01 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=8571 and https://bugs.opendaylight.org/show_bug.cgi?id=8622   <--- skitt to look into resolving the Odlparent Karaf 4 Blocker Bugs
16:26:37 <anipbu> #info some discussion on Karaf 4 Dependency Resolution between colindixon skitt  rovarga
16:27:49 <colindixon> #info colindixon added some of this discussion to bug 8622
16:28:22 <colindixon> #Info skitt notes that beanutils (and having two versions?) in AAA is the current place where unintentional bundle refreshes are causing issues, there's a lot of discussion of how to get down to one version
16:28:42 <colindixon> #action rgoulding to look into AAA optional dependencies on beanutils and what it might be causing issues with Karaf 4
16:29:09 <colindixon> #info if you embed dependencies and then re-export them, that can cause problem by creating cycles
16:33:02 <colindixon> #info some more conversations around replacing org.json with jackson and gson, and the general idea is that in OpenDaylight should probably move to gson
16:33:42 <colindixon> #action rgoulding to look into and maybe lean on AAA's dependencies to maybe get away from org.joon
16:33:45 <colindixon> #Undo
16:33:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2c00bd0>
16:33:48 <colindixon> #action rgoulding to look into and maybe lean on AAA's dependencies to maybe get away from org.json
16:37:12 <colindixon> #topic netconf committers
16:39:32 <colindixon> #info colindixon basically says he's willing to take anything he can get, but we need to some point where there's regular interaction with the netconf comitters, no regular interaction doesn't work
16:40:11 <colindixon> #link https://lists.opendaylight.org/pipermail/netconf-dev/2017-June/001205.html
16:40:44 <colindixon> #Info TomP and rgoulding add that people need to at least appear every few days (maybe once a week would work if it was communicated), but once a moth or once per multiple weeks really doesn't work
16:43:16 <colindixon> #topic deprecating the config subsystem
16:43:47 <colindixon> #Info TomP says that basically it's just the controller and netconf that use the config subsystem now
16:45:02 <colindixon> #info TomP asks if it's time to remove the config subsystem way to do mounts in NETCONF
16:45:20 <colindixon> #Info it's been deprecated (in that it says don't do it) since Beryllium, could we take it out?
16:50:04 <colindixon> #info the other thing using the config subsytem is YANGlib, which seems to be an optional feature to act as a schemastore
16:52:31 <colindixon> #info rovarga says that this is probalby required for RFC-8040 support
16:54:32 <colindixon> #chair anipbu rgoulding
16:54:32 <odl_meetbot> Current chairs: anipbu colindixon rgoulding
16:54:39 <colindixon> #topic review merged and pending patches
16:54:53 <colindixon> if one of you two wants to take notes, please feel free, I have to jump to another call
16:55:06 <colindixon> in either event either ping me or just hit #endmeeting when you're done to end the meeting
16:55:31 <colindixon> #info AAA is now Activatorless—it's all Blueprint
16:58:48 <rgoulding> #endmeeting