16:03:29 <rgoulding> #startmeeting kernel projects
16:03:29 <odl_meetbot> Meeting started Tue Jun 27 16:03:29 2017 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:29 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:04:03 <rgoulding> #chair colindixon
16:04:03 <odl_meetbot> Current chairs: colindixon rgoulding
16:04:23 <colindixon> #topic agenda bashing
16:04:28 <rgoulding> #info Karaf 4 Discussion
16:04:40 <rgoulding> #info odlparent 2.0.0
16:04:53 <rgoulding> #info odl-mdsal-apidocs Bug 8752 - apidoc explorer show/hide and list operations no longer works
16:04:57 <colindixon> #link https://wiki.opendaylight.org/index.php?title=Kernel_Projects_Call&oldid=58253#Upcoming_Agenda_Topics pulling from here
16:05:01 <rgoulding> #info Bug 8750 - Unnable to receive DataTreeChanged notifications
16:05:09 <rgoulding> #info NETCONF encrypted passwords patch
16:05:29 <rgoulding> #topic Karaf 4 Discussion
16:05:59 <anipbu> https://git.opendaylight.org/gerrit/#/q/topic:odlparent200
16:06:27 <anipbu> https://lists.opendaylight.org/pipermail/controller-dev/2017-June/013611.html
16:06:35 <anipbu> https://git.opendaylight.org/gerrit/#/c/59303/
16:07:20 <rgoulding> #action kernel committers to review the features in integration-distribution
16:08:52 <rgoulding> #chair anipbu
16:08:52 <odl_meetbot> Current chairs: anipbu colindixon rgoulding
16:11:03 <rgoulding> #info benchmarks should not be included in the integration distribution
16:12:57 <rgoulding> #info some of the netconf feature repositories seemto be missing
16:13:58 <rgoulding> #topic odl-mdsal-apidocs
16:14:07 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=8752
16:15:02 <anipbu> #info kernel projects agree to move forward with merging patch 59303.  any missing features will be added with a separate patch
16:16:35 <colindixon> #info it seems like we need to actually fix this, but we don't know how yet
16:16:40 <rgoulding> #topic Bug 8750 - Unnable to receive DataTreeChanged notifications
16:16:47 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=8750
16:18:25 <rgoulding> #info is the data actually stored in the data store?
16:18:37 <rgoulding> #info events don’t seem to get propagated
16:18:53 <rgoulding> #info has anyone else noticed this?
16:20:48 <rgoulding> #info if you POST into config data store, is the data actually getting stored in the DS
16:21:00 <colindixon> #info rovarga_ asks if the data is actually getting written into the data store
16:21:35 <colindixon> #info yrineu says that he's able to do a post and then see the results
16:22:43 <rgoulding> #action yrineu to do a get to see if the data is actually present in config datastore
16:22:48 <rgoulding> undo
16:22:51 <rgoulding> #undo
16:22:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2e69710>
16:23:25 <rgoulding> #action yrnieu to update Bug 8750 after trying to do an HTTP GET and see if the data is propagated to the DS
16:23:56 <colindixon> #info it seems as though the general feeling is that the issue has to be in the code logic in NIC, but maybe looking at the toaster would help
16:25:48 <colindixon> #info TomP wants to know if the listener is actually getting registered
16:26:23 <colindixon> #Info TomP wants to know if it's single node or clustered
16:26:54 <colindixon> #info rovarga_ asks if this is DCLs or DTCLs? rovarga_ notes that DCLs might need to be migrated to DTCLs
16:27:17 <rgoulding> #info yrineu confirms that it is org.opendaylight.controller.md.sal.binding.api.DataTreeChangeListener;
16:30:52 <rgoulding> #info when we merge the integration distribution patch then we will see the result
16:31:06 <rgoulding> #info implicit reproduction attempt through automated CSIT
16:31:28 <rgoulding> #topic NETCONF encrypted passwords patch
16:31:39 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/52528/
16:35:31 <rgoulding> #action jmorvay to follow up with Tomas Cere about encrypted passwords patch
16:36:47 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=1643
16:37:07 <rgoulding> #info the above bug explains that we shoudl be able to filter what we see on the northbound
16:38:09 <rgoulding> #topic RESTCONF bp patch
16:38:38 <rgoulding> #info tpantelis left in existing config yang for backwards compatibility
16:38:43 <rgoulding> #info should we just remove it?
16:39:10 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/57368/
16:39:25 <rgoulding> #info the patch above has the existing config yang, but it is a NOOP
16:39:38 <rgoulding> #info it is deprecated, but is still present
16:40:09 <rgoulding> #info jmorvay says in NETCONF they just deprecated the config yang in previous release and removed in present one
16:40:52 <rgoulding> #info tpantelis to push a patch to remove the module classes and config
16:42:35 <rgoulding> #topic remove the CSS based netconf connector
16:42:44 <rgoulding> #info it has been deprecated since Beryllium
16:42:50 <rgoulding> #info can we remove it?
16:43:07 <rgoulding> #info jmorvay thinks it is safe to remove it
16:43:26 <rgoulding> #info we advised for several releases to use odl-netconf-{clustered}-topology
16:43:37 <rgoulding> #info should we do a weather item?
16:44:10 <rgoulding> #action tpantelis to send a weather item to controller-dev netconf-dev and release
16:45:28 <rgoulding> #info we should release note that we are killing it
16:46:47 <rgoulding> #info can release notes be a living document?
16:47:27 <colindixon> #link https://github.com/opendaylight/docs/tree/master/docs/getting-started-guide/project-release-notes just edit files there
16:48:05 <rgoulding> #action colindixon to send email to release mailing list suggesting that we should update release notes as we go through the release
16:48:42 <colindixon> #link http://docs.opendaylight.org/en/latest/getting-started-guide/release_notes.html they're immediately rendered there on every docs merge
16:51:23 <rgoulding> #info is this something that we should be checking at M3 when all features should be in?
16:51:34 <rgoulding> #undo
16:51:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ef2c10>
16:51:39 <rgoulding> #info rovarga asks is this something that we should be checking at M3 when all features should be in?
16:51:53 <rgoulding> #info give a nudge at M3 to start this document?
16:52:13 <rgoulding> #action colindixon to add this to M3 readout for docs
16:52:36 <rgoulding> #topic merged/on-deck patches
16:55:37 <rgoulding> #action rgoulding investigate if we can get rid of beanutils once shiro.ini is dead and we are on shiro-core 1.4.0
16:56:30 <rgoulding> #endmeeting