16:02:07 <rgoulding> #startmeeting kernel projects
16:02:07 <odl_meetbot> Meeting started Tue Jul 18 16:02:07 2017 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:07 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:07 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:02:21 <rgoulding> #topic agenda bashing
16:02:31 <rgoulding> #info Karaf 4 Update
16:02:40 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d
16:02:48 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d
16:03:32 <rgoulding> #info Bug 8413
16:03:40 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=8771
16:03:51 <rgoulding> #info NETCONF encryption patches
16:03:58 <rgoulding> #info NETCONF public key authentication patch
16:05:00 <rgoulding> #topic karaf 4 update
16:06:23 <rgoulding> #info projects dependent on odl-netconf-connector will still have failing distribution-check
16:07:39 <rgoulding> #action rgoulding to push snmp into integration/distribution
16:08:47 <rgoulding> #topic Bug8771
16:08:52 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=8771
16:12:36 <rgoulding> #info only when install odl-netconf-clustered-topology
16:13:13 <rgoulding> #info this is every single distribution-check job that fails
16:13:24 <rgoulding> #undo
16:13:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2e1e450>
16:15:56 <rgoulding> #info this is every single distribution-check job that installs the feature above
16:24:55 <rgoulding> #info several bundles getting uninstalled
16:25:01 <rgoulding> #info 2017-06-29 10:02:55,000 | INFO  | config-pusher    | ConfigPusherImpl                 | 142 - org.opendaylight.controller.config-persister-impl - 0.7.0.SNAPSHOT | Pushing configuration snapshot 00-netty.xml(odl-netconf-impl,odl-netconf-impl)
16:25:01 <rgoulding> 2017-06-29 10:02:57,573 | INFO  | pool-2-thread-1  | FeaturesServiceImpl              | 9 - org.apache.karaf.features.core - 4.0.9 | Changes to perform:
16:25:03 <rgoulding> 2017-06-29 10:02:57,573 | INFO  | pool-2-thread-1  | FeaturesServiceImpl              | 9 - org.apache.karaf.features.core - 4.0.9 |   Region: root
16:25:04 <rgoulding> 2017-06-29 10:02:57,573 | INFO  | pool-2-thread-1  | FeaturesServiceImpl              | 9 - org.apache.karaf.features.core - 4.0.9 |     Bundles to uninstall:
16:25:05 <rgoulding> 2017-06-29 10:02:57,573 | INFO  | pool-2-thread-1  | FeaturesServiceImpl              | 9 - org.apache.karaf.features.core - 4.0.9 |       org.opendaylight.netconf.config-netconf-connector/1.3.0.SNAPSHOT
16:25:06 <rgoulding> 2017-06-29 10:02:57,573 | INFO  | pool-2-thread-1  | FeaturesServiceImpl              | 9 - org.apache.karaf.features.
16:26:56 <rgoulding> #info 2017-06-29 10:02:49,570 | INFO  | pool-2-thread-1  | FeaturesServiceImpl              | 9 - org.apache.karaf.features.core - 4.0.9 |     io.netty.handler/4.1.8.Final (Should be wired to: bcprov/1.56.0 (through [io.netty.handler/4.1.8.Final] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.bouncycastle.asn1.x500)(version>=1.54.0)(!(version>=2.0.0)))"; resolution:=optional), bcpkix/1.56.0 (through [io.netty.handler/4.1.8.Final
16:26:56 <rgoulding> osgi.wiring.package; filter:="(&(osgi.wiring.package=org.bouncycastle.cert)(version>=1.54.0)(!(version>=2.0.0)))"; resolution:=optional))
16:27:05 <rgoulding> #info bcpkix needs to be pusehd into startupbundles
16:27:44 <rgoulding> #info should stop the bundle refresh
16:30:00 <rgoulding> #topic Bug8413
16:30:15 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=8413
16:31:12 <rgoulding> #info issues like this need performance snapshot and memory dump
16:31:46 <rgoulding> #action Sai to get this info and attach to bug
16:32:24 <rgoulding> #topic NETCONF encryption
16:32:32 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/60298/
16:32:45 <rgoulding> #undo
16:32:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2d02950>
16:32:46 <rgoulding> #undo
16:32:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2e79090>
16:32:52 <rgoulding> is this reproducible with Carbon and Nitrogen?
16:33:00 <rgoulding> #info is this reproducible with Carbon and Nitrogen?
16:33:04 <rgoulding> #info try with carbon and nitrogen
16:33:13 <rgoulding> #info many issues fixed since Boron-SR1
16:33:19 <rgoulding> #info this was tried with Boron
16:33:38 <rgoulding> #topic NETCONF encryption
16:33:45 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/60298/
16:35:12 <rgoulding> #info the patch is creating multiple sessions one after another
16:35:22 <rgoulding> #info the patch should be changed from a listener to an RPC
16:36:14 <rgoulding> #info issue a message in the log
16:36:18 <rgoulding> #info at warning level
16:37:03 <rgoulding> #info small change really and will improve code
16:37:22 <rgoulding> #info will get rid of race condition and multiple session issue
16:37:38 <rgoulding> #info testtool bug hit the race
16:39:57 <rgoulding> #topic NETCONF public key authentication
16:40:05 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/59537/
16:40:39 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/59537/6
16:40:46 <rgoulding> #undo
16:40:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2f09490>
16:41:04 <rgoulding> #action tcere to take a look tomorrow
16:41:38 <rgoulding> #info any CSIT on this yet?
16:41:53 <rgoulding> #action Atul to do some CSIT for public key auth tests
16:42:38 <rgoulding> #topic merged/pending patches
16:42:46 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d
16:43:31 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d
16:44:38 <rgoulding> #action tpantelis to review a few patches that Robert added him as a reviewer to
16:45:31 <rgoulding> #endmeeting