16:01:39 <rgoulding> #startmeeting kernel projects
16:01:39 <odl_meetbot> Meeting started Tue Aug  1 16:01:39 2017 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:39 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:01:47 <rgoulding> #topic agenda bashing
16:04:45 <rgoulding> #info kernel projects status for Nitrogen
16:04:55 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d
16:05:01 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d
16:05:15 <rgoulding> #topic kernel projects status for Nitrogen
16:07:32 <rgoulding> #info AAA just needed Bug 8195 which was in this morning
16:07:54 <rgoulding> #info yangtools is code complete for Nitrogen.  Some issues with correctness of Yang 1.1 which should be nailed down by RC0
16:08:01 <rgoulding> #info yangtools in reasonable shape and good to go
16:08:22 <rgoulding> #info MD-SAL has a few changes that need to go in.  One of those involves performance/correctness to Binding Spec v2
16:08:29 <rgoulding> #info improvements to Data Tree Sharding
16:08:48 <rgoulding> #info patches will also affect controller
16:09:37 <rgoulding> #info controller doesn’t seem to have any outstanding work for Nitrogen
16:10:00 <rgoulding> #info tell-tell based prognosis:  kinda late in the game but we can give it a try if downstream projects are okay with it
16:10:41 <rgoulding> #info most of the bugs were edge cases with retries etc.
16:10:57 <rgoulding> #info the performance aspect of it may be different though and there may be some kinks that we have not yet caught
16:11:06 <rgoulding> #info things we can only catch in much wider testing
16:11:25 <rgoulding> #info we should be good to go flipping it on depending on what releng/release teams say
16:11:36 <rgoulding> #info we are not worse than we were before
16:12:12 <rgoulding> #info Robert thinks it is go at this point
16:12:22 <rgoulding> #info all we need to do is ask release to see whether we can flip it on in Nitrogen
16:12:34 <rgoulding> #info if not in Nitrogen then first thing when we do branch cutting
16:12:57 <rgoulding> #info TomP waiting for switch in order to move to Artery
16:13:08 <rgoulding> #info just slicing without Artery will help
16:13:14 <rgoulding> #info probably too late for Artery for Nitrogen
16:14:43 <rgoulding> #info offset 1 M5 is this thursday
16:14:56 <rgoulding> #info RC0 is 8/14/2017, not this thursday but next
16:15:44 <rgoulding> #info rovarga the plan ahead involves flipping the switch, but keeping the old protocol for one release.  then we can remove completely in a following release
16:16:03 <rgoulding> #info it is keeping us from removing TransactionTimeouts
16:17:57 <rgoulding> #info odlparent is fine with 2.0.2 for Nitrogen
16:18:13 <rgoulding> #info NETCONF project release status
16:18:25 <rgoulding> #info jmorvay Bug 7891 fixed thanks to Luis Gomez
16:18:56 <rgoulding> #info Bug7883 and Bug 8916 are major/blocker but not confirmed yet
16:19:24 <rgoulding> #action jmorvay to look and see if these are true blockers for Nitrogen
16:20:59 <rgoulding> #topic merged/pending patches
16:21:09 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d
16:22:32 <rgoulding> #info plan to remove yang-data-impl XML parser that is scheduled.  downstream users have been transitioned.  That is to reduce the numberof old parsers to support code maintenance going forward
16:23:07 <rgoulding> #info for MD-SAL Bug-8733 includes performance optimizations
16:24:15 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/59537/
16:25:19 <rgoulding> #info some style issues etc. but after they are fixed we can commence with further review
16:25:25 <rgoulding> #info you still have to use password?
16:26:31 <rgoulding> #info if the user has given public key and username/password credentials, both methods will be tried.  public key-auth is tried first, then username/password.
16:27:25 <rgoulding> #info the issue is that if a device only uses public key-auth you still need to specify username/password in put request
16:27:36 <rgoulding> #info they might still be forced to configure something here
16:28:27 <rgoulding> #info this should be an authentication “choice”
16:31:10 <rgoulding> #info the passphrase should be encrypted
16:35:17 <rgoulding> #info NETCONF username/password encryption password in review by jmorvay
16:37:34 <rgoulding> #action rgoulding to make release note for the log message for failed decryption
16:39:24 <rgoulding> #endmeeting