15:59:33 <rgoulding> #startmeeting kernel projects
15:59:33 <odl_meetbot> Meeting started Tue Aug  8 15:59:33 2017 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:59:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:33 <odl_meetbot> The meeting name has been set to 'kernel_projects'
15:59:46 <rgoulding> #topic agenda bashing
15:59:48 <rgoulding> #info kernel projects status for Nitrogen
15:59:55 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d
16:00:03 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d
16:04:11 <rgoulding> #info odlparent 2.0.3
16:04:34 <rgoulding> #topic odlparent 2.0.3 release
16:05:07 <rgoulding> #link https://lists.opendaylight.org/pipermail/odlparent-dev/2017-August/001289.html
16:05:18 <rgoulding> #info fixes issues with bouncy castle starting restarts in NETCONF
16:05:25 <rgoulding> #info bumps version for javassist
16:06:10 <rgoulding> #info staging repository is in the email and can be added to ~/.m2/settings.xml
16:06:25 <rgoulding> #info skitt asks projects to test if they can
16:06:49 <rgoulding> #info mdsal, aaa and netconf are required, and some other offset 1 & 2 projects will need to be patched for javassist changes
16:07:24 <rgoulding> #info two projects have trouble adding features (packetcable encounters OOM during SFT)
16:07:36 <rgoulding> #info increasing timeout does help for SFT for packetcable
16:07:56 <rgoulding> #info Bug8941 is the bug for OOM issue
16:08:15 <rgoulding> #info we will need to fix broken unit tests that are fixed by this bug
16:08:34 <rgoulding> #info in the next two days, vrpolak will provide status on whether this change fixes SFT
16:08:45 <rgoulding> #info skitt, should we hold off on 2.0.3 then?
16:08:58 <rgoulding> #info vrpolak, aside from OOM we aren’t seeing other issues.
16:09:14 <rgoulding> #info rovarga we should start adopting it ASAP then to rule out false positives etc.
16:09:24 <rgoulding> #info distribution is also seeing this issue
16:09:32 <rgoulding> #info even if distribution needs 2.0.4 we can adopt 2.0.3 now
16:10:17 <rgoulding> #info rovarga asks vrpolak if we have heap dump of OOM
16:10:27 <rgoulding> #info vrpolak cannot find a heapdump anywhere on the filesystem
16:10:51 <rgoulding> #info vrpolak says that something funny is happening with how surefire is handling this case
16:11:36 <rgoulding> #info rovarga asks zxirro to take a look at the workspaces for heap dump since JVM claims heap dump was taken
16:12:32 <vrpolak> #link https://jenkins.opendaylight.org/sandbox/job/distribution-verify-nitrogen/3/console  <-- run with *.hprof missing
16:12:56 <rgoulding> #action zxirro to look at patch and system for missing heapdump
16:13:19 <vrpolak> #link https://git.opendaylight.org/gerrit/61274  <-- example Change which generates .hprof
16:13:53 <rgoulding> #info rovarga asks if there is a way to get all logs with a link instead of using recursive curl method
16:14:08 <rgoulding> #info zxirro says that the only ways he know how to do it are to do it with recursive wget / curl
16:14:25 <rgoulding> #info rovarga asks if we can use RO access w/ SCP access on the directories
16:14:36 <rgoulding> #info zxirro thinks LF IT staff will push back
16:14:54 <rgoulding> #info zxirro says SSH is an exception for GIT interactions
16:15:11 <rgoulding> #info zxirro doesn’t think they will allow it since it is managed internally by LF IT
16:15:38 <rgoulding> #info rovarga we have generated features which are part of the space, but downloading the features.xml takes a very long time at present
16:15:53 <rgoulding> #info zxirro maybe we can just make it a single zip?
16:16:12 <rgoulding> #info rovarga having directory exploded useful for console log etc
16:16:22 <rgoulding> #info in which downloading the entire shebang would be a waste of time
16:16:30 <rgoulding> #info but sometimes you need the interesting bits that are archived
16:16:35 <rgoulding> #info there are two use cases
16:16:47 <rgoulding> #info zxirro instructs rovarga to issue a help desk ticket for this
16:17:38 <rgoulding> #link https://nexus.opendaylight.org/content/repositories/odlparent-1061/
16:17:55 <rgoulding> #info add the above repo temporarily in order to test 2.0.3 with local build
16:18:02 <rgoulding> #info make sure to remove afterwards though!
16:18:33 <rgoulding> #topic kernel projects status for Nitrogen
16:18:59 <rgoulding> #info rovarga says that there is OOM issue shared between Carbon andNitrogen
16:19:37 <rgoulding> #info we plan to do branch cutting at M5 Offset 2
16:19:53 <rgoulding> #info in this release that coincides iwht RC0
16:19:57 <rgoulding> #info which is Monday
16:20:33 <rgoulding> #info one more issue in NETCONF related to parsing XML
16:20:57 <rgoulding> #info blocking bug in NETCONF Bug8944
16:21:02 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/61333/
16:21:06 <rgoulding> #info above is the candidate patch
16:21:10 <rgoulding> #info should be done by end of week
16:21:13 <rgoulding> #info some changes are needed
16:22:18 <rgoulding> #topic pending/merged patches
16:22:28 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT+age:7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d
16:24:08 <rgoulding> #info protocol-framework moved to netconf
16:24:10 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/60902/
16:24:16 <rgoulding> #info should we be good to go with removing from controller
16:24:48 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/60903/2
16:25:01 <rgoulding> #info rovarga will hunt down rogue users fo it and switch them to netconf
16:25:07 <rgoulding> #info just changed groupId and movped it
16:25:19 <rgoulding> #info lldp library needs to be removed, but it is too late in the relase
16:25:26 <rgoulding> #info shague was looking to do this at some point
16:25:32 <rgoulding> #info some sort of caretaker project
16:25:48 <rgoulding> #info no status updates or anything and won’t participate in the normal simultaneous release process
16:26:01 <rgoulding> #info same issue with yangtools triemap implementation
16:26:31 <rgoulding> #info discussion still ongoing on how to handle this
16:27:13 <rgoulding> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AAA+Patches=project:aaa+status:open+NOT+age:7d
16:27:51 <rgoulding> #info all outstanding yangtools patches are planned for after the branch cut
16:27:58 <rgoulding> #info some will be backportedto Nitrogen post release
16:28:09 <rgoulding> #info MDSAL patches are mostly fixes to binding spec v2
16:28:22 <rgoulding> #info should not be an issue since there are no consumers at present
16:28:26 <rgoulding> #info same story for controller
16:29:05 <rgoulding> #endmeeting