15:58:23 <ryangoulding> #startmeeting kernel projects
15:58:23 <odl_meetbot> Meeting started Tue Sep 12 15:58:23 2017 UTC.  The chair is ryangoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:58:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:58:23 <odl_meetbot> The meeting name has been set to 'kernel_projects'
15:58:29 <ryangoulding> #topic agenda bashing
15:58:39 <ryangoulding> #info Checkstyle more rulez
15:58:51 <ryangoulding> #info JavaDoc sites, next step? Merge https://git.opendaylight.org/gerrit/#/c/60213/
15:58:59 <ryangoulding> #info Discussion: Should each thing create its own ExecutorService or should we have a single central shared one? Like an EE servers's manged thread pools.
15:59:12 <ryangoulding> #link
15:59:13 <ryangoulding> https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&infrautils+patches=project:infrautils+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT
15:59:13 <ryangoulding> :7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d
15:59:19 <ryangoulding> #link
15:59:20 <ryangoulding> https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Modified+In+Last+7+Days&odlparent+patches=project:odlparent+status:open+NOT+age:7d&infrautils+patches=project:infrautils+status:open+NOT+age:7d&yangtools+Patches=project:yangtools+status:open+NOT+age:7d&mdsal+Patchs=project:mdsal+status:open+NOT+age:7d&controller+patches=project:controller+status:open+NOT+age:7d&netconf+patches=project:netconf+status:open+NOT+age:7d&AA
15:59:21 <ryangoulding> tches=project:aaa+status:open+NOT+age:7d
16:04:55 <ryangoulding> #topic Bug 8413
16:05:04 <ryangoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=8413
16:06:37 <ryangoulding> #action jmorvay to take a look this week, but he has been caught up with Nitrogen release process
16:06:46 <ryangoulding> #info previously tcere was looking, but he is out
16:06:57 <ryangoulding> #info jmorvay will update appropriately once he finds something else otu
16:09:02 <ryangoulding> #topic Michael’s topics
16:09:11 <ryangoulding> #info we will discuss these next week when Michael is on the call
16:14:21 <ryangoulding> #topic merged/on-deck patches
16:14:25 <ryangoulding> #undo
16:14:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x144ebd0>
16:14:49 <ryangoulding> #topic distribution-check jobs failing might be AAA
16:15:08 <ryangoulding> #info SFT failing and AAA is only one writing so it appears to be a likely candidate
16:15:42 <ryangoulding> #action rovarga to find a failed job and send to rgoulding
16:15:50 <ryangoulding> #action rgoulding to take a further look into why this is happening
16:16:44 <ryangoulding> #topic on-deck / merged patches
16:16:56 <ryangoulding> #link
16:16:56 <ryangoulding> https://git.opendaylight.org/gerrit/#/dashboard/?title=Core+Patches+Merged+In+Last+7+Days&odlparent+patches=project:odlparent+status:merged+NOT+age:7d&infrautils+patches=project:infrautils+status:merged+NOT+age:7d&yangtools+Patches=project:yangtools+status:merged+NOT+age:7d&mdsal+Patchs=project:mdsal+status:merged+NOT+age:7d&controller+patches=project:controller+status:merged+NOT+age:7d&netconf+patches=project:netconf+status:merged+NOT
16:16:57 <ryangoulding> :7d&AAA+Patches=project:aaa+status:merged+NOT+age:7d
16:17:42 <ryangoulding> #info a slew of patches will go in the day after nitrogen release
16:18:59 <ryangoulding> #info yangtools will soon be disconnected from the rest of the release, but is blocked until we have nitrogen release candidate.  Then consumers will revert to a release version.
16:19:13 <ryangoulding> #info we will likely need a week of breakage to handle the yangtools API changes etc.
16:23:22 <ryangoulding> #info Bug9092
16:23:30 <ryangoulding> #link https://git.opendaylight.org/gerrit/#/c/62849/1
16:23:39 <ryangoulding> #info ^ workaround for json serialization in nitrogen
16:23:50 <ryangoulding> #info permanent solution in oxygen will involve using yangtools apis
16:28:28 <ryangoulding> #endmeeting