15:54:26 <rgoulding> #startmeeting kernel projects
15:54:26 <odl_meetbot> Meeting started Tue Sep 26 15:54:26 2017 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:54:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:54:26 <odl_meetbot> The meeting name has been set to 'kernel_projects'
15:54:30 <rgoulding> #topic agenda bashing
15:54:38 <rgoulding> #info JavaDoc sites, next step? Merge https://git.opendaylight.org/gerrit/#/c/60213/
15:54:51 <rgoulding> #info continued from last week… Discussion: Should each thing create its own ExecutorService or should we have a single central shared one? Like an EE servers's manged thread pools.
15:54:58 <rgoulding> #info Websocket and clustering: https://git.opendaylight.org/gerrit/#/c/63264/
15:55:10 <rgoulding> #info merged/pending patches in the last week
15:59:56 <rgoulding> #link https://www.opendaylight.org/events/odl-oxygen-developer-design-forum
16:03:43 <rgoulding> #topic Oxygen DDF
16:03:54 <rgoulding> #link https://www.opendaylight.org/events/odl-oxygen-developer-design-forum
16:04:56 <rgoulding> #link https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum
16:05:55 <rgoulding> #topic JavaDoc site docs
16:06:01 <rgoulding> #info JavaDoc sites, next step? Merge https://git.opendaylight.org/gerrit/#/c/60213/
16:06:06 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/60213/
16:06:29 <rgoulding> #info Michael V. feels stuck on how to move forward with this.  We probably need Thanh’s help
16:08:41 <zxiiro> thanks for the reminder. let me jump on the call
16:10:14 <rgoulding> #info instead of just putting it in “sites” put it in a new location perhaps
16:10:21 <rgoulding> #info perhaps something like “/javadocs”
16:10:33 <rgoulding> #info that way we can have both systems concurrently while making the transition
16:10:48 <rgoulding> #info vorburger feels like this is caution for cuation’s sake because he doesn’t know if there are any users of this
16:12:05 <rgoulding> #info each component had its own maven site, which made it somewhat hard to use
16:12:11 <rgoulding> #info but the point is there could have been some users
16:12:53 <rgoulding> #info if we determine that we can build javadoc in the new location w/ better format then we can probably stop building theold one
16:13:16 <rgoulding> #action vorburger to open helpdesk ticket to make anew site for “javadoc(s)"
16:14:10 <rgoulding> #info we need the javadocs to be deployed to some directory, then we could point the site to the directory
16:14:21 <rgoulding> #info vorburger says it is put in target
16:15:43 <zxiiro> #link deploy-site.xml example https://github.com/opendaylight/odlparent/blob/master/deploy-site.xml
16:16:06 <rgoulding> #link https://github.com/opendaylight/odlparent/blob/master/deploy-site.xml#L38
16:16:40 <rgoulding> #info we could put the javadocs here, or change this to wherever the javadoc is generated
16:17:21 <rgoulding> #link https://github.com/opendaylight/odlparent/blob/master/deploy-site.xml#L20
16:17:39 <rgoulding> #info content/sites/javadoc instead of content/sites/site for the second site url
16:18:04 <rgoulding> #info every project will need this file to deploy
16:18:14 <rgoulding> #info we could get jjb to push the file in
16:18:26 <rgoulding> #info start with odlparent first then figure out how to handle other projects
16:19:07 <rgoulding> #topic Websocket and clustering: https://git.opendaylight.org/gerrit/#/c/63264/
16:19:19 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/63264/
16:19:46 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=9147
16:20:39 <rgoulding> #link https://git.opendaylight.org/gerrit/#/q/topic:ListenerAdapterTreeMigration
16:22:29 <vorburger> zxiiro: I've just started a new https://bugs.opendaylight.org/show_bug.cgi?id=9215, perhaps we could use that to collaborate together on a JavaDoc for odlparent POC ?
16:23:01 <zxiiro> vorburger: sure
16:23:12 <zxiiro> vorburger: I'm pretty slammed this week on tasks but I'll try to keep up with it
16:23:33 <rgoulding> #info it appears that ths is the right approach
16:23:37 <rgoulding> #info this code just predates that change
16:24:18 <zxiiro> vorburger: I'm wondering. Can javadoc be generated separately from the code build? wondering if it'd be more efficient to have a separate job that just builds javadocs
16:24:33 <zxiiro> vorburger: I'll ask on the bug..
16:24:51 <rgoulding> #info ClusteredDOMDataTreeChangeListener should eventually be killed eventually, but probably not as relevant to this individual use case
16:24:56 <rgoulding> #info it is mroe forward looking
16:26:52 <rgoulding> #info tree based change is by design
16:29:58 <rgoulding> #topic Discussion: Should each thing create its own ExecutorService or should we have a single central shared one? Like an EE servers's manged thread pools.
16:30:17 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/59177/
16:30:27 <rgoulding> #info prompted by thinking about how https://git.opendaylight.org/gerrit/#/c/59177/ users should obtain an ExecutorService
16:30:40 <rgoulding> #link https://bugs.opendaylight.org/show_bug.cgi?id=11
16:32:41 <rgoulding> #info one application may starve another if there is not application awareness in the threading model
16:32:44 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63439/
16:33:22 <rgoulding> #info the existing mechanisms are not meant to be global services,they are meant for morelocal use cases
16:33:38 <rgoulding> #info threadpools are allocated to handle a certain exchange point (i.e., DTCL)
16:33:44 <rgoulding> #info so they are grouped by workflow
16:34:04 <rgoulding> #info there is a competing bug that says we should be able to better isolate application workflows
16:34:38 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/63439
16:35:28 <rgoulding> #info in this patch, this ensures that no work stealing is achieved.  each workload is mapped to a key
16:35:56 <rgoulding> #info so you don’t have a Thread per DTCL
16:36:52 <rgoulding> #topic merged/pending patches
16:37:51 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/48710/
16:37:57 <rgoulding> #info not completely not impactful
16:38:08 <rgoulding> #info David is putting in additional changes to adjust for this ^^
16:38:19 <rgoulding> #info does this impact only trailing whitespace in src/main/resources
16:38:53 <rgoulding> #info activates checkstyle on src/main/resources, but only real impact is that non-java files are validated (line endings, no trailing tabs/spaces)
16:39:44 <rgoulding> #info is checkstyle checking the extension?
16:39:51 <rgoulding> #info vorburger thinks just by file extension
16:40:23 <rgoulding> #info when odlparent with this patch is adopted there may be some work to clean up src/main/resources
16:40:38 <rgoulding> #info should be trivial and there is info on how to make the change when we transition to the new odlparent version
16:41:05 <rgoulding> #info no one really barked about putting this in
16:41:11 <rgoulding> #info this will need to be release noted for sure though
16:41:15 <rgoulding> #info in 3.0.0
16:41:35 <rgoulding> #info this patch is listed in an email that vorburger sent out and agreed we should handle this with release note
16:42:37 <rgoulding> #info rovarga thinks this is okay;  need to follow up with Stephen who has -1
16:42:55 <rgoulding> #info I'll remove my -1, and merge it
16:42:56 <rgoulding> Yeah that too
16:42:57 <rgoulding> My audio is broken apparently
16:44:22 <rgoulding> #endmeeting