16:00:48 <rgoulding> #startmeeting kernel projects
16:00:48 <odl_meetbot> Meeting started Tue Oct 31 16:00:48 2017 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:48 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:00:59 <rgoulding> #topic agenda bashing
16:13:52 <rgoulding> #info odlparent 3.0 release timing
16:13:58 <rgoulding> #info merged/pending patchs
16:14:04 <rgoulding> #topic odlparent 3.0 release timing
16:14:33 <rgoulding> #topic yangtools 2.0.0 is getting there, and adjustment patches in controller/mdsal are getting done.  will still require changees as yangtools is still changing
16:14:39 <rgoulding> #undo
16:14:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1540c90>
16:14:45 <rgoulding> #info yangtools 2.0.0 is getting there, and adjustment patches in controller/mdsal are getting done.  will still require changees as yangtools is still changing
16:15:07 <rgoulding> #info and odlparent release will need to be planned for htis, and yangtools will likely start pulling in the snapshot version
16:15:36 <rgoulding> #info two big ticket items are karaf 4.1.2 and 4.1.3 (which gives us the ability to use version ranges)
16:16:18 <rgoulding> #info there will be netty api breakages
16:16:39 <rgoulding> #info release of karaf 4.1.3 should happen anytime now (upstream controlled)
16:17:19 <rgoulding> #info akka might also be a candidate but it is fine if we miss it
16:32:17 <rgoulding> #topic FindBugs discussion
16:32:31 <rgoulding> #info enabling static analysis tooling for null checking like FB or spotcheck
16:32:48 <rgoulding> #info the alternative is to eliminate use of null (using guava and things like Optional instead)
16:33:13 <rgoulding> #info we need to centralize on some static analysis tools at some point
16:34:19 <rgoulding> #info can still return null for Optional (BAD!) but it can happen.  This is something static analysis can pick up and warn us about
16:34:43 <rovarga_> #link https://git.opendaylight.org/gerrit/#/c/64816/5/yang/yang-model-api/src/main/java/org/opendaylight/yangtools/yang/model/api/DataNodeContainer.java
16:35:30 <rgoulding> #info in the above patch, new code should use the new method (findDataChildByName “find” similar to guava naming convention)
16:35:47 <rgoulding> #info that way you can get compatibility and also deprecation warnings around the old method (“getDataChildByName")
16:37:28 <rgoulding> #action take the Annotation discussion to the mailing list
16:37:47 <rgoulding> #info may need instruction material on how to enable this in other IDE(s) aside from Eclipse
16:39:14 <rgoulding> #info the issue is that findbugs isn’t really actively maintained and spotbugs we have more active upstream community
16:40:13 <rgoulding> #info should be the same code base with new fixes on top
16:49:10 <rgoulding> #topic Member fails to rejoin cluster after it is quarantined
16:49:11 <rgoulding> #link https://jira.opendaylight.org/browse/CONTROLLER-1783
16:56:03 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/62451/
16:56:44 <rgoulding> #action LuisGomez to add log of after the stop in Oxygen or Nitrogen
16:58:54 <rovarga_> #link fix for karaf restart: https://git.opendaylight.org/gerrit/64971
16:59:45 <rgoulding> #info wasn’t in Nitrogen so shouldn’t need to block SR1 for that
17:01:44 <rgoulding> #endmeeting