17:02:22 <rgoulding> #startmeeting kernel projects
17:02:22 <odl_meetbot> Meeting started Tue Dec 12 17:02:22 2017 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:22 <odl_meetbot> The meeting name has been set to 'kernel_projects'
17:02:28 <rgoulding> #topic agenda bashing
17:02:39 <rgoulding> #info Take a decision together re. latest odlparent 3.0.0 full switch over time box date (and some back-ports to a 2.0.6/2.0.7 as a fallback)
17:02:47 <rgoulding> #link https://wiki.opendaylight.org/view/ODL_Root_Parent:BigBumpOfJan2018
17:04:18 <rgoulding> #topic odlparent 3.0.0
17:04:45 <rgoulding> #info issues with AAA sorted through a few changes in odlparent
17:05:44 <rgoulding> #info GSON patch still needed?
17:05:55 <rgoulding> #info skitt says it would be good to have
17:05:57 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/66056/
17:11:32 <rgoulding> #info vorburger afraid it may be late in the cycle ot make the switch
17:13:46 <rgoulding> #info due to holidays we may end up slipping
17:13:54 <rgoulding> #info if many leaf projects in
17:13:56 <rgoulding> #undo
17:13:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2a39710>
17:14:15 <rgoulding> #info if many leaf projects do not adhere and do the upgrade, that would delay the simultaneous release
17:17:17 <rgoulding> #info odlparent upgrade gives us several things including ability to use version ranges, upstream dependencies upgrade (incl. guava), latest karaf shell (much better looking)
17:17:36 <rgoulding> #info since it is tied with yangtools 2.0.0, it gives us several bugfixes in the yangtools parser
17:20:17 <rgoulding> #info the question isn’t whether to do it, but rather when to do it
17:23:20 <rgoulding> #info vorburger is stressing that the timeline is the issue
17:23:28 <rgoulding> #info when do you think projects actually will do this?
17:34:35 <rgoulding> #action update wiki as we complete patches
17:41:09 <rgoulding> #topic “version” in integration
17:41:16 <rgoulding> #info “version” feature uses CSS
17:41:40 <rgoulding> #info need to migrate to blueprint
17:42:13 <rgoulding> #info Luis asks is CSS deprecated officially?
17:42:32 <rgoulding> #info CSS is deprecated
17:44:13 <rgoulding> #link https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-distribution-version/src/main/feature/feature.xml#L12
17:44:23 <rgoulding> #info we need to officially release messaging that CSS is done
17:44:29 <rgoulding> #info has TomP done this?
17:44:33 <rgoulding> #action rgoulding to ask tpantelis'
17:47:59 <rgoulding> #topic release management in Fluorine
17:48:12 <rgoulding> #info i.e., application projects releasing independently
17:48:26 <rgoulding> #info how to add artifacts to the distribution
17:49:06 <rgoulding> #info karaf-plugin in odlparent is used to look at all the features/dependencies and make sure it is stashed in system/ so that we can start offline
17:49:17 <rgoulding> #info when we build distribution we are using karaf-maven-plugin
17:49:33 <rgoulding> #info that creates zips, tar/gz and kar(s) for single features and feature repositories
17:49:44 <rgoulding> #info that is probably what we should use based on this newly proposed model
17:50:17 <rgoulding> #info have the application projects generate a kar, copy the file somewhere, then feature:install on that needed feature
17:52:10 <rgoulding> #info this should be do-able using the off the shelf karaf-maven-plugin
17:53:10 <rgoulding> #endmeeting