13:56:17 <klou> #startmeeting nitrogen release review
13:56:17 <odl_meetbot> Meeting started Tue Sep 12 13:56:17 2017 UTC.  The chair is klou. Information about MeetBot at http://ci.openstack.org/meetbot.html.
13:56:17 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:56:17 <odl_meetbot> The meeting name has been set to 'nitrogen_release_review'
13:57:05 <klou> Good Morning Folks!  We will start the review.
13:57:37 <klou> PTL for Topology Processing Framework and TSC members - please #info in
13:58:56 <klou> AnZa - Andrej: are you ready?
13:59:50 <AnZa> yep
14:00:13 <klou> #topic TOPOLOGY PROCESSING FRAMEWORK
14:00:31 <klou> #info AnZa represents TOPOLOGY PROCESSING FRAMEWORK
14:00:52 <klou> #link https://git.opendaylight.org/gerrit/#/c/62964/ - release notes
14:01:09 <klou> #info Release notes look good - thank you!
14:01:58 <klou> #info M5 milestone status reported in https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1316886236
14:02:23 <klou> Have you tested RC3?  Any blocker issues or concerns?
14:02:38 <AnZa> No blocker issues, no concerns
14:03:52 <klou> I see the CSIT failure is not an issue - is this something we can address in future releases?
14:04:24 <AnZa> We have some problem in tests which we can possibly fix.
14:05:08 <klou> Please make an effort to address these test problems in oxygen
14:05:19 <AnZa> we will make our best
14:05:29 <klou> Do you have anything else to add?
14:05:36 <AnZa> nothing thanks
14:05:43 <klou> everything looks good
14:06:01 <klou> #info TOPOLOGY PROCESSING FRAMEWORK approved for nitrogen release.  Congrats!
14:06:56 <klou> Let's move on to SXP
14:07:05 <michal_rehak> klou: good morning
14:07:21 <klou> Good Morning Michal!
14:07:27 <klou> #topic SXP
14:07:44 <klou> #info michal_rehak represents SXP
14:08:02 <klou> #link https://git.opendaylight.org/gerrit/#/c/62914/ - release notes
14:08:23 <klou> release notes look good - thank you!
14:08:40 <klou> Have you tested RC3?  Any blocker issues or concerns?
14:08:59 <michal_rehak> RC3 was tested and works as intended - no blockers nor issues
14:09:35 <klou> #info M5 milestone status provided - CLM violations explained
14:10:33 <klou> There are CSIT failures but they have all been explained as OKAY or IGNORE
14:10:48 <michal_rehak> right - we hit some csit infrastructure issues
14:10:56 <klou> Will the CSIT related problems be addressed in oxygen?
14:10:57 <michal_rehak> most failures are intermittent
14:11:07 <michal_rehak> most of them
14:11:22 <michal_rehak> some failures are present in csit only
14:11:36 <michal_rehak> thanks to sxp nodes topology setup  in one karaf instance
14:12:27 <klou> please make an effort to address the CSIT related problems (where possible) in oxygen
14:12:34 <klou> everything looks good
14:12:41 <michal_rehak> some of them are already merged
14:12:56 <klou> good
14:13:10 <klou> #info SXP approved for nitrogen release.  Congrats!
14:13:18 <michal_rehak> klou: thank you
14:14:09 <klou> Thank you michal_rehak!  Let's move on to bier
14:14:51 <klou> Xiong - are you ready?
14:17:57 <klou> do we have any other project ready?  we can come back to bier
14:18:24 <Xiong__> Hi Klou.
14:18:42 <Xiong__> I was offline .
14:18:49 <klou> ok no problem
14:18:57 <klou> #topic BIER
14:19:09 <klou> #info Xiong represents BIER
14:19:12 <Xiong__> Sorry. I am ready now
14:19:33 <klou> #info https://git.opendaylight.org/gerrit/#/c/63013/ - release notes
14:20:06 <klou> #info M5 milestone status provided - no CLM violations
14:20:23 <klou> Have you tested RC3?  Any blockers or concerns?
14:20:38 <Xiong__> Yes,no blockers nor issues.
14:21:15 <klou> I see that there is one CSIT problem that you have been trying to resolve  - what is the latest update?
14:21:50 <Xiong__> I have updated the robot and submitted a patch to be reviewed and some complie problem to be resolved. I will continue to track  and fix the failure with Jamo.
14:22:48 <klou> Will you be able to fix the CSIT problem before nitrogen release?
14:23:34 <Xiong__> https://git.opendaylight.org/gerrit/#/c/61029/
14:24:15 <Xiong__> Yes, We will try our best to fix it as soon as possible.
14:24:58 <klou> ok, we will conditionally approve bier for release pending CSIT resolution
14:25:13 <Xiong__> Thank you!
14:25:29 <klou> #info BIER approved for nitrogen release pending CSIT resolution. Thank you!
14:26:27 <klou> next project is controller
14:28:13 <klou> #topic CONTROLLER
14:28:24 <klou> #tpantelis represents CONTROLLER
14:28:45 <klou> #link https://git.opendaylight.org/gerrit/#/c/59986/ - release notes
14:29:17 <klou> Tom - are you ready?
14:29:26 <tpantelis> sure
14:29:55 <klou> Have you tested RC3?  Any blockers/concerns?
14:30:43 <tpantelis> I haven't really tested it but your colleague Luis runs the CSIT tests along with Vratko
14:31:13 <tpantelis> Luis had an issue but I think I've convinced him it's a CI issue
14:31:59 <klou> Thanks for being frank!  Yes I am aware of the work Vrakto and Luis have been doing.
14:32:11 <tpantelis> So it Luis and Vratko don't have any blocker issues of which I'm not aware of then we're good to go
14:32:48 <klou> I do not see an M5 milestone readout from controller - have you looked at the sonar report of CLM violations?
14:33:16 <tpantelis> I didn't send M5? thought  I did but I coild be wrong
14:33:26 <tpantelis> what is CLM violation?
14:33:54 <klou> Please look at this link: https://sonar.opendaylight.org/component_issues/index?id=org.opendaylight.controller%3Areleasepom#resolved=false|severities=BLOCKER%2CCRITICAL
14:35:08 <klou> BTW, I believe the release team did not send out a reminder on M5 for offset 0 projects so it is not entirely project teams' fault
14:35:12 <tpantelis> So what is CLM?
14:35:28 <tpantelis> what's the expectation here?
14:37:07 <tpantelis> these have to be addressed?  None are important. 3 of them are in non-production code
14:37:09 <klou> Good questions!  CLM is short for component ...?  I believe the gist is to have control over security vulnerability problems
14:37:50 <tpantelis> security? How are those 4 "violations" related to security?
14:38:38 <tpantelis> Using a logger intead of "System.out.println"? how is that a security risk...
14:38:59 <klou> some could be false positives
14:39:42 <klou> main point is we want you to confirm that you have no concerns about them
14:39:44 <tpantelis> Again as I said 3 of them are in non-production code. I can push a patch to fix them if you want
14:39:55 <tpantelis> I have no concerns
14:40:07 <klou> not necessary - I trust your judgment Tom!
14:40:38 <klou> I believe we are ready to approve controller given our discussion
14:40:43 <tpantelis> ok
14:40:57 <klou> #info CONTROLLER approved for nitrogen release!  Congrats!
14:41:03 <klou> thank you Tom!
14:41:29 <klou> Let's move on to daexim
14:41:42 <ssaxena> Kit, I'm here.
14:41:54 <ssaxena> I sent a mail with relevant information.
14:42:00 <klou> GM Shaleen!
14:42:06 <klou> #topic DAEXIM
14:42:06 <ssaxena> Morning!
14:42:20 <klou> #info ssaxena represents DAEXIM
14:42:41 <klou> #link https://git.opendaylight.org/gerrit/#/c/63008/ - release notes
14:43:12 <klou> #info M5 milestone readout provided and documented in nitrogen tracking spreadsheet
14:43:23 <klou> Have you tested RC3?  Any issues/concerns?
14:43:33 <ssaxena> We have tested RC3. No concerns.
14:43:55 <ssaxena> I'm just waiting for documentation (user & developer guides) to be merged.
14:43:56 <ssaxena> https://git.opendaylight.org/gerrit/#/c/62941/
14:44:36 <klou> #info DAEXIM is a new project - everything looks good
14:44:43 <ssaxena> Thanks.
14:45:00 <klou> #info No CSIT failures
14:45:10 <klou> Anything you want to add Shaleen?
14:45:19 <ssaxena> Nothing from my side.
14:45:30 <klou> #info DAEXIM approved for nitrogen release.  Congrats!
14:45:37 <ssaxena> Great. Thanks.
14:45:42 <klou> Thank you ssaxena!
14:46:24 <klou> next project is eman
14:47:02 <klou> Frank - are you ready?
14:47:10 <Frank_> Frank here. I've just sent an update to eman release notes to gerrit
14:47:22 <klou> #topic EMAN
14:47:46 <klou> #info Frank Sandoval represents EMAN
14:48:04 <Frank_> yes
14:48:05 <klou> #link https://git.opendaylight.org/gerrit/#/c/63036/ - release notes
14:48:20 <klou> Thank you for updating the release notes!
14:48:54 <Frank_> sure. the only thing changed in eman for Nitrogen is update to karaf4
14:49:04 <klou> #info M5 milestone readout provided and documented in nitrogen tracking spreadsheet
14:49:15 <klou> Have you tested RC3?  Any blockers/concersn?
14:51:13 <klou> Frank_: are you still there?
14:52:14 <klou> Thank you for updating the SNMP release notes also!  I understand it is a project in maintenance mode with very light touch.
14:52:43 <Franks> hello again
14:53:29 <klou> Hello Frank - please respond to the RC3 question and whether you have blockers/concerns
14:54:02 <Franks> sorry, hit the wrong key sequence. Have tested RC23 locally, no known issues
14:54:15 <Franks> RC3 that is
14:54:29 <klou> #info EMAN has no CSIT problems
14:54:51 <klou> EMAN looks good - let's do SNMP quickly
14:55:11 <klou> #info EMAN approved for nitrogen release.  Congrats!
14:55:21 <klou> #topic SNMP
14:55:25 <Franks> thank you!
14:55:37 <Franks> I was also asked to update snmp
14:55:57 <klou> #info Frank Sandoval represents SNMP
14:56:13 <klou> #info SNMP is in maintenance mode with very light touch
14:56:26 <klou> #link https://git.opendaylight.org/gerrit/#/c/63038/ - release notes
14:56:27 <Franks> I've sent a change to gerrit to update release notes for snmp as well https://git.opendaylight.org/gerrit/#/c/63038/
14:56:45 <klou> Thank you Frank!  I provided the link also
14:56:56 <klou> Do you have any concerns regarding SNMP?
14:57:23 <Franks> I do not. It continues to work and I know of no issues
14:58:18 <klou> Given SNMP is not active, we will approve it for release - thank you Frank!
14:58:32 <Franks> Great. Thanks a bunch!
14:58:48 <klou> #info SNMP approved for nitrogen release.  Thank you!
14:59:06 <Franks> thanks, good bye
14:59:37 <klou> next project is faas
15:00:47 <xingjun> hello
15:00:57 <klou> #topic FAAS
15:01:13 <klou> #info xingjun represents FAAS
15:01:57 <klou> xingjun - I see you have a link for the release notes but it is not a gerrit patch.  Could you please submit a gerrit patch?
15:02:10 <xingjun> sorry, will do.
15:02:54 <klou> Have you tested RC3?  Any blockers/concerns?
15:03:08 <xingjun> I downloaded rc3 and tested it
15:03:11 <xingjun> no issues found
15:04:19 <klou> I do not see a M5 milestone readout for faas - have you looked at the sonar report for faas?
15:04:48 <klou> Here is a link: https://sonar.opendaylight.org/component_issues/index?id=org.opendaylight.faas%3Afaas.project#resolved=false|severities=BLOCKER%2CCRITICAL
15:04:50 <xingjun> I sent the M5 status this morning to the release and faas mailing list
15:05:13 <xingjun> no
15:05:25 <klou> Sorry - did not get a chance to read it
15:05:37 <xingjun> I did't check the the sonar report
15:05:58 <klou> Do you have concerns on the 3 issues in the report link I sent?
15:06:06 <klou> Any action we should take?
15:06:52 <xingjun> I can create bug fixes for next release, don't think it has big impact
15:07:51 <xingjun> just looked
15:07:56 <klou> ok
15:08:22 <klou> #info FAAS has no CSIT problems
15:09:13 <klou> #action xingjun to submit release notes as gerrit patch
15:09:38 <xingjun> doing it now :)
15:09:54 <klou> #action xingjun to review sonar blocker/critical issues for validity and take actions (as needed) for next release
15:10:11 <xingjun> ok
15:10:32 <klou> #info FAAS approved for nitrogen release pending release notes submission as gerrit patch.  Thank you!
15:10:43 <xingjun> thanks!
15:11:15 <klou> Thank you xingjun!
15:11:26 <xingjun> no problem cheers
15:11:28 <klou> next project is genius
15:11:33 <vievks> hello, i am here
15:11:40 <klou> #topic GENIUS
15:11:49 <klou> #vievks represents GENIUS
15:12:06 <klou> #info vievks represents GENIUS
15:12:22 <klou> #link https://git.opendaylight.org/gerrit/#/c/62951 -release notes
15:13:04 <klou> #info M5 milestone readout provided and documented in nitrogen tracking spreadsheet - CLM violations explained - thank you!
15:13:16 <klou> Have you tested RC3? Any blockers/concerns?
15:13:36 <vievks> yes tested RC3, no issues seen
15:13:51 <klou> #info GENIUS has no CSIT problems
15:14:04 <klou> everything looks good - anything else you want to bring up or add?
15:14:58 <vievks> there are few patches under review, as indicated in M5 they will be merged before SR1
15:15:18 <vievks> no other issues!
15:15:36 <klou> #info GENIUS approved for nitrogen release.  Congrats and Thank you!
15:15:48 <vievks> thank you!
15:17:11 <klou> Do we have any other project wanting to go through the review now?
15:17:51 <klou> I will end the meeting for this segment in 5 minutes otherwise
15:24:18 <klou> #endmeeting