17:59:41 <klou> #startmeeting nitrogen release review
17:59:41 <odl_meetbot> Meeting started Tue Sep 12 17:59:41 2017 UTC.  The chair is klou. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:59:41 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:41 <odl_meetbot> The meeting name has been set to 'nitrogen_release_review'
18:00:04 <klou> #info We are starting the 2nd segment of our nitrogen release review
18:00:28 <klou> #info First project is LISPFLOWMAPPING
18:00:37 <klou> #topic LISPFLOWMAPPING
18:00:53 <klou> #info vina_ermagan represents LISPFLOWMAPPING
18:01:12 <klou> #link https://git.opendaylight.org/gerrit/#/c/63058/ - release notes
18:01:15 <vina_ermagan> #info Vina Ermagan representing LISP Flow Mapping in release review
18:01:40 <klou> #info M5 milestone readout provided and documented in nitrogen tracking spreadsheet
18:02:07 <klou> Vina, Have you tested RC3?  Any blockers/issues?
18:03:09 <vina_ermagan> Yes, RC3 has been tested, no issues that we know of so far
18:04:02 <klou> I see that there is one CSIT failure for lispflowmapping in the spreadsheet "Pending"
18:04:32 <klou> Can you review this CSIT failure and assess whether it is something of concern?
18:04:54 <klou> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1968173395
18:05:54 <vina_ermagan> Thanks klou, yes, this failure is ok. I'll mark the spreadsheet to ok.
18:07:02 <klou> That's good to know - is this CSIT failure something your team can address for future releases?
18:08:23 <vina_ermagan> The 3 node clustering tests are not fully operational yet, so failures are expected. We have it in our roadmap to fix
18:08:57 <klou> Thank you!  Everything looks good!
18:09:18 <klou> #info LISPFLOWMAPPING approved for nitrogen release! Congrats and Thank you!
18:09:49 <vina_ermagan> Thanks klou!
18:10:33 <klou> Next project is unimgr - do we have unimgr representative here?
18:12:15 <klou> It does not look like we have anyone representing unimgr -let's go to groupbasedpolicy
18:12:44 <klou> Do we have Michael Cmarada here?
18:12:54 <michal-cmarada> Hi, Michal Cmarada for groupbasedpolicy
18:13:08 <klou> #topic GROUPBASEDPOLICY
18:13:29 <klou> #info Michael Cmarada representing GROUPBASEDPOLICY
18:13:51 <klou> #link https://git.opendaylight.org/gerrit/#/c/63045/ - release notes
18:14:25 <klou> #M5 milestone readout provided and documented in nitrogen tracking spreadsheet
18:14:32 <klou> #undo
18:14:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x14a6350>
18:14:51 <klou> #info M5 milestone readout provided and documented in nitrogen tracking spreadsheet
18:15:04 <klou> Michael, Have you tested RC3?  Any blockers/concerns?
18:15:32 <michal-cmarada> Yes, there were no issues found
18:16:28 <klou> I see that there are 3 CSIT failures that you have marked as something we can ignore - thank you!  Is this something you can address going forward for future releases?
18:16:41 <michal-cmarada> yes, sure
18:17:14 <klou> I will give you an action to look at resolving the CSIT failures for future releases
18:17:42 <klou> #action michal_cmarada to look at addressing GROUPBASEDPOLICY CSIT failure for future releases
18:17:46 <michal-cmarada> ok
18:17:54 <klou> Do you have anything to add?
18:18:03 <michal-cmarada> no nothing more
18:18:14 <klou> #info GROUPBASEDPOLICY approved for nitrogen release!  Congrats and thank you!
18:18:33 <michal-cmarada> thanks
18:18:41 <klou> Let's move to honeycomb/vbd which is also under your purview
18:18:48 <michal-cmarada> ok, great
18:18:51 <klou> #topic HONEYCOMB/VBD
18:19:08 <klou> #info Michal CMarada represents HONEYCOMB/VBD
18:19:25 <klou> #link https://git.opendaylight.org/gerrit/#/c/63049/ - release notes
18:19:50 <klou> #info M5 milestone readout provided and documented in nitrogen tracking spreadsheet
18:20:15 <klou> Michal, Have you tested RC3 for HONEYCOMB/VBD?  Any blockers/concerns?
18:20:30 <michal-cmarada> yes, it was tested. no issues found
18:20:50 <klou> #info There are no CSIT failures for HONEYCOMB/VBD
18:20:58 <klou> Do you have anything you want to add?
18:21:13 <michal-cmarada> nothing
18:21:24 <klou> #info HONEYCOMB/VBD approved for nitrogen release!  Congrats and thank you!
18:21:37 <michal-cmarada> thank you. bye
18:23:17 <klou> Do we have representatives for unimgr, ttp, or coe projects here?
18:24:45 <klou> Do we have any other project representative here ready for review?
18:28:57 <klou> coe's review is scheduled for 12:20 PM PST - this meeting will continue until then
18:29:40 <klou> Feel free to let me know if anyone wants to go through the review between now and then - I will be here
19:16:35 <klou> Hello premsankar - are you representing coe for the nitrogen release review?
19:16:48 <premsankar> Hi Klou Yes
19:17:04 <klou> #topic COE
19:17:16 <premsankar> Just to give a quick background
19:17:29 <klou> Please go ahead
19:17:34 <premsankar> We had 2 activities - Kuryr Integration and Baremetal development
19:18:02 <klou> #info premsankar represents COE
19:18:05 <premsankar> Kuryr integration involves mostly integration and bug fixing in ODL modules and it is done
19:18:29 <premsankar> Baremetal is about development of components for Kubernetes integration
19:19:06 <premsankar> We had few HPE engineers leave the project in midway and hence, have not completed our planned activities
19:19:46 <klou> Are the document requirements not met?
19:19:47 <premsankar> We had plans to tag ourselves as experimental for this release and intend to complete the pending in Oxygen
19:20:15 <premsankar> We technically don't have any documentation to be done unless we complete the baremetal implementation
19:20:49 <klou> Thanks for the background info!
19:21:06 <premsankar> I had written to An Ho about tagging ourselves experimental
19:21:36 <klou> Do you have intentions to do release notes (it may be a good idea even for experimental)?
19:21:51 <premsankar> You read my mind :)
19:22:04 <premsankar> I will probably release notes
19:22:48 <premsankar> Anything else we want to address ?
19:23:19 <klou> Other than what you have described, do you have any other issues/blockers/concerns that may prevent your release as experimental?
19:23:30 <premsankar> None
19:24:45 <klou> I am not positive on what the requirements are for experimental release - please go ahead and do the release notes and I will indicate that coe is approved for experimental release pending release notes
19:24:58 <premsankar> Sure. Thanks!
19:25:09 <klou> Please note that things could change
19:25:15 <premsankar> ok
19:25:33 <klou> #action premsankar do create release notes for COE
19:26:03 <klou> #info COE approved for experimental release pending release notes!  Thank you!
19:26:08 <premsankar> Thanks!
19:26:55 <klou> premsankar - please update the spreadsheet with your gerrit patch for release notes when ready.  Thank you!
19:27:12 <premsankar> Sure!
19:28:16 <klou> Do we have any other projects ready for nitrogen release review?
19:29:52 <klou> Thank you all for participating in this segment (Day 2 Session 2) of nitrogen release review!
19:29:58 <klou> #endmeeting