15:00:56 <colindixon> #startmeeting nitrogen release sync
15:00:56 <odl_meetbot> Meeting started Wed Jun  7 15:00:56 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:56 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:56 <odl_meetbot> The meeting name has been set to 'nitrogen_release_sync'
15:01:02 <colindixon> #topic agenda bashing
15:02:06 <anipbu> what's the zoom link?
15:02:19 <zxiiro> anipbu: https://zoom.us/j/557300337
15:02:44 <colindixon> anipbu: I think it should be in the ODL google calendar and have gone to discuss and release lists, is there another place I should send it
15:03:05 <colindixon> #info karaf 4 status
15:03:25 <colindixon> #info remove projects from autorelease, releng/builder, and integration/distribution
15:03:42 <colindixon> #info Boron-SR4
15:03:46 <colindixon> #info other general topics
15:03:50 <colindixon> #topic Boron-SR4
15:04:30 <colindixon> #info we believe that it's good to go, we've notified all the projects and reaching out to projects with test failres to see if they want voluntarily mark their test isssues as "ignore"
15:05:26 <colindixon> #info the only major issue we have is with CLM, do we want to do it for SRs
15:06:10 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#SR4_Prebuild
15:06:10 <anipbu> https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=119564471
15:06:12 <colindixon> #info colindixon says for right now, lets ignore it, staring with Carbon, it probably makes sense to start tracking CLM "failures" the same way we track CSIT failures to make that faster
15:06:36 <colindixon> #info anipbu says he expects Boron-SR4 on time on schedule
15:07:01 <colindixon> #action colindixon to make sure that the release notes speak to the CVEs fix in SR3 and workarounds for others
15:07:49 <colindixon> #action colindixon to open a bug against Boron-SR4 for security content of the release
15:08:36 <colindixon> #topic karaf 4 status
15:09:36 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf
15:09:38 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
15:10:13 <colindixon> #info we're missing skitt and rovarga today, but I think the status seems something like "nearly all projecs have karaf 4 feautures, but we're still sorting out dependency issues"
15:10:21 <anipbu> https://lists.opendaylight.org/pipermail/release/2017-June/011159.html
15:10:36 <colindixon> #info skitt is working on seeing if moving to the Karaf 3 resolver in Karaf 4 just fixes all of our issues
15:15:27 <colindixon> #info during the DDF, skitt also presented other possible ways with dependency=true and/or using other techniques like if we can get access to --no-refresh-bundles with feature:install by default
15:15:35 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf
15:15:40 <colindixon> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
15:15:46 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-June/011159.html
15:16:04 <colindixon> #topic removing projects from autorelease, releng/builder, integregration/distribution
15:16:24 <colindixon> #info zxiiro says that all the offset 0 projects are in autorelease, but nothing else is
15:16:46 <colindixon> #info plan is to remove odlparent as soon as we downgrade all projects to depend on the carbon version of odlparent
15:17:21 <colindixon> #info currently we're blocked on the fact that infrautils depends on an oldparent module that was added in nitrogen, so if we remove odlparent from autorelease, it will fail
15:18:05 <colindixon> #info we've removed the autorealease-validate-nitrogen job in releng/builder from everyone but offset 0 projects
15:18:40 <colindixon> #info currently integration/distribution is not in autorelease, so it's not on the critical path to have projects removed from it
15:19:05 <colindixon> #info in the short-to-medium-term, we shoudl remove all but offset 0 projects from integration/distribution and add it back to autorelease
15:19:18 <colindixon> #action zxiiro to open a bug about infrauitls and it's dependency on nitrogent odlparent
15:19:49 <colindixon> #action colindixon to open a bug to remove all non-offset0 projects from int/dist and add it back to autorelease
15:20:56 <colindixon> #topic karaf 4 dependency resolution
15:21:07 <colindixon> #info skitt says he's waiting for some info from karaf 4 upstream
15:22:02 <colindixon> #info skitt still needs to test using karaf 3 resolver in karaf 4
15:22:30 <colindixon> http://karaf.922171.n3.nabble.com/Basic-questions-about-bundles-and-features-td4050547.html
15:22:58 <colindixon> http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
15:23:54 <skitt> http://karaf.922171.n3.nabble.com/complete-documentation-for-features-xml-tc4048897.html
15:31:51 <colindixon> #info it seems like there are a few possible ways forward: (1) use the karaf 3 resolver in karaf 4, (2) fix all bundles/features to be reloadable, (3) we could move to using dependency=true, which won't reload them, but it doesn't load them for you, it's possible that adding prerequisite=true as well would fix it, but that seems to expose bugs in Karaf, (4) figure out if we can effectively enable --no-auto-refresh
15:31:51 <colindixon> globally when all features are installed
15:32:16 <colindixon> #info the plan of record is to target (1) as a stop-gap and then either (3) or (4)
15:34:25 <colindixon> #info skitt says the hope is that once we get (1) working, we can then add projects back and then we can accomplish either (3) or (4) with only changes in odlparent, so we won't have to kick all projects out again
15:35:18 <colindixon> #info skitt asks if int/dist is planning to move away from boot features, rovarga says they're considering it, but haven't done it yet
15:36:17 <anipbu> colindixon: here's the bugs tot rack.  and i have updated the spreadsheet: https://bugs.opendaylight.org/show_bug.cgi?id=8622
15:36:57 <colindixon> #info colindixon asks why, rovarga says that it avoids hitting two feature installation code paths in Karaf since boot features and feature:install hit different things, the downside is that project-local distributions (and SFT) will have to be modified to do a feature:install instead
15:37:05 <colindixon> #info this would also have to change CSTI
15:37:23 <colindixon> #info it also is not how most downstreams work, but it is how the upstream OpenDaylight distribution works
15:37:49 <colindixon> thanks anipbu
15:38:21 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8622 the new bug to track karaf 4 depenency resolution issues
15:39:48 <colindixon> #info rovarga suggests that we treat infrautils as an offset 1 project for now and drop it from autorelease until we find a way forward
15:39:57 <colindixon> #action zxiiro to remove infrautils from autorelease
15:42:05 <colindixon> #endmeeting