15:05:42 <colindixon> #startmeeting nitrogen release sync
15:05:42 <odl_meetbot> Meeting started Wed Jun 14 15:05:42 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:05:42 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:42 <odl_meetbot> The meeting name has been set to 'nitrogen_release_sync'
15:05:45 <colindixon> #topic where we are
15:06:10 <colindixon> #info we are halfway through migrating to odlparent 1.9.0 release
15:06:21 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0 all patches
15:06:33 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0+status:open open patches
15:06:53 <colindixon> #info zxiiro is merging them in a particluar order
15:07:59 <vorburger> #info https://git.opendaylight.org/gerrit/#/c/58831/ failed, zxiiro is looking into it
15:08:09 <colindixon> #Undo
15:08:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1db4790>
15:08:20 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/58831/ failed to bump, zxiiro is looking into it
15:13:01 <colindixon> #info it seems like the patch is failing becuase (a) autorelease nitgrogen is just broken, (b) distribution3 check because it doesn't have karaf 3 anymore, (c) the nitrogen distribution check is failing becuase int/dist is still looking for 1.9.0-SNAPSHOT
15:13:10 <colindixon> #action zxiiro will e-mail the list to make sure nobdy is surprised before we merge it
15:15:29 <colindixon> #Info colindixon notes that it looks like the release script worked to produce 1.9.0 and things are good, for 1.9.0 we shouldn't need a stability branch, since we'll hit 2.0.0 next week
15:16:45 <colindixon> #info however the plan going forward is to have stability branches after the fact to avoid the overhead unless we need it
15:18:08 <colindixon> #Info vorburger notes that it probably makes sense to bump to 2.0.0 as late as possible but before Karaf 3 is removed
15:19:20 <colindixon> #Info early next week, we'll start moving projects into autorelease after validattion of Karaf 4 readiness
15:20:43 <vorburger> #link https://bugs.opendaylight.org/show_bug.cgi?id=8686 is what's currently blocking netvirt and genius
15:22:52 <vorburger> #link https://bugs.opendaylight.org/show_bug.cgi?id=8694 is what's currently blocking netvirt and genius (the 8686 is "just" shutdown)
15:24:33 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
15:29:55 <colindixon> #topic reviewing karaf 4 tracking sheet
15:30:01 <colindixon> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
15:30:10 <colindixon> #Info listen to recording for some blow-by-blow review
15:30:29 <colindixon> #info there is a discussion about when and if we want to remove the non-offset-0 projects from int/dist
15:30:49 <colindixon> #info the current plan was to combine that with removing karaf 3 from int/dist
15:31:12 <colindixon> #info the new plan is to break that into two patches, first drop all non-offset-0 projects, then drop karaf 3
15:31:30 <colindixon> #action LuisGomez to break apart the patch for int/dist into two parts: first drop all non-offset-0 projects, then drop karaf 3
15:35:14 <colindixon> #topic projects that aren't leaves and may be unresponsive
15:35:24 <colindixon> #Info this list is: dlux, snmp, tsdr, l2switch
15:37:25 <colindixon> #info colindixon says he should be able to get l2switch to work
15:38:36 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/351/dependencies.log.gz dependencies log
15:41:01 <colindixon> #info vorburger notes that we should drop dependencies on dead projects
15:41:13 <colindixon> #info colindixon and anipbu agree, but point out it's not that easy
15:43:35 <colindixon> #action zxiiro will ping all projects (including these 4 that might be non-responsive)
15:53:17 <colindixon> #action zxiiro and/or vorburger to add infrautils back to autorelease assuming that it works with 1.9.0 odlparent
15:53:48 <colindixon> #endmeeting