15:02:52 <colindixon> #startmeeting nitrogen release sync
15:02:52 <odl_meetbot> Meeting started Mon Jun 19 15:02:52 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:52 <odl_meetbot> The meeting name has been set to 'nitrogen_release_sync'
15:02:56 <colindixon> #topic where we are
15:03:38 <colindixon> #info zxiiro says that migration to 1.9.0 of ODL parent is mostly done, it's only 5 leaf projects that are causing problems
15:04:09 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0 patches
15:04:28 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0+status:open 4 projects unmerged: bier, sdni, snmp4sdn, nic
15:05:14 <colindixon> #info colindixon and zxiiro ask skitt about odlparent 2.0.0, skitt says probably tomorrow
15:05:38 <colindixon> #action skitt will send zxiiro an e-mail when we're ready to start the release
15:06:27 <colindixon> #Info skitt basically says we're just doing the guava bump for now
15:06:55 <skitt> #link Guava bump: https://git.opendaylight.org/gerrit/49820
15:07:02 <colindixon> #info the guava bump should mostly affect offset 0 projects, and they should mostly be ready for it
15:07:54 <colindixon> #link http://karaf.922171.n3.nabble.com/template/NamlServlet.jtp?macro=user_nodes&user=497737 skitt's interactions with karaf uspstream
15:08:23 <colindixon> #undo
15:08:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1de6410>
15:08:38 <colindixon> #topic karaf 4 upstream issues
15:08:53 <anipbu> 8622
15:09:04 <anipbu> https://bugs.opendaylight.org/show_bug.cgi?id=8622
15:09:09 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8622 we're still working on this bug (which may not be correctly named)
15:09:15 <colindixon> #link http://karaf.922171.n3.nabble.com/template/NamlServlet.jtp?macro=user_nodes&user=497737 skitt's interactions with karaf uspstream
15:09:47 <colindixon> #info skitt's current understanding is that it works, we just need to figure out how to avoid refreshes, which we should be able to do, there are a few outstanding patches for netconf that fix some things there
15:09:55 <colindixon> #Info we might need some fixes for aaa for things around beans
15:10:46 <colindixon> #info skitt's impression is that things are getting better in karaf 4 local distribtions, vorburger says that genius folks seem to be having success, netvirt is struggling quite a bit more
15:12:33 <colindixon> #info colindixon asks if there are patterns to what breaks in karaf 4 that we can look for
15:13:00 <colindixon> #info skitt says that there are some things which are bugs that happened to work in karaf 3, but don't work anymore
15:13:47 <vorburger> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2017-June/004788.html <== this is, AFAIK, the latest on where netvirt is at (Karaf 4 is NOK; many CSIT still failing for them)
15:14:57 <colindixon> #info other times are when karaf 4 tracks package dependcies much more closely and refreshses things when they change those, in netconf, this seems to have happened when there are package exports that aren't really needed espcially when there are cycles
15:15:32 <colindixon> #Info also optional dependencies now trigger refreshes if they become available
15:20:12 <colindixon> #topic plan going forward
15:22:51 <colindixon> #Info the plan is to basically merge odlparent-2.0.0 patch and then get people to try to test things
15:22:58 <anipbu> https://lists.opendaylight.org/pipermail/netvirt-dev/2017-June/004775.html
15:23:10 <colindixon> #info vorburger asks is the plan to go forward despite netvirt's issues
15:24:42 <colindixon> #info basically that's when yangtools merges patches, then everything is broken
15:25:46 <colindixon> #Info vorburger advocates for fixing openflowplugin first
15:26:03 <colindixon> #Info vorburger points out that people are responding and things are making progress
15:30:50 <colindixon> #info the cost of bumping yantools will be basically the loss in fixing openflow plugin until all it's dependencies have also migrated
15:31:38 <colindixon> #info that's likely to be a few days, but the question is do we want to eat those days _this_ week or next week
15:36:33 <colindixon> was that a wait?
15:36:34 <colindixon> sorry
15:37:06 <colindixon> #info the consesus seems to be that if we're on a good debugging roll with openflow plugin, giving them an extra 24-48 hours to keep chugging makes sense
15:37:28 <colindixon> #info some combination of anipbu, skitt and vorburger will try to reach out to netvirt/ofp and see if that helps
15:37:30 <colindixon> #endmeeting