15:06:05 <colindixon> #startmeeting nitrogen release sync
15:06:05 <odl_meetbot> Meeting started Fri Jul 28 15:06:05 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:06:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:06:05 <odl_meetbot> The meeting name has been set to 'nitrogen_release_sync'
15:06:13 <colindixon> #topic state of the world
15:06:22 <colindixon> #chair CaseyODL zxiiro anipbu
15:06:22 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon zxiiro
15:06:42 <anipbu> #topic karaf
15:06:55 <anipbu> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956   <--- Karaf 4 status spreadsheet
15:06:56 <colindixon> #info in general, we're in less great shape than we'd like
15:07:52 <colindixon> #info only 21 projects are in integration/distribution right now, which is less than half than those that were in carbon
15:09:18 <colindixon> #info 5 projects have made no progress on karaf 4: eman, nemo, ofconfig, tsdr, usc
15:09:38 <colindixon> #info anipbu notes that he's responsible for nemo and usc, so he'll work on it this week
15:11:08 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/autorelease-release-nitrogen/122/dependencies.log.gz Nitrogen dependencies.log
15:11:13 <colindixon> #info colindixon asks if the remaining projects are leaf projects, anipbu says he thinks yes, so we can and will drop them at RC0 barring something significant happening
15:11:26 <zxiiro> #link https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/400/dependencies.log.gz Carbon dependencies.log
15:13:28 <colindixon> #info based on the carbon dependencies log, both iotdm and cardinal depend on tsdr, iotdm isn't in nitrogen, and the tsdr dependency from cardinal isn't real based on skitt looking at it
15:13:33 <anipbu> #action anipbu to reach out to cardinal and ask them to remove dep on tsdr
15:14:02 <colindixon> #info thus it seems like these are all leaf projects and do not pose a release risk to nitrogen
15:15:57 <colindixon> #link anipbu notes that NETCONF has a bug that is blocking it from moving to karaf 4 fully and/or any of it's dependencies https://bugs.opendaylight.org/show_bug.cgi?id=7891
15:17:12 <colindixon> #link the NETCONF project is aware of this and working on it, but understaffed https://lists.opendaylight.org/pipermail/release/2017-July/011758.html
15:17:59 <colindixon> #info it should be noted that NETCONF is understaffed at the moment, this remains a significant risk to the nitrogen release
15:18:13 <colindixon> #topic projects that aren't in distribution
15:18:36 <colindixon> #info anipbu wants to talk about the projects that were not leaves in carbon, but have yet to make it back to the distribution
15:18:55 <colindixon> #info anipbu notes that SNMP hasn't gotten there yet
15:20:03 <colindixon> #info skitt says he'll look on Monday if Frank doesn't get to it by then, also he notes that TomP and Ryan Goulding should also be committers as soon as Frank votes publicly (he's given private notes)
15:20:24 <colindixon> #info sfc is blocked on netconf (see the above bug)
15:20:39 <colindixon> #info l2swithc isn't in there yet, but should be easy to get in
15:20:51 <colindixon> #action colindixon and/or klou will reach out to sai and get him to add it to distribution
15:22:28 <colindixon> #topic leaf projects not in the distribution
15:22:31 <colindixon> #info fast review of each
15:22:58 <colindixon> #info alto isn't done, would be fine to drop
15:23:24 <colindixon> #info bier is at 67% and would be fine to drop
15:24:09 <colindixon> #info cardinal has a patch to be added to the distribution, but running into problems, need help, zxiiro has been trying to help needs help from integration
15:24:48 <colindixon> #info dlux is done, but just needs to send their intent to participate, colindixon says they're done he'll send it on their behalf
15:25:32 <colindixon> #action colindixon to talk about making dlux a leaf project in oxygen unless we can fix it's resource issue
15:26:02 <colindixon> #info eman already discussed, hasn't started
15:26:48 <colindixon> #info faas is at 33%, grouppolicy depends on faas at least by our script
15:27:17 <colindixon> #action anipbu to look into if GBP actually depends on FaaS and maybe remove that
15:27:28 <colindixon> #info faas depends on sfc which depends on netconf
15:27:40 <colindixon> #info groupbased policy is a non-leaf project, blocked by netconf
15:27:55 <colindixon> #info honeycomb/vbd has a patch open to be added to the distribution, is a leaf projewct
15:28:14 <colindixon> #undo
15:28:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x300b150>
15:28:32 <colindixon> #info honeycomb/vbd has a patch open to be added to the distribution, groupbasedpolicy and lispflowmapping both depend on vbd
15:29:04 <colindixon> #action anipbu to follow up with honeycomb/vbd to see where they are and if they're going to make it
15:29:08 <colindixon> #info l2switch see above
15:29:23 <colindixon> #info mdsal is done, but hasn't submitted their intent to participate
15:29:41 <colindixon> #action colindixon will send intent to participate on mdsal's behalf
15:30:16 <colindixon> #Info neutron was added to the distribution, removed, has been added back again
15:30:57 <colindixon> #info nic has a patch to be added into the distribution, is having problems, is leaf project
15:31:46 <colindixon> #info ocpplugin has a patch and it verifies, so they are likely good
15:32:05 <colindixon> #info ofconfig hasn't started (see above)
15:32:23 <colindixon> #Info packetcable has a failing patch to be added to the distribution, last touched on the 24th, leaf projct
15:32:39 <colindixon> #info sfc blocked on netconf
15:32:57 <colindixon> #info snmp see above, skitt will follow up if frank doesn't
15:33:19 <colindixon> #info snmp4sdn has a patch to distribution that verifies, so they're OK
15:34:45 <colindixon> #info colindixon asks if that's real, skitt notes that they still pull in the AD-SAL still, I guess if they don't break anyone else, that's fine
15:35:30 <colindixon> #info tsdr was talked about above
15:36:14 <colindixon> #info unimgr has been asking for help, colindixon and zxiiro helped some, they are a leaf project
15:36:54 <colindixon> #info usc and nemo were talked about above
15:40:24 <colindixon> #info THESE PROJECTS ARE NON-LEAF AND NOT DONE: dlux, faas, groupbasedpolicy, honeycomb/vbd, l2switch, mdsal, netconf, sfc, tsdr
15:40:43 <colindixon> #unod
15:40:45 <colindixon> #undo
15:40:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2cfc150>
15:41:23 <colindixon> #info THESE PROJECTS ARE NON-LEAF AND NOT DONE: faas, groupbasedpolicy, honeycomb/vbd, l2switch, netconf, sfc, tsdr
15:41:46 <colindixon> #info for what it's worth dlux and mdsal haven't done paperwork, but are code-complete
15:44:08 <colindixon> #endmeeting