#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:12 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:00:16)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52666 usual agenda (colindixon, 18:00:23)
    2. colindixon (colindixon, 18:00:29)
    3. Thanh (zxiiro, 18:01:12)
    4. hideyuki (hideyuki, 18:01:35)
    5. Anil Vishnoi (vishnoianil, 18:02:42)
    6. abhijitkumbhare (abhijitkumbhare, 18:03:28)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-01-12-18.00.html last week's meeting minutes (colindixon, 18:03:29)
    8. jamoluhrsen (jamoluhrsen, 18:05:09)
    9. edwarnicke (edwarnicke, 18:05:30)
    10. anipbu (anipbu, 18:05:39)
    11. Daniel Farrell for Stephen Kitt (dfarrell07, 18:05:46)
    12. rgoulding (Ryan Goulding) for Alexis de Talhou�t (rgoulding, 18:06:02)
    13. LuisGomez (LuisGomez, 18:07:11)
    14. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 18:07:36)
    15. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (colindixon, 18:07:37)
    16. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 18:07:38)
    17. ACTION: colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia (colindixon, 18:07:39)
    18. ACTION: phrobb to send mail about Nitrogen DDF timing (colindixon, 18:07:40)
    19. phrobb sent out registration codes for TSC members to attend the leadership summit the week of 2/14 near Lake Tahoe (colindixon, 18:08:05)
    20. colindixon sent this to the OPNFV TSC list to figure out what they need for their next release: https://lists.opendaylight.org/pipermail/tsc/2017-January/006532.html (colindixon, 18:08:13)

  2. TSC mailing list conversations and votes (colindixon, 18:09:33)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-November/006368.html projects with few/no active committers (colindixon, 18:09:41)
    2. https://lists.opendaylight.org/pipermail/release/2017-January/009034.html flagship features in Carbon (colindixon, 18:09:54)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-December/006485.html Carbon hackfest date/location (colindixon, 18:10:04)
    4. shague (shague_, 18:10:20)

  3. next week's TSC call (colindixon, 18:10:35)
    1. (colindixon, 18:10:40)
    2. Given the Chinese new year and less time to advertise, we are leaning toward having a normal 1/26 TSC call and resume APAC-timing on 2/23. (colindixon, 18:10:49)
    3. anipbu notes 2/23 sounds good, abhijitkumbhare and vishnoianil say they're fine either way (colindixon, 18:12:11)
    4. AGREED: we will have a normal time meeting on 1/26 (colindixon, 18:12:26)
    5. ACTION: colindixon to update the wiki to note that we will have a normal time slot meeting on 1/26 (colindixon, 18:12:38)

  4. events (colindixon, 18:12:46)
    1. https://www.opendaylight.org/global-events (colindixon, 18:12:52)
    2. ACTION: CaseyODL to cancel the eventing TSC webex and calendar invite for 1/26 (colindixon, 18:14:20)
    3. https://wiki.opendaylight.org/view/Events:Main (colindixon, 18:14:26)
    4. CFP for Open Networking Summit closes on Saturdy, January 21st: TWO DAYS FROM NOW!! http://events.linuxfoundation.org/events/open-networking-summit/program/cfp (colindixon, 18:14:58)

  5. boron (colindixon, 18:16:03)
    1. Boron Autorelease Job building successfully. (anipbu, 18:16:16)

  6. carbon (colindixon, 18:16:33)
    1. Missing M3 Status from 1 Project: controller (anipbu, 18:16:38)
    2. https://lists.opendaylight.org/pipermail/release/2017-January/009111.html <--- Carbon M3 Offset 1 Status is due today (1/19) (anipbu, 18:16:52)
    3. https://logs.opendaylight.org/releng/jenkins092/autorelease-release-carbon/131/ <--- Current Failure in LISP Flow Mapping Integration Test org.opendaylight.lispflowmapping.integrationtest.MappingServiceIntegrationTest (anipbu, 18:17:05)
    4. https://lists.opendaylight.org/pipermail/release/2017-January/009079.html <--- Changes to the if-feature related API in Yangtools (anipbu, 18:17:33)
    5. https://lists.opendaylight.org/pipermail/release/2017-January/009106.html <--- Make distribution-check more strict (anipbu, 18:17:46)
    6. https://lists.opendaylight.org/pipermail/release/2017-January/009089.html <--- Advise projects to review instructions on including config files for Karaf 4 upgrades (anipbu, 18:18:22)
    7. If-feature argument may be boolean expression in compliance with Yang 1.1 (anipbu, 18:21:11)
    8. https://lists.opendaylight.org/pipermail/tsc/2017-January/006520.html Guava 21 is still working through (colindixon, 18:22:22)
    9. https://git.opendaylight.org/gerrit/#/q/topic:guava21 <--- Patches to be merged by releng on behalf of projects after +2 with TSC approval (anipbu, 18:22:35)
    10. the plan is to do Guava 21 and then Karaf 4 of vice versa to avoid having two moving targets (colindixon, 18:22:39)
    11. Will iimpact 14 projects: faas, yangtools, netvirt, openflowplugin, groupbasedpolicy, ovsdb, genius, mdsal, bgpcep, odlparent, didm, centinel, controller, yangtools, (anipbu, 18:22:50)
    12. Need Guava21 IRC Working Session (Flag Day). Guava21 IRC Working session date TBD. rovarga the session date should be sometime between M4 and M5 (anipbu, 18:22:57)

  7. system integration and test (colindixon, 18:23:31)
    1. nothing major to report (colindixon, 18:23:40)

  8. infastructure (colindixon, 18:23:58)
    1. lots of work to move things using JClouds to using Heat, we've moved robot workloads from 20 to 30, so we now have much smaller queues, thanks zxiiro!!! (colindixon, 18:24:28)
    2. this saturday, we'll have a 2-hour work maintainence window for security and updating Jenkins and Gerrit (2.12, not 2.13) (colindixon, 18:25:01)
    3. that will be be 12-2p pacific (colindixon, 18:25:20)

  9. committer-at-large reps to the board of directors (colindixon, 18:26:43)
    1. phrobb started the voting on 1/13; you should have a mail from "Phil Robb (CIVS poll supervisor) <civs@cs.cornell.edu>" with subject "Poll: OpenDaylight Individual Committer Member Board Seat Election" sent around 9a pacific on Friday January 13th. (colindixon, 18:26:49)
    2. Election ends on Wednesday, January 25th at 23:59 UTC. (colindixon, 18:26:58)
    3. If you think you should have gotten a voting e-mail, but didn't reach out to Phil. (colindixon, 18:27:21)
    4. https://wiki.opendaylight.org/view/Committer_Members_Board_Representation Process for committer-at-large representavies on the board (colindixon, 18:27:40)
    5. https://linuxfoundation.echosign.com/public/hostedForm?formid=AI3XA256U2H44Y Link to form to become a committer member (colindixon, 18:28:03)
    6. https://wiki.opendaylight.org/view/Committer_Board_Members:2017_Election (dfarrell07, 18:28:07)
    7. https://wiki.opendaylight.org/view/Committer_Board_Members:2017_Election people standing for election and their statments (colindixon, 18:28:20)
    8. https://lists.opendaylight.org/pipermail/project-proposals/2017-January/000567.html (hideyuki, 18:29:05)
    9. https://lists.opendaylight.org/pipermail/project-proposals/2017-January/000567.html (anipbu, 18:29:06)
    10. ACTION: colindixon to follow up with the FPC agent project proposal to schedule a slot for them (colindixon, 18:30:11)

  10. cookies (colindixon, 18:30:48)


Meeting ended at 18:30:52 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  3. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  4. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
  5. phrobb to send mail about Nitrogen DDF timing
  6. colindixon to update the wiki to note that we will have a normal time slot meeting on 1/26
  7. CaseyODL to cancel the eventing TSC webex and calendar invite for 1/26
  8. colindixon to follow up with the FPC agent project proposal to schedule a slot for them


Action items, by person

  1. anipbu
    1. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
  2. CaseyODL
    1. CaseyODL to cancel the eventing TSC webex and calendar invite for 1/26
  3. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    3. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
    4. colindixon to update the wiki to note that we will have a normal time slot meeting on 1/26
    5. colindixon to follow up with the FPC agent project proposal to schedule a slot for them
  4. vishnoianil
    1. colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
  5. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  6. UNASSIGNED
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    2. phrobb to send mail about Nitrogen DDF timing


People present (lines said)

  1. colindixon (63)
  2. anipbu (16)
  3. odl_meetbot (6)
  4. dfarrell07 (4)
  5. zxiiro (4)
  6. hideyuki (3)
  7. CaseyODL (3)
  8. rgoulding (2)
  9. edwarnicke (2)
  10. abhijitkumbhare (2)
  11. vishnoianil (2)
  12. LuisGomez (1)
  13. shague_ (1)
  14. tykeal- (1)
  15. jamoluhrsen (1)


Generated by MeetBot 0.1.4.