18:00:28 <colindixon> #startmeeting tsc
18:00:28 <odl_meetbot> Meeting started Thu Feb  2 18:00:28 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:28 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:34 <colindixon> #topic roll call and agenda bashin
18:00:37 <colindixon> #info colindixon
18:00:44 <colindixon> #chair anipbu phrobb CaseyODL
18:00:44 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon phrobb
18:01:16 <colindixon> TSC members #info in here
18:01:33 <adetalhouet> #info adetalhouet
18:01:36 <anipbu> #info anipbu
18:01:41 <skitt> #info skitt
18:01:45 <abhijitkumbhare> #info abhijitkumbhare
18:01:53 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52852#Agenda
18:02:00 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-01-26-18.00.html last week's meeting minutes
18:02:14 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
18:02:15 <colindixon> #action colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
18:02:16 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
18:02:17 <colindixon> #action colindixon, vishnoianil, gzhao, anipbu and others to work to advertise APAC-friendly TSC calls to the India and China communities, as well as projects/PTLs in Asia
18:02:24 <zxiiro> #info Thanh
18:02:39 <hideyuki> #info Hideyuki
18:02:52 <colindixon> #action anipbu will add a field for the spreadsheet/bugs on autorelease failures with short root cause analysis of how it got through verify without breaking
18:02:54 <rovarga> #info rovarga
18:03:26 <CaseyODL> Hi, everyone.  I am working on a "Local Experts Guide" for the ODLUGs.
18:03:30 <colindixon> #action jamoluhrsen CaseyODL and tykeal to look at ask.opendaylight.org and figure out why it's not generating emails
18:03:33 <CaseyODL> The Local Experts Guide is a list of experts in the OpenDaylight community who have volunteered to make themselves available to speak at ODLUG Events  If you are interested in volunteering, please enter your Name, Email, Areas of Expertise, and Home Location (City / Country).  You can also enter your travel dates and times if you are willing to speak at
18:03:33 <CaseyODL> locations away from home.
18:03:33 <CaseyODL> https://docs.google.com/spreadsheets/d/1kQqUroilC7v7dH9kiROlwL_exNOaMiq-isj0PYyegfs/edit?usp=sharing
18:04:28 <LuisGomez> #info LuisGomez
18:04:33 <colindixon> #topic Katie helping anipbu with release management
18:04:37 <jamoluhrsen> #info jamoluhrsen
18:04:46 <jamoluhrsen> webex not working, digging up dial in
18:04:53 <vishnoianil> #info Anil Vishnoi
18:05:08 <shague_> #info shague
18:05:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006563.html
18:06:05 <colindixon> #topic local experts guide
18:06:19 <colindixon> #info
18:06:30 <colindixon> #Info The Local Experts Guide is a list of experts in the OpenDaylight community who have volunteered to make themselves available to speak at ODLUG Events  If you are interested in volunteering, please enter your Name, Email, Areas of Expertise, and Home Location (City / Country).  You can also enter your travel dates and times if you are willing to speak at
18:06:50 <colindixon> #link https://docs.google.com/spreadsheets/d/1kQqUroilC7v7dH9kiROlwL_exNOaMiq-isj0PYyegfs/edit?usp=sharing you can filll out this spreadsheet
18:06:57 <colindixon> jamoluhrsen: sorry
18:07:07 <jamoluhrsen> colindixon: im in
18:07:44 <colindixon> #action tykeal and CaseyODL to look at maybe using LDAP for this
18:07:47 <colindixon> #undo
18:07:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x192ee10>
18:07:53 <colindixon> #action tykeal and CaseyODL to look at maybe using LDAP for location of people
18:08:16 <colindixon> #undo
18:08:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x192ee10>
18:10:00 <colindixon> #topic events
18:10:09 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
18:11:04 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#ODL_Nitrogen_Developer_Design_Forum we need to close on the Nitrogen dates
18:11:46 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#Linux_Foundation_Leadership_Summit there will be f2f board meeting and a cross-project TSC mixer at the OS LS
18:12:09 <colindixon> #info docs folks are planning a docsfest the Sunday before ONS and the Monday morning of ONS (4/2-4/3)
18:12:53 <colindixon> #action colindixon to send mail about docfest to Open-O, OPNFV, OpenECOMP?, …
18:14:12 <colindixon> #info there was a question about when we expect decisions on the submissions on talks for the Open Networking Summit
18:14:21 <colindixon> #info phrobb says the plan is to get noices out by the end of the month
18:14:45 <colindixon> #topic boron
18:14:55 <colindixon> #info nothing this week
18:14:57 <colindixon> #topic carbon
18:15:14 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-January/009111.html   <--- Missing M3 Status from 1 project snmp
18:15:25 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-February/009207.html   <--- Carbon M3 Offset 2 Status Due Today
18:15:35 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-February/009208.html   <--- Carbon M4 Offset 0 Status Due Today
18:16:01 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/26161/   <--- Controller has merged patch to move the Karaf 3 features and add matching Karaf 4 features for all the controller features.
18:16:28 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006565.html   <--- RFC 8040 for RESTCONF has been published.
18:16:36 <anipbu> #link https://tools.ietf.org/rfcdiff?url1=draft-ietf-netconf-restconf-18.txt&url2=rfc8040.txt   <--- Diff between Draft 18 and rfc 8040
18:16:44 <anipbu> rovarga: Is there any impact to projects?  Or any action items for end users or projects in Carbon or should be planned for Boron.
18:17:15 <anipbu> #info OpenDaylight shipped draft-17 in Boron SR1, and will be backporting RFC to Boron SR3.  OpenDaylight has already delivered draft-18 in Carbon, and will be adding changes from 18-to-RFC in Carbon as well.  The changes 18-to-RFC are minimal and compatible.
18:18:29 <anipbu> #info some impact in Boron for projects
18:19:46 <colindixon> #info in general, most people shouldn't get hit by RESCONF unless they were using the new URLs, which very few people were using
18:20:24 <colindixon> #info the next project to merge Karaf 4 should be aaa
18:20:58 <colindixon> #info rovarga notes that we're having issues with verify vs. merge where we have different memory usages and that's making merges hard
18:22:15 <colindixon> #action rovarga zxiiro skitt to look at why verify vs. merge is so different and possibly fixing (by not using the jenkins maven plugin?)
18:24:27 <colindixon> #Info zxiiro says that the issue with moving from jenkins maven to stock maven is that it publishes as it goes, rovarga suggests that we stage the artifacts in temporary directory and then publish them after the build
18:25:04 <colindixon> #topic system integration and test
18:25:43 <colindixon> #info jamoluhrsen says that we're running ~500 CSIT jobs per night, 5 nights per week, they take about 11 hours
18:25:53 <colindixon> #Info gating CSIT jobs are bumped to the front of the queue
18:26:08 <colindixon> #topic infrsatructure
18:26:59 <colindixon> #Info zxiiro and anil went through a bunch of patches of how we're using Heat, this will help things not time out when deploys take a bit longer, and also clean up better when things do fail despite that
18:27:52 <colindixon> #link new tab in jenkins to see the last 30 jobs that ran https://jenkins.opendaylight.org/releng/view/01-Recent/
18:28:06 <colindixon> #Info API limits increased from 5000 to 30000, so we have more room again
18:28:56 <colindixon> #topic FPC Agent Creation Review
18:29:04 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:FpcAgent
18:29:18 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2017-January/000567.html proposed on 1/9/2017
18:29:56 <colindixon> #info iETF draft for forwarding policy configuration
18:30:39 <colindixon> #link https://datatracker.ietf.org/doc/draft-ietf-dmm-fpc-cpdp/ IETF draft
18:31:37 <colindixon> #info FPC provides a mechanism by which a FPC Client in the mobility control plane may manipulate dataplane forwarding elements (Dataplane Nodes or ‘DPNs’) via Agents.
18:33:59 <colindixon> #info there are two different modes: one where the agent mostly just translates a client's commads to a southbound data plane, another where the client says very few things and the agend makes most of the decisions
18:34:27 <colindixon> #info (note that all this content and presentation is from the wiki page with no slides, so no worries if you can't see screen sharing)
18:36:45 <colindixon> #Info the current agent pretty much only goes to 0MQ pub/sub at the SB, but they're working to build OpenFlow as well
18:39:33 <colindixon> #info LuisGomez asks what DPN is using 0MQ, Lyle says that the current DPN is coming from Intel as part of M-CORD via ON.lab with code dropping mid-to-late February
18:40:03 <colindixon> #info Lyle says that if you're a contributor to M-CORD, you might be able to ask to see the code now
18:40:21 <colindixon> #info Lyle also says that ther'es a really basic stub to be able to test and play with stuff, but not a real DPN
18:42:54 <jamoluhrsen> offset 2?
18:43:01 <colindixon> #info Lyle says the goal is to make it work with lots of different places in 3GPP, 5G, with southbounds for 0MQ and eventually OFP
18:43:57 <colindixon> #Info vishnoianil asks about FPC's offset, Lyle says offset 1 for now, but maybe offset 2 by the time they depend on OFP to get more space
18:44:17 <colindixon> #info anipbu asks if they want to be in Carbon, Lyle says no, not carbon
18:45:06 <colindixon> #info vishnoianil asks what the plans are with drafts of the IETF spec? the code supports draft 4 now, the plan is to move to the lastest draft for the next release (as well as compatibility for draft 4)
18:46:25 <colindixon> #info Lyle is hoping to see a final draft from the IETF by July, but we'll see
18:46:42 <colindixon> #info anipbu asks if IPR has gone in, Lyle says yes, phrobb says it's on his to do list
18:47:01 <colindixon> #startvote shall the TSC move the FPC Agent project to an incubation project? -1,0,+1
18:47:01 <odl_meetbot> Begin voting on: shall the TSC move the FPC Agent project to an incubation project? Valid vote options are -1, 0, +1.
18:47:01 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:47:02 <rovarga> #vote +1
18:47:02 <vishnoianil> #vote +1
18:47:03 <edwarnicke> #vote +1
18:47:03 <hideyuki> +1
18:47:03 <skitt> #vote +1
18:47:03 <jamoluhrsen> #vote +1
18:47:04 <LuisGomez> #vote +1
18:47:04 <anipbu> #vote +1
18:47:06 <hideyuki> #vote +1
18:47:06 <adetalhouet> #vote +1
18:47:06 <colindixon> #vote +1
18:47:07 <zxiiro> #vote +1
18:47:07 <abhijitkumbhare> #vote +1
18:47:09 <shague_> #vote +1
18:47:20 <rovarga> fastest vote ever? :)
18:47:26 <vishnoianil> :)
18:47:31 <colindixon> #endvote
18:47:31 <odl_meetbot> Voted on "shall the TSC move the FPC Agent project to an incubation project?" Results are
18:47:31 <odl_meetbot> +1 (13): rovarga, adetalhouet, skitt, zxiiro, LuisGomez, edwarnicke, shague_, hideyuki, colindixon, jamoluhrsen, anipbu, vishnoianil, abhijitkumbhare
18:47:34 <jamoluhrsen> need a meetbot feature to track voting speed
18:47:41 <rovarga> jamoluhrsen: +1
18:47:47 <vishnoianil> congratulations fpc project :)
18:47:48 <dfarrell07> impressive, new TSC ;)
18:47:56 <jamoluhrsen> welcom fpc
18:47:57 <colindixon> #agreed the FPC agent project is a incubation project
18:47:59 <dfarrell07> congrats FPC project, and welcome :)
18:48:00 <LuisGomez> congrats
18:48:02 <skitt> impressive, new project I'd say dfarrell07 ;-)
18:48:20 <vishnoianil> skitt, +1
18:48:48 <colindixon> #topic new repositories integration/packaging
18:49:22 <colindixon> #info  Some external tools expect things like ansible and puppet configuration to be their own repos
18:49:28 <colindixon> #info  Thus, integration/packaging is asking for new repos without needing a new project
18:49:33 <colindixon> #info  It seems like the TSC should be able to bless this as a way to solve a mundane technical detail
18:50:26 <colindixon> #info there are external repos (in dfarrell07's github) that we would like to move back into OpenDaylight
18:51:04 <colindixon> #info the interesting part here is that for technical reasons, they'd like to have multiple repos under one project to avoid more overhead
18:51:47 <colindixon> #info asking for the same committers for now, but dfarrell07 might argue that they drift in the future
18:52:49 <colindixon> #info edwarnicke points out that he'e expect that differnt packaging will have different expertise, dfarrell07 responds that there are lots of tight couplings as well
18:53:35 <colindixon> #Info rovarga asks about switching to a top-level project, dfarrell07 says it doesn't seem like a great fit except that they look vaguely the same from a distance
18:55:23 <colindixon> #info edwarnicke says it sounds to him like it's really 3 projects, and that would make things different
18:56:04 <colindixon> #info colindixon says that to him, if there's differnt committer lists, that seems like a good sign you might need 3 different projects
18:57:10 <colindixon> #Info anipbu asks what the overhead of having a project given that it doesn't participate in release, dfarrell07 says TSC representation doesn't quite fit, also JJB jobs, etc.
18:58:10 <colindixon> #info colindixon says his take is that this not be generally interpreted as a good thing to do: having multiple repos per project, but in this case since it's solving a techincal issue for a specific reason
18:58:21 <vishnoianil> is current integration/packaging repo maintain the stable branches ?
18:58:45 <jamoluhrsen> no branches
18:58:47 <jamoluhrsen> master
18:59:03 <skitt> rovarga, would this make sense for odlparent's Maven plugins?
18:59:03 <skitt> rovarga, i.e. a separate repo for those (for bootstrapping builds)
18:59:37 <colindixon> #info colindixon asks if there's any infra issues, tykeal and zxiiro say no except maybe three-nesded deep names
18:59:53 <colindixon> #info dfarrell07 says maybe also project facts template
18:59:55 <jamoluhrsen> can we link in that integration mail thread?
19:00:10 * jamoluhrsen finding mail
19:00:17 <dfarrell07> #link https://lists.opendaylight.org/pipermail/integration-dev/2017-January/009034.html Int/Pack discussion/vote mailing list thread
19:00:27 <jamoluhrsen> :P
19:00:29 <colindixon> #startvote shall the TSC allow the integration/packaging project to get two sub-repos for puppet and ansible? -1,0,+1
19:00:29 <odl_meetbot> Begin voting on: shall the TSC allow the integration/packaging project to get two sub-repos for puppet and ansible? Valid vote options are -1, 0, +1.
19:00:29 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:00:30 <vishnoianil> #vote +1
19:00:33 <colindixon> #vote +1
19:00:34 <edwarnicke> #vote +1
19:00:37 <abhijitkumbhare> #vote +1
19:00:38 <skitt> #vote +1
19:00:45 <zxiiro> #vote +1
19:00:56 <rovarga> #vote +0
19:00:56 <odl_meetbot> rovarga: +0 is not a valid option. Valid options are -1, 0, +1.
19:00:57 <anipbu> #vote +1
19:00:58 <rovarga> #vote 0
19:01:06 <jamoluhrsen> #vote +1
19:01:09 <adetalhouet> #vote 0
19:01:26 <hideyuki> #vote +1
19:01:39 <colindixon> #endvote
19:01:39 <odl_meetbot> Voted on "shall the TSC allow the integration/packaging project to get two sub-repos for puppet and ansible?" Results are
19:01:39 <odl_meetbot> 0 (2): rovarga, adetalhouet
19:01:39 <odl_meetbot> +1 (9): skitt, anipbu, edwarnicke, hideyuki, colindixon, abhijitkumbhare, zxiiro, vishnoianil, jamoluhrsen
19:02:45 <colindixon> #agreed the integration/packaing projet can get two more repos for puppet and ansible
19:03:08 <colindixon> #info rovarga notes that there's potential namespace issues around nexus, feature names, project names, etc.
19:03:25 <colindixon> #Info vrpolak_ notes that this is already broke when integration split
19:04:56 <vrpolak_> Project lifecycle ties repository archival with project termination. https://wiki.opendaylight.org/view/Integration/Packaging
19:04:59 <colindixon> #action colindixon to work with rovarga to write up namespace management issues (edwarnicke says that his take is probalby just use org.opendaylight.<repo>)
19:05:00 <rovarga> edwarnicke: exactly my point -- even I got the mapping assumptions wrong :)
19:05:39 <colindixon> #topic cookies
19:05:42 <colindixon> #endmeeting