#opendaylight-meeting: TSC

Meeting started by dfarrell07 at 04:34:25 UTC (full logs).

Meeting summary

    1. jamoluhrsen (jamoluhrsen, 04:35:27)
    2. Anil Vishnoi (vishnoianil, 04:35:27)
    3. abhijitkumbhare (abhijitkumbhare, 04:35:32)
    4. Hideyuki (hideyuki, 04:35:35)
    5. Daniel Farrell for shague (dfarrell07, 04:35:49)

  1. agenda bashing and roll call (anipbu, 04:35:58)
    1. Thanh (zxiiro, 04:36:01)
    2. anipbu (anipbu, 04:36:13)
    3. sridharg for shague (sridharg, 04:36:39)
    4. lori for adetalhouet (lori, 04:37:44)

  2. agenda bashing (vishnoianil, 04:39:04)
    1. https://wiki.opendaylight.org/view/TSC:Main (abhijitkumbhare, 04:39:17)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-02-09-18.00.html (hideyuki, 04:40:25)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-02-09-18.00.txt (vishnoianil, 04:41:48)
    4. ACTION: olindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (vishnoianil, 04:42:45)
    5. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (vishnoianil, 04:43:02)
    6. ACTION: colindixon to remove carbon hackfest and off-cycle releases from discussions list on next week's agenda (vishnoianil, 04:45:02)
    7. https://git.opendaylight.org/gerrit/#/c/50848/ <--- merged for dlux (anipbu, 04:45:15)
    8. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (vishnoianil, 04:46:07)
    9. vrpolak to start thinking about how to create a karaf 4 distribtion and when, maybe send mail (vishnoianil, 04:46:33)
    10. > vrpolak to start thinking about how to create a karaf 4 distribtion and when, maybe send mail: Change contributed, but no merge no mail yet: https://git.opendaylight.org/gerrit/51762 (vrpolak, 04:46:40)
    11. https://git.opendaylight.org/gerrit/#/c/51762/ <--- distribution work to move to karaf 4 (jamoluhrsen, 04:47:25)

  3. update (vishnoianil, 04:47:41)
  4. events (vishnoianil, 04:48:00)
    1. ONS in first week of april (vishnoianil, 04:48:12)
    2. various session on Tuesday (vishnoianil, 04:48:22)
    3. https://www.opendaylight.org/global-events (hideyuki, 04:48:32)
    4. phil is working on documentation hackfest venue/details (on monday) (vishnoianil, 04:48:45)
    5. https://wiki.opendaylight.org/view/Events (hideyuki, 04:49:00)
    6. as of now we don;t have place for hackfest on sunday yet (vishnoianil, 04:49:33)
    7. Linux con china is CFP closing on march 18 (vishnoianil, 04:50:03)

  5. Boron updates (vishnoianil, 04:50:23)
    1. boron is pretty quite :) (vishnoianil, 04:50:47)

  6. carbon updates (vishnoianil, 04:50:55)
    1. we are at offset 1 M1 (vishnoianil, 04:51:13)
    2. we are missing status from M4 (dlux, l2switch, snmp, ) and offset 0 (AAA) (vishnoianil, 04:51:57)
    3. kathie will do the follow-up with these projects (vishnoianil, 04:52:13)
    4. https://wiki.opendaylight.org/view/Weather#odlparent_maven-enforcer-plugin_to_forbid_use_of_mockito-all (anipbu, 04:53:12)
    5. https://wiki.opendaylight.org/view/Weather#Genius_AbstractDataChangeListener_clean-up (anipbu, 04:53:28)

  7. System integration and testing (jamo) (vishnoianil, 04:53:30)
    1. ongoing work on infra issue, we fix few real issue and infra should be stable now (vishnoianil, 04:54:00)
    2. please reach out to jamo/andy/thanh if you see any issues related to infra (vishnoianil, 04:54:14)

  8. Infrastructure (vishnoianil, 04:54:34)
    1. merged a patch to avoid using jjbuilder static builder (vishnoianil, 04:55:01)
    2. https://git.opendaylight.org/gerrit/#/c/51766/ (abelur, 04:55:39)
    3. https://git.opendaylight.org/gerrit/51766 Patch to use dynamic builder (zxiiro, 04:55:42)

  9. committer promotion (vishnoianil, 04:56:15)
    1. Nominate Sam Hague as a committer on releng/builde (vishnoianil, 04:56:20)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-February/006641.html (hideyuki, 04:56:26)
    3. https://git.opendaylight.org/gerrit/#/q/project:releng/builder+owner:%22Sam+Hague+%253Cshague%2540redhat.com%253E%22 (vishnoianil, 04:56:34)
    4. https://git.opendaylight.org/gerrit/#/q/project:releng/builder+reviewer:%22Sam+Hague+%253Cshague%2540redhat.com%253E%22 (vishnoianil, 04:56:40)
    5. VOTE: Voted on "Shall the TSC approve the committer promotion for Sam Hague to releng/builder?" Results are, +1: 10 (vishnoianil, 05:00:19)
    6. AGREED: TSC has approved the committer promotion for Sam Hague to releng/builder (anipbu, 05:01:35)
    7. Nominate Marcus Williams as a committer on releng/builder (vishnoianil, 05:01:48)
    8. https://lists.opendaylight.org/pipermail/tsc/2017-February/006642.html (hideyuki, 05:01:55)
    9. https://git.opendaylight.org/gerrit/#/q/project:releng/builder+owner:%22Marcus+G+K+Williams+%253Cmarcus.williams%2540intel.com%253E%22 (vishnoianil, 05:01:55)
    10. https://git.opendaylight.org/gerrit/#/q/project:releng/builder+reviewer:%22Marcus+G+K+Williams+%253Cmarcus.williams%2540intel.com%253E%22 (vishnoianil, 05:02:03)
    11. VOTE: Voted on "Shall the TSC approve the committer promition for Marcus Williamsto releng/builder?" Results are, +1: 8 (vishnoianil, 05:03:42)
    12. https://lists.opendaylight.org/pipermail/tsc/2017-February/006643.html (hideyuki, 05:04:10)
    13. Nominate Daniel Farrell as a committer on releng/builder (vishnoianil, 05:04:24)
    14. https://git.opendaylight.org/gerrit/#/q/project:releng/builder+owner:%22Daniel+Farrell+%253Cdfarrell%2540redhat.com%253E%22 (vishnoianil, 05:04:31)
    15. https://git.opendaylight.org/gerrit/#/q/project:releng/builder+reviewer:%22Daniel+Farrell+%253Cdfarrell%2540redhat.com%253E%22 (vishnoianil, 05:04:38)
    16. VOTE: Voted on "Shall the TSC approve the committer promition for Daniel Farrell for releng/builder?" Results are, +1: 9 (vishnoianil, 05:05:53)
    17. AGREED: TSC has approved the committer promotion for Daniel Farrell to releng/builder (vishnoianil, 05:06:12)
    18. Nominate Vratko Polak as a committer on releng/autorelease (vishnoianil, 05:06:41)
    19. https://git.opendaylight.org/gerrit/#/q/project:releng/autorelease+owner:%22Vratko+Pol%25C3%25A1k+%253Cvrpolak%2540cisco.com%253E%22 (vishnoianil, 05:07:02)
    20. https://git.opendaylight.org/gerrit/#/q/project:releng/autorelease+reviewedby:%22Vratko+Pol%25C3%25A1k+%253Cvrpolak%2540cisco.com%253E%22 (vishnoianil, 05:07:09)
    21. https://wiki.opendaylight.org/view/Weather#odlparent_maven-enforcer-plugin_to_forbid_use_of_mockito-all (katiezhang, 05:08:16)
    22. VOTE: Voted on "Shall the TSC approve the committer promition for Vratko Polak for releng/autorelease project?" Results are, +1: 9 (vishnoianil, 05:09:05)
    23. AGREED: TSC has approved the committer promotion for Vratko Polak for releng/autorelease (vishnoianil, 05:09:27)
    24. Nominate Anil Belur as a committer on releng/autorelease (vishnoianil, 05:09:40)
    25. https://git.opendaylight.org/gerrit/#/q/project:releng/autorelease+owner:%22Anil+Belur+%253Cabelur%2540linuxfoundation.org%253E%22 (vishnoianil, 05:09:47)
    26. https://git.opendaylight.org/gerrit/#/q/project:releng/autorelease+reviewedby:%22Anil+Belur+%253Cabelur%2540linuxfoundation.org%253E%22 (vishnoianil, 05:10:06)
    27. big thanks from the TSC for Anil's work in autorelease (jamoluhrsen, 05:10:29)
    28. VOTE: Voted on "Shall the TSC approve the committer promition for Anil Belur to releng/autorelease project?" Results are, +1: 9 (vishnoianil, 05:11:59)
    29. AGREED: TSC has approved the committer promotion for Anil Belur for releng/autorelease (vishnoianil, 05:12:12)
    30. Committer promotion for Tomas Janciga to IoTDM project (vishnoianil, 05:13:59)
    31. https://git.opendaylight.org/gerrit/#/q/owner:%22Tomas+Janciga%22+project:iotdm (vishnoianil, 05:14:36)
    32. https://git.opendaylight.org/gerrit/#/q/reviewer:tjanciga%2540cisco.com+status:merged (vishnoianil, 05:16:05)
    33. https://git.opendaylight.org/gerrit/#/q/reviewer:tjanciga%2540cisco.com+project:iotdm (zxiiro, 05:16:40)
    34. VOTE: Voted on "Shall the TSC approve the committer promition for Tomas Janciga to IoTDM project?" Results are, +1: 9 (vishnoianil, 05:17:24)
    35. AGREED: TSC has approved the committer promotion for Tomas Janciga to IoTDM project (vishnoianil, 05:17:40)
    36. Committer promotion for Ravi Sabapathy to LACP project (vishnoianil, 05:18:04)
    37. https://git.opendaylight.org/gerrit/#/q/Ravi+Sabapathy+project:lacp (anipbu, 05:22:17)
    38. https://lists.opendaylight.org/pipermail/lacp-dev/2017-February/000163.html (anipbu, 05:26:16)
    39. https://git.opendaylight.org/gerrit/#/q/Ravi+Sabapathy+project:lacp (vishnoianil, 05:29:23)
    40. ACTION: vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project (vishnoianil, 05:34:30)

  10. cookies and beer (vishnoianil, 05:34:51)


Meeting ended at 05:35:17 UTC (full logs).

Action items

  1. olindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  3. colindixon to remove carbon hackfest and off-cycle releases from discussions list on next week's agenda
  4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  5. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project


Action items, by person

  1. anipbu
    1. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project
  2. phrobb
    1. olindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. vishnoianil
    1. vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project
  4. zxiiro
    1. olindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs


People present (lines said)

  1. vishnoianil (83)
  2. odl_meetbot (34)
  3. anipbu (18)
  4. zxiiro (16)
  5. jamoluhrsen (15)
  6. dfarrell07 (14)
  7. hideyuki (14)
  8. abhijitkumbhare (12)
  9. LuisGomez (7)
  10. lori (7)
  11. sridharg (4)
  12. abelur (4)
  13. katiezhang (2)
  14. CaseyODL (2)
  15. vrpolak (1)
  16. gzhao (0)
  17. phrobb (0)


Generated by MeetBot 0.1.4.